source: projects/specs/trunk/n/ntfs-3g/ntfs-3g-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Linux NTFS userspace driver
2Summary(ja):    Linux NTFS ユーザ空間ドライバ
3Name:           ntfs-3g
4Version:        2009.4.4
5Release:        1%{?_dist_release}
6License:        GPL
7Group:          System Environment/Base
8Source0:        http://www.ntfs-3g.org/%{name}-%{version}.tgz
9Source1:        20-ntfs-config-write-policy.fdi
10URL:            http://www.ntfs-3g.org/
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13%description
14The ntfs-3g driver is an open source, GPL licensed, third generation
15Linux NTFS driver. It provides full read-write access to NTFS, excluding
16access to encrypted files, writing compressed files, changing file
17ownership, access right.
18
19Technically it's based on and a major improvement to the third
20generation Linux NTFS driver, ntfsmount. The improvements include
21functionality, quality and performance enhancements.
22
23ntfs-3g features are being merged to ntfsmount. In the meanwhile,
24ntfs-3g is currently the only free, as in either speech or beer, NTFS
25driver for Linux that supports unlimited file creation and deletion.
26
27%package devel
28Summary:        Development files and libraries for ntfs-3g
29Summary(ja):    ntfs-3g の開発ファイルとライブラリ
30Group:          Development/Libraries
31Requires:       %{name} = %{version}-%{release}
32
33%description devel
34Headers and libraries for developing applications that use ntfs-3g
35functionality.
36
37%prep
38%setup -q
39
40%build
41%configure --disable-static --disable-ldconfig \
42           --exec-prefix=/ \
43           --bindir=/bin \
44           --sbindir=/sbin \
45           --libdir=/%{_lib}
46make %{?_smp_mflags}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50mkdir -p $RPM_BUILD_ROOT/sbin
51make DESTDIR=$RPM_BUILD_ROOT install
52rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
53
54# make the symlink an actual copy to avoid confusion
55rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
56cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
57
58# make compatibility symlinks
59ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
60ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
61ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
62mkdir -p $RPM_BUILD_ROOT%{_bindir}
63ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
64ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
65
66# Put the .pc file in the right place.
67mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
68mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
69
70mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
71cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
72
73rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post -p /sbin/ldconfig
79
80%postun -p /sbin/ldconfig
81
82%files
83%defattr(-,root,root,-)
84%doc AUTHORS ChangeLog COPYING CREDITS NEWS README
85/sbin/mount.ntfs
86%attr(4754,root,root) /sbin/mount.ntfs-3g
87/sbin/mount.ntfs-fuse
88/bin/ntfs-3g
89/bin/ntfs-3g.probe
90/bin/ntfsmount
91%{_bindir}/ntfs-3g
92%{_bindir}/ntfsmount
93/%{_lib}/libntfs-3g.so.*
94%{_datadir}/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi
95%{_mandir}/man8/*
96
97
98%files devel
99%defattr(-,root,root,-)
100%{_includedir}/ntfs-3g/
101/%{_lib}/libntfs-3g.so
102%{_libdir}/pkgconfig/*.pc
103
104%changelog
105* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
106- new upstream release
107- use internal fuse-lite, remove BR: fuse-devel and R: fuse
108- move binaries to /bin
109- move libraries to /%%{_lib}
110- add fdi file to enable hal automounting
111
112* Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
113- new upstream release
114
115* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
116- new upstream release
117
118* Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
119- new upstream release
120
121* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
122- new upstream release
123
124* Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
125- initial build for Vine Linux
126
127* Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
128- bump to 1.516
129- fix bugzilla 232031
130
131* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
132- bump to 1.417
133
134* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
135- bump to 1.416
136- drop patch0, upstreamed
137
138* Wed Apr  4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
139- allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
140
141* Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
142- bump to 1.328
143- drop patch, use --disable-ldconfig instead
144
145* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
146- 1.0 release!
147
148* Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
149- symlink to mount.ntfs
150
151* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
152- bump to 20070118
153
154* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
155- bump to latest version for all active dists
156
157* Wed Jan  3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
158- bump to latest version (note that upstream fixed their date mistake)
159
160* Wed Nov  1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
161- add an obsoletes for ntfsprogs-fuse
162- make some convenience symlinks
163
164* Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
165- add some extra Provides
166
167* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
168- add explicit Requires on fuse
169
170* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
171- fixed versioning (bumped epoch, since it now shows as older)
172- change sbin symlink to actual copy to be safe
173
174* Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
175- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.