source: projects/specs/trunk/n/ntfs-3g/ntfs-3g-vl.spec @ 9550

Revision 9550, 8.2 KB checked in by inagaki, 9 years ago (diff)

2015-05-08 Ryoichi INAGAKI <ryo1@…>

  • ntfs-3g: reverted file location <Vine Linux:2914>


RevLine 
[7076]1%bcond_with externalfuse
2
[521]3Summary:        Linux NTFS userspace driver
4Summary(ja):    Linux NTFS ユーザ空間ドライバ
5Name:           ntfs-3g
[7076]6
[9526]7Version:        2015.3.14
[9550]8Release:        2%{?_dist_release}
[7076]9
[9526]10License:        GPLv2+
[521]11Group:          System Environment/Base
[7076]12URL:            http://www.ntfs-3g.org/
13
[7478]14Source0:        http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}.tgz
[521]15Source1:        20-ntfs-config-write-policy.fdi
[7076]16Patch0:         ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
17
[521]18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19
[7076]20BuildRequires:  libtool
21BuildRequires:  libattr-devel
22BuildRequires:  libconfig-devel
23BuildRequires:  libgcrypt-devel
24BuildRequires:  gnutls-devel
25BuildRequires:  libuuid-devel
26%if %{with externalfuse}
27BuildRequires:  fuse-devel
28Requires:       fuse
29%endif
30
[521]31%description
[9526]32NTFS-3G is a stable, open source, GPL licensed, POSIX, read/write NTFS
33driver for Linux and many other operating systems. It provides safe
34handling of the Windows XP, Windows Server 2003, Windows 2000, Windows
35Vista, Windows Server 2008 and Windows 7 NTFS file systems. NTFS-3G can
36create, remove, rename, move files, directories, hard links, and streams;
37it can read and write normal and transparently compressed files, including
38streams and sparse files; it can handle special files like symbolic links,
39devices, and FIFOs, ACL, extended attributes; moreover it provides full
40file access right and ownership support.
[521]41
42%package devel
43Summary:        Development files and libraries for ntfs-3g
44Summary(ja):    ntfs-3g の開発ファイルとライブラリ
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
[9526]47Requires:       pkgconfig
[7076]48Provides:       ntfsprogs-devel = %{version}-%{release}
49Obsoletes:      ntfsprogs-devel < 2.0.0-3
[521]50
51%description devel
52Headers and libraries for developing applications that use ntfs-3g
53functionality.
54
[7076]55%package -n ntfsprogs
56Summary:        NTFS filesystem libraries and utilities
57Summary(ja):    NTFS ファイルシステム用ライブラリおよびユーティリティ
58Group:          System Environment/Base
59Provides:       ntfsprogs-gnomevfs = %{version}-%{release}
60Obsoletes:      ntfsprogs-gnomevfs < 2.0.0-3
61
62%description -n ntfsprogs
63The ntfsprogs package currently consists of a library and utilities
64such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
65(for a full list of included utilities see man 8 ntfsprogs after
66installation).
67
68
[521]69%prep
[7076]70%setup -q -n %{name}_ntfsprogs-%{version}
71%patch0 -p1 -b .unsupported
[521]72
73%build
[7076]74%configure --disable-static \
75           --disable-ldconfig \
76%{?with_ externalfuse:--with-fuse=external} \
[521]77           --exec-prefix=/ \
[9550]78           --bindir=/bin \
79           --sbindir=/sbin \
80           --libdir=/%{_lib} \
[7076]81           --enable-crypto \
[9526]82           --enable-extras \
83           --enable-quarantined
84
[7076]85make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
[521]86
87%install
88rm -rf $RPM_BUILD_ROOT
[7076]89make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
[9550]90
[7076]91rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
[9550]92rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.{la,a}
[521]93
[9550]94mkdir -p $RPM_BUILD_ROOT/sbin
[521]95
[9550]96# make the symlink an actual copy to avoid confusion
97rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
98cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
99
[521]100# make compatibility symlinks
[9550]101ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
102ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
103ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
104ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
105mkdir -p $RPM_BUILD_ROOT%{_bindir}
106ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
107ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
[521]108
[9550]109# Put the .pc file in the right place.
110mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
111mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
[521]112
[9526]113# We get this on our own, thanks.
114rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
[7076]115
[521]116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(-,root,root,-)
125%doc AUTHORS ChangeLog COPYING CREDITS NEWS README
[9550]126/sbin/mount.ntfs
127%attr(4754,root,root) /sbin/mount.ntfs-3g
128/sbin/mount.ntfs-fuse
129/sbin/mount.lowntfs-3g
130/bin/lowntfs-3g
131/bin/ntfs-3g
132/bin/ntfs-3g.probe
133/bin/ntfs-3g.secaudit
134/bin/ntfs-3g.usermap
135/bin/ntfsmount
[521]136%{_bindir}/ntfs-3g
137%{_bindir}/ntfsmount
[9550]138/%{_lib}/libntfs-3g.so.*
[7076]139%{_mandir}/man8/mount.lowntfs-3g.*
140%{_mandir}/man8/mount.ntfs-3g.*
141%{_mandir}/man8/ntfs-3g*
[521]142
143%files devel
144%defattr(-,root,root,-)
145%{_includedir}/ntfs-3g/
[9550]146/%{_lib}/libntfs-3g.so
[521]147%{_libdir}/pkgconfig/*.pc
148
[7076]149%files -n ntfsprogs
150%doc AUTHORS COPYING CREDITS ChangeLog NEWS README
[9550]151/bin/ntfscat
152/bin/ntfscluster
153/bin/ntfscmp
154/bin/ntfsfix
155/bin/ntfsinfo
156/bin/ntfsls
[7076]157# extras
[9550]158/bin/ntfsck
159/bin/ntfsdecrypt
160/bin/ntfsdump_logfile
161/bin/ntfsfallocate
162/bin/ntfsmftalloc
163/bin/ntfsmove
164/bin/ntfstruncate
165/bin/ntfswipe
166/sbin/fsck.ntfs
167/sbin/mkfs.ntfs
168/sbin/mkntfs
169/sbin/ntfsclone
170/sbin/ntfscp
171/sbin/ntfslabel
172/sbin/ntfsresize
173/sbin/ntfsundelete
[7076]174%{_mandir}/man8/mkntfs.8*
175%{_mandir}/man8/mkfs.ntfs.8*
176%{_mandir}/man8/ntfs[^m][^o]*.8*
[9526]177%exclude %{_mandir}/man8/ntfs-3g*
[7076]178
[521]179%changelog
[9550]180* Fri May  8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-2
181- reverted file location <Vine Linux:2914>
182
[9526]183* Fri Apr 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-1
184- new upstream release
185- dropt hal files, since hal is very old
186
[8285]187* Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
188- new upstream release
189
[8283]190* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
191- rebuilt with gnutls-3.2 and libgcrypt-1.6
192
[7478]193* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
194- new upstream release
195
[7076]196* Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
197- new upstream release
198- merge ntfsprogs
199  - add Obsoletes and Provides ntfsprogs*
200  - add BR: for ntfsprogs
201
[2782]202* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
203- new upstream release
204- fix %%files (add lowntfs-3g)
205
[521]206* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
207- new upstream release
208- use internal fuse-lite, remove BR: fuse-devel and R: fuse
209- move binaries to /bin
210- move libraries to /%%{_lib}
211- add fdi file to enable hal automounting
212
213* Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
214- new upstream release
215
216* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
217- new upstream release
218
219* Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
220- new upstream release
221
222* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
223- new upstream release
224
225* Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
226- initial build for Vine Linux
227
228* Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
229- bump to 1.516
230- fix bugzilla 232031
231
232* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
233- bump to 1.417
234
235* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
236- bump to 1.416
237- drop patch0, upstreamed
238
239* Wed Apr  4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
240- allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
241
242* Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
243- bump to 1.328
244- drop patch, use --disable-ldconfig instead
245
246* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
247- 1.0 release!
248
249* Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
250- symlink to mount.ntfs
251
252* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
253- bump to 20070118
254
255* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
256- bump to latest version for all active dists
257
258* Wed Jan  3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
259- bump to latest version (note that upstream fixed their date mistake)
260
261* Wed Nov  1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
262- add an obsoletes for ntfsprogs-fuse
263- make some convenience symlinks
264
265* Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
266- add some extra Provides
267
268* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
269- add explicit Requires on fuse
270
271* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
272- fixed versioning (bumped epoch, since it now shows as older)
273- change sbin symlink to actual copy to be safe
274
275* Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
276- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.