source: projects/specs/trunk/n/ntfs-3g/ntfs-3g-vl.spec @ 12370

Revision 12370, 9.3 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

dosfstools-4.1-1

fontconfig-2.13.1-1

gd-2.3.0-1

itstool-2.0.6-1

logrotate-3.16.0-1

ntfs-3g-2017.3.23-1

pciutils-3.6.4-1

redis-5.0.8-1

shared-mime-info-1.15-1

RevLine 
[7076]1%bcond_with externalfuse
2
[12370]3Summary:        Linux NTFS userspace driver
4Summary(ja):    Linux NTFS ユーザ空間ドライバ
5Name:           ntfs-3g
6Version:        2017.3.23
7Release:        1%{?_dist_release}
8Group:          System Environment/Base
9Vendor:         Project Vine
10Distribution:   Vine Linux
[7076]11
[12370]12License:        GPLv2+
13URL:            https://www.tuxera.com/community/open-source-ntfs-3g/
14Source0:        https://tuxera.com/opensource/ntfs-3g_ntfsprogs-%{version}.tgz
[7076]15Patch0:         ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
[12370]16Patch1:         check-mftmirr.patch
17Patch2:         ntfs-3g-big-sectors.patch
18# Fix for ntfsclone crash.
19# Discussed with upstream developer but not upstream yet, see:
20# https://bugzilla.redhat.com/show_bug.cgi?id=1601146#c4
21Patch3:         ntfsclone-full-clusters-bz1601146.patch
22# Upstream fix for CVE-2019-9755
23# https://sourceforge.net/p/ntfs-3g/ntfs-3g/ci/85c1634a26faa572d3c558d4cf8aaaca5202d4e9/
24Patch4:         ntfs-3g-CVE-2019-9755.patch
[7076]25
[12370]26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
[521]27
[7076]28BuildRequires:  libtool
29BuildRequires:  libattr-devel
[10698]30%if %{?_dist_release} != "vl6"
[7076]31BuildRequires:  libconfig-devel
[10698]32%endif
[7076]33BuildRequires:  libgcrypt-devel
34BuildRequires:  gnutls-devel
35BuildRequires:  libuuid-devel
36%if %{with externalfuse}
37BuildRequires:  fuse-devel
38Requires:       fuse
39%endif
40
[521]41%description
[9526]42NTFS-3G is a stable, open source, GPL licensed, POSIX, read/write NTFS
43driver for Linux and many other operating systems. It provides safe
44handling of the Windows XP, Windows Server 2003, Windows 2000, Windows
45Vista, Windows Server 2008 and Windows 7 NTFS file systems. NTFS-3G can
46create, remove, rename, move files, directories, hard links, and streams;
47it can read and write normal and transparently compressed files, including
48streams and sparse files; it can handle special files like symbolic links,
49devices, and FIFOs, ACL, extended attributes; moreover it provides full
50file access right and ownership support.
[521]51
52%package devel
53Summary:        Development files and libraries for ntfs-3g
54Summary(ja):    ntfs-3g の開発ファイルとライブラリ
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
[9526]57Requires:       pkgconfig
[7076]58Provides:       ntfsprogs-devel = %{version}-%{release}
59Obsoletes:      ntfsprogs-devel < 2.0.0-3
[521]60
61%description devel
62Headers and libraries for developing applications that use ntfs-3g
63functionality.
64
[7076]65%package -n ntfsprogs
66Summary:        NTFS filesystem libraries and utilities
67Summary(ja):    NTFS ファイルシステム用ライブラリおよびユーティリティ
68Group:          System Environment/Base
69Provides:       ntfsprogs-gnomevfs = %{version}-%{release}
70Obsoletes:      ntfsprogs-gnomevfs < 2.0.0-3
71
72%description -n ntfsprogs
73The ntfsprogs package currently consists of a library and utilities
74such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
75(for a full list of included utilities see man 8 ntfsprogs after
76installation).
77
78
[521]79%prep
[7076]80%setup -q -n %{name}_ntfsprogs-%{version}
81%patch0 -p1 -b .unsupported
[12370]82%patch1 -p0 -b .check-mftmirr
83%patch2 -p0 -b .big-sectors
84%patch3 -p0 -b .ntfsclone
85%patch4 -p1 -b .CVE-2019-9755
[521]86
87%build
[12370]88export CFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64"
89%configure \
90                --disable-static \
91                --disable-ldconfig \
92%if %{with externalfuse}
93                --with-fuse=external \
94%endif
95                --exec-prefix=/ \
96                --bindir=/bin \
97                --sbindir=/sbin \
98                --libdir=/%{_lib} \
99                --enable-posix-acls \
100                --enable-xattr-mappings \
101                --enable-crypto \
102                --enable-extras \
103                --enable-quarantined
[9526]104
[7076]105make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
[521]106
107%install
108rm -rf $RPM_BUILD_ROOT
[7076]109make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
[9550]110
[7076]111rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
[9550]112rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.{la,a}
[521]113
[9550]114mkdir -p $RPM_BUILD_ROOT/sbin
[521]115
[9550]116# make the symlink an actual copy to avoid confusion
117rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
118cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
119
[521]120# make compatibility symlinks
[9550]121ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
122ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
123ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
124ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
125mkdir -p $RPM_BUILD_ROOT%{_bindir}
126ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
127ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
[521]128
[9550]129# Put the .pc file in the right place.
130mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
131mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
[521]132
[9526]133# We get this on our own, thanks.
134rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
[7076]135
[521]136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post -p /sbin/ldconfig
140
141%postun -p /sbin/ldconfig
142
143%files
144%defattr(-,root,root,-)
[12370]145%license COPYING
146%doc AUTHORS ChangeLog CREDITS NEWS README
[9550]147/sbin/mount.ntfs
148%attr(4754,root,root) /sbin/mount.ntfs-3g
149/sbin/mount.ntfs-fuse
150/sbin/mount.lowntfs-3g
151/bin/lowntfs-3g
152/bin/ntfs-3g
153/bin/ntfs-3g.probe
154/bin/ntfsmount
[521]155%{_bindir}/ntfs-3g
156%{_bindir}/ntfsmount
[9550]157/%{_lib}/libntfs-3g.so.*
[7076]158%{_mandir}/man8/mount.lowntfs-3g.*
159%{_mandir}/man8/mount.ntfs-3g.*
160%{_mandir}/man8/ntfs-3g*
[521]161
162%files devel
163%defattr(-,root,root,-)
164%{_includedir}/ntfs-3g/
[9550]165/%{_lib}/libntfs-3g.so
[521]166%{_libdir}/pkgconfig/*.pc
167
[7076]168%files -n ntfsprogs
[12370]169%license COPYING
170%doc AUTHORS CREDITS ChangeLog NEWS README
[9550]171/bin/ntfscat
172/bin/ntfscluster
173/bin/ntfscmp
174/bin/ntfsfix
175/bin/ntfsinfo
176/bin/ntfsls
[12370]177/bin/ntfssecaudit
178/bin/ntfsusermap
[7076]179# extras
[9550]180/bin/ntfsck
181/bin/ntfsdecrypt
182/bin/ntfsdump_logfile
183/bin/ntfsfallocate
184/bin/ntfsmftalloc
185/bin/ntfsmove
[10698]186/bin/ntfsrecover
[9550]187/bin/ntfstruncate
188/bin/ntfswipe
189/sbin/fsck.ntfs
190/sbin/mkfs.ntfs
191/sbin/mkntfs
192/sbin/ntfsclone
193/sbin/ntfscp
194/sbin/ntfslabel
195/sbin/ntfsresize
196/sbin/ntfsundelete
[7076]197%{_mandir}/man8/mkntfs.8*
198%{_mandir}/man8/mkfs.ntfs.8*
199%{_mandir}/man8/ntfs[^m][^o]*.8*
[9526]200%exclude %{_mandir}/man8/ntfs-3g*
[7076]201
[521]202%changelog
[12370]203* Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2017.3.23-1
204- new upstream release.
205- imported Patch1-4 from rawhide.
206
[10698]207* Mon Jul 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016.2.22-1
208- new upstream release.
209
[9906]210* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015.3.14-3
211- rebuilt with gnutls-3.4.x.
212
[9550]213* Fri May  8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-2
214- reverted file location <Vine Linux:2914>
215
[9526]216* Fri Apr 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-1
217- new upstream release
218- dropt hal files, since hal is very old
219
[8285]220* Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
221- new upstream release
222
[8283]223* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
224- rebuilt with gnutls-3.2 and libgcrypt-1.6
225
[7478]226* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
227- new upstream release
228
[7076]229* Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
230- new upstream release
231- merge ntfsprogs
232  - add Obsoletes and Provides ntfsprogs*
233  - add BR: for ntfsprogs
234
[2782]235* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
236- new upstream release
237- fix %%files (add lowntfs-3g)
238
[521]239* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
240- new upstream release
241- use internal fuse-lite, remove BR: fuse-devel and R: fuse
242- move binaries to /bin
243- move libraries to /%%{_lib}
244- add fdi file to enable hal automounting
245
246* Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
247- new upstream release
248
249* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
250- new upstream release
251
252* Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
253- new upstream release
254
255* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
256- new upstream release
257
258* Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
259- initial build for Vine Linux
260
261* Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
262- bump to 1.516
263- fix bugzilla 232031
264
265* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
266- bump to 1.417
267
268* Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
269- bump to 1.416
270- drop patch0, upstreamed
271
272* Wed Apr  4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
273- allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
274
275* Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
276- bump to 1.328
277- drop patch, use --disable-ldconfig instead
278
279* Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
280- 1.0 release!
281
282* Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
283- symlink to mount.ntfs
284
285* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
286- bump to 20070118
287
288* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
289- bump to latest version for all active dists
290
291* Wed Jan  3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
292- bump to latest version (note that upstream fixed their date mistake)
293
294* Wed Nov  1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
295- add an obsoletes for ntfsprogs-fuse
296- make some convenience symlinks
297
298* Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
299- add some extra Provides
300
301* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
302- add explicit Requires on fuse
303
304* Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
305- fixed versioning (bumped epoch, since it now shows as older)
306- change sbin symlink to actual copy to be safe
307
308* Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
309- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.