source: projects/specs/trunk/n/nss_db/nss_db-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define db_version 4.0.14
2
3Summary:     An NSS library for the Berkeley DB.
4Summary(ja): Berkeley DB ÍÑ NSS ¥é¥¤¥Ö¥é¥ê
5Name:        nss_db
6Version:     2.2
7Release:     17vl1
8
9Source: ftp://sources.redhat.com/pub/glibc/releases/nss_db-%{version}.tar.gz
10Source1: http://www.sleepycat.com/update/%{db_version}/db-%{db_version}.tar.gz
11
12URL:         http://sources.redhat.com/glibc/
13Patch0:      nss_db-2.2-external.patch
14Patch1:      nss_db-2.2-compat.patch
15License:     GPL
16Group:       System Environment/Libraries
17PreReq:      /sbin/ldconfig
18BuildPrereq: autoconf, automake15, libtool
19Conflicts:   glibc < 2.2
20Requires:    make
21BuildRoot:   %{_tmppath}/%{name}-%{version}-root
22
23%define __find_requires %{_builddir}/%{name}-%{version}/find-requires
24
25
26%description
27Nss_db is a set of C library extensions which allow Berkeley Databases
28to be used as a primary source of aliases, ethers, groups, hosts,
29networks, protocol, users, RPCs, services, and shadow passwords
30(instead of or in addition to using flat files or NIS). Install nss_db
31if your flat name service files are too large and lookups are slow.
32
33
34%package compat
35Summary: An NSS compatibility library for Berkeley Databases and glibc 2.0.x.
36Summary(ja): Berkeley DB ¤È glibc 2.0.x ÍÑ NSS ¸ß´¹¥é¥¤¥Ö¥é¥ê
37Group: System Environment/Libraries
38
39
40%description compat
41Nss_db-compat is a set of C library extensions which allow Berkeley
42Databases to be used as a primary source of aliases, ethers, groups,
43hosts, networks, protocol, users, RPCs, services, and shadow passwords
44(instead of or in addition to using flat files or NIS) from programs
45linked against glibc 2.0.x.
46
47
48%prep
49%setup -q -a 0 -a 1
50%patch0 -p1 -b .external
51libtoolize -f
52aclocal-1.5
53automake-1.5 -a
54autoconf
55
56mv %{name}-%{version} %{name}-compat-%{version}
57pushd %{name}-compat-%{version}
58%patch0 -p1 -b .external
59%patch1 -p1 -b .compat
60libtoolize -f
61aclocal-1.5
62automake-1.5 -a
63autoconf
64popd
65
66find_requires=`rpm --eval %%{__find_requires}`
67echo "$find_requires | grep -v GLIBC_PRIVATE" > find-requires
68chmod +x find-requires
69
70
71%build
72dbdir=`pwd`/db-instroot
73CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
74
75pushd db-%{db_version}/dist
76./configure --disable-shared --with-pic --with-uniquename=_nssdb --prefix=$dbdir
77make
78make install
79popd
80
81%configure --with-db=${dbdir}
82make
83
84pushd %{name}-compat-%{version}
85%configure --with-db=${dbdir}
86make
87popd
88
89
90%install
91[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
92install -m755 -d ${RPM_BUILD_ROOT}/{%{_lib},/var/db,%{_bindir}}
93install -m644 db-Makefile ${RPM_BUILD_ROOT}/var/db/Makefile
94install -m755 makedb ${RPM_BUILD_ROOT}/%{_bindir}/
95install -m755 .libs/libnss_db.so.[0-9]* ${RPM_BUILD_ROOT}/%{_lib}/
96pushd %{name}-compat-%{version}
97install -m755 .libs/libnss_db.so.[0-9]* ${RPM_BUILD_ROOT}/%{_lib}/
98popd
99
100
101%clean
102rm -rf ${RPM_BUILD_ROOT}
103
104
105%post -p /sbin/ldconfig
106
107
108%postun -p /sbin/ldconfig
109
110
111%files
112%defattr(-,root,root)
113%doc AUTHORS COPYING* ChangeLog NEWS README THANKS
114/%{_lib}/libnss_db*2.*
115%{_bindir}/makedb
116%config /var/db/*
117
118
119%ifnarch sparc64 ia64
120
121%files compat
122%defattr(-,root,root)
123/%{_lib}/libnss_db*1.*
124
125
126%post compat -p /sbin/ldconfig
127
128%postun compat -p /sbin/ldconfig
129
130%endif
131
132
133%changelog
134* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2-17vl1
135- based on 2.2-17 from Rawhide and built for Vine Linux
136
137* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
138- automated rebuild
139
140* Sun May 26 2002 Tim Powers <timp@redhat.com>
141- automated rebuild
142
143* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-15
144- rebuild in new environment
145
146* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-14
147- rebuild
148
149* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-13
150- whoops, __set_errno() is a glibc-internal symbol as well (#63373)
151
152* Wed Apr  3 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-12
153- filter out dependency on glibc private symbols
154
155* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-11
156- don't use libc-internal symbols and interfaces
157
158* Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-10
159- rebuild
160
161* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-9
162- rebuild
163
164* Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-8
165- build using a bundled Berkeley DB with a unique name to avoid possible symbol
166  collisions with binaries using different versions (mix multiple versions of
167  any shared library in a single process, observe as wackiness ensues)
168
169* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-7
170- rebuild against db4-devel
171
172* Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.2-6
173- require db3-devel at build-time, not db3 (#49544)
174
175* Tue May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
176- don't include copies of the shared libraries with the soname for their names
177
178* Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
179- rebuild in new environment
180
181* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
182- don't own /var/db, the filesystem package does
183
184* Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
185- require make (#27313)
186- add the docs to the package
187
188* Tue Dec 19 2000 Nalin Dahyabhai <nalin@redhat.com>
189- update to 2.2
190
191* Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
192- separate from db3
Note: See TracBrowser for help on using the repository browser.