source: projects/specs/trunk/n/nss/nss-vl.spec @ 10387

Revision 10387, 27.3 KB checked in by tomop, 8 years ago (diff)

nss-3.21.1-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define _unpackaged_files_terminate_build 1
4
5%define nspr_version 4.11
6%define unsupported_tools_directory %{_libdir}/nss/unsupported-tools
7
8# Produce .chk files for the final stripped binaries
9#
10# NOTE: The LD_LIBRARY_PATH line guarantees shlibsign links
11# against the freebl that we just built. This is necessary
12# because the signing algorithm changed on 3.14 to DSA2 with SHA256
13# whereas we previously signed with DSA and SHA1. We must Keep this line
14# until all mock platforms have been updated.
15# After %%{__os_install_post} we would add
16# export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%%{_libdir}
17%define __spec_install_post \
18    %{?__debug_package:%{__debug_install_post}} \
19    %{__arch_install_post} \
20    %{__os_install_post} \
21    $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libsoftokn3.so \
22    $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libfreebl3.so \
23    $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libnssdbm3.so \
24%{nil}
25
26
27Summary:          Network Security Services
28Name:             nss
29Version:          3.21.1
30Release:          2%{?_dist_release}
31License:          MPLv1.1 or GPLv2+ or LGPLv2+
32URL:              http://www.mozilla.org/projects/security/pki/nss/
33Group:            System Environment/Libraries
34
35Source0:          %{name}-%{version}.tar.gz
36Source1:          nss.pc.in
37Source2:          nss-config.in
38Source3:          blank-cert8.db
39Source4:          blank-key3.db
40Source5:          blank-secmod.db
41Source6:          blank-cert9.db
42Source7:          blank-key4.db
43Source8:          system-pkcs11.txt
44Source12:         %{name}-pem-20140125.tar.bz2
45Source101:        nss-util.pc.in
46Source102:        nss-util-config.in
47Source103:        nss-softokn.pc.in
48Source104:        nss-softokn-config.in
49
50Patch2:           add-relro-linker-option.patch
51Patch3:           renegotiate-transitional.patch
52Patch6:           nss-enable-pem.patch
53Patch16:          nss-539183.patch
54Patch18:          nss-646045.patch
55# TODO: Remove this patch when the ocsp test are fixed
56Patch40:          nss-3.14.0.0-disble-ocsp-test.patch
57Patch50:          iquote.patch
58# As of nss-3.21 we compile NSS with -Werror.
59# see https://bugzilla.mozilla.org/show_bug.cgi?id=1182667
60# This requires a cleanup of the PEM module as we have it here.
61# TODO: submit a patch to the interim nss-pem upstream project
62# The submission will be very different from this patch as
63# cleanup there is already in progress there.
64Patch51:          pem-compile-with-Werror.patch
65Patch52:          Bug-1001841-disable-sslv2-libssl.patch
66Patch53:          Bug-1001841-disable-sslv2-tests.patch
67Patch54:          sslauth-no-v2.patch
68Patch55:          enable-fips-when-system-is-in-fips-mode.patch
69# rhbz: https://bugzilla.redhat.com/show_bug.cgi?id=1026677
70Patch56:          p-ignore-setpolicy.patch
71# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=943144
72Patch62: nss-fix-deadlock-squash.patch
73# Two patches from from rhel6.8 that are also needed for rhel-7
74# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1054373
75Patch74: race.patch
76Patch94: nss-3.16-token-init-race.patch
77Patch99: ssl-server-min-key-sizes.patch
78Patch100: fix-min-library-version-in-SSLVersionRange.patch
79# Add support for sha384 tls cipher suites, dss cipher suites, and
80# server-side dhe key exchange
81# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=102794
82# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
83# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
84Patch101: dhe-sha384-dss-support.patch
85# TODO: From upstream review: For the client authentication case, should
86# probably drop our hack of swapping between sha256 and sha384 and plan
87# on implementing the fix we already have a patch for. What is that fix?
88Patch102: client_auth_for_sha384_prf_support.patch
89Patch103: nss-fix-client-auth-init-hashes.patch
90Patch104: nss-map-oid-to-hashalg.patch
91Patch105: nss-remove-bogus-assert.patch
92Patch106: nss-old-pkcs11-num.patch
93Patch107: nss-enable-384-cipher-tests.patch
94Patch108: nss-sni-c-v-fix.patch
95Patch109: nss-fix-signature-and-hash.patch
96Patch110: nss-sslstress-txt-ssl3-lower-value-in-range.patch
97
98# Enable by default two additional ciphers and fix order of two tables
99# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
100# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
101# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1211403
102Patch112: rh1238290.patch
103# Local: keep as long nss-softokn lacks support
104Patch113: disable-extended-master-secret-with-old-softoken.patch
105# extra tests needed
106Patch114: tests-extra.patch
107Patch115: nss-prevent-abi-issue.patch
108Patch116: nss-tests-prevent-abi-issue.patch
109Patch117: fix-nss-test-filtering.patch
110Patch118: fix-allowed-sig-alg.patch
111Patch119: nss-ssl-ssl3con-delete-duplicates.patch
112
113# Local patches
114Patch1002: hasht-dont-include-prtypes.patch
115Patch1007: pkcs1sig-include-prtypes.patch
116# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
117# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
118Patch1008: nss-util-3.19.1-tls12-mechanisms.patch
119
120
121
122BuildRoot:        %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
123BuildRequires:    nspr-devel >= %{nspr_version}
124BuildRequires:    sqlite3-devel
125BuildRequires:    zlib-devel
126BuildRequires:    pkgconfig
127BuildRequires:    gawk
128BuildRequires:    psmisc
129BuildRequires:    perl
130Provides:         mozilla-nss
131Obsoletes:        mozilla-nss
132Requires:         nspr >= %{nspr_version}
133
134%description
135Network Security Services (NSS) is a set of libraries designed to
136support cross-platform development of security-enabled client and
137server applications. Applications built with NSS can support SSL v2
138and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
139v3 certificates, and other security standards.
140
141
142%package tools
143Summary:          Tools for the Network Security Services
144Group:            System Environment/Base
145Requires:         nss = %{version}-%{release}
146
147%description tools
148Network Security Services (NSS) is a set of libraries designed to
149support cross-platform development of security-enabled client and
150server applications. Applications built with NSS can support SSL v2
151and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
152v3 certificates, and other security standards.
153
154Install the nss-tools package if you need command-line tools to
155manipulate the NSS certificate and key database.
156
157
158%package devel
159Summary:          Development libraries for Network Security Services
160Group:            Development/Libraries
161Requires:         nss = %{version}-%{release}
162Requires:         nspr-devel >= %{nspr_version}
163Provides:         mozilla-nss-devel
164Obsoletes:        mozilla-nss-devel
165
166%description devel
167Header and Library files for doing development with Network Security Services.
168
169
170%package pkcs11-devel
171Summary:          Development libraries for PKCS #11 (Cryptoki) using NSS
172Group:            Development/Libraries
173Requires:         nss-devel = %{version}-%{release}
174
175%description pkcs11-devel
176Library files for developing PKCS #11 modules using basic NSS
177low level services.
178
179
180## to build compat32 for x86_64 architecture support
181%package -n compat32-%{name}
182Summary:          Network Security Services
183Group: System Environment/Libraries
184
185%description -n compat32-%{name}
186Network Security Services (NSS) is a set of libraries designed to
187support cross-platform development of security-enabled client and
188server applications. Applications built with NSS can support SSL v2
189and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
190v3 certificates, and other security standards.
191
192
193%prep
194%setup -q
195%setup -q -T -D -n %{name}-%{version} -a 12
196
197%patch2 -p0 -b .relro
198%patch3 -p0 -b .transitional
199%patch6 -p0 -b .libpem
200%patch16 -p0 -b .539183
201pushd nss
202%patch18 -p1 -b .646045
203popd
204%patch40 -p0 -b .noocsptest
205%patch50 -p0 -b .iquote
206%patch51 -p1 -b -Werror
207pushd nss
208%patch52 -p1 -b .disableSSL2libssl
209%patch53 -p1 -b .disableSSL2tests
210%patch54 -p1 -b .sslauth-no-v2
211%patch55 -p1 -b .852023_enable_fips_when_in_fips_mode
212%patch56 -p1 -b .1026677_ignore_set_policy
213%patch62 -p1 -b .fix_deadlock
214%patch99 -p1 -b .min_key_sizes
215%patch100 -p0 -b .1171318
216%patch101 -p1 -b .dhe_and_sha384
217%patch102 -p1 -b .client_auth_prf
218%patch112 -p1 -b .1238290
219%patch113 -p1 -b .disable-ems
220%patch114 -p1 -b .extra
221%patch115 -p1 -b .abi_lib
222%patch116 -p1 -b .abi_tests
223%patch117 -p1 -b .test-filtering
224%patch74 -p1 -b .race
225popd
226%patch94 -p0 -b .init-token-race
227%patch103 -p0 -b .fix_client_auth_crash
228%patch104 -p0 -b .use_oids
229%patch105 -p0 -b .remove_bogus_assert
230%patch106 -p0 -b .old_pkcs11_num
231%patch107 -p0 -b .enable_384_cipher_tests
232%patch108 -p0 -b .sni_c_v_fix
233%patch109 -p0 -b .fix_signature_and_hash
234%patch110 -p0 -b .no_ssl2
235pushd nss
236%patch118 -p1 -b .allowed-sig-alg
237popd
238%patch119 -p0 -b .delete_duplicates
239
240%patch1002 -p0 -b .prtypes
241%patch1007 -p0 -b .include_prtypes
242%patch1008 -p1 -b .tls12_mechs
243
244
245pemNeedsFromSoftoken="lowkeyi lowkeyti softoken softoknt"
246for file in ${pemNeedsFromSoftoken}; do
247    %{__cp} ./nss/lib/softoken/${file}.h ./nss/lib/ckfw/pem/
248done
249%{__cp} ./nss/lib/softoken/lowkeyi.h ./nss/cmd/rsaperf
250%{__cp} ./nss/lib/softoken/lowkeyti.h ./nss/cmd/rsaperf
251
252pushd nss/tests/ssl
253# Create versions of sslcov.txt and sslstress.txt that disable tests
254# for SSL2 and EXPORT ciphers.
255cat sslcov.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslcov.noSSL2orExport.txt
256cat sslstress.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslstress.noSSL2orExport.txt
257popd
258
259%build
260
261export NSS_NO_SSL2=1
262
263NSS_NO_PKCS11_BYPASS=1
264export NSS_NO_PKCS11_BYPASS
265
266# partial RELRO support as a security enhancement
267LDFLAGS+=-Wl,-z,relro
268export LDFLAGS
269
270FREEBL_NO_DEPEND=1
271export FREEBL_NO_DEPEND
272
273# Must export FREEBL_LOWHASH=1 for nsslowhash.h so that it gets
274# copied to dist and the rpm install phase can find it
275# This due of the upstream changes to fix
276# https://bugzilla.mozilla.org/show_bug.cgi?id=717906
277FREEBL_LOWHASH=1
278export FREEBL_LOWHASH
279
280# Enable compiler optimizations and disable debugging code
281BUILD_OPT=1
282export BUILD_OPT
283
284# Generate symbolic info for debuggers
285XCFLAGS=$RPM_OPT_FLAGS
286export XCFLAGS
287
288PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
289PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
290
291export PKG_CONFIG_ALLOW_SYSTEM_LIBS
292export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS
293
294NSPR_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nspr | sed 's/-I//'`
295NSPR_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nspr | sed 's/-L//'`
296
297export NSPR_INCLUDE_DIR
298export NSPR_LIB_DIR
299
300#export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
301#export FREEBL_LIB_DIR=%{_libdir}
302export USE_SYSTEM_FREEBL=0
303
304NSS_USE_SYSTEM_SQLITE=1
305export NSS_USE_SYSTEM_SQLITE
306
307export USE_SYSTEM_ZLIB=1
308export ZLIB_LIBS=%{_libdir}
309
310%ifarch x86_64 ppc64 ia64 s390x
311USE_64=1
312export USE_64
313%endif
314
315# uncomment if the iquote patch is activated
316export IN_TREE_FREEBL_HEADERS_FIRST=1
317
318#export NSS_BLTEST_NOT_AVAILABLE=1
319#
320#%{__make} -C ./nss/coreconf
321#%{__make} -C ./nss/lib/dbm
322%{__make} -C ./nss
323
324
325%install
326
327# There is no make install target so we'll do it ourselves.
328
329%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3
330%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3/templates
331%{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
332%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}
333%{__mkdir_p} $RPM_BUILD_ROOT/%{unsupported_tools_directory}
334%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
335
336# Copy the binary libraries we want
337for file in libsoftokn3.so libfreebl3.so libnss3.so libnssutil3.so \
338            libssl3.so libsmime3.so libnssckbi.so libnsspem.so libnssdbm3.so
339do
340  %{__install} -m 755 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
341done
342
343# Install the empty NSS db files
344# Legacy db
345%{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb
346%{__install} -m 644 %{SOURCE3} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert8.db
347%{__install} -m 644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key3.db
348%{__install} -m 644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/secmod.db
349# Shared db
350%{__install} -p -m 644 %{SOURCE6} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert9.db
351%{__install} -p -m 644 %{SOURCE7} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key4.db
352%{__install} -p -m 644 %{SOURCE8} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/pkcs11.txt
353
354
355# Copy the development libraries we want
356for file in libcrmf.a libnssb.a libnssckfw.a
357do
358  %{__install} -m 644 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
359done
360
361# Copy the binaries we want
362for file in certutil cmsutil crlutil modutil pk12util signtool signver ssltap
363do
364  %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{_bindir}
365done
366
367# Copy the binaries we ship as unsupported
368for file in atob btoa derdump ocspclnt pp selfserv shlibsign strsclnt symkeyutil tstclnt vfyserv vfychain
369do
370  %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{unsupported_tools_directory}
371done
372
373# Copy the include files
374for file in dist/public/nss/*.h
375do
376  %{__install} -m 644 $file $RPM_BUILD_ROOT/%{_includedir}/nss3
377done
378
379# Copy some freebl include files we also want
380for file in blapi.h alghmac.h
381do
382  %{__install} -p -m 644 dist/private/nss/$file $RPM_BUILD_ROOT/%{_includedir}/nss3
383done
384
385# Set up our package file
386%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
387%{__cat} %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \
388                          -e "s,%%prefix%%,%{_prefix},g" \
389                          -e "s,%%exec_prefix%%,%{_prefix},g" \
390                          -e "s,%%includedir%%,%{_includedir}/nss3,g" \
391                          -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
392                          -e "s,%%NSS_VERSION%%,%{version},g" \
393                          -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
394                          $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss.pc
395
396NSS_VMAJOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
397NSS_VMINOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
398NSS_VPATCH=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
399
400export NSS_VMAJOR
401export NSS_VMINOR
402export NSS_VPATCH
403
404%{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
405%{__cat} %{SOURCE2} | sed -e "s,@libdir@,%{_libdir},g" \
406                          -e "s,@prefix@,%{_prefix},g" \
407                          -e "s,@exec_prefix@,%{_prefix},g" \
408                          -e "s,@includedir@,%{_includedir}/nss3,g" \
409                          -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
410                          -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
411                          -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
412                          > $RPM_BUILD_ROOT/%{_bindir}/nss-config
413
414chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-config
415
416%{__cat} %{SOURCE101} | sed -e "s,%%libdir%%,%{_libdir},g" \
417                          -e "s,%%prefix%%,%{_prefix},g" \
418                          -e "s,%%exec_prefix%%,%{_prefix},g" \
419                          -e "s,%%includedir%%,%{_includedir}/nss3,g" \
420                          -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
421                          -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
422                          $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-util.pc
423
424NSSUTIL_VMAJOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMAJOR" | awk '{print $3}'`
425NSSUTIL_VMINOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMINOR" | awk '{print $3}'`
426NSSUTIL_VPATCH=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VPATCH" | awk '{print $3}'`
427
428export NSSUTIL_VMAJOR
429export NSSUTIL_VMINOR
430export NSSUTIL_VPATCH
431
432%{__cat} %{SOURCE102} | sed -e "s,@libdir@,%{_libdir},g" \
433                          -e "s,@prefix@,%{_prefix},g" \
434                          -e "s,@exec_prefix@,%{_prefix},g" \
435                          -e "s,@includedir@,%{_includedir}/nss3,g" \
436                          -e "s,@MOD_MAJOR_VERSION@,$NSSUTIL_VMAJOR,g" \
437                          -e "s,@MOD_MINOR_VERSION@,$NSSUTIL_VMINOR,g" \
438                          -e "s,@MOD_PATCH_VERSION@,$NSSUTIL_VPATCH,g" \
439                          > $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
440
441chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
442
443%{__cat} %{SOURCE103} | sed -e "s,%%libdir%%,%{_libdir},g" \
444                          -e "s,%%prefix%%,%{_prefix},g" \
445                          -e "s,%%exec_prefix%%,%{_prefix},g" \
446                          -e "s,%%includedir%%,%{_includedir}/nss3,g" \
447                          -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
448                          -e "s,%%NSSUTIL_VERSION%%,%{version},g" \
449                          -e "s,%%SOFTOKEN_VERSION%%,%{version},g" > \
450                          $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-softokn.pc
451
452SOFTOKEN_VMAJOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMAJOR" | awk '{print $3}'`
453SOFTOKEN_VMINOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMINOR" | awk '{print $3}'`
454SOFTOKEN_VPATCH=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VPATCH" | awk '{print $3}'`
455
456export SOFTOKEN_VMAJOR
457export SOFTOKEN_VMINOR
458export SOFTOKEN_VPATCH
459
460%{__cat} %{SOURCE104} | sed -e "s,@libdir@,%{_libdir},g" \
461                          -e "s,@prefix@,%{_prefix},g" \
462                          -e "s,@exec_prefix@,%{_prefix},g" \
463                          -e "s,@includedir@,%{_includedir}/nss3,g" \
464                          -e "s,@MOD_MAJOR_VERSION@,$SOFTOKEN_VMAJOR,g" \
465                          -e "s,@MOD_MINOR_VERSION@,$SOFTOKEN_VMINOR,g" \
466                          -e "s,@MOD_PATCH_VERSION@,$SOFTOKEN_VPATCH,g" \
467                          > $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
468
469chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
470
471
472%clean
473%{__rm} -rf $RPM_BUILD_ROOT
474
475
476%post
477/sbin/ldconfig >/dev/null 2>/dev/null
478
479%postun
480/sbin/ldconfig >/dev/null 2>/dev/null
481
482
483%files
484%defattr(-,root,root)
485%{_libdir}/libnss3.so
486%{_libdir}/libnssutil3.so
487%{_libdir}/libnssdbm3.so
488%{_libdir}/libssl3.so
489%{_libdir}/libsmime3.so
490%{_libdir}/libsoftokn3.so
491%{_libdir}/libnssckbi.so
492%{_libdir}/libnsspem.so
493%{_libdir}/libfreebl3.so
494%{unsupported_tools_directory}/shlibsign
495%{_libdir}/libfreebl3.chk
496%{_libdir}/libnssdbm3.chk
497%{_libdir}/libsoftokn3.chk
498%dir %{_sysconfdir}/pki/nssdb
499%config(noreplace) %{_sysconfdir}/pki/nssdb/cert8.db
500%config(noreplace) %{_sysconfdir}/pki/nssdb/key3.db
501%config(noreplace) %{_sysconfdir}/pki/nssdb/secmod.db
502%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/cert9.db
503%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/key4.db
504%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/pkcs11.txt
505
506%files tools
507%defattr(-,root,root)
508%{_bindir}/certutil
509%{_bindir}/cmsutil
510%{_bindir}/crlutil
511%{_bindir}/modutil
512%{_bindir}/pk12util
513%{_bindir}/signtool
514%{_bindir}/signver
515%{_bindir}/ssltap
516%{unsupported_tools_directory}/atob
517%{unsupported_tools_directory}/btoa
518%{unsupported_tools_directory}/derdump
519%{unsupported_tools_directory}/ocspclnt
520%{unsupported_tools_directory}/pp
521%{unsupported_tools_directory}/selfserv
522%{unsupported_tools_directory}/strsclnt
523%{unsupported_tools_directory}/symkeyutil
524%{unsupported_tools_directory}/tstclnt
525%{unsupported_tools_directory}/vfyserv
526%{unsupported_tools_directory}/vfychain
527
528
529%files devel
530%defattr(-,root,root)
531%{_libdir}/libcrmf.a
532%{_libdir}/pkgconfig/nss.pc
533%{_libdir}/pkgconfig/nss-softokn.pc
534%{_libdir}/pkgconfig/nss-util.pc
535%{_bindir}/nss-config
536%{_bindir}/nss-softokn-config
537%{_bindir}/nss-util-config
538
539%dir %{_includedir}/nss3
540%{_includedir}/nss3/alghmac.h
541%{_includedir}/nss3/base64.h
542%{_includedir}/nss3/blapi.h
543%{_includedir}/nss3/blapit.h
544%{_includedir}/nss3/cert.h
545%{_includedir}/nss3/certdb.h
546%{_includedir}/nss3/certt.h
547%{_includedir}/nss3/ciferfam.h
548%{_includedir}/nss3/cmmf.h
549%{_includedir}/nss3/cmmft.h
550%{_includedir}/nss3/cms.h
551%{_includedir}/nss3/cmsreclist.h
552%{_includedir}/nss3/cmst.h
553%{_includedir}/nss3/crmf.h
554%{_includedir}/nss3/crmft.h
555%{_includedir}/nss3/cryptohi.h
556%{_includedir}/nss3/cryptoht.h
557%{_includedir}/nss3/ecl-exp.h
558%{_includedir}/nss3/hasht.h
559%{_includedir}/nss3/jar-ds.h
560%{_includedir}/nss3/jar.h
561%{_includedir}/nss3/jarfile.h
562%{_includedir}/nss3/key.h
563%{_includedir}/nss3/keyhi.h
564%{_includedir}/nss3/keyt.h
565%{_includedir}/nss3/keythi.h
566%{_includedir}/nss3/nss.h
567%{_includedir}/nss3/nssb64.h
568%{_includedir}/nss3/nssb64t.h
569%{_includedir}/nss3/nssckbi.h
570%{_includedir}/nss3/nssilckt.h
571%{_includedir}/nss3/nssilock.h
572%{_includedir}/nss3/nsslocks.h
573%{_includedir}/nss3/nsslowhash.h
574%{_includedir}/nss3/nsspem.h
575%{_includedir}/nss3/nssrwlk.h
576%{_includedir}/nss3/nssrwlkt.h
577%{_includedir}/nss3/nssutil.h
578%{_includedir}/nss3/ocsp.h
579%{_includedir}/nss3/ocspt.h
580%{_includedir}/nss3/p12.h
581%{_includedir}/nss3/p12plcy.h
582%{_includedir}/nss3/p12t.h
583%{_includedir}/nss3/pk11func.h
584%{_includedir}/nss3/pk11pqg.h
585%{_includedir}/nss3/pk11priv.h
586%{_includedir}/nss3/pk11pub.h
587%{_includedir}/nss3/pk11sdr.h
588%{_includedir}/nss3/pkcs11.h
589%{_includedir}/nss3/pkcs11f.h
590%{_includedir}/nss3/pkcs11n.h
591%{_includedir}/nss3/pkcs11p.h
592%{_includedir}/nss3/pkcs11t.h
593%{_includedir}/nss3/pkcs11u.h
594%{_includedir}/nss3/pkcs12.h
595%{_includedir}/nss3/pkcs12t.h
596%{_includedir}/nss3/pkcs7t.h
597%{_includedir}/nss3/pkcs1sig.h
598%{_includedir}/nss3/portreg.h
599%{_includedir}/nss3/preenc.h
600%{_includedir}/nss3/secasn1.h
601%{_includedir}/nss3/secasn1t.h
602%{_includedir}/nss3/seccomon.h
603%{_includedir}/nss3/secder.h
604%{_includedir}/nss3/secdert.h
605%{_includedir}/nss3/secdig.h
606%{_includedir}/nss3/secdigt.h
607%{_includedir}/nss3/secerr.h
608%{_includedir}/nss3/sechash.h
609%{_includedir}/nss3/secitem.h
610%{_includedir}/nss3/secmime.h
611%{_includedir}/nss3/secmod.h
612%{_includedir}/nss3/secmodt.h
613%{_includedir}/nss3/secoid.h
614%{_includedir}/nss3/secoidt.h
615%{_includedir}/nss3/secpkcs5.h
616%{_includedir}/nss3/secpkcs7.h
617%{_includedir}/nss3/secport.h
618%{_includedir}/nss3/shsign.h
619%{_includedir}/nss3/smime.h
620%{_includedir}/nss3/ssl.h
621%{_includedir}/nss3/sslerr.h
622%{_includedir}/nss3/sslproto.h
623%{_includedir}/nss3/sslt.h
624%{_includedir}/nss3/utilrename.h
625%{_includedir}/nss3/utilmodt.h
626%{_includedir}/nss3/utilpars.h
627%{_includedir}/nss3/utilparst.h
628         
629
630%files pkcs11-devel
631%defattr(-, root, root)
632%{_includedir}/nss3/nssbase.h
633%{_includedir}/nss3/nssbaset.h
634%{_includedir}/nss3/nssckepv.h
635%{_includedir}/nss3/nssckft.h
636%{_includedir}/nss3/nssckfw.h
637%{_includedir}/nss3/nssckfwc.h
638%{_includedir}/nss3/nssckfwt.h
639%{_includedir}/nss3/nssckg.h
640%{_includedir}/nss3/nssckmdt.h
641%{_includedir}/nss3/nssckt.h
642%{_libdir}/libnssb.a
643%{_libdir}/libnssckfw.a
644
645
646## to build compat32 for x86_64 architecture support
647%if %{build_compat32}
648%files -n compat32-%{name}
649%defattr(-,root,root)
650%{_libdir}/*.so
651%ghost %{_libdir}/libsoftokn3.chk
652%ghost %{_libdir}/libfreebl3.chk
653%{unsupported_tools_directory}/shlibsign
654%endif
655
656
657%changelog
658* Mon Jun 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.21.1-2
659- enabled softokn and freebl.
660- dropped Patch47 and Patch49.
661
662* Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.21.1-1
663- update to 3.21.1
664- import patches from centos package
665
666* Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.16.1-1
667- update to 3.16.1
668
669* Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.3-1
670- update to 3.14.3
671- import patches from fedora package
672
673* Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.1-1
674- update to 3.14.1
675
676* Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.6-2
677- add Source101 (nss-util.pc.in)
678- add Source102 (nss-util-config.in)
679
680* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.6-1
681- new upstream release
682
683* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.3-1
684- new upstream release
685
686* Thu Dec 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-2
687- fix nss.pc
688
689* Wed Dec 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-1
690- new upstream release
691
692* Fri Sep 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.11-1
693- new upstram release
694
695* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.10-1
696- update to 3.12.10
697
698* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.9-1
699- update to 3.12.9.with.ckbi.1.82
700- update nss-pem source
701- define NSS_USE_SYSTEM_SQLITE, remove unneeded Patch2
702
703* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-2
704- rebuild with rpm-4.8.1 for pkg-config file
705
706* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12.6-1
707- new upstream release
708- update nss-pem Source12 to 20091210 (from 3.12.6-2.fc14)
709
710* Sat Jan 23 2010 NAKAMURA Kenta <kenta@vinelinux.org> 3.12.5-2
711- built with FREEBL_NO_DEPEND environmental variable to include nsslowhash.h
712
713* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.5-1
714- new upstream release
715
716* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-4
717- rebuild to fix the package built with broken environment.
718
719* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-3
720- fixed %%files for compat32
721
722* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-2
723- added compat32 subpackages
724
725* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-1
726- new upstream release
727
728* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
729- new upstream release
730
731* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.11.4-0vl1
732- initial build for Vine Linux
733
734* Fri Mar 02 2007 Kai Engert <kengert@redhat.com> - 3.11.5-2
735- Fix rhbz#230545, failure to enable FIPS mode
736- Fix rhbz#220542, make NSS more tolerant of resets when in the
737  middle of prompting for a user password.
738
739* Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 3.11.5-1
740- Update to 3.11.5
741- This update fixes two security vulnerabilities with SSL 2
742- Do not use -rpath link option
743- Added several unsupported tools to tools package
744
745* Tue Jan  9 2007 Bob Relyea <rrelyea@redhat.com> - 3.11.4-4
746- disable ECC, cleanout dead code
747
748* Tue Nov 28 2006 Kai Engert <kengert@redhat.com> - 3.11.4-1
749- Update to 3.11.4
750
751* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-2
752- Revert the attempt to require latest NSPR, as it is not yet available
753  in the build infrastructure.
754
755* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-1
756- Update to 3.11.3
757
758* Thu Aug 03 2006 Kai Engert <kengert@redhat.com> - 3.11.2-2
759- Add /etc/pki/nssdb
760
761* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.11.2-1.1
762- rebuild
763
764* Fri Jun 30 2006 Kai Engert <kengert@redhat.com> - 3.11.2-1
765- Update to 3.11.2
766- Enable executable bit on shared libs, also fixes debug info.
767
768* Wed Jun 14 2006 Kai Engert <kengert@redhat.com> - 3.11.1-2
769- Enable Elliptic Curve Cryptography (ECC)
770
771* Fri May 26 2006 Kai Engert <kengert@redhat.com> - 3.11.1-1
772- Update to 3.11.1
773- Include upstream patch to limit curves
774
775* Wed Feb 15 2006 Kai Engert <kengert@redhat.com> - 3.11-4
776- add --noexecstack when compiling assembler on x86_64
777
778* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.2
779- bump again for double-long bug on ppc(64)
780
781* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.1
782- rebuilt for new gcc4.1 snapshot and glibc changes
783
784* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 3.11-3
785- rebuild
786
787* Fri Dec 16 2005 Christopher Aillon <caillon@redhat.com> 3.11-2
788- Update file list for the devel packages
789
790* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-1
791- Update to 3.11
792
793* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs.2
794- Add patch to allow building on ppc*
795- Update the pkgconfig file to Require nspr
796
797* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs
798- Initial import into Fedora Core, based on a CVS snapshot of
799  the NSS_3_11_RTM tag
800- Fix up the pkcs11-devel subpackage to contain the proper headers
801- Build with RPM_OPT_FLAGS
802- No need to have rpath of /usr/lib in the pc file
803
804* Thu Dec 15 2005 Kai Engert <kengert@redhat.com>
805- Adressed review comments by Wan-Teh Chang, Bob Relyea,
806  Christopher Aillon.
807
808* Sat Jul  9 2005 Rob Crittenden <rcritten@redhat.com> 3.10-1
809- Initial build
Note: See TracBrowser for help on using the repository browser.