source: projects/specs/trunk/n/nss-pam-ldapd/nss-pam-ldapd-vl.spec @ 11965

Revision 11965, 16.3 KB checked in by tomop, 5 years ago (diff)

new: nss-pam-ldapd-0.9.10-2

Line 
1%bcond_with systemd
2%global nssdir /%{_lib}
3%global pamdir /%{_lib}/security
4
5%define _hardened_build 1
6
7Name:           nss-pam-ldapd
8Version:        0.9.10
9Release:        2%{?_dist_release}
10Summary:        An nsswitch module which uses directory servers
11License:        LGPLv2+
12URL:            http://arthurdejong.org/nss-pam-ldapd/
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        http://arthurdejong.org/nss-pam-ldapd/nss-pam-ldapd-%{version}.tar.gz
17Source1:        http://arthurdejong.org/nss-pam-ldapd/nss-pam-ldapd-%{version}.tar.gz.sig
18%if %{with systemd}
19Source3:        nslcd.tmpfiles
20Source4:        nslcd.service
21%else
22Source100:      nslcd.init
23%endif
24
25# Pylint tests fail w/o certain imports and are not needed for nslcd anyway,
26# plus, we don't ship the python utilities
27Patch0001:      0001-Disable-pylint-tests.patch
28Patch0002:      0002-Watch-for-uint32_t-overflows.patch
29
30BuildRequires:  gcc
31BuildRequires:  openldap-devel, krb5-devel
32BuildRequires:  autoconf, automake
33BuildRequires:  pam-devel
34%if %{with systemd}
35BuildRequires:  systemd-units
36%{?systemd_requires}
37%else
38Requires(pre):    shadow-utils
39Requires(post):   initscripts, chkconfig
40Requires(preun):  initscripts, chkconfig
41Requires(postun): initscripts, chkconfig
42%endif
43
44# Pull in nscd, which is recommended.
45Recommends:     nscd
46
47Provides:       nss-ldapd = %{version}-%{release}
48
49# Obsolete PADL's nss_ldap
50Provides:       nss_ldap = 264-5
51Obsoletes:      nss_ldap < 264-5
52
53%description
54The nss-pam-ldapd daemon, nslcd, uses a directory server to look up name
55service information (users, groups, etc.) on behalf of a lightweight
56nsswitch module.
57
58%prep
59%autosetup -p1
60autoreconf -f -i
61
62%build
63%configure --libdir=%{nssdir} \
64           --disable-utils \
65           --with-pam-seclib-dir=%{pamdir}
66%make_build
67
68%check
69make check
70
71%install
72rm -rf $RPM_BUILD_ROOT
73make install DESTDIR=$RPM_BUILD_ROOT
74mkdir -p $RPM_BUILD_ROOT/%{_libdir}
75%if %{with systemd}
76mkdir -p $RPM_BUILD_ROOT/%{_unitdir}
77install -p -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_unitdir}/
78mkdir -p -m 0755 $RPM_BUILD_ROOT/%{_tmpfilesdir}
79install -p -m 0644 %{SOURCE3} $RPM_BUILD_ROOT/%{_tmpfilesdir}/%{name}.conf
80%else
81mkdir -p -m 0755 $RPM_BUILD_ROOT/%{_localstatedir}/run/nslcd
82mkdir -p -m 0755 $RPM_BUILD_ROOT/%{_initdir}
83install -p -m 0755 %{SOURCE100} $RPM_BUILD_ROOT/%{_initdir}/nslcd
84%endif
85
86
87ln -s libnss_ldap.so.2 $RPM_BUILD_ROOT/%{nssdir}/libnss_ldap.so
88
89sed -i -e 's,^uid.*,uid nslcd,g' -e 's,^gid.*,gid ldap,g' \
90$RPM_BUILD_ROOT/%{_sysconfdir}/nslcd.conf
91touch -r nslcd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/nslcd.conf
92mkdir -p -m 0755 $RPM_BUILD_ROOT/var/run/nslcd
93
94%files
95%doc AUTHORS ChangeLog COPYING HACKING NEWS README TODO
96%{_sbindir}/*
97%{nssdir}/*.so*
98%{pamdir}/pam_ldap.so
99%{_mandir}/*/*
100%attr(0600,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/nslcd.conf
101%attr(0775,nslcd,root) /var/run/nslcd
102%if %{with systemd}
103%attr(0644,root,root) %config(noreplace) %{_tmpfilesdir}/%{name}.conf
104%{_unitdir}/nslcd.service
105%else
106%{_initdir}/nslcd
107%endif
108
109%pre
110getent group  ldap  > /dev/null || \
111/usr/sbin/groupadd -r -g 55 ldap
112getent passwd nslcd > /dev/null || \
113/usr/sbin/useradd -r -g ldap -c 'LDAP Client User' \
114    -u 65 -d / -s /sbin/nologin nslcd 2> /dev/null || :
115
116%post
117# The usual stuff.
118/sbin/ldconfig
119%if %{with systemd}
120%systemd_post nslcd.service
121%else
122if [ $1 -eq 1 ]; then
123  /sbin/chkconfig --add nslcd
124fi
125%endif
126
127%preun
128%if %{with systemd}
129%systemd_preun nslcd.service
130%else
131if [ $1 -eq 0 ]; then
132  /sbin/service nslcd stop >/dev/null 2>&1 || :
133  /sbin/chkconfig --del nslcd
134fi
135%endif
136
137%postun
138/sbin/ldconfig
139%if %{with systemd}
140%systemd_postun_with_restart nslcd.service
141%else
142if [ $1 -ne 0 ]; then
143  /sbin/service nslcd condrestart >/dev/null 2>&1 || :
144fi
145%endif
146
147%changelog
148* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.10-2
149- initial build for Vine Linux.
150
151* Mon Sep  3 2018 Jakub Hrozek <jhrozek@redhat.com> - 0.9.10-1
152- New upstream release 0.9.10
153
154* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.9-4
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
156
157* Wed May 30 2018 Jakub Hrozek <jhrozek@redhat.com> - 0.9.9-3
158- Also change the pemissions on tmpfiles
159- Related: rhbz#1583211 - nslcd, the local LDAP daemon, fails to start
160                          with SELinux enabled
161
162* Wed May 30 2018 Jakub Hrozek <jhrozek@redhat.com> - 0.9.9-2
163- Apply a patch by Lukas Slebodnik to allow root to write to the
164  /var/run/nslcd directory
165- Resolves: rhbz#1583211 - nslcd, the local LDAP daemon, fails to start
166                           with SELinux enabled
167
168* Sun Apr  1 2018 Jakub Hrozek <jhrozek@redhat.com> - 0.9.9-1
169- Upgrade to the latest upstream
170  - Disable the python utilities
171  - Don't bother with failing pylint test as we don't ship the python
172    utilities
173- Drop unused validname and exitcode patches, port strtoid overflow
174  patch
175
176* Sat Mar 31 2018 Jakub Hrozek <jhrozek@redhat.com> - 0.8.14-12
177- Get rid of all conditions that are always true for both EPEL-7 and Fedora
178  as it's quite unlikely we'd use this specfile on EPEL-6
179- Remove the sysvinit script and all the scriptlets around it
180- Unconditionally use systemd scriptlet macros and systemd_requires
181- Unconditionally build the PAM module as the PADL module is long dead
182- Remove the auto-migration of settings from nss_ldap as it's been
183  long gone from Fedora
184- Don't check /etc/sysconfig/authconfig as authconfig is on its way
185  out from Fedora
186- Use only spaces, not tabs, to stop my editor from looking like a
187  Christmas tree
188- Remove the obsolete Group stanza
189- Make nscd Recommended, not Required
190
191* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.14-11
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
193
194* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.14-10
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
196
197* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.14-9
198- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
199
200* Wed Feb  8 2017 Jakub Hrozek <jhrozek@redhat.com> 0.8.14-8
201- Apply a patch from Stanislav Moravec to fix nslcd return code
202
203* Tue Mar 29 2016 Nalin Dahyabhai <nalin@redhat.com> 0.8.14-7
204- move the packaged tmpfiles.d file from /etc/tmpfiles.d to %%{_tmpfilesdir},
205  per heads-up from Ville Skyttä on devel@
206
207* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.14-6
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
209
210* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.14-5
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
212
213* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.14-4
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
215
216* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.14-3
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
218
219* Wed May 07 2014 Nalin Dahyabhai <nalin@redhat.com> 0.8.14-2
220- where we check for USELDAP=yes in /etc/sysconfig/authconfig as an indication
221  of nss_ldap being in use, to decide whether to enable the nslcd service or
222  not, also check for USELDAPAUTH=yes, which indicates pam_ldap is being used
223
224* Sat Oct 05 2013 Jakub Hrozek <jhrozek@redhat.com>  0.8.14-1
225- New upstream release 0.8.14
226- Remove upstreamed patches
227
228* Sat Oct 05 2013 Jakub Hrozek <jhrozek@redhat.com>  0.8.13-4
229- Backport fixes for #1003011
230
231* Sat Oct 05 2013 Jakub Hrozek <jhrozek@redhat.com>  0.8.13-3
232- Build with _hardened_build macro
233
234* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.13-2
235- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
236
237* Mon May  6 2013 Nalin Dahyabhai <nalin@redhat.com> 0.8.13-1
238- update to 0.8.13
239- correct a syntax error in the fix that was added for #832706
240
241* Tue Apr 30 2013 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-4
242- in %%post, attempt to rewrite any instances of "map group uniqueMember ..."
243  to be "map group member ..." in nslcd.conf, as the attribute name changed
244  in 0.8.4 (via freeipa ticket #3589)
245
246* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.12-3
247- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
248
249* Fri Jan 18 2013 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-2
250- drop local patch to make the client flush some more read buffers
251
252* Fri Jan 18 2013 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-1
253- update to 0.8.12 (#846793)
254- make building pam_ldap conditional on the targeted release
255- add "After=named.service dirsrv.target slapd.service" to nslcd.service,
256  to make sure that nslcd is started after them if they're to be started
257  on the local system (#832706)
258- alter the versioned Obsoletes: on pam_ldap to include the F18 package
259- use %%{_unitdir} when deciding where to put systemd configuration, based
260  on patch from Václav Pavlín (#850232)
261- use new systemd macros for scriptlet hooks, when available, based on
262  patch from Václav Pavlín (#850232)
263
264* Sun Sep 09 2012 Jakub Hrozek <jhrozek@redhat.com> 0.7.17-1
265- new upstream release 0.7.17
266
267* Sun Aug 05 2012 Jakub Hrozek <jhrozek@redhat.com> - 0.7.16-5
268- Obsolete PADL's nss_ldap
269
270* Sat Aug 04 2012 Jakub Hrozek <jhrozek@redhat.com> - 0.7.16-4
271- Build the PAM module, obsoletes PADL's pam-ldap (#856006)
272
273* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.16-3
274- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
275
276* Mon May 14 2012 Jakub Hrozek <jhrozek@redhat.com> 0.7.16-2
277- backport upstream revision r1659 related to broken pipe when
278  requesting a large group
279- use grep -E instead of egrep to avoid rpmlint warnings
280
281* Sat Apr 28 2012 Jakub Hrozek <jhrozek@redhat.com> 0.7.16-1
282- new upstream release 0.7.16
283
284* Thu Mar 15 2012 Jakub Hrozek <jhrozek@redhat.com> 0.7.15-2
285- Do not print "Broken Pipe" error message when requesting a large group
286
287* Fri Mar 9 2012 Jakub Hrozek <jhrozek@redhat.com> 0.7.15-1
288- new upstream release 0.7.15
289
290* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.14-3
291- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
292
293* Fri Dec 16 2011 Jakub Hrozek <jhrozek@redhat.com> 0.7.14-2
294- Do not overflow large UID/GID values on 32bit architectures
295
296* Mon Nov 28 2011 Nalin Dahyabhai <nalin@redhat.com>
297- use the same conditional test for deciding when to create the .so symlink as
298  we do later on for deciding when to include it in the package (#757004)
299
300* Fri Sep 23 2011 Jakub Hrozek <jhrozek@redhat.com> 0.7.14-1
301- new upstream release 0.7.14
302- obsoletes nss-pam-ldapd-0.7.x-buffers.patch
303
304* Wed Aug 24 2011 Nalin Dahyabhai <nalin@redhat.com> 0.7.13-8
305- include backported enhancement to take URIs in the form "dns:DOMAIN" in
306  addition to the already-implemented "dns" (#730309)
307
308* Thu Jul 14 2011 Nalin Dahyabhai <nalin@redhat.com> 0.7.13-7
309- switch to only munging the contents of /etc/nslcd.conf on the very first
310  install (#706454)
311- make sure that we have enough space to parse any valid GID value when
312  parsing a user's primary GID (#716822)
313- backport support for the "validnames" option from SVN and use it to allow
314  parentheses characters by modifying the default setting (#690870), then
315  modify the default again to also allow shorter and shorter names to pass
316  muster (#706860)
317
318* Wed Jul 13 2011 Nalin Dahyabhai <nalin@redhat.com> 0.7.13-6
319- convert to systemd-native startup (#716997)
320
321* Mon Jun 13 2011 Nalin Dahyabhai <nalin@redhat.com> 0.7.13-5
322- change the file path Requires: we have for pam_ldap into a package name
323  Requires: (#601931)
324
325* Wed Mar 30 2011 Nalin Dahyabhai <nalin@redhat.com> 0.7.13-4
326- tag nslcd.conf with %%verify(not md5 size mtime), since we always tweak
327  it in %%post (#692225)
328
329* Tue Mar  1 2011 Nalin Dahyabhai <nalin@redhat.com> 0.7.13-3
330- add a tmpfiles configuration to ensure that /var/run/nslcd is created when
331  /var/run is completely empty at boot (#656643)
332
333* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.13-2
334- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
335
336* Mon Dec 13 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.13-1
337- update to 0.7.13
338
339* Fri Oct 29 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.12-1
340- update to 0.7.12
341
342* Fri Oct 15 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.11-1
343- update to 0.7.11
344
345* Wed Sep 29 2010 jkeating - 0.7.10-2
346- Rebuilt for gcc bug 634757
347
348* Fri Sep 24 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.10-1
349- update to 0.7.10
350
351* Thu Sep 23 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.9-2
352- when creating /var/run/nslcd in the buildroot, specify that 0755 is a
353  permissions value and not another directory name (#636880)
354
355* Mon Aug 30 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.9-1
356- update to 0.7.9
357
358* Wed Aug 18 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.8-1
359- update to 0.7.8
360
361* Wed Jul  7 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.7-1
362- update to 0.7.7
363
364* Mon Jun 28 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.6-3
365- don't accidentally set multiple 'gid' settings in nslcd.conf, and try to
366  clean up after older versions of this package that did (#608314)
367
368* Thu May 27 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.6-2
369- make inclusion of the .so symlink conditional on being on a sufficiently-
370  new Fedora where pam_ldap isn't part of the nss_ldap package, so having
371  this package conflict with nss_ldap doesn't require that pam_ldap be
372  removed (#596691)
373
374* Thu May 27 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.6-1
375- update to 0.7.6
376
377* Mon May 17 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.5-3
378- switch to the upstream patch for #592411
379
380* Fri May 14 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.5-2
381- don't return an uninitialized buffer as the value for an optional attribute
382  that isn't present in the directory server entry (#592411)
383
384* Fri May 14 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.5-1
385- update to 0.7.5
386
387* Fri May 14 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.4-1
388- update to 0.7.4
389- stop trying to migrate retry timeout parameters from old ldap.conf files
390- add an explicit requires: on nscd to make sure it's at least available on
391  systems that are using nss-pam-ldapd; otherwise it's usually optional
392
393* Tue Mar 23 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.3-1
394- update to 0.7.3
395
396* Thu Feb 25 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.2-2
397- bump release for post-review commit
398
399* Thu Feb 25 2010 Nalin Dahyabhai <nalin@redhat.com> 0.7.2-1
400- add comments about why we have a .so link at all, and not a -devel subpackage
401
402* Wed Jan 13 2010 Nalin Dahyabhai <nalin@redhat.com>
403- obsolete/provides nss-ldapd
404- import configuration from nss-ldapd.conf, too
405
406* Tue Jan 12 2010 Nalin Dahyabhai <nalin@redhat.com>
407- rename to nss-pam-ldapd
408- also check for import settings in /etc/nss_ldap.conf and /etc/pam_ldap.conf
409
410* Thu Sep 24 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.11-2
411- rebuild
412
413* Wed Sep 16 2009 Nalin Dahyabhai <nalin@redhat.com>
414- apply Mitchell Berger's patch to clean up the init script, use %%{_initddir},
415  and correct the %%post so that it only thinks about turning on nslcd when
416  we're first being installed (#522947)
417- tell status() where the pidfile is when the init script is called for that
418
419* Tue Sep  8 2009 Nalin Dahyabhai <nalin@redhat.com>
420- fix typo in a comment, capitalize the full name for "LDAP Client User" (more
421  from #516049)
422
423* Wed Sep  2 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.11-1
424- update to 0.6.11
425
426* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-4
427- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
428
429* Thu Jun 18 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.10-3
430- update URL: and Source:
431
432* Mon Jun 15 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.10-2
433- add and own /var/run/nslcd
434- convert hosts to uri during migration
435
436* Thu Jun 11 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.10-1
437- update to 0.6.10
438
439* Fri Apr 17 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.8-1
440- bump release number to 1 (part of #491767)
441- fix which group we check for during %%pre (part of #491767)
442
443* Tue Mar 24 2009 Nalin Dahyabhai <nalin@redhat.com>
444- require chkconfig by package rather than path (Jussi Lehtola, part of #491767)
445
446* Mon Mar 23 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.8-0.1
447- update to 0.6.8
448
449* Mon Mar 23 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.7-0.1
450- start using a dedicated user
451
452* Wed Mar 18 2009 Nalin Dahyabhai <nalin@redhat.com> 0.6.7-0.0
453- initial package (#445965)
Note: See TracBrowser for help on using the repository browser.