source: projects/specs/trunk/n/nspr/nspr-vl.spec @ 7899

Revision 7899, 7.5 KB checked in by daisuke, 11 years ago (diff)

nspr: update to 4.10.1
nss: update to 3.15.2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Netscape Portable Runtime
4Summary(ja):    Netscape ポータブルランタイム
5Name:           nspr
6Version:        4.10.1
7Release:        1%{?_dist_release}
8License:        MPLv1.1/GPLv2+/LGPLv2+
9URL:            http://www.mozilla.org/projects/nspr/
10Group:          System Environment/Libraries
11Source0:        %{name}-%{version}.tar.gz
12
13Patch1:         nspr-config-pc.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16Provides:       mozilla-nspr
17Obsoletes:      mozilla-nspr
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: daisuke
22
23%description
24NSPR provides platform independence for non-GUI operating system
25facilities. These facilities include threads, thread synchronization,
26normal file and network I/O, interval timing and calendar time, basic
27memory management (malloc and free) and shared library linking.
28
29%package devel
30Summary:        Development libraries for the Netscape Portable Runtime
31Group:          Development/Libraries
32Requires:       nspr = %{version}-%{release}
33Requires:       pkgconfig
34Provides:       mozilla-nspr-devel
35Obsoletes:      mozilla-nspr-devel
36
37%description devel
38Header files for doing development with the Netscape Portable Runtime.
39
40
41## to build compat32 for x86_64 architecture support
42%package -n compat32-%{name}
43Summary:        Netscape Portable Runtime
44Group: System Environment/Libraries
45
46%description -n compat32-%{name}
47NSPR provides platform independence for non-GUI operating system
48facilities. These facilities include threads, thread synchronization,
49normal file and network I/O, interval timing and calendar time, basic
50memory management (malloc and free) and shared library linking.
51
52
53
54%prep
55
56%setup -q
57
58# Original nspr-config is not suitable for our distribution,
59# because on different platforms it contains different dynamic content.
60# Therefore we produce an adjusted copy of nspr-config that will be
61# identical on all platforms.
62# However, we need to use original nspr-config to produce some variables
63# that go into nspr.pc for pkg-config.
64
65cp ./nspr/config/nspr-config.in ./nspr/config/nspr-config-pc.in
66%patch1 -p0
67
68%build
69
70./nspr/configure \
71                 --prefix=%{_prefix} \
72                 --libdir=%{_libdir} \
73                 --includedir=%{_includedir}/nspr4 \
74%ifarch x86_64 ppc64 ia64 s390x
75                 --enable-64bit \
76%endif
77                 --enable-optimize="$RPM_OPT_FLAGS" \
78                 --disable-debug
79
80make
81
82%install
83
84%{__rm} -Rf $RPM_BUILD_ROOT
85
86DESTDIR=$RPM_BUILD_ROOT \
87  make install
88
89NSPR_LIBS=`./config/nspr-config --libs`
90NSPR_CFLAGS=`./config/nspr-config --cflags`
91NSPR_VERSION=`./config/nspr-config --version`
92%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
93
94# Get rid of the things we don't want installed (per upstream)
95%{__rm} -rf \
96   $RPM_BUILD_ROOT/%{_bindir}/compile-et.pl \
97   $RPM_BUILD_ROOT/%{_bindir}/prerr.properties \
98   $RPM_BUILD_ROOT/%{_libdir}/libnspr4.a \
99   $RPM_BUILD_ROOT/%{_libdir}/libplc4.a \
100   $RPM_BUILD_ROOT/%{_libdir}/libplds4.a \
101   $RPM_BUILD_ROOT/%{_datadir}/aclocal/nspr.m4 \
102   $RPM_BUILD_ROOT/%{_includedir}/nspr4/md
103
104%clean
105%{__rm} -rf $RPM_BUILD_ROOT
106
107%post
108/sbin/ldconfig >/dev/null 2>/dev/null
109
110%postun
111/sbin/ldconfig >/dev/null 2>/dev/null
112
113%files
114%defattr(-,root,root)
115%{_libdir}/libnspr4.so
116%{_libdir}/libplc4.so
117%{_libdir}/libplds4.so
118
119%files devel
120%defattr(-, root, root)
121%{_includedir}/nspr4
122%{_libdir}/pkgconfig/nspr.pc
123%{_bindir}/nspr-config
124
125%if %{build_compat32}
126%files -n compat32-%{name}
127%defattr(-,root,root)
128%{_libdir}/*.so
129%endif
130
131
132%changelog
133* Thu Oct 17 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.10.1-1
134- update to 4.10.1
135
136* Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.6-1
137- update to 4.9.6
138
139* Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.4-1
140- update to 4.9.4
141
142* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.2
143- new upstream release
144
145* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9-1
146- new upstram release
147- update Patch1 (nspr-config-pc.patch)
148
149* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.9-1
150- new upstram release
151
152* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.8-1
153- new upstream release
154
155* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.7-1
156- new upstream release
157
158* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.6-2
159- rebuild with rpm-4.8.1 for pkg-config file
160
161* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.6-1
162- new upstream release
163
164* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.8.4-1
165- new upstream release
166
167* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.2-1
168- new upstream release
169
170* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.8-2
171- added compat32 subpackages
172
173* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8-1
174- new upstream release
175
176* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.4-1
177- new upstream release
178
179* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.1-1
180- new upstream release
181
182* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.7-0vl1
183- new upstream release
184
185* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.6-0vl1
186- initial build for Vine Linux
187
188* Wed Mar 07 2007 Kai Engert <kengert@redhat.com> - 4.6.6-1
189- Update to 4.6.6
190- Adjust IPv6 patch to latest upstream version
191
192* Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 4.6.5-2
193- Update to latest ipv6 upstream patch
194- Add upstream patch to fix a thread cleanup issue
195- Now requires pkgconfig
196
197* Mon Jan 22 2007 Wan-Teh Chang <wtchang@redhat.com> - 4.6.5-1
198- Update to 4.6.5
199
200* Tue Jan 16 2007 Kai Engert <kengert@redhat.com> - 4.6.4-2
201- Include upstream patch to fix ipv6 support (rhbz 222554)
202
203* Tue Nov 21 2006 Kai Engert <kengert@redhat.com> - 4.6.4-1
204- Update to 4.6.4
205
206* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 4.6.3-1
207- Update to 4.6.3
208
209* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.6.2-1.1
210- rebuild
211
212* Fri May 26 2006 Kai Engert <kengert@redhat.com> - 4.6.2-1
213- Update to 4.6.2
214- Tweak nspr-config to be identical on all platforms.
215
216* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.2
217- bump again for double-long bug on ppc(64)
218
219* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.1
220- rebuilt for new gcc4.1 snapshot and glibc changes
221
222* Thu Jan  5 2006 Kai Engert <kengert@redhat.com> 4.6.1-2
223- Do not use -ansi when compiling, because of a compilation
224  problem with latest glibc and anonymous unions.
225  See also bugzilla.mozilla.org # 322427.
226
227* Wed Jan  4 2006 Kai Engert <kengert@redhat.com>
228- Add an upstream patch to fix gcc visibility issues.
229
230* Tue Jan  3 2006 Christopher Aillon <caillon@redhat.com>
231- Stop shipping static libraries; NSS and dependencies no longer
232  require static libraries to build.
233
234* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 4.6.1-1
235- Update to 4.6.1
236
237* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
238- rebuilt
239
240* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-4
241- Use the NSPR version numbering scheme reported by NSPR,
242  which unfortunately is not exactly the same as the real
243  version (4.6 != 4.6.0 according to RPM and pkgconfig).
244
245* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-3
246- Correct the CFLAGS reported by pkgconfig
247
248* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-2
249- Temporarily include the static libraries allowing nss and
250  its dependencies to build.
251
252* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-1
253- Update to NSPR 4.6
254
255* Wed Apr 20 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-2
256- NSPR doesn't have make install, but it has make real_install.  Use it.
257
258* Thu Apr 14 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-1
259- Let's make an RPM.
Note: See TracBrowser for help on using the repository browser.