source: projects/specs/trunk/n/nspr/nspr-vl.spec @ 5920

Revision 5920, 8.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Netscape Portable Runtime
4Summary(ja):    Netscape ポータブルランタイム
5Name:           nspr
6Version:        4.9
7Release:        1%{?_dist_release}
8License:        MPLv1.1/GPLv2+/LGPLv2+
9URL:            http://www.mozilla.org/projects/nspr/
10Group:          System Environment/Libraries
11Source0:        %{name}-%{version}.tar.bz2
12Source1:        nspr.pc.in
13Source2:        nspr-config-vars.in
14
15Patch1:         nspr-config-pc.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18Provides:       mozilla-nspr
19Obsoletes:      mozilla-nspr
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: daisuke
24
25%description
26NSPR provides platform independence for non-GUI operating system
27facilities. These facilities include threads, thread synchronization,
28normal file and network I/O, interval timing and calendar time, basic
29memory management (malloc and free) and shared library linking.
30
31%package devel
32Summary:        Development libraries for the Netscape Portable Runtime
33Group:          Development/Libraries
34Requires:       nspr = %{version}-%{release}
35Requires:       pkgconfig
36Provides:       mozilla-nspr-devel
37Obsoletes:      mozilla-nspr-devel
38
39%description devel
40Header files for doing development with the Netscape Portable Runtime.
41
42
43## to build compat32 for x86_64 architecture support
44%package -n compat32-%{name}
45Summary:        Netscape Portable Runtime
46Group: System Environment/Libraries
47
48%description -n compat32-%{name}
49NSPR provides platform independence for non-GUI operating system
50facilities. These facilities include threads, thread synchronization,
51normal file and network I/O, interval timing and calendar time, basic
52memory management (malloc and free) and shared library linking.
53
54
55
56%prep
57
58%setup -q
59
60# Original nspr-config is not suitable for our distribution,
61# because on different platforms it contains different dynamic content.
62# Therefore we produce an adjusted copy of nspr-config that will be
63# identical on all platforms.
64# However, we need to use original nspr-config to produce some variables
65# that go into nspr.pc for pkg-config.
66
67cp ./mozilla/nsprpub/config/nspr-config.in ./mozilla/nsprpub/config/nspr-config-pc.in
68%patch1 -p0
69
70cp %{SOURCE2} ./mozilla/nsprpub/config/
71
72%build
73
74./mozilla/nsprpub/configure \
75                 --prefix=%{_prefix} \
76                 --libdir=%{_libdir} \
77                 --includedir=%{_includedir}/nspr4 \
78%ifarch x86_64 ppc64 ia64 s390x
79                 --enable-64bit \
80%endif
81                 --enable-optimize="$RPM_OPT_FLAGS" \
82                 --disable-debug
83
84make
85
86%install
87
88%{__rm} -Rf $RPM_BUILD_ROOT
89
90DESTDIR=$RPM_BUILD_ROOT \
91  make install
92
93NSPR_LIBS=`./config/nspr-config --libs`
94NSPR_CFLAGS=`./config/nspr-config --cflags`
95NSPR_VERSION=`./config/nspr-config --version`
96%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
97
98cat ./config/nspr-config-vars > \
99                     $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nspr.pc
100
101cat %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \
102                     -e "s,%%prefix%%,%{_prefix},g" \
103                     -e "s,%%exec_prefix%%,%{_prefix},g" \
104                     -e "s,%%includedir%%,%{_includedir}/nspr4,g" \
105                     -e "s,%%NSPR_VERSION%%,$NSPR_VERSION,g" \
106                     -e "s,%%FULL_NSPR_LIBS%%,$NSPR_LIBS,g" \
107                     -e "s,%%FULL_NSPR_CFLAGS%%,$NSPR_CFLAGS,g" >> \
108                     $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nspr.pc
109
110%{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
111%{__cp} ./config/nspr-config-pc $RPM_BUILD_ROOT/%{_bindir}/nspr-config
112
113# Get rid of the things we don't want installed (per upstream)
114%{__rm} -rf \
115   $RPM_BUILD_ROOT/%{_bindir}/compile-et.pl \
116   $RPM_BUILD_ROOT/%{_bindir}/prerr.properties \
117   $RPM_BUILD_ROOT/%{_libdir}/libnspr4.a \
118   $RPM_BUILD_ROOT/%{_libdir}/libplc4.a \
119   $RPM_BUILD_ROOT/%{_libdir}/libplds4.a \
120   $RPM_BUILD_ROOT/%{_datadir}/aclocal/nspr.m4 \
121   $RPM_BUILD_ROOT/%{_includedir}/nspr4/md
122
123%clean
124%{__rm} -rf $RPM_BUILD_ROOT
125
126%post
127/sbin/ldconfig >/dev/null 2>/dev/null
128
129%postun
130/sbin/ldconfig >/dev/null 2>/dev/null
131
132%files
133%defattr(-,root,root)
134%{_libdir}/libnspr4.so
135%{_libdir}/libplc4.so
136%{_libdir}/libplds4.so
137
138%files devel
139%defattr(-, root, root)
140%{_includedir}/nspr4
141%{_libdir}/pkgconfig/nspr.pc
142%{_bindir}/nspr-config
143
144%if %{build_compat32}
145%files -n compat32-%{name}
146%defattr(-,root,root)
147%{_libdir}/*.so
148%endif
149
150
151%changelog
152* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9-1
153- new upstram release
154- update Patch1 (nspr-config-pc.patch)
155
156* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.9-1
157- new upstram release
158
159* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.8-1
160- new upstream release
161
162* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.7-1
163- new upstream release
164
165* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.6-2
166- rebuild with rpm-4.8.1 for pkg-config file
167
168* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.6-1
169- new upstream release
170
171* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.8.4-1
172- new upstream release
173
174* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.2-1
175- new upstream release
176
177* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.8-2
178- added compat32 subpackages
179
180* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8-1
181- new upstream release
182
183* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.4-1
184- new upstream release
185
186* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.1-1
187- new upstream release
188
189* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.7-0vl1
190- new upstream release
191
192* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.6-0vl1
193- initial build for Vine Linux
194
195* Wed Mar 07 2007 Kai Engert <kengert@redhat.com> - 4.6.6-1
196- Update to 4.6.6
197- Adjust IPv6 patch to latest upstream version
198
199* Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 4.6.5-2
200- Update to latest ipv6 upstream patch
201- Add upstream patch to fix a thread cleanup issue
202- Now requires pkgconfig
203
204* Mon Jan 22 2007 Wan-Teh Chang <wtchang@redhat.com> - 4.6.5-1
205- Update to 4.6.5
206
207* Tue Jan 16 2007 Kai Engert <kengert@redhat.com> - 4.6.4-2
208- Include upstream patch to fix ipv6 support (rhbz 222554)
209
210* Tue Nov 21 2006 Kai Engert <kengert@redhat.com> - 4.6.4-1
211- Update to 4.6.4
212
213* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 4.6.3-1
214- Update to 4.6.3
215
216* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.6.2-1.1
217- rebuild
218
219* Fri May 26 2006 Kai Engert <kengert@redhat.com> - 4.6.2-1
220- Update to 4.6.2
221- Tweak nspr-config to be identical on all platforms.
222
223* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.2
224- bump again for double-long bug on ppc(64)
225
226* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.1
227- rebuilt for new gcc4.1 snapshot and glibc changes
228
229* Thu Jan  5 2006 Kai Engert <kengert@redhat.com> 4.6.1-2
230- Do not use -ansi when compiling, because of a compilation
231  problem with latest glibc and anonymous unions.
232  See also bugzilla.mozilla.org # 322427.
233
234* Wed Jan  4 2006 Kai Engert <kengert@redhat.com>
235- Add an upstream patch to fix gcc visibility issues.
236
237* Tue Jan  3 2006 Christopher Aillon <caillon@redhat.com>
238- Stop shipping static libraries; NSS and dependencies no longer
239  require static libraries to build.
240
241* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 4.6.1-1
242- Update to 4.6.1
243
244* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
245- rebuilt
246
247* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-4
248- Use the NSPR version numbering scheme reported by NSPR,
249  which unfortunately is not exactly the same as the real
250  version (4.6 != 4.6.0 according to RPM and pkgconfig).
251
252* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-3
253- Correct the CFLAGS reported by pkgconfig
254
255* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-2
256- Temporarily include the static libraries allowing nss and
257  its dependencies to build.
258
259* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-1
260- Update to NSPR 4.6
261
262* Wed Apr 20 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-2
263- NSPR doesn't have make install, but it has make real_install.  Use it.
264
265* Thu Apr 14 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-1
266- Let's make an RPM.
Note: See TracBrowser for help on using the repository browser.