source: projects/specs/trunk/n/nspr/nspr-vl.spec @ 12228

Revision 12228, 8.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Netscape Portable Runtime
4Summary(ja):    Netscape ポータブルランタイム
5Name:           nspr
6Version:        4.22
7Release:        1%{?_dist_release}
8License:        MPLv2.0
9URL:            http://www.mozilla.org/projects/nspr/
10Group:          System Environment/Libraries
11Source0:        https://archive.mozilla.org/pub/nspr/releases/v%{version}/src/%{name}-%{version}.tar.gz
12
13Patch1:         nspr-config-pc.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16Provides:       mozilla-nspr
17Obsoletes:      mozilla-nspr
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: daisuke
22
23%description
24NSPR provides platform independence for non-GUI operating system
25facilities. These facilities include threads, thread synchronization,
26normal file and network I/O, interval timing and calendar time, basic
27memory management (malloc and free) and shared library linking.
28
29%package devel
30Summary:        Development libraries for the Netscape Portable Runtime
31Group:          Development/Libraries
32Requires:       nspr = %{version}-%{release}
33Requires:       pkgconfig
34Provides:       mozilla-nspr-devel
35Obsoletes:      mozilla-nspr-devel
36
37%description devel
38Header files for doing development with the Netscape Portable Runtime.
39
40
41## to build compat32 for x86_64 architecture support
42%package -n compat32-%{name}
43Summary:        Netscape Portable Runtime
44Group: System Environment/Libraries
45
46%description -n compat32-%{name}
47NSPR provides platform independence for non-GUI operating system
48facilities. These facilities include threads, thread synchronization,
49normal file and network I/O, interval timing and calendar time, basic
50memory management (malloc and free) and shared library linking.
51
52
53
54%prep
55
56%setup -q
57
58# Original nspr-config is not suitable for our distribution,
59# because on different platforms it contains different dynamic content.
60# Therefore we produce an adjusted copy of nspr-config that will be
61# identical on all platforms.
62# However, we need to use original nspr-config to produce some variables
63# that go into nspr.pc for pkg-config.
64
65cp ./nspr/config/nspr-config.in ./nspr/config/nspr-config-pc.in
66%patch1 -p0
67
68%build
69
70LDFLAGS+=-Wl,-z,relro
71export LDFLAGS
72
73%define _configure ./nspr/configure
74%configure \
75                 --prefix=%{_prefix} \
76                 --libdir=%{_libdir} \
77                 --includedir=%{_includedir}/nspr4 \
78%ifarch x86_64 ppc64 ia64 s390x
79                 --enable-64bit \
80%endif
81                 --enable-optimize="$RPM_OPT_FLAGS" \
82                 --disable-debug
83
84make
85
86%install
87
88%{__rm} -Rf $RPM_BUILD_ROOT
89
90DESTDIR=$RPM_BUILD_ROOT \
91  make install
92
93mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
94
95NSPR_LIBS=`./config/nspr-config --libs`
96NSPR_CFLAGS=`./config/nspr-config --cflags`
97NSPR_VERSION=`./config/nspr-config --version`
98%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
99
100# Get rid of the things we don't want installed (per upstream)
101%{__rm} -rf \
102   $RPM_BUILD_ROOT/%{_bindir}/compile-et.pl \
103   $RPM_BUILD_ROOT/%{_bindir}/prerr.properties \
104   $RPM_BUILD_ROOT/%{_libdir}/libnspr4.a \
105   $RPM_BUILD_ROOT/%{_libdir}/libplc4.a \
106   $RPM_BUILD_ROOT/%{_libdir}/libplds4.a \
107   $RPM_BUILD_ROOT/%{_datadir}/aclocal/nspr.m4 \
108   $RPM_BUILD_ROOT/%{_includedir}/nspr4/md
109
110%clean
111%{__rm} -rf $RPM_BUILD_ROOT
112
113%post
114/sbin/ldconfig >/dev/null 2>/dev/null
115
116%postun
117/sbin/ldconfig >/dev/null 2>/dev/null
118
119%files
120%defattr(-,root,root)
121%{_libdir}/libnspr4.so
122%{_libdir}/libplc4.so
123%{_libdir}/libplds4.so
124
125%files devel
126%defattr(-, root, root)
127%{_includedir}/nspr4
128%{_libdir}/pkgconfig/nspr.pc
129%{_bindir}/nspr-config
130
131%if %{build_compat32}
132%files -n compat32-%{name}
133%defattr(-,root,root)
134%{_libdir}/*.so
135%endif
136
137
138%changelog
139* Fri Sep 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.22-1
140- update to 4.22.
141
142* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.20-1
143- update to 4.20.
144- dropped Patch2.
145
146* Sat Oct 07 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.13.1-1
147- update to 4.13.1.
148
149* Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11-1
150- update to 4.11
151
152* Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.10.6-1
153- update to 4.10.6
154
155* Thu Oct 17 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.10.1-1
156- update to 4.10.1
157
158* Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.6-1
159- update to 4.9.6
160
161* Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.4-1
162- update to 4.9.4
163
164* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.2
165- new upstream release
166
167* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9-1
168- new upstram release
169- update Patch1 (nspr-config-pc.patch)
170
171* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.9-1
172- new upstram release
173
174* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.8-1
175- new upstream release
176
177* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.7-1
178- new upstream release
179
180* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.6-2
181- rebuild with rpm-4.8.1 for pkg-config file
182
183* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.6-1
184- new upstream release
185
186* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.8.4-1
187- new upstream release
188
189* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.2-1
190- new upstream release
191
192* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.8-2
193- added compat32 subpackages
194
195* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8-1
196- new upstream release
197
198* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.4-1
199- new upstream release
200
201* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.1-1
202- new upstream release
203
204* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.7-0vl1
205- new upstream release
206
207* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.6-0vl1
208- initial build for Vine Linux
209
210* Wed Mar 07 2007 Kai Engert <kengert@redhat.com> - 4.6.6-1
211- Update to 4.6.6
212- Adjust IPv6 patch to latest upstream version
213
214* Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 4.6.5-2
215- Update to latest ipv6 upstream patch
216- Add upstream patch to fix a thread cleanup issue
217- Now requires pkgconfig
218
219* Mon Jan 22 2007 Wan-Teh Chang <wtchang@redhat.com> - 4.6.5-1
220- Update to 4.6.5
221
222* Tue Jan 16 2007 Kai Engert <kengert@redhat.com> - 4.6.4-2
223- Include upstream patch to fix ipv6 support (rhbz 222554)
224
225* Tue Nov 21 2006 Kai Engert <kengert@redhat.com> - 4.6.4-1
226- Update to 4.6.4
227
228* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 4.6.3-1
229- Update to 4.6.3
230
231* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.6.2-1.1
232- rebuild
233
234* Fri May 26 2006 Kai Engert <kengert@redhat.com> - 4.6.2-1
235- Update to 4.6.2
236- Tweak nspr-config to be identical on all platforms.
237
238* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.2
239- bump again for double-long bug on ppc(64)
240
241* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.1
242- rebuilt for new gcc4.1 snapshot and glibc changes
243
244* Thu Jan  5 2006 Kai Engert <kengert@redhat.com> 4.6.1-2
245- Do not use -ansi when compiling, because of a compilation
246  problem with latest glibc and anonymous unions.
247  See also bugzilla.mozilla.org # 322427.
248
249* Wed Jan  4 2006 Kai Engert <kengert@redhat.com>
250- Add an upstream patch to fix gcc visibility issues.
251
252* Tue Jan  3 2006 Christopher Aillon <caillon@redhat.com>
253- Stop shipping static libraries; NSS and dependencies no longer
254  require static libraries to build.
255
256* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 4.6.1-1
257- Update to 4.6.1
258
259* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
260- rebuilt
261
262* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-4
263- Use the NSPR version numbering scheme reported by NSPR,
264  which unfortunately is not exactly the same as the real
265  version (4.6 != 4.6.0 according to RPM and pkgconfig).
266
267* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-3
268- Correct the CFLAGS reported by pkgconfig
269
270* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-2
271- Temporarily include the static libraries allowing nss and
272  its dependencies to build.
273
274* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-1
275- Update to NSPR 4.6
276
277* Wed Apr 20 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-2
278- NSPR doesn't have make install, but it has make real_install.  Use it.
279
280* Thu Apr 14 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-1
281- Let's make an RPM.
Note: See TracBrowser for help on using the repository browser.