source: projects/specs/trunk/n/nspr/nspr-vl.spec @ 11889

Revision 11889, 7.9 KB checked in by tomop, 5 years ago (diff)

nspr-4.20-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Netscape Portable Runtime
4Summary(ja):    Netscape ポータブルランタイム
5Name:           nspr
6Version:        4.20
7Release:        1%{?_dist_release}
8License:        MPLv2.0
9URL:            http://www.mozilla.org/projects/nspr/
10Group:          System Environment/Libraries
11Source0:        %{name}-%{version}.tar.gz
12
13Patch1:         nspr-config-pc.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16Provides:       mozilla-nspr
17Obsoletes:      mozilla-nspr
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: daisuke
22
23%description
24NSPR provides platform independence for non-GUI operating system
25facilities. These facilities include threads, thread synchronization,
26normal file and network I/O, interval timing and calendar time, basic
27memory management (malloc and free) and shared library linking.
28
29%package devel
30Summary:        Development libraries for the Netscape Portable Runtime
31Group:          Development/Libraries
32Requires:       nspr = %{version}-%{release}
33Requires:       pkgconfig
34Provides:       mozilla-nspr-devel
35Obsoletes:      mozilla-nspr-devel
36
37%description devel
38Header files for doing development with the Netscape Portable Runtime.
39
40
41## to build compat32 for x86_64 architecture support
42%package -n compat32-%{name}
43Summary:        Netscape Portable Runtime
44Group: System Environment/Libraries
45
46%description -n compat32-%{name}
47NSPR provides platform independence for non-GUI operating system
48facilities. These facilities include threads, thread synchronization,
49normal file and network I/O, interval timing and calendar time, basic
50memory management (malloc and free) and shared library linking.
51
52
53
54%prep
55
56%setup -q
57
58# Original nspr-config is not suitable for our distribution,
59# because on different platforms it contains different dynamic content.
60# Therefore we produce an adjusted copy of nspr-config that will be
61# identical on all platforms.
62# However, we need to use original nspr-config to produce some variables
63# that go into nspr.pc for pkg-config.
64
65cp ./nspr/config/nspr-config.in ./nspr/config/nspr-config-pc.in
66%patch1 -p0
67
68%build
69
70LDFLAGS+=-Wl,-z,relro
71export LDFLAGS
72
73%define _configure ./nspr/configure
74%configure \
75                 --prefix=%{_prefix} \
76                 --libdir=%{_libdir} \
77                 --includedir=%{_includedir}/nspr4 \
78%ifarch x86_64 ppc64 ia64 s390x
79                 --enable-64bit \
80%endif
81                 --enable-optimize="$RPM_OPT_FLAGS" \
82                 --disable-debug
83
84make
85
86%install
87
88%{__rm} -Rf $RPM_BUILD_ROOT
89
90DESTDIR=$RPM_BUILD_ROOT \
91  make install
92
93mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
94
95NSPR_LIBS=`./config/nspr-config --libs`
96NSPR_CFLAGS=`./config/nspr-config --cflags`
97NSPR_VERSION=`./config/nspr-config --version`
98%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
99
100# Get rid of the things we don't want installed (per upstream)
101%{__rm} -rf \
102   $RPM_BUILD_ROOT/%{_bindir}/compile-et.pl \
103   $RPM_BUILD_ROOT/%{_bindir}/prerr.properties \
104   $RPM_BUILD_ROOT/%{_libdir}/libnspr4.a \
105   $RPM_BUILD_ROOT/%{_libdir}/libplc4.a \
106   $RPM_BUILD_ROOT/%{_libdir}/libplds4.a \
107   $RPM_BUILD_ROOT/%{_datadir}/aclocal/nspr.m4 \
108   $RPM_BUILD_ROOT/%{_includedir}/nspr4/md
109
110%clean
111%{__rm} -rf $RPM_BUILD_ROOT
112
113%post
114/sbin/ldconfig >/dev/null 2>/dev/null
115
116%postun
117/sbin/ldconfig >/dev/null 2>/dev/null
118
119%files
120%defattr(-,root,root)
121%{_libdir}/libnspr4.so
122%{_libdir}/libplc4.so
123%{_libdir}/libplds4.so
124
125%files devel
126%defattr(-, root, root)
127%{_includedir}/nspr4
128%{_libdir}/pkgconfig/nspr.pc
129%{_bindir}/nspr-config
130
131%if %{build_compat32}
132%files -n compat32-%{name}
133%defattr(-,root,root)
134%{_libdir}/*.so
135%endif
136
137
138%changelog
139* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.20-1
140- update to 4.20.
141- dropped Patch2.
142
143* Sat Oct 07 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.13.1-1
144- update to 4.13.1.
145
146* Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11-1
147- update to 4.11
148
149* Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.10.6-1
150- update to 4.10.6
151
152* Thu Oct 17 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.10.1-1
153- update to 4.10.1
154
155* Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.6-1
156- update to 4.9.6
157
158* Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.4-1
159- update to 4.9.4
160
161* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.2
162- new upstream release
163
164* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9-1
165- new upstram release
166- update Patch1 (nspr-config-pc.patch)
167
168* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.9-1
169- new upstram release
170
171* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.8-1
172- new upstream release
173
174* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.7-1
175- new upstream release
176
177* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.6-2
178- rebuild with rpm-4.8.1 for pkg-config file
179
180* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.6-1
181- new upstream release
182
183* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.8.4-1
184- new upstream release
185
186* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.2-1
187- new upstream release
188
189* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.8-2
190- added compat32 subpackages
191
192* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8-1
193- new upstream release
194
195* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.4-1
196- new upstream release
197
198* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.1-1
199- new upstream release
200
201* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.7-0vl1
202- new upstream release
203
204* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.6-0vl1
205- initial build for Vine Linux
206
207* Wed Mar 07 2007 Kai Engert <kengert@redhat.com> - 4.6.6-1
208- Update to 4.6.6
209- Adjust IPv6 patch to latest upstream version
210
211* Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 4.6.5-2
212- Update to latest ipv6 upstream patch
213- Add upstream patch to fix a thread cleanup issue
214- Now requires pkgconfig
215
216* Mon Jan 22 2007 Wan-Teh Chang <wtchang@redhat.com> - 4.6.5-1
217- Update to 4.6.5
218
219* Tue Jan 16 2007 Kai Engert <kengert@redhat.com> - 4.6.4-2
220- Include upstream patch to fix ipv6 support (rhbz 222554)
221
222* Tue Nov 21 2006 Kai Engert <kengert@redhat.com> - 4.6.4-1
223- Update to 4.6.4
224
225* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 4.6.3-1
226- Update to 4.6.3
227
228* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.6.2-1.1
229- rebuild
230
231* Fri May 26 2006 Kai Engert <kengert@redhat.com> - 4.6.2-1
232- Update to 4.6.2
233- Tweak nspr-config to be identical on all platforms.
234
235* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.2
236- bump again for double-long bug on ppc(64)
237
238* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.1
239- rebuilt for new gcc4.1 snapshot and glibc changes
240
241* Thu Jan  5 2006 Kai Engert <kengert@redhat.com> 4.6.1-2
242- Do not use -ansi when compiling, because of a compilation
243  problem with latest glibc and anonymous unions.
244  See also bugzilla.mozilla.org # 322427.
245
246* Wed Jan  4 2006 Kai Engert <kengert@redhat.com>
247- Add an upstream patch to fix gcc visibility issues.
248
249* Tue Jan  3 2006 Christopher Aillon <caillon@redhat.com>
250- Stop shipping static libraries; NSS and dependencies no longer
251  require static libraries to build.
252
253* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 4.6.1-1
254- Update to 4.6.1
255
256* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
257- rebuilt
258
259* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-4
260- Use the NSPR version numbering scheme reported by NSPR,
261  which unfortunately is not exactly the same as the real
262  version (4.6 != 4.6.0 according to RPM and pkgconfig).
263
264* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-3
265- Correct the CFLAGS reported by pkgconfig
266
267* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-2
268- Temporarily include the static libraries allowing nss and
269  its dependencies to build.
270
271* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-1
272- Update to NSPR 4.6
273
274* Wed Apr 20 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-2
275- NSPR doesn't have make install, but it has make real_install.  Use it.
276
277* Thu Apr 14 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-1
278- Let's make an RPM.
Note: See TracBrowser for help on using the repository browser.