source: projects/specs/trunk/n/nspr/nspr-vl.spec @ 11203

Revision 11203, 7.9 KB checked in by tomop, 7 years ago (diff)

nspr-4.13.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Netscape Portable Runtime
4Summary(ja):    Netscape ポータブルランタイム
5Name:           nspr
6Version:        4.13.1
7Release:        1%{?_dist_release}
8License:        MPLv2.0
9URL:            http://www.mozilla.org/projects/nspr/
10Group:          System Environment/Libraries
11Source0:        %{name}-%{version}.tar.gz
12
13Patch1:         nspr-config-pc.patch
14Patch2:         nspr-561901.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17Provides:       mozilla-nspr
18Obsoletes:      mozilla-nspr
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: daisuke
23
24%description
25NSPR provides platform independence for non-GUI operating system
26facilities. These facilities include threads, thread synchronization,
27normal file and network I/O, interval timing and calendar time, basic
28memory management (malloc and free) and shared library linking.
29
30%package devel
31Summary:        Development libraries for the Netscape Portable Runtime
32Group:          Development/Libraries
33Requires:       nspr = %{version}-%{release}
34Requires:       pkgconfig
35Provides:       mozilla-nspr-devel
36Obsoletes:      mozilla-nspr-devel
37
38%description devel
39Header files for doing development with the Netscape Portable Runtime.
40
41
42## to build compat32 for x86_64 architecture support
43%package -n compat32-%{name}
44Summary:        Netscape Portable Runtime
45Group: System Environment/Libraries
46
47%description -n compat32-%{name}
48NSPR provides platform independence for non-GUI operating system
49facilities. These facilities include threads, thread synchronization,
50normal file and network I/O, interval timing and calendar time, basic
51memory management (malloc and free) and shared library linking.
52
53
54
55%prep
56
57%setup -q
58
59# Original nspr-config is not suitable for our distribution,
60# because on different platforms it contains different dynamic content.
61# Therefore we produce an adjusted copy of nspr-config that will be
62# identical on all platforms.
63# However, we need to use original nspr-config to produce some variables
64# that go into nspr.pc for pkg-config.
65
66cp ./nspr/config/nspr-config.in ./nspr/config/nspr-config-pc.in
67%patch1 -p0
68%patch2 -p0
69
70%build
71
72LDFLAGS+=-Wl,-z,relro
73export LDFLAGS
74
75%define _configure ./nspr/configure
76%configure \
77                 --prefix=%{_prefix} \
78                 --libdir=%{_libdir} \
79                 --includedir=%{_includedir}/nspr4 \
80%ifarch x86_64 ppc64 ia64 s390x
81                 --enable-64bit \
82%endif
83                 --enable-optimize="$RPM_OPT_FLAGS" \
84                 --disable-debug
85
86make
87
88%install
89
90%{__rm} -Rf $RPM_BUILD_ROOT
91
92DESTDIR=$RPM_BUILD_ROOT \
93  make install
94
95mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
96
97NSPR_LIBS=`./config/nspr-config --libs`
98NSPR_CFLAGS=`./config/nspr-config --cflags`
99NSPR_VERSION=`./config/nspr-config --version`
100%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
101
102# Get rid of the things we don't want installed (per upstream)
103%{__rm} -rf \
104   $RPM_BUILD_ROOT/%{_bindir}/compile-et.pl \
105   $RPM_BUILD_ROOT/%{_bindir}/prerr.properties \
106   $RPM_BUILD_ROOT/%{_libdir}/libnspr4.a \
107   $RPM_BUILD_ROOT/%{_libdir}/libplc4.a \
108   $RPM_BUILD_ROOT/%{_libdir}/libplds4.a \
109   $RPM_BUILD_ROOT/%{_datadir}/aclocal/nspr.m4 \
110   $RPM_BUILD_ROOT/%{_includedir}/nspr4/md
111
112%clean
113%{__rm} -rf $RPM_BUILD_ROOT
114
115%post
116/sbin/ldconfig >/dev/null 2>/dev/null
117
118%postun
119/sbin/ldconfig >/dev/null 2>/dev/null
120
121%files
122%defattr(-,root,root)
123%{_libdir}/libnspr4.so
124%{_libdir}/libplc4.so
125%{_libdir}/libplds4.so
126
127%files devel
128%defattr(-, root, root)
129%{_includedir}/nspr4
130%{_libdir}/pkgconfig/nspr.pc
131%{_bindir}/nspr-config
132
133%if %{build_compat32}
134%files -n compat32-%{name}
135%defattr(-,root,root)
136%{_libdir}/*.so
137%endif
138
139
140%changelog
141* Sat Oct 07 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.13.1-1
142- update to 4.13.1.
143
144* Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11-1
145- update to 4.11
146
147* Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.10.6-1
148- update to 4.10.6
149
150* Thu Oct 17 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.10.1-1
151- update to 4.10.1
152
153* Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.6-1
154- update to 4.9.6
155
156* Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.4-1
157- update to 4.9.4
158
159* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.2
160- new upstream release
161
162* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9-1
163- new upstram release
164- update Patch1 (nspr-config-pc.patch)
165
166* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.9-1
167- new upstram release
168
169* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.8-1
170- new upstream release
171
172* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.7-1
173- new upstream release
174
175* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.6-2
176- rebuild with rpm-4.8.1 for pkg-config file
177
178* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.6-1
179- new upstream release
180
181* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.8.4-1
182- new upstream release
183
184* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.2-1
185- new upstream release
186
187* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.8-2
188- added compat32 subpackages
189
190* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8-1
191- new upstream release
192
193* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.4-1
194- new upstream release
195
196* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7.1-1
197- new upstream release
198
199* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.7-0vl1
200- new upstream release
201
202* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.6-0vl1
203- initial build for Vine Linux
204
205* Wed Mar 07 2007 Kai Engert <kengert@redhat.com> - 4.6.6-1
206- Update to 4.6.6
207- Adjust IPv6 patch to latest upstream version
208
209* Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 4.6.5-2
210- Update to latest ipv6 upstream patch
211- Add upstream patch to fix a thread cleanup issue
212- Now requires pkgconfig
213
214* Mon Jan 22 2007 Wan-Teh Chang <wtchang@redhat.com> - 4.6.5-1
215- Update to 4.6.5
216
217* Tue Jan 16 2007 Kai Engert <kengert@redhat.com> - 4.6.4-2
218- Include upstream patch to fix ipv6 support (rhbz 222554)
219
220* Tue Nov 21 2006 Kai Engert <kengert@redhat.com> - 4.6.4-1
221- Update to 4.6.4
222
223* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 4.6.3-1
224- Update to 4.6.3
225
226* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.6.2-1.1
227- rebuild
228
229* Fri May 26 2006 Kai Engert <kengert@redhat.com> - 4.6.2-1
230- Update to 4.6.2
231- Tweak nspr-config to be identical on all platforms.
232
233* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.2
234- bump again for double-long bug on ppc(64)
235
236* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.6.1-2.1
237- rebuilt for new gcc4.1 snapshot and glibc changes
238
239* Thu Jan  5 2006 Kai Engert <kengert@redhat.com> 4.6.1-2
240- Do not use -ansi when compiling, because of a compilation
241  problem with latest glibc and anonymous unions.
242  See also bugzilla.mozilla.org # 322427.
243
244* Wed Jan  4 2006 Kai Engert <kengert@redhat.com>
245- Add an upstream patch to fix gcc visibility issues.
246
247* Tue Jan  3 2006 Christopher Aillon <caillon@redhat.com>
248- Stop shipping static libraries; NSS and dependencies no longer
249  require static libraries to build.
250
251* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 4.6.1-1
252- Update to 4.6.1
253
254* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
255- rebuilt
256
257* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-4
258- Use the NSPR version numbering scheme reported by NSPR,
259  which unfortunately is not exactly the same as the real
260  version (4.6 != 4.6.0 according to RPM and pkgconfig).
261
262* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 4.6-3
263- Correct the CFLAGS reported by pkgconfig
264
265* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-2
266- Temporarily include the static libraries allowing nss and
267  its dependencies to build.
268
269* Tue Jul 12 2005 Christopher Aillon <caillon@redhat.com> 4.6-1
270- Update to NSPR 4.6
271
272* Wed Apr 20 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-2
273- NSPR doesn't have make install, but it has make real_install.  Use it.
274
275* Thu Apr 14 2005 Christopher Aillon <caillon@redhat.com> 4.4.1-1
276- Let's make an RPM.
Note: See TracBrowser for help on using the repository browser.