source: projects/specs/trunk/n/nsd/nsd-vl.spec @ 9639

Revision 9639, 10.5 KB checked in by tomop, 9 years ago (diff)

nsd-4.1.3-1

Line 
1Summary: Fast and lean authoritative DNS Name Server
2Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
3Name: nsd
4Version: 4.1.3
5Release: 1%{?_dist_release}
6License: BSD
7Url: http://www.nlnetlabs.nl/%{name}/
8Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
9Source1: nsd.init
10Source3: nsd.sysconfig
11Group: System Environment/Daemons
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires: flex, libevent-devel, openssl-devel
14Requires(pre): shadow-utils
15
16%description
17NSD is a complete implementation of an authoritative DNS name server.
18For further information about what NSD is and what NSD is not please
19consult the REQUIREMENTS document which is a part of this distribution
20
21%description -l ja
22NSD は Authoritative DNSネームサーバの完全な実装です。
23NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
24
25%prep
26%setup -q
27
28%build
29%configure \
30        --with-configdir=%{_sysconfdir}/nsd \
31        --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
32        --with-zonesdir=%{_sysconfdir}/nsd \
33        --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
34        --with-dbfile=%{_localstatedir}/lib/%{name}/nsd.db \
35        --with-difffile=%{_localstatedir}/lib/%{name}/ixfr.db \
36        --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
37        --with-max-ips=1024 \
38        --with-ssl \
39        --with-user=nsd \
40        --enable-bind8-stats \
41        --enable-checking \
42        --enable-mmap \
43        --enable-nsec3 \
44        --enable-ratelimit
45
46%{__make} %{?_smp_mflags}
47#convert to utf8
48iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
49iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
50mv -f doc/RELNOTES.utf8 doc/RELNOTES
51mv -f doc/CREDITS.utf8 doc/CREDITS
52
53
54%install
55rm -rf %{buildroot}
56%{__make} DESTDIR=%{buildroot} install
57install -d -m 0755 %{buildroot}%{_initrddir}
58install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
59install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
60install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
61install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
62install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
63
64# change .sample to normal config files
65head -150 %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample > %{buildroot}%{_sysconfdir}/nsd/nsd.conf
66echo "database: /var/lib/nsd/nsd.db" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
67head -175 %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample | tail -26 >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
68echo "# include: \"/some/path/file\"" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
69rm %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample
70
71%clean
72rm -rf ${RPM_BUILD_ROOT}
73
74%files
75%defattr(-,root,root,-)
76%doc doc/*
77%doc contrib/nsd.zones2nsd.conf
78%dir %{_sysconfdir}/nsd/
79%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
80#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
81%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
82%attr(0755,root,root) %{_initrddir}/%{name}
83%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
84%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
85%{_sbindir}/*
86%{_mandir}/*/*
87
88%pre
89getent group nsd >/dev/null || groupadd -r nsd
90getent passwd nsd >/dev/null || \
91useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
92-c "nsd daemon account" nsd
93exit 0
94
95%post
96/sbin/chkconfig --add %{name}
97chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
98chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
99if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
100  /usr/sbin/nsd-control-setup
101fi
102
103%preun
104if [ $1 -eq 0 ]; then
105        /sbin/service %{name} stop
106        /sbin/chkconfig --del %{name}
107fi
108
109%postun
110if [ "$1" -ge "1" ]; then
111  /sbin/service %{name} condrestart
112fi
113
114%changelog
115* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
116- new upstream release.
117- dropped Source2 (no longer needed).
118
119* Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
120- new upstream release
121
122* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
123- new upstream release
124
125* Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
126- new upstream release
127
128* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
129- new upstream release
130
131* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
132- initial build for Vine Linux
133
134* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
135- Updated to nsd 3.2.4
136
137* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
138- Incorporated Ville Mattila's fixes  to nsd.cron
139- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
140
141* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
142- rebuilt with new openssl
143
144* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
145- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
146
147* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
148-Updated to version 3.2.3
149
150* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
152
153* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
154- Fixed /dev/nul which cause a file \%%1 to be written by cron
155- Bump for EVR.
156
157* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
158- Upgraded to 3.2.2 security release
159  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
160
161* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
162- Make various file paths used by the nsd.init script configurable
163  from /etc/sysconfig/nsd.
164- Add template /etc/sysconfig/nsd.
165
166* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
167- nsd used the 'named' subsystem in one call in the init script
168
169* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
171
172* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
173- Fix init script 'unary operator' error.
174
175* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
176- Updated to new version 3.2.1
177
178* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
179- rebuild with new openssl
180
181* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
182- Updates summary as per Richard Hughes guidelines
183
184* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
185- Bump version after pre-release version correction.
186
187* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
188- 3.2.0-1
189
190* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
191- updated to 3.1.1
192
193* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
194- fix license tag
195- fix static user creation
196
197* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
198- Updated to 3.1.0
199
200* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
201- Fix /dev/null redirection [Venkatesh Krishnamurthi]
202
203* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
204- Updated to 3.0.8
205
206* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
207- Autorebuild for GCC 4.3
208
209* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
210- Rebuild for new libcrypto
211
212* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
213- Updated to new version
214- fix RELNOTES/README to be utf8
215- Fix path to nsd.db in cron job.
216
217* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
218- Modified cron to only rebuild/reload when zone updates
219  have been received
220
221* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
222- Added hourly cron job to do various maintenance tasks
223- Added nsd rebuild to create the proper nsd.db file on startup
224- Added nsd patch on shutdown to ensure zonefiles are up to date
225
226* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
227- nsdc update and nsdc notify are no longer needed in initscript.
228
229* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
230- Bump release for upgrade path.
231
232* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
233- Do not include examples from nsd.conf.sample that causes
234  bogus network traffic.
235
236* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
237- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
238- Enable NSEC3
239- Delay running nsdc update until after nsd has started
240- Delete xfrd.state on nsd stop
241- Run nsdc notify in the background, since it can take
242  a very long time when remote servers are unavailable.
243
244* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
245- Upgraded to 3.0.6
246- Do not include bind2nsd, since it didn't compile for me
247
248* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
249- Fix init script, bug #245546
250
251* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
252- Upgraded to 3.0.5
253
254* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
255- Upgraded to 3.0.3
256
257* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
258- Upgraded to 3.0.2.
259- Use new configuration file nsd.conf. Still needs migration script.
260  patch from Farkas Levente <lfarkas@bppiac.hu>
261
262* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
263- Bump version for upgrade path
264
265* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
266- Upgraded to 2.3.6
267- Removed obsolete workaround in nsd.init
268- Fixed spec file so daemon gets properly restarted on upgrade
269
270* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
271- Rebuild requested for PT_GNU_HASH support from gcc
272- Removed dbaccess.c from doc section
273
274* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
275- Bump version for FC-x upgrade path
276
277* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
278- Upgraded to nsd-2.3.5
279
280* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
281- Upgraded to nsd-2.3.4.
282- Removed manual install targets because DESTDIR is now supported
283- Re-enabled --checking, checking patch no longer needed and removed.
284- Work around in nsd.init for nsd failing to start when there is no ipv6
285
286* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
287- chkconfig and attribute  changes as proposed by Dmitry Butskoy
288
289* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
290- Moved pid file to /var/run/nsd/nsd.pid.
291- Use _localstatedir instead of "/var"
292
293* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
294- Added BuildRequires for openssl-devel, removed Requires for openssl.
295
296* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
297- upgraded to nsd-2.3.3
298
299* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
300- minor cleanups
301
302* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
303- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
304  Extras policies (eg do not start daemon on fresh install)
305
306* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
307- Initial version
Note: See TracBrowser for help on using the repository browser.