source: projects/specs/trunk/n/nsd/nsd-vl.spec @ 5790

Revision 5790, 9.9 KB checked in by daisuke, 12 years ago (diff)

update to 3.2.10

Line 
1Summary: Fast and lean authoritative DNS Name Server
2Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
3Name: nsd
4Version: 3.2.10
5Release: 1%{?_dist_release}
6License: BSD
7Url: http://www.nlnetlabs.nl/%{name}/
8Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
9Source1: nsd.init
10Source2: nsd.cron
11Source3: nsd.sysconfig
12Patch0: nsd-install.patch
13Group: System Environment/Daemons
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: flex, openssl-devel
16Requires(pre): shadow-utils
17
18%description
19NSD is a complete implementation of an authoritative DNS name server.
20For further information about what NSD is and what NSD is not please
21consult the REQUIREMENTS document which is a part of this distribution
22
23%description -l ja
24NSD は Authoritative DNSネームサーバの完全な実装です。
25NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
26
27%prep
28%setup -q
29%patch0 -p1
30
31%build
32%configure --enable-bind8-stats --enable-checking --enable-nsec3 \
33           --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid --with-ssl \
34           --with-user=nsd --with-difffile=%{_localstatedir}/lib/%{name}/ixfr.db \
35           --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
36           --with-dbfile=%{_localstatedir}/lib/%{name}/nsd.db
37
38%{__make} %{?_smp_mflags}
39#convert to utf8
40iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
41iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
42mv -f doc/RELNOTES.utf8 doc/RELNOTES
43mv -f doc/CREDITS.utf8 doc/CREDITS
44
45
46%install
47rm -rf %{buildroot}
48%{__make} DESTDIR=%{buildroot} install
49install -d -m 0755 %{buildroot}%{_initrddir}
50install -d -m 0755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
51install -c -m 0755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/nsd
52install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
53install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
54install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
55install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
56install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
57
58# change .sample to normal config files
59head -76 %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample > %{buildroot}%{_sysconfdir}/nsd/nsd.conf
60rm %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample
61echo "database: /var/lib/nsd/nsd.db" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
62echo "# include: \"/some/path/file\"" >> %{buildroot}%{_sysconfdir}/nsd/nsd.conf
63
64%clean
65rm -rf ${RPM_BUILD_ROOT}
66
67%files
68%defattr(-,root,root,-)
69%doc doc/*
70%doc contrib/nsd.zones2nsd.conf
71%dir %{_sysconfdir}/nsd/
72%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
73#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
74%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
75%attr(0755,root,root) %{_initrddir}/%{name}
76%{_sysconfdir}/cron.hourly/nsd
77%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
78%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
79%{_sbindir}/*
80%{_mandir}/*/*
81
82%pre
83getent group nsd >/dev/null || groupadd -r nsd
84getent passwd nsd >/dev/null || \
85useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
86-c "nsd daemon account" nsd
87exit 0
88
89%post
90/sbin/chkconfig --add %{name}
91
92%preun
93if [ $1 -eq 0 ]; then
94        /sbin/service %{name} stop
95        /sbin/chkconfig --del %{name}
96fi
97
98%postun
99if [ "$1" -ge "1" ]; then
100  /sbin/service %{name} condrestart
101fi
102
103%changelog
104* Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
105- new upstream release
106
107* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
108- new upstream release
109
110* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
111- initial build for Vine Linux
112
113* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
114- Updated to nsd 3.2.4
115
116* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
117- Incorporated Ville Mattila's fixes  to nsd.cron
118- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
119
120* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
121- rebuilt with new openssl
122
123* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
124- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
125
126* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
127-Updated to version 3.2.3
128
129* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
131
132* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
133- Fixed /dev/nul which cause a file \%%1 to be written by cron
134- Bump for EVR.
135
136* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
137- Upgraded to 3.2.2 security release
138  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
139
140* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
141- Make various file paths used by the nsd.init script configurable
142  from /etc/sysconfig/nsd.
143- Add template /etc/sysconfig/nsd.
144
145* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
146- nsd used the 'named' subsystem in one call in the init script
147
148* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
150
151* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
152- Fix init script 'unary operator' error.
153
154* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
155- Updated to new version 3.2.1
156
157* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
158- rebuild with new openssl
159
160* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
161- Updates summary as per Richard Hughes guidelines
162
163* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
164- Bump version after pre-release version correction.
165
166* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
167- 3.2.0-1
168
169* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
170- updated to 3.1.1
171
172* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
173- fix license tag
174- fix static user creation
175
176* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
177- Updated to 3.1.0
178
179* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
180- Fix /dev/null redirection [Venkatesh Krishnamurthi]
181
182* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
183- Updated to 3.0.8
184
185* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
186- Autorebuild for GCC 4.3
187
188* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
189- Rebuild for new libcrypto
190
191* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
192- Updated to new version
193- fix RELNOTES/README to be utf8
194- Fix path to nsd.db in cron job.
195
196* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
197- Modified cron to only rebuild/reload when zone updates
198  have been received
199
200* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
201- Added hourly cron job to do various maintenance tasks
202- Added nsd rebuild to create the proper nsd.db file on startup
203- Added nsd patch on shutdown to ensure zonefiles are up to date
204
205* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
206- nsdc update and nsdc notify are no longer needed in initscript.
207
208* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
209- Bump release for upgrade path.
210
211* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
212- Do not include examples from nsd.conf.sample that causes
213  bogus network traffic.
214
215* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
216- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
217- Enable NSEC3
218- Delay running nsdc update until after nsd has started
219- Delete xfrd.state on nsd stop
220- Run nsdc notify in the background, since it can take
221  a very long time when remote servers are unavailable.
222
223* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
224- Upgraded to 3.0.6
225- Do not include bind2nsd, since it didn't compile for me
226
227* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
228- Fix init script, bug #245546
229
230* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
231- Upgraded to 3.0.5
232
233* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
234- Upgraded to 3.0.3
235
236* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
237- Upgraded to 3.0.2.
238- Use new configuration file nsd.conf. Still needs migration script.
239  patch from Farkas Levente <lfarkas@bppiac.hu>
240
241* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
242- Bump version for upgrade path
243
244* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
245- Upgraded to 2.3.6
246- Removed obsolete workaround in nsd.init
247- Fixed spec file so daemon gets properly restarted on upgrade
248
249* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
250- Rebuild requested for PT_GNU_HASH support from gcc
251- Removed dbaccess.c from doc section
252
253* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
254- Bump version for FC-x upgrade path
255
256* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
257- Upgraded to nsd-2.3.5
258
259* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
260- Upgraded to nsd-2.3.4.
261- Removed manual install targets because DESTDIR is now supported
262- Re-enabled --checking, checking patch no longer needed and removed.
263- Work around in nsd.init for nsd failing to start when there is no ipv6
264
265* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
266- chkconfig and attribute  changes as proposed by Dmitry Butskoy
267
268* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
269- Moved pid file to /var/run/nsd/nsd.pid.
270- Use _localstatedir instead of "/var"
271
272* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
273- Added BuildRequires for openssl-devel, removed Requires for openssl.
274
275* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
276- upgraded to nsd-2.3.3
277
278* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
279- minor cleanups
280
281* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
282- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
283  Extras policies (eg do not start daemon on fresh install)
284
285* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
286- Initial version
Note: See TracBrowser for help on using the repository browser.