source: projects/specs/trunk/n/nsd/nsd-vl.spec @ 12374

Revision 12374, 13.3 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

libevent-2.1.11-1

memcached-1.6.5-1

netatalk-3.1.12-2

nfs-utils-2.4.3-1

nsd-4.3.0-3

perl-Event-Lib-1.03-5

tmux-3.0a-1

unbound-1.10.0-2

zabbix-4.0.19-2

Line 
1%bcond_with systemd
2
3Summary: Fast and lean authoritative DNS Name Server
4Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
5Name: nsd
6Version: 4.3.0
7Release: 3%{?_dist_release}%{?with_systemd:.systemd}
8Group: System Environment/Daemons
9Vendor: Project Vine
10Distribution: Vine Linux
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13License: BSD
14Url: http://www.nlnetlabs.nl/%{name}/
15Source: https://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
16Source1: nsd.init
17Source3: nsd.sysconfig
18Source10: nsd.service
19Source11: nsd-keygen.service
20Source12: tmpfiles-nsd.conf
21
22BuildRequires: flex, libevent-devel, openssl-devel
23Requires(pre): shadow-utils
24%if %{with systemd}
25%global piddir /run/%{name}
26BuildRequires: systemd-devel
27%{?systemd_requires}
28%else
29%global piddir %{_localstatedir}/run/%{name}
30Requires(post): /sbin/chkconfig
31Requires(preun): /sbin/chkconfig
32Requires(preun): /sbin/service
33Requires(postun): /sbin/service
34%endif
35
36%description
37NSD is a complete implementation of an authoritative DNS name server.
38For further information about what NSD is and what NSD is not please
39consult the REQUIREMENTS document which is a part of this distribution
40
41%description -l ja
42NSD は Authoritative DNSネームサーバの完全な実装です。
43NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
44
45%prep
46%setup -q
47autoreconf
48
49
50%build
51%configure \
52        --with-configdir=%{_sysconfdir}/nsd \
53        --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
54        --with-zonesdir=%{_sysconfdir}/nsd \
55        --with-pidfile=%{piddir}/%{name}/%{name}.pid \
56    --with-zonelistfile=%{_sharedstatedir}/nsd/zone.list \
57        --with-ssl \
58        --with-user=nsd \
59        --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
60        --with-max-ips=1024 \
61        --with-dbfile="" \
62        --enable-bind8-stats \
63        --enable-zone-stats \
64        --enable-checking \
65        --enable-mmap \
66        --enable-nsec3 \
67        --enable-ratelimit \
68        --enable-pie \
69        --enable-relro-now \
70        --enable-recvmmsg \
71        --enable-packed \
72        --enable-memclean \
73%if %{with systemd}
74        --enable-systemd \
75%endif
76        %{nil}
77
78%{__make} %{?_smp_mflags}
79#convert to utf8
80iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
81iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
82mv -f doc/RELNOTES.utf8 doc/RELNOTES
83mv -f doc/CREDITS.utf8 doc/CREDITS
84
85
86%install
87rm -rf %{buildroot}
88%{__make} DESTDIR=%{buildroot} install
89install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
90install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
91
92%if %{with systemd}
93mkdir -p %{buildroot}%{_unitdir}
94install -m 0644 %{SOURCE10} %{SOURCE11} %{buildroot}%{_unitdir}
95mkdir -p %{buildroot}%{_tmpfilesdir}
96install -m 0644 %{SOURCE12} %{buildroot}%{_tmpfilesdir}/nsd.conf
97%else
98install -d -m 0755 %{buildroot}%{_initrddir}
99install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
100install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
101install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
102%endif
103
104# change .sample to normal config files
105mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
106sed -i \
107        -e 's/# database:.*$/database: ""/' \
108        -e 's/# round-robin:.*$/round-robin: yes/' \
109        -e 's/# minimal-responses:.*$/minimal-responses: yes/' \
110        -e 's/# refuse-any:.*$/refuse-any: yes/' \
111        -e 's/# control-enable:.*$/control-enable: yes/' \
112        -e 's|# control-interface: ::1|control-interface: %{piddir}/nsd.ctl|' \
113        %{buildroot}%{_sysconfdir}/nsd/nsd.conf
114
115
116%clean
117rm -rf ${RPM_BUILD_ROOT}
118
119%files
120%defattr(-,root,root,-)
121%doc doc/*
122%doc contrib/nsd.zones2nsd.conf
123%dir %{_sysconfdir}/nsd/
124%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
125#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
126%if %{with systemd}
127%attr(0644,root,root) %{_unitdir}/nsd.service
128%attr(0644,root,root) %{_unitdir}/nsd-keygen.service
129%attr(0644,root,root) %{_tmpfilesdir}/nsd.conf
130%else
131%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
132%attr(0755,root,root) %{_initrddir}/%{name}
133%endif
134%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
135%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
136%{_sbindir}/*
137%{_mandir}/*/*
138
139%pre
140getent group nsd >/dev/null || groupadd -r nsd
141getent passwd nsd >/dev/null || \
142useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
143-c "nsd daemon account" nsd
144exit 0
145
146%post
147chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
148chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
149%if %{with systemd}
150%systemd_post nsd.service
151%systemd_post nsd-keygen.service
152%else
153/sbin/chkconfig --add %{name}
154if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
155  /usr/sbin/nsd-control-setup
156fi
157%endif
158
159%preun
160%if %{with systemd}
161%systemd_preun nsd.service
162%systemd_preun nsd-keygen.service
163%else
164if [ $1 -eq 0 -o -x /bin/systemctl ]; then
165        /sbin/service %{name} stop
166        /sbin/chkconfig --del %{name}
167fi
168%endif
169
170%postun
171%if %{with systemd}
172%systemd_postun_with_restart nsd.service
173%systemd_postun nsd-keygen.service
174%else
175if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
176  /sbin/service %{name} condrestart
177fi
178%endif
179
180%changelog
181* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-3
182- rebuilt with libevent-2.1.11.
183
184* Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-2
185- fixed nsd-keygen.service.
186- updated nsd.conf.
187
188* Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
189- new upstream release.
190- dropped Patch0.
191- added systemd support (disabled as default).
192
193* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.4-1
194- new upstream release.
195
196* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.2-1
197- new upstream release.
198
199* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.25-1
200- new upstream release.
201- rebuilt with openssl-1.1.1 and libevent-2.1.8.
202
203* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.19-1
204- new upstream release.
205
206* Wed Mar  8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
207- new upstream release.
208
209* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
210- new upstream release.
211
212* Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
213- new upstream release.
214
215* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
216- rebuilt with openssl-1.0.2g.
217
218* Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
219- new upstream release.
220
221* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
222- new upstream release.
223
224* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
225- new upstream release.
226
227* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
228- new upstream release.
229- dropped Source2 (no longer needed).
230
231* Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
232- new upstream release
233
234* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
235- new upstream release
236
237* Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
238- new upstream release
239
240* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
241- new upstream release
242
243* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
244- initial build for Vine Linux
245
246* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
247- Updated to nsd 3.2.4
248
249* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
250- Incorporated Ville Mattila's fixes  to nsd.cron
251- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
252
253* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
254- rebuilt with new openssl
255
256* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
257- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
258
259* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
260-Updated to version 3.2.3
261
262* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
264
265* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
266- Fixed /dev/nul which cause a file \%%1 to be written by cron
267- Bump for EVR.
268
269* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
270- Upgraded to 3.2.2 security release
271  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
272
273* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
274- Make various file paths used by the nsd.init script configurable
275  from /etc/sysconfig/nsd.
276- Add template /etc/sysconfig/nsd.
277
278* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
279- nsd used the 'named' subsystem in one call in the init script
280
281* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
282- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
283
284* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
285- Fix init script 'unary operator' error.
286
287* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
288- Updated to new version 3.2.1
289
290* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
291- rebuild with new openssl
292
293* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
294- Updates summary as per Richard Hughes guidelines
295
296* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
297- Bump version after pre-release version correction.
298
299* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
300- 3.2.0-1
301
302* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
303- updated to 3.1.1
304
305* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
306- fix license tag
307- fix static user creation
308
309* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
310- Updated to 3.1.0
311
312* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
313- Fix /dev/null redirection [Venkatesh Krishnamurthi]
314
315* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
316- Updated to 3.0.8
317
318* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
319- Autorebuild for GCC 4.3
320
321* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
322- Rebuild for new libcrypto
323
324* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
325- Updated to new version
326- fix RELNOTES/README to be utf8
327- Fix path to nsd.db in cron job.
328
329* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
330- Modified cron to only rebuild/reload when zone updates
331  have been received
332
333* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
334- Added hourly cron job to do various maintenance tasks
335- Added nsd rebuild to create the proper nsd.db file on startup
336- Added nsd patch on shutdown to ensure zonefiles are up to date
337
338* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
339- nsdc update and nsdc notify are no longer needed in initscript.
340
341* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
342- Bump release for upgrade path.
343
344* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
345- Do not include examples from nsd.conf.sample that causes
346  bogus network traffic.
347
348* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
349- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
350- Enable NSEC3
351- Delay running nsdc update until after nsd has started
352- Delete xfrd.state on nsd stop
353- Run nsdc notify in the background, since it can take
354  a very long time when remote servers are unavailable.
355
356* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
357- Upgraded to 3.0.6
358- Do not include bind2nsd, since it didn't compile for me
359
360* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
361- Fix init script, bug #245546
362
363* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
364- Upgraded to 3.0.5
365
366* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
367- Upgraded to 3.0.3
368
369* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
370- Upgraded to 3.0.2.
371- Use new configuration file nsd.conf. Still needs migration script.
372  patch from Farkas Levente <lfarkas@bppiac.hu>
373
374* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
375- Bump version for upgrade path
376
377* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
378- Upgraded to 2.3.6
379- Removed obsolete workaround in nsd.init
380- Fixed spec file so daemon gets properly restarted on upgrade
381
382* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
383- Rebuild requested for PT_GNU_HASH support from gcc
384- Removed dbaccess.c from doc section
385
386* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
387- Bump version for FC-x upgrade path
388
389* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
390- Upgraded to nsd-2.3.5
391
392* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
393- Upgraded to nsd-2.3.4.
394- Removed manual install targets because DESTDIR is now supported
395- Re-enabled --checking, checking patch no longer needed and removed.
396- Work around in nsd.init for nsd failing to start when there is no ipv6
397
398* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
399- chkconfig and attribute  changes as proposed by Dmitry Butskoy
400
401* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
402- Moved pid file to /var/run/nsd/nsd.pid.
403- Use _localstatedir instead of "/var"
404
405* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
406- Added BuildRequires for openssl-devel, removed Requires for openssl.
407
408* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
409- upgraded to nsd-2.3.3
410
411* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
412- minor cleanups
413
414* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
415- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
416  Extras policies (eg do not start daemon on fresh install)
417
418* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
419- Initial version
Note: See TracBrowser for help on using the repository browser.