source: projects/specs/trunk/n/nsd/nsd-vl.spec @ 12121

Revision 12121, 11.3 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1Summary: Fast and lean authoritative DNS Name Server
2Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
3Name: nsd
4Version: 4.2.2
5Release: 1%{?_dist_release}
6License: BSD
7Url: http://www.nlnetlabs.nl/%{name}/
8Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
9Source1: nsd.init
10Source3: nsd.sysconfig
11Patch0: nsd-4.1.10-config.patch
12Group: System Environment/Daemons
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14Vendor: Project Vine
15Distribution: Vine Linux
16
17BuildRequires: flex, libevent-devel, openssl-devel
18Requires(pre): shadow-utils
19
20%description
21NSD is a complete implementation of an authoritative DNS name server.
22For further information about what NSD is and what NSD is not please
23consult the REQUIREMENTS document which is a part of this distribution
24
25%description -l ja
26NSD は Authoritative DNSネームサーバの完全な実装です。
27NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
28
29%prep
30%setup -q
31
32%patch0 -p1
33
34%build
35%configure \
36        --with-configdir=%{_sysconfdir}/nsd \
37        --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
38        --with-zonesdir=%{_sysconfdir}/nsd \
39        --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
40        --with-dbfile=%{_localstatedir}/lib/%{name}/nsd.db \
41        --with-difffile=%{_localstatedir}/lib/%{name}/ixfr.db \
42        --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
43        --with-max-ips=1024 \
44        --with-ssl \
45        --with-user=nsd \
46        --enable-bind8-stats \
47        --enable-checking \
48        --enable-mmap \
49        --enable-nsec3 \
50        --enable-ratelimit
51
52%{__make} %{?_smp_mflags}
53#convert to utf8
54iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
55iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
56mv -f doc/RELNOTES.utf8 doc/RELNOTES
57mv -f doc/CREDITS.utf8 doc/CREDITS
58
59
60%install
61rm -rf %{buildroot}
62%{__make} DESTDIR=%{buildroot} install
63install -d -m 0755 %{buildroot}%{_initrddir}
64install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
65install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
66install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
67install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
68install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
69
70# change .sample to normal config files
71mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
72
73%clean
74rm -rf ${RPM_BUILD_ROOT}
75
76%files
77%defattr(-,root,root,-)
78%doc doc/*
79%doc contrib/nsd.zones2nsd.conf
80%dir %{_sysconfdir}/nsd/
81%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
82#%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
83%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
84%attr(0755,root,root) %{_initrddir}/%{name}
85%ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
86%attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
87%{_sbindir}/*
88%{_mandir}/*/*
89
90%pre
91getent group nsd >/dev/null || groupadd -r nsd
92getent passwd nsd >/dev/null || \
93useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
94-c "nsd daemon account" nsd
95exit 0
96
97%post
98/sbin/chkconfig --add %{name}
99chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
100chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
101if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
102  /usr/sbin/nsd-control-setup
103fi
104
105%preun
106if [ $1 -eq 0 ]; then
107        /sbin/service %{name} stop
108        /sbin/chkconfig --del %{name}
109fi
110
111%postun
112if [ "$1" -ge "1" ]; then
113  /sbin/service %{name} condrestart
114fi
115
116%changelog
117* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.2-1
118- new upstream release.
119
120* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.25-1
121- new upstream release.
122- rebuilt with openssl-1.1.1 and libevent-2.1.8.
123
124* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.19-1
125- new upstream release.
126
127* Wed Mar  8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
128- new upstream release.
129
130* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
131- new upstream release.
132
133* Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
134- new upstream release.
135
136* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
137- rebuilt with openssl-1.0.2g.
138
139* Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
140- new upstream release.
141
142* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
143- new upstream release.
144
145* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
146- new upstream release.
147
148* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
149- new upstream release.
150- dropped Source2 (no longer needed).
151
152* Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
153- new upstream release
154
155* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
156- new upstream release
157
158* Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
159- new upstream release
160
161* Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
162- new upstream release
163
164* Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
165- initial build for Vine Linux
166
167* Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
168- Updated to nsd 3.2.4
169
170* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
171- Incorporated Ville Mattila's fixes  to nsd.cron
172- Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
173
174* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
175- rebuilt with new openssl
176
177* Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
178- The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
179
180* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
181-Updated to version 3.2.3
182
183* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
185
186* Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
187- Fixed /dev/nul which cause a file \%%1 to be written by cron
188- Bump for EVR.
189
190* Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
191- Upgraded to 3.2.2 security release
192  http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
193
194* Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
195- Make various file paths used by the nsd.init script configurable
196  from /etc/sysconfig/nsd.
197- Add template /etc/sysconfig/nsd.
198
199* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
200- nsd used the 'named' subsystem in one call in the init script
201
202* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
204
205* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
206- Fix init script 'unary operator' error.
207
208* Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
209- Updated to new version 3.2.1
210
211* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
212- rebuild with new openssl
213
214* Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
215- Updates summary as per Richard Hughes guidelines
216
217* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
218- Bump version after pre-release version correction.
219
220* Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
221- 3.2.0-1
222
223* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
224- updated to 3.1.1
225
226* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
227- fix license tag
228- fix static user creation
229
230* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
231- Updated to 3.1.0
232
233* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
234- Fix /dev/null redirection [Venkatesh Krishnamurthi]
235
236* Tue May  6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
237- Updated to 3.0.8
238
239* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
240- Autorebuild for GCC 4.3
241
242* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
243- Rebuild for new libcrypto
244
245* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
246- Updated to new version
247- fix RELNOTES/README to be utf8
248- Fix path to nsd.db in cron job.
249
250* Thu Nov  8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
251- Modified cron to only rebuild/reload when zone updates
252  have been received
253
254* Wed Nov  7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
255- Added hourly cron job to do various maintenance tasks
256- Added nsd rebuild to create the proper nsd.db file on startup
257- Added nsd patch on shutdown to ensure zonefiles are up to date
258
259* Tue Oct  2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
260- nsdc update and nsdc notify are no longer needed in initscript.
261
262* Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
263- Bump release for upgrade path.
264
265* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
266- Do not include examples from nsd.conf.sample that causes
267  bogus network traffic.
268
269* Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
270- Change locations of ixfr.db and xfrd.state to /var/lib/nsd
271- Enable NSEC3
272- Delay running nsdc update until after nsd has started
273- Delete xfrd.state on nsd stop
274- Run nsdc notify in the background, since it can take
275  a very long time when remote servers are unavailable.
276
277* Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
278- Upgraded to 3.0.6
279- Do not include bind2nsd, since it didn't compile for me
280
281* Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
282- Fix init script, bug #245546
283
284* Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
285- Upgraded to 3.0.5
286
287* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
288- Upgraded to 3.0.3
289
290* Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
291- Upgraded to 3.0.2.
292- Use new configuration file nsd.conf. Still needs migration script.
293  patch from Farkas Levente <lfarkas@bppiac.hu>
294
295* Mon Oct 16 2006  Paul Wouters <paul@xelerance.com> 2.3.6-2
296- Bump version for upgrade path
297
298* Thu Oct 12 2006  Paul Wouters <paul@xelerance.com> 2.3.6-1
299- Upgraded to 2.3.6
300- Removed obsolete workaround in nsd.init
301- Fixed spec file so daemon gets properly restarted on upgrade
302
303* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
304- Rebuild requested for PT_GNU_HASH support from gcc
305- Removed dbaccess.c from doc section
306
307* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
308- Bump version for FC-x upgrade path
309
310* Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
311- Upgraded to nsd-2.3.5
312
313* Sun May  7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
314- Upgraded to nsd-2.3.4.
315- Removed manual install targets because DESTDIR is now supported
316- Re-enabled --checking, checking patch no longer needed and removed.
317- Work around in nsd.init for nsd failing to start when there is no ipv6
318
319* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
320- chkconfig and attribute  changes as proposed by Dmitry Butskoy
321
322* Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
323- Moved pid file to /var/run/nsd/nsd.pid.
324- Use _localstatedir instead of "/var"
325
326* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
327- Added BuildRequires for openssl-devel, removed Requires for openssl.
328
329* Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
330- upgraded to nsd-2.3.3
331
332* Wed Dec  7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
333- minor cleanups
334
335* Mon Dec  5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
336- Upgraded to 2.3.2. Changed post scripts to comply to Fedora
337  Extras policies (eg do not start daemon on fresh install)
338
339* Tue Oct  4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
340- Initial version
Note: See TracBrowser for help on using the repository browser.