source: projects/specs/trunk/n/notify-sharp/notify-sharp-vl.spec @ 521

Revision 521, 4.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define svndate 20080912
2%define mono_dir %{_prefix}/lib/mono
3%define monodoc_dir %{_prefix}/lib/monodoc
4
5Name:           notify-sharp
6Version:        0.4.0
7Release:        3.%{svndate}svn%{?_dist_release}
8Summary:        A C# implementation for Desktop Notifications
9Summary(ja):    デスクトップ通知の C# による実装
10Group:          System Environment/Libraries
11License:        MIT
12URL:            http://trac.galago-project.org/wiki/DesktopNotifications
13#svn checkout, revision 3017. To reproduce tarball:
14#svn co -r 3017  http://svn.galago-project.org/trunk/notify-sharp notify-sharp-20080912 && tar -cvjf notify-sharp-20080912.tar.bz2 notify-sharp-20080912
15Source0:        %{name}-%{svndate}.tar.bz2
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  mono-devel, gtk-sharp2, gnome-sharp2, ndesk-dbus-glib
19BuildRequires:  autoconf, automake, libtool
20BuildRequires:  monodoc
21
22Packager:       kazutaka
23
24%description
25notify-sharp is a C# client implementation for Desktop Notifications,
26i.e. notification-daemon. It is inspired by the libnotify API.
27
28Desktop Notifications provide a standard way of doing passive pop-up
29notifications on the Linux desktop. These are designed to notify the
30user of something without interrupting their work with a dialog box
31that they must close. Passive popups can automatically disappear after
32a short period of time.
33
34%package devel
35Summary:        Development files for notify-sharp
36Summary(ja):    notify-sharp の開発用ファイル
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       pkgconfig
40
41%description devel
42Development files for notify-sharp
43
44%package doc
45Summary:        Documention files for notify-sharp
46Summary(ja):    notify-sharp のドキュメント
47Group:          Documentation
48Requires:       %{name} = %{version}-%{release}
49Requires:       monodoc
50
51%description doc
52Documentation files for notify-sharp
53
54%prep
55%setup -qn %{name}-%{svndate}
56
57##sed -i -e 's!${exec_prefix}/lib!%{_libdir}!' notify-sharp.pc.in
58sed -i -e 's!${exec_prefix}/lib!%{_prefix}/lib!' notify-sharp.pc.in
59
60%build
61autoreconf --install
62%configure --libdir=%{_prefix}/lib
63make
64
65%install
66rm -rf ${RPM_BUILD_ROOT}
67make install DESTDIR=${RPM_BUILD_ROOT} pkgconfigdir=%{_libdir}/pkgconfig
68
69
70%clean
71rm -rf ${RPM_BUILD_ROOT}
72
73
74%files
75%defattr(-,root,root,-)
76%doc COPYING NEWS README AUTHORS
77#%{_libdir}/mono/gac/notify-sharp/
78#%{_libdir}/mono/notify-sharp/notify-sharp.dll
79%{mono_dir}/gac/notify-sharp/
80%{mono_dir}/notify-sharp/notify-sharp.dll
81
82%files devel
83%defattr(-,root,root,-)
84%{_libdir}/pkgconfig/notify-sharp.pc
85
86%files doc
87%defattr(-,root,root,-)
88#%{_libdir}/monodoc/sources/*
89%{monodoc_dir}/sources/*
90
91%changelog
92* Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-3.20080912svn
93- rebuild with latest rpm to update mono-dependencies
94
95* Sat Jun 13 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.0-2.20080912svn
96- added mono_dir, monodoc_dir macros
97- added --libdir=%%{_prefix}/lib option to %%configure
98- added pkgconfigdir=%%{_libdir}/pkgconfig option to make install
99
100* Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1.20080912svn
101- initial build for Vine Linux based on fedora development
102
103* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-0.6.20080912svn
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
105
106* Tue Oct 9 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.5.20080912svn
107- Fix doc package dependencies.
108
109* Wed Sep 24 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.4.20080912svn
110- Replace with simple sed line in spec
111- Build documentation, add monodoc dependencies.
112
113* Wed Sep 24 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.3.20080912svn
114- Add patch to fix libdir on all arches.
115
116* Mon Sep 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.2.20080912svn
117- Update changelog
118- Fix whitespace issues
119
120* Fri Sep 12 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.1.20080912svn
121- Redid svn checkout and tarball creation process
122- Added autoreconfig shebang + autotools deps
123
124* Sat May 31 2008 Nigel Jones <dev@nigelj.com> - 0.4.0-0.1.20080531svn
125- Initial RPM based on David Nielsen's work on fedorapeople.org
Note: See TracBrowser for help on using the repository browser.