source: projects/specs/trunk/n/notify-python/notify-python-vl.spec @ 4616

Revision 4616, 3.0 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary:        Python bindings for libnotify
4Summary(ja):    libnotify の Python バインディング
5
6Name:           notify-python
7Version:        0.1.1
8Release:        4%{?_dist_release}
9
10Group:          Development/Languages
11# No version specified, just COPYING.
12License:        LGPLv2+
13URL:            http://www.galago-project.org/specs/notification
14Source0:        http://www.galago-project.org/files/releases/source/notify-python/notify-python-%{version}.tar.gz
15Patch0:         libnotify07.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19BuildRequires:  python-devel, pkgconfig, libnotify-devel, pygtk2-devel
20BuildRequires:  gtk2-devel, dbus-devel, dbus-glib-devel
21
22Requires:   libnotify
23Requires:   notification-daemon
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%define pypkgname pynotify
29
30%description
31Python bindings for libnotify
32
33%prep
34%setup -q
35%patch0 -p1 -b .libnotify07
36
37# WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
38# from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
39
40%build
41CFLAGS="$RPM_OPT_FLAGS"
42PYTHON=%{__python}
43%configure
44touch src/pynotify.override
45make
46
47%install
48rm -rf $RPM_BUILD_ROOT
49make DESTDIR=$RPM_BUILD_ROOT install
50# remove unnecessary la file
51rm $RPM_BUILD_ROOT/%{python_sitearch}/gtk-2.0/%{pypkgname}/_%{pypkgname}.la
52
53 
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(-,root,root,-)
59%doc
60%{python_sitearch}/gtk-2.0/%{pypkgname}
61%{_datadir}/pygtk/2.0/defs/%{pypkgname}.defs
62%{_libdir}/pkgconfig/%{name}.pc
63
64%changelog
65* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.1-4
66- rebuild with libnotify-0.7.2
67- add Patch0 (libnotify07.patch) from fedora
68
69* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.1-3
70- rebuilt with rpm-4.8.1 for pkg-config
71
72* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.1-2
73- rebuild with python-2.6
74
75* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.1-1
76- initial build for Vine Linux
77
78* Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.1.1-4
79- fix license tag
80
81* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.1-3
82- Autorebuild for GCC 4.3
83
84* Fri Jan  4 2008  <jdennis@redhat.com> - 0.1.1-2
85- Resolves bug# 427499: attach_to_status_icon not created
86  force regeneration of pynotify.c
87
88* Wed Jan  2 2008 John Dennis <jdennis@redhat.com> - 0.1.1-1
89- upgrade to current upstream
90- no longer remove package config file (notify-python.pc), resolves bug #427001
91
92* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.1.0-4
93- rebuild for python 2.5
94
95* Tue Aug 15 2006 Luke Macken <lmacken@redhat.com> - 0.1.0-3
96- Add notify-python-0.1.0-attach_to_status_icon.patch to allow the attaching
97  notifications to status icons.
98
99* Thu Jul 20 2006 John Dennis <jdennis@redhat.com> - 0.1.0-2
100- change use of python_sitelib to python_sitearch, add BuildRequires
101
102* Wed Jul 19 2006 John Dennis <jdennis@redhat.com> - 0.1.0-1
103- Initial build
104
Note: See TracBrowser for help on using the repository browser.