source: projects/specs/trunk/n/notification-daemon/notification-daemon-vl.spec @ 521

Revision 521, 7.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define gtk2_version            2.10.0
2%define glib2_version           2.8.0
3%define dbus_version            0.60
4%define libnotify_version       0.4.0
5
6Summary: Notification Daemon
7Name: notification-daemon
8Version: 0.4.0
9Release: 4%{?_dist_release}
10URL: http://www.galago-project.org/specs/notification/
11License: GPL
12Group: System Environment/Libraries
13
14Source0: %{name}-%{version}.tar.bz2
15Source1: notification-daemon-0.4.0-ja.po
16Patch1:  notification-daemon-0.4.0-ja.patch
17
18# patches from ubuntu
19Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
20Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
21Patch105: notification-daemon-0.4.0-spacing.patch
22Patch107: notification-daemon-0.4.0-memleak-daemon.patch
23Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
24
25# vine theme based on ubuntu engine
26Source200: notification-daemon-engine-vine.tar.bz2
27Patch200: notification-daemon-0.4.0-vine-theme.patch
28Patch201: notification-daemon-0.4.0-default-theme.patch
29
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Requires: dbus >= %{dbus_version}
33Requires: dbus-glib >= %{dbus_version}
34Requires(post): GConf2
35BuildRequires: glib2-devel >= %{glib2_version}
36BuildRequires: dbus-devel >= %{dbus_version}
37BuildRequires: dbus-glib-devel >= %{dbus_version}
38BuildRequires: libnotify-devel >= %{libnotify_version}
39BuildRequires: libsexy-devel
40#BuildRequires: libnotify >= %{libnotify_version}
41
42%description
43notification-daemon is the server implementation of the freedesktop.org
44desktop notification specification. 
45
46%prep
47%setup -q -a 200
48
49%patch1 -p1 -b .ja
50
51%patch103 -p1
52%patch104 -p1
53%patch105 -p0
54%patch107 -p1
55%patch109 -p1
56
57%patch200 -p1
58%patch201 -p1
59
60# install japanese message catalog
61%{__cp} %{SOURCE1} po/ja.po
62
63%build
64autoreconf -f -i
65%configure --disable-schemas-install
66make %{?_smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70%{__make} install DESTDIR=$RPM_BUILD_ROOT
71
72%find_lang %name
73
74# remove unpackaged files
75rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
76
77# install desktop file
78desktop-file-install --delete-original  \
79        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
80        --add-category DesktopSettings \
81        ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
82
83
84%pre
85if [ "$1" -gt 1 ]; then
86    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87    gconftool-2 --makefile-uninstall-rule \
88      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
89fi
90
91%post
92export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93gconftool-2 --makefile-install-rule \
94  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
95
96touch --no-create %{_datadir}/icons/hicolor
97if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
98    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
99fi
100
101%preun
102if [ "$1" -eq 0 ]; then
103    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
104    gconftool-2 --makefile-uninstall-rule \
105      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
106fi
107
108%postun
109touch --no-create %{_datadir}/icons/hicolor
110if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
111    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
112fi
113
114
115%clean
116rm -rf %{buildroot}
117
118
119%files -f %{name}.lang
120%defattr(-,root,root)
121%doc COPYING ChangeLog NEWS
122%{_bindir}/notification-properties
123%{_sysconfdir}/gconf/schemas/%{name}.schemas
124%dir %{_libdir}/notification-daemon-1.0
125%dir %{_libdir}/notification-daemon-1.0/engines
126%{_libdir}/notification-daemon-1.0/engines/*.so
127%{_libexecdir}/notification-daemon
128%{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
129%{_datadir}/applications/notification-properties.desktop
130%{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
131%{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
132%{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
133%{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
134%{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
135%{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
136%{_datadir}/notification-daemon/notification-properties.glade
137
138%changelog
139* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
140- add Categories=DesktopSettings for notification-properties.desktop
141
142* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
143- add Source200, Patch200,201
144  - add vine theme engine based on ubuntu engine.
145
146- add patch101-109 from ubuntu
147  - Patch103: fix xinerama stack
148  - Patch104: dont crash on critical warnings
149  - Patch105: fix notification spacing
150  - Patch107: fix memleak
151  - Patch109: fix crash on theme changing
152
153* Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
154- add japanese translation (Source1 and Patch1)
155- prperly install/uninstall gconf schemas
156- update gtk icon cache with %%post, %%postun
157
158* Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
159- new upstream release
160- change required gtk2 version to 2.10.0
161
162* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
163- applied new versioning policy
164
165* Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
166- rebuilt with libwnck 2.20.2
167
168* Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
169- new upstream release
170- rebuilt with libsexy 0.1.10
171- added BuildRequores: libsexy-devel
172
173* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
174- new upstream release
175
176* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
177- initial build for Vine Linux partialy based on FC package.
178
179* Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
180- Add patch to fix struct handling in the dbus glib binding for dbus 0.61
181  so image data works again
182
183* Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
184- BuildRequires love, for all you lovers out there.
185
186* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
187- bump again for double-long bug on ppc(64)
188
189* Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
190- remove empty scripts from .spec file
191
192* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
193- rebuilt for new gcc4.1 snapshot and glibc changes
194
195* Fri Feb  3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
196- Add patch to determine whether a compositing manager is running
197  when drawing a new notification bubble, as long as the CM grabs
198  the appropriate XSelection.
199
200* Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
201- Make it so that marked-up messages appear with markup
202
203* Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
204- Provide desktop-notification-daemon, since libnotify requires a
205  notification deamon, but not this specific one.  Other notification
206  daemons can exist on the system so long as they meet the provides
207  (and the API of course).
208
209* Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
210- Fix positioning of the notification bubble to not draw off-screen
211
212* Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
213- Actuall release of 0.3.1
214
215* Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
216- Upgrade to upstream 0.3.1
217
218* Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
219- inital build
Note: See TracBrowser for help on using the repository browser.