source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 4.76
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10URL: http://www.insecure.org/nmap/
11Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
12#Source1: zenmap.desktop
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libpcap-devel
16BuildRequires: pcre-devel
17BuildRequires: python-devel
18BuildRequires: pygtk2-devel
19
20%description
21Nmap is a utility for network exploration or security auditing. It
22supports ping scanning (determine which hosts are up), many port
23scanning techniques (determine what services the hosts are offering),
24and TCP/IP fingerprinting (remote host operating system
25identification). Nmap also offers flexible target and port
26specification, decoy scanning, determination of TCP sequence
27predictability characteristics, sunRPC scanning, reverse-identd
28scanning, and more.
29
30%description -l ja
31Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
32ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
33技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
34の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
35ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
36予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
37機能も提供します。
38
39%package frontend
40Summary: Gtk+ frontend for nmap
41Summary(ja): Nmap の GTK+ フロントエンド
42Group: Applications/System
43Requires: nmap = %{version}-%{release}
44Requires: python pygtk2 pysqlite
45Provides: zenmap = %{version}-%{release}
46
47%description frontend
48This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
49be installed before installing nmap-frontend.
50
51%description frontend -l ja
52Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
53する前に、nmap パッケージをインストールする必要があります。
54
55%prep
56%setup -q
57
58%build
59export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
60%configure
61make
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make install DESTDIR=$RPM_BUILD_ROOT
66
67rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
68cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
69gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
70pushd $RPM_BUILD_ROOT%{_mandir}/man1
71ln -s zenmap.1.gz nmapfe.1.gz
72ln -s zenmap.1.gz xnmap.1.gz
73popd
74
75#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
76#mkdir zenmap
77#mv *.svg zenmap
78#mv *.png zenmap
79#popd
80
81#desktop-file-install --vendor= \
82#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
83#       %{SOURCE1};
84rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
85
86%clean
87rm -rf %{buildroot}
88
89%files
90%defattr(-,root,root)
91%doc COPYING COPYING.OpenSSL CHANGELOG
92%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
93%{_bindir}/nmap
94%{_datadir}/nmap
95#%{_libexecdir}/nmap
96%{_mandir}/man1/nmap.1*
97
98%files frontend
99%defattr(-,root,root)
100%{_bindir}/nmapfe
101%{_bindir}/xnmap
102%{_bindir}/zenmap
103%{python_sitelib}/*
104%{_datadir}/applications/*.desktop
105#%{_datadir}/icons/*
106#%{_datadir}/pixmaps/zenmap
107%{_datadir}/zenmap
108%{_mandir}/man1/zenmap.1*
109%{_mandir}/man1/nmapfe.1*
110%{_mandir}/man1/xnmap.1*
111
112%changelog
113* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
114- new upstream release
115- spec in UTF-8
116- added BuildRequires: libpcap-devel instead of libpcap
117- removed BuildRequires: desktop-file-utils
118
119* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
120- rebuilt with libpcap 1.0.0
121
122* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
123- rebuilt with python-2.5.2
124
125* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
126- updated python sitelib files path
127
128* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
129- new upstream release
130
131* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
132- new upstream release
133- rebuild with new environment/toolchain
134
135* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
136- new upstream release
137- added BuildRequires: desktop-file-utils
138
139* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
140- new upstream release
141
142* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
143- rebuild for VineSeed Plus
144
145* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
146- new upstream release
147
148* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
149- new upstream release
150
151* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
152- new upstream release
153- added Japanese summary to nmap-frontend
154
155* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
156- new upstream release
157
158* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
159- rebuild with new openssl
160
161* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
162- new upstream release
163
164* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
165- new upstream release
166
167* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
168- new upstream release
169
170* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
171- new upstream release
172
173* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
174- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
175
176* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
177- new upstream release
178- rebuild with new toolchains
179
180* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
181- new upstream release
182- delete Version Tag from nmap-frontend package
183- fix BuildRoot
184
185* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
186- new upstream release
187- 2.54BETA is developpment release, but it is more stable than 2.53.
188
189* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
190- unfortunately increase release: 1vl2 from 0vl2
191  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
192- patch to build on current glibc22 system
193
194* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
195- 2.53-0vl2: use better macros
196
197* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
198- rebuild for VineSeed based on the original site's srpm
199- add Japanese summary and description
200
201* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
202- Updated description
203- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
204- Fixed nmap distribution URL (source0)
205- Added this .rpm to base Nmap distribution
206
207* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
208- based on origional spec file from
209        http://www.insecure.org/nmap/index.html#download
210- general cleanups, removed lots of commenrts since it made the spec hard to
211        read
212- changed group to Applications/System
213- quiet setup
214- no need to create dirs in the install section, "make
215        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
216- using defined %{prefix}, %{version} etc. for easier/quicker maint.
217- added docs
218- gzip man pages
219- strip after files have been installed into buildroot
220- created separate package for the frontend so that Gtk+ isn't needed for the
221        CLI nmap
222- not using -f in files section anymore, no need for it since there aren't that
223        many files/dirs
224- added desktop entry for gnome
225
226* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
227- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
228
229* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
230- Made some changes, and merged in another .spec file sent in
231  by Oren Tirosh <oren@hishome.net>
232
233* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
234- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.