source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 11905

Revision 11905, 9.5 KB checked in by ara_t, 5 years ago (diff)

nmap: update to 7.70

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 7.70
7Release: 1%{?_dist_release}
8
9License: GPL
10Group: Applications/System
11URL: http://www.insecure.org/nmap/
12Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
13#Source1: zenmap.desktop
14
15# Patches from Fedora rawhide
16#prevent possible race condition for shtool, rhbz#158996
17Patch1: nmap-4.03-mktemp.patch
18
19#don't suggest to scan microsoft
20Patch2: nmap-4.52-noms.patch
21
22# upstream provided patch for rhbz#845005, not yet in upstream repository
23Patch5: ncat_reg_stdin.diff
24Patch6: nmap-6.25-displayerror.patch
25
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: libpcap-devel
29BuildRequires: pcre-devel
30BuildRequires: python-devel
31BuildRequires: pygtk2-devel
32BuildRequires: openssl-devel
33BuildRequires: lua-devel
34
35%description
36Nmap is a utility for network exploration or security auditing. It
37supports ping scanning (determine which hosts are up), many port
38scanning techniques (determine what services the hosts are offering),
39and TCP/IP fingerprinting (remote host operating system
40identification). Nmap also offers flexible target and port
41specification, decoy scanning, determination of TCP sequence
42predictability characteristics, sunRPC scanning, reverse-identd
43scanning, and more.
44
45%description -l ja
46Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
47ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
48技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
49の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
50ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
51予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
52機能も提供します。
53
54%package frontend
55Summary: Gtk+ frontend for nmap
56Summary(ja): Nmap の GTK+ フロントエンド
57Group: Applications/System
58Requires: nmap = %{version}-%{release}
59Requires: python pygtk2 pysqlite
60Provides: zenmap = %{version}-%{release}
61
62%description frontend
63This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
64be installed before installing nmap-frontend.
65
66%description frontend -l ja
67Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
68する前に、nmap パッケージをインストールする必要があります。
69
70%prep
71%setup -q
72
73%patch1 -p1 -b .mktemp
74%patch2 -p1 -b .noms
75%patch5 -p1 -b .ncat_reg_stdin
76%patch6 -p1 -b .displayerror
77
78%build
79export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
80%configure
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
88rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_ndiff
89cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
90gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
91pushd $RPM_BUILD_ROOT%{_mandir}/man1
92ln -s zenmap.1.gz nmapfe.1.gz
93ln -s zenmap.1.gz xnmap.1.gz
94popd
95
96#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
97#mkdir zenmap
98#mv *.svg zenmap
99#mv *.png zenmap
100#popd
101
102#desktop-file-install --vendor= \
103#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
104#       %{SOURCE1};
105rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
106
107%find_lang %{name} --with-man
108
109%clean
110rm -rf %{buildroot}
111
112%files -f %{name}.lang
113%defattr(-,root,root)
114%doc COPYING CHANGELOG
115%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
116%{_bindir}/nmap
117%{_bindir}/ncat
118%{_bindir}/ndiff
119%{_bindir}/nping
120%{_datadir}/nmap
121%{_datadir}/ncat
122#%{_libexecdir}/nmap
123%{_mandir}/man1/nmap.1*
124%{_mandir}/man1/ncat.1*
125%{_mandir}/man1/ndiff.1*
126%{_mandir}/man1/nping.1*
127
128%files frontend
129%defattr(-,root,root)
130%{_bindir}/nmapfe
131%{_bindir}/xnmap
132%{_bindir}/zenmap
133%{python_sitelib}/*
134%{_datadir}/applications/*.desktop
135#%{_datadir}/icons/*
136#%{_datadir}/pixmaps/zenmap
137%{_datadir}/zenmap
138%{_mandir}/man1/zenmap.1*
139%{_mandir}/man1/nmapfe.1*
140%{_mandir}/man1/xnmap.1*
141
142%changelog
143* Sat Nov 17 2018 Toshiaki Ara <ara_t@384.jp> 7.70-1
144- update to 7.70
145- add Patches from Fedora rawhide
146
147* Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-2
148- rebuild with gcc-5.4.0
149
150* Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-1
151- new upstream release
152
153* Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
154- new upstream release
155
156* Thu Dec 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.01-1
157- new upstream release
158
159* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
160- new upstream release
161
162* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
163- new upstream release
164
165* Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
166- rebuild with pcre-8.31
167
168* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
169- new upstream release
170
171* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
172- new upstream release
173
174* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
175- new upstream release
176
177* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
178- new upstream release
179- fix %files to add nping
180
181* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
182- new upstream release
183- add BuildRequires: openssl-devel, lua-devel
184- fix %files to add ncat and ndiff
185
186* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
187- new upstream release
188- spec in UTF-8
189- added BuildRequires: libpcap-devel instead of libpcap
190- removed BuildRequires: desktop-file-utils
191
192* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
193- rebuilt with libpcap 1.0.0
194
195* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
196- rebuilt with python-2.5.2
197
198* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
199- updated python sitelib files path
200
201* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
202- new upstream release
203
204* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
205- new upstream release
206- rebuild with new environment/toolchain
207
208* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
209- new upstream release
210- added BuildRequires: desktop-file-utils
211
212* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
213- new upstream release
214
215* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
216- rebuild for VineSeed Plus
217
218* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
219- new upstream release
220
221* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
222- new upstream release
223
224* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
225- new upstream release
226- added Japanese summary to nmap-frontend
227
228* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
229- new upstream release
230
231* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
232- rebuild with new openssl
233
234* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
235- new upstream release
236
237* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
238- new upstream release
239
240* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
241- new upstream release
242
243* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
244- new upstream release
245
246* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
247- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
248
249* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
250- new upstream release
251- rebuild with new toolchains
252
253* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
254- new upstream release
255- delete Version Tag from nmap-frontend package
256- fix BuildRoot
257
258* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
259- new upstream release
260- 2.54BETA is developpment release, but it is more stable than 2.53.
261
262* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
263- unfortunately increase release: 1vl2 from 0vl2
264  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
265- patch to build on current glibc22 system
266
267* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
268- 2.53-0vl2: use better macros
269
270* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
271- rebuild for VineSeed based on the original site's srpm
272- add Japanese summary and description
273
274* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
275- Updated description
276- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
277- Fixed nmap distribution URL (source0)
278- Added this .rpm to base Nmap distribution
279
280* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
281- based on origional spec file from
282        http://www.insecure.org/nmap/index.html#download
283- general cleanups, removed lots of commenrts since it made the spec hard to
284        read
285- changed group to Applications/System
286- quiet setup
287- no need to create dirs in the install section, "make
288        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
289- using defined %{prefix}, %{version} etc. for easier/quicker maint.
290- added docs
291- gzip man pages
292- strip after files have been installed into buildroot
293- created separate package for the frontend so that Gtk+ isn't needed for the
294        CLI nmap
295- not using -f in files section anymore, no need for it since there aren't that
296        many files/dirs
297- added desktop entry for gnome
298
299* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
300- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
301
302* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
303- Made some changes, and merged in another .spec file sent in
304  by Oren Tirosh <oren@hishome.net>
305
306* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
307- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.