source: projects/specs/trunk/n/nmap/nmap-vl.spec @ 10105

Revision 10105, 8.9 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Network exploration tool and security scanner
4Summary(ja): 多機能なポートスキャナー
5Name: nmap
6Version: 7.12
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10URL: http://www.insecure.org/nmap/
11Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
12#Source1: zenmap.desktop
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libpcap-devel
16BuildRequires: pcre-devel
17BuildRequires: python-devel
18BuildRequires: pygtk2-devel
19BuildRequires: openssl-devel
20BuildRequires: lua-devel
21
22%description
23Nmap is a utility for network exploration or security auditing. It
24supports ping scanning (determine which hosts are up), many port
25scanning techniques (determine what services the hosts are offering),
26and TCP/IP fingerprinting (remote host operating system
27identification). Nmap also offers flexible target and port
28specification, decoy scanning, determination of TCP sequence
29predictability characteristics, sunRPC scanning, reverse-identd
30scanning, and more.
31
32%description -l ja
33Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
34ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
35技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
36の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
37ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
38予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
39機能も提供します。
40
41%package frontend
42Summary: Gtk+ frontend for nmap
43Summary(ja): Nmap の GTK+ フロントエンド
44Group: Applications/System
45Requires: nmap = %{version}-%{release}
46Requires: python pygtk2 pysqlite
47Provides: zenmap = %{version}-%{release}
48
49%description frontend
50This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
51be installed before installing nmap-frontend.
52
53%description frontend -l ja
54Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
55する前に、nmap パッケージをインストールする必要があります。
56
57%prep
58%setup -q
59
60%build
61export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
62%configure
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
70rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_ndiff
71cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
72gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
73pushd $RPM_BUILD_ROOT%{_mandir}/man1
74ln -s zenmap.1.gz nmapfe.1.gz
75ln -s zenmap.1.gz xnmap.1.gz
76popd
77
78#pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
79#mkdir zenmap
80#mv *.svg zenmap
81#mv *.png zenmap
82#popd
83
84#desktop-file-install --vendor= \
85#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
86#       %{SOURCE1};
87rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
88
89%find_lang %{name} --with-man
90
91%clean
92rm -rf %{buildroot}
93
94%files -f %{name}.lang
95%defattr(-,root,root)
96%doc COPYING CHANGELOG
97%doc docs/README docs/nmap.usage.txt docs/nmap.dtd
98%{_bindir}/nmap
99%{_bindir}/ncat
100%{_bindir}/ndiff
101%{_bindir}/nping
102%{_datadir}/nmap
103%{_datadir}/ncat
104#%{_libexecdir}/nmap
105%{_mandir}/man1/nmap.1*
106%{_mandir}/man1/ncat.1*
107%{_mandir}/man1/ndiff.1*
108%{_mandir}/man1/nping.1*
109
110%files frontend
111%defattr(-,root,root)
112%{_bindir}/nmapfe
113%{_bindir}/xnmap
114%{_bindir}/zenmap
115%{python_sitelib}/*
116%{_datadir}/applications/*.desktop
117#%{_datadir}/icons/*
118#%{_datadir}/pixmaps/zenmap
119%{_datadir}/zenmap
120%{_mandir}/man1/zenmap.1*
121%{_mandir}/man1/nmapfe.1*
122%{_mandir}/man1/xnmap.1*
123
124%changelog
125* Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-1
126- new upstream release
127
128* Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
129- new upstream release
130
131* Thu Dec 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.01-1
132- new upstream release
133
134* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
135- new upstream release
136
137* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
138- new upstream release
139
140* Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
141- rebuild with pcre-8.31
142
143* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
144- new upstream release
145
146* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
147- new upstream release
148
149* Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
150- new upstream release
151
152* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
153- new upstream release
154- fix %files to add nping
155
156* Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
157- new upstream release
158- add BuildRequires: openssl-devel, lua-devel
159- fix %files to add ncat and ndiff
160
161* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
162- new upstream release
163- spec in UTF-8
164- added BuildRequires: libpcap-devel instead of libpcap
165- removed BuildRequires: desktop-file-utils
166
167* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
168- rebuilt with libpcap 1.0.0
169
170* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
171- rebuilt with python-2.5.2
172
173* Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
174- updated python sitelib files path
175
176* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
177- new upstream release
178
179* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
180- new upstream release
181- rebuild with new environment/toolchain
182
183* Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
184- new upstream release
185- added BuildRequires: desktop-file-utils
186
187* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
188- new upstream release
189
190* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
191- rebuild for VineSeed Plus
192
193* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
194- new upstream release
195
196* Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
197- new upstream release
198
199* Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
200- new upstream release
201- added Japanese summary to nmap-frontend
202
203* Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
204- new upstream release
205
206* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
207- rebuild with new openssl
208
209* Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
210- new upstream release
211
212* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
213- new upstream release
214
215* Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
216- new upstream release
217
218* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
219- new upstream release
220
221* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
222- merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
223
224* Sat May  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
225- new upstream release
226- rebuild with new toolchains
227
228* Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
229- new upstream release
230- delete Version Tag from nmap-frontend package
231- fix BuildRoot
232
233* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
234- new upstream release
235- 2.54BETA is developpment release, but it is more stable than 2.53.
236
237* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
238- unfortunately increase release: 1vl2 from 0vl2
239  ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
240- patch to build on current glibc22 system
241
242* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
243- 2.53-0vl2: use better macros
244
245* Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
246- rebuild for VineSeed based on the original site's srpm
247- add Japanese summary and description
248
249* Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
250- Updated description
251- Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
252- Fixed nmap distribution URL (source0)
253- Added this .rpm to base Nmap distribution
254
255* Mon Dec 13 1999 Tim Powers <timp@redhat.com>
256- based on origional spec file from
257        http://www.insecure.org/nmap/index.html#download
258- general cleanups, removed lots of commenrts since it made the spec hard to
259        read
260- changed group to Applications/System
261- quiet setup
262- no need to create dirs in the install section, "make
263        prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
264- using defined %{prefix}, %{version} etc. for easier/quicker maint.
265- added docs
266- gzip man pages
267- strip after files have been installed into buildroot
268- created separate package for the frontend so that Gtk+ isn't needed for the
269        CLI nmap
270- not using -f in files section anymore, no need for it since there aren't that
271        many files/dirs
272- added desktop entry for gnome
273
274* Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
275- Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
276
277* Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
278- Made some changes, and merged in another .spec file sent in
279  by Oren Tirosh <oren@hishome.net>
280
281* Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
282- initial build for RH 5.x
Note: See TracBrowser for help on using the repository browser.