source: projects/specs/trunk/n/ngraph/ngraph-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A software for drawing scientific graphs
2Summary(ja): 2次元グラフ作成プログラム
3Name: ngraph
4Version: 6.3.30
5Release: 2%{?_dist_release}
6License: distributable, Copyright(C)Satoshi ISHIZAKA,1997-2004
7Group: Applications/Engineering
8Source: Ngraph-%{version}-src.tar.gz
9Source1: http://www2e.biglobe.ne.jp/~isizaka/bin/ileaf-widgets.tar.Z
10Source2: ngraph.sh
11Source3: Ngraph-6.3.30-doc.tar.gz
12URL: http://www2e.biglobe.ne.jp/~isizaka/
13Patch: Ngraph-install.diff
14Patch1: Ngraph-6.3.14-lesstif-make.diff
15Patch2: Ngraph-6.3.14-lesstif-make-ppc.diff
16#Requires: glibc >= 2.2.4, lesstif
17#Exclusivearch: i386 ppc
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: libICE-devel
21BuildRequires: libSM-devel
22BuildRequires: libX11-devel
23BuildRequires: libXext-devel
24BuildRequires: libXt-devel
25BuildRequires: openMotif-devel
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30
31%description
32   Ngraph is a software drawing scientific graphs for students,
33researchers, and engineers. Ngraph makes a graph from data  files written
34in a general ASCII format. Fitting by a n-th polynomial, user-defined
35functionals is available. Furthermore, masking invalid data, evaluation
36of plotted data points, a transformation by a mathematical expression are
37also available.Ngraph will assist making a scientific graph for the purpose
38of your presentation, and also analysing data.Copyright (C) Satoshi ISHIZAKA.
39   Motif or Lesstif libraries must be required to build the binaries.
40This package include ileaf-widgets.tar.Z (Copyright 1993 Interleaf, Inc.),
41codes for ComboBox Widget, which are required when ngraph is build with
42Motif 1.2 or Lesstif. The copyright and permission notice of this widget
43are written in a document file, TODO.jis.
44
45%description -l ja
46  Ngraphは理工系学生、研究者、技術者のために作られた2次元グラフ作成プログ
47ラムです。 汎用性のあるASCII形式のテキストファイルから数値デ−タを読み込
48みグラフにプロットすることができます。 またn次関数・ユ−ザ定義関数による
49最小二乗フィットができるほか、 プロットされたデ−タの評価・マスク・変更も
50可能であり、 さらに指定した数式で入力デ−タを加工する高度な数式変換機能な
51どを備えるなど、 プレゼンテ−ション用グラフ作成の目的のみに留まらずデ−タ
52解析をアシストします。(作者:石坂 智(いしざか さとし)さんのドキュメントより)
53  バイナリをビルトするためには Motif または Lesstif を使用します。Motif 1.2
54または Lesstif の場合、さらに ComboBox Widget (Copyright 1993 Interleaf,Inc.)
55を使用し、このパッケージはこれを含みます。この Widget の著作権や許諾権に
56関しては TODO.jis に書かれています。
57
58
59%prep
60%setup -q -a 3 -n Ngraph-%{version}-src
61%patch -p1
62
63
64%build
65if [ -n "`rpm -qa | grep lesstif`" ]
66then
67%ifarch i386
68                patch -p0 <%{PATCH1}
69%else
70                patch -p0 <%{PATCH2}
71%endif
72        cd combo
73        tar -zxf ${RPM_SOURCE_DIR}/ileaf-widgets.tar.Z
74        gcc -c -o ComboBox.o ComboBox.c -I/usr/X11R6/include
75        cd ..
76fi
77
78%ifnarch %{ix86}
79sed -e "s/-m486//g" Makefile > Makefile.new
80mv -f Makefile.new Makefile
81%endif
82
83make
84
85
86%install
87rm -rf ${RPM_BUILD_ROOT}
88mkdir -p ${RPM_BUILD_ROOT}/usr/{lib,bin}
89make INSTALLDIR=/usr/lib/Ngraph BINDIR=/usr/bin install
90mv $RPM_BUILD_ROOT/usr/bin/ngraph $RPM_BUILD_ROOT/usr/bin/ngraph.exe
91install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/usr/bin/ngraph
92
93pushd ${RPM_BUILD_ROOT}/usr/lib/Ngraph
94rmdir doc
95ln -s /usr/doc/ngraph-%{version}/doc .
96popd
97
98
99%clean
100rm -rf ${RPM_BUILD_ROOT}
101
102
103%files
104%defattr(-,root,root)
105%doc INSTALL.jis TODO.jis doc/
106/usr/bin/ngraph*
107/usr/lib/Ngraph/
108
109%changelog
110* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.30-2vl5
111- added BuildRequires
112
113* Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.3.30-1vl5
114- applied new versioning policy, spec in utf-8
115
116* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.3.30-0vl3
117- do not pass "-m486" option on non-i386 archtectures
118
119* Sat Oct 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.30-0vl2
120- s/Copyright/License/
121- built with openMotif instead of lesstif
122
123* Wed Mar 30 2005 Jun Nishii <jun@vinelinux.org> 6.3.30-0vl1
124- ver.up
125
126* Wed Mar 27 2002 Jun Nishii <jun@vinelinux.org> 6.3.14-0vl1
127- ver.up source and doc
128- make symlink to doc from /usr/lib/Ngraph to call Help file
129
130* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
131- 6.3.06-0vl1
132- added %defattr
133
134* Wed Sep 27 2000 Jun Nishii <jun@vinelinux.org>
135- 6.3.06-0vl1
136
137* Tue Jan 11 2000 Amane Tanaka <amane@bd5.so-net.ne.jp>
138- Build section was changed to execute correct patch for compiling with
139- Lesstif by using S.Sakoda's patch information. Thanks, Mr.Sakoda!
140
141* Sat Jan 8 2000 Amane Tanaka <amane@bd5.so-net.ne.jp>
142- Compiled with Motif-2.1.0 on i386 support
143- Packager: Seiji Sakoda <sakoda@cc.nda.ac.jp> --> AT
144
145* Mon Nov 8 1999 Seiji Sakoda <sakoda@cc.nda.ac.jp>
146- update to version 6.3.06
147- Compiled with Lesstif-0.89.4 with ComboBox support
148- Packager: Amane Tanaka <amane@bd5.so-net.ne.jp> ---> SS
Note: See TracBrowser for help on using the repository browser.