source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 9712

Revision 9712, 21.8 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.9.4
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 0.3.5
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 5.0.11
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66
67# to fix https://svn.boost.org/trac/boost/ticket/8731
68Patch100:   boost-changeset_84950.diff
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
71
72BuildRequires:      pcre-devel
73BuildRequires:      zlib-devel
74BuildRequires:      openssl-devel
75BuildRequires:      gd-devel
76BuildRequires:      perl
77BuildRequires:      perl(ExtUtils::Embed)
78BuildRequires:      libxml2-devel
79BuildRequires:      libxslt-devel
80BuildRequires:      curl-devel
81%if %{with geoip}
82BuildRequires:      GeoIP-devel
83%endif
84
85%if "%{?_dist_release}" == "vl4"
86Requires:           perl >= 5.8.6
87%else
88Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
89%endif
90# for /usr/sbin/useradd
91Requires(pre):      shadow-utils
92Requires(post):     chkconfig
93# for /sbin/service
94Requires(preun):    chkconfig, initscripts
95Requires(postun):   initscripts
96%if "%{_dist_release}" > "vl6"
97Requires(pre):      www-common
98%endif
99
100Provides: webserver
101
102Vendor: Project Vine
103Distribution: Vine Linux
104Packager: daisuke
105
106%description
107Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
108proxy server written by Igor Sysoev.
109
110%description -l ja
111Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
112堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
113 - HTTP(S) サーバ
114 - HTTP(S) リバースプロキシサーバ
115 - IMAP/POP3 プロキシサーバ
116
117%package passenger
118Summary: Nginx with mod_passenger support
119Summary(ja): Passenger サポート入りの Nginx
120Group: System Environment/Daemons
121BuildRequires: ruby, rubygem-rake
122Requires: ruby, rubygem-rake
123%if "%{_dist_release}" >= "vl7"
124BuildRequires: ruby-devel, ruby-rubygems
125Requires: ruby-rubygems
126%else
127BuildRequires: rubygems
128Requires: rubygems
129%endif
130Requires: nginx
131
132%description passenger
133Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
134This package contains nginx server with passenger support.
135
136%description -l ja passenger
137Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
138堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
139 - HTTP(S) サーバ
140 - HTTP(S) リバースプロキシサーバ
141 - IMAP/POP3 プロキシサーバ
142このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
143
144%prep
145%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
146
147%patch0 -p0
148
149pushd passenger-%{passenger_version}/ext/
150%patch100 -p2
151popd
152
153%build
154# nginx does not utilize a standard configure script.  It has its own
155# and the standard configure options cause the nginx configure script
156# to error out.  This is is also the reason for the DESTDIR environment
157# variable.  The configure script(s) have been patched (Patch1 and
158# Patch2) in order to support installing into a build environment.
159
160export DESTDIR=%{buildroot}
161
162
163CONFIGOPTS="\
164    --user=%{nginx_user} \
165    --group=%{nginx_group} \
166    --prefix=%{nginx_datadir} \
167    --sbin-path=%{_sbindir}/%{name} \
168    --conf-path=%{nginx_confdir}/%{name}.conf \
169    --error-log-path=%{nginx_logdir}/error.log \
170    --http-log-path=%{nginx_logdir}/access.log \
171    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
172    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
173    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
174    --pid-path=%{_localstatedir}/run/%{name}.pid \
175    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
176    --with-file-aio \
177    --with-ipv6 \
178    --with-http_ssl_module \
179    --with-http_spdy_module \
180    --with-http_realip_module \
181    --with-http_addition_module \
182    --with-http_xslt_module \
183    --with-http_image_filter_module \
184%if %{with geoip}
185    --with-http_geoip_module \
186%endif
187    --with-http_sub_module \
188    --with-http_dav_module \
189    --with-http_flv_module \
190    --with-http_mp4_module \
191    --with-http_gunzip_module \
192    --with-http_gzip_static_module \
193    --with-http_auth_request_module \
194    --with-http_random_index_module \
195    --with-http_secure_link_module \
196    --with-http_degradation_module \
197    --with-http_stub_status_module \
198    --with-http_perl_module \
199    --with-mail \
200    --with-mail_ssl_module \
201    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
202    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
203    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
204%if %{with wsgi}
205    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
206%endif
207%ifarch i686
208    --with-cpu-opt=pentiumpro \
209    --with-zlib-asm=pentiumpro \
210    --with-md5-asm \
211    --with-sha1-asm \
212%endif
213"
214
215
216## build with passenger
217./configure \
218    $CONFIGOPTS \
219    --with-cc-opt="%{optflags}" \
220    --add-module=passenger-%{passenger_version}/ext/nginx
221
222make %{?_smp_mflags}
223mv objs/nginx objs/nginx.passenger
224
225## build without passenger
226./configure \
227    $CONFIGOPTS \
228    --with-cc-opt="%{optflags}"
229
230make %{?_smp_mflags}
231
232%install
233rm -rf %{buildroot}
234make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
235find %{buildroot} -type f -name .packlist -exec rm -f {} \;
236find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
237find %{buildroot} -type f -empty -exec rm -f {} \;
238find %{buildroot} -type f -exec chmod 0644 {} \;
239find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
240mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
241%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
242chmod 0755 %{buildroot}%{_sbindir}/nginx.*
243%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
244%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
245%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
246%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
247%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
248%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
249%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
250%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
251%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
252%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
253%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
254%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
255%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
256%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
257%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
258%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
259%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
260%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
261%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
262%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
263
264%if %{with wsgi}
265%{__install} -p -m 0644 \
266    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
267    %{buildroot}%{nginx_confdir}
268cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
269%endif
270
271# upstream fair module document
272cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
273
274touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
275
276# convert to UTF-8 all files that give warnings.
277for textfile in CHANGES
278do
279    mv $textfile $textfile.old
280    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
281    rm -f $textfile.old
282done
283
284%clean
285rm -rf %{buildroot}
286
287%post
288if [ $1 == 1 ]; then
289    /sbin/chkconfig --add %{name}
290fi
291update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
292
293%post passenger
294update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
295
296%preun
297if [ $1 = 0 ]; then
298    /sbin/service %{name} stop >/dev/null 2>&1
299    /sbin/chkconfig --del %{name}
300    update-alternatives --remove nginx %{_sbindir}/nginx.normal
301fi
302
303%preun passenger
304if [ $1 = 0 ]; then
305    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
306fi
307
308
309%postun
310if [ $1 == 2 ]; then
311    /sbin/service %{name} upgrade || :
312fi
313
314%files
315%defattr(-,root,root,-)
316%doc LICENSE CHANGES README
317%doc README.upstream_fair
318%doc %{?with_wsgi:README.mod_wsgi}
319%{nginx_datadir}/
320%{_sbindir}/%{name}.normal
321%{_mandir}/man3/%{name}.3pm.gz
322%{_initrddir}/%{name}
323%dir %{nginx_confdir}
324%dir %{nginx_confdir}/conf.d
325%config(noreplace) %{nginx_confdir}/conf.d/*.conf
326%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
327%config(noreplace) %{nginx_confdir}/sites.d/*
328%config(noreplace) %{nginx_confdir}/win-utf
329%config(noreplace) %{nginx_confdir}/%{name}.conf.default
330%config(noreplace) %{nginx_confdir}/mime.types.default
331%config(noreplace) %{nginx_confdir}/fastcgi_params
332%config(noreplace) %{nginx_confdir}/fastcgi_params.default
333%config(noreplace) %{nginx_confdir}/koi-win
334%config(noreplace) %{nginx_confdir}/koi-utf
335%config(noreplace) %{nginx_confdir}/%{name}.conf
336%config(noreplace) %{nginx_confdir}/mime.types
337%config(noreplace) %{nginx_confdir}/fastcgi.conf
338%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
339%config(noreplace) %{nginx_confdir}/scgi_params
340%config(noreplace) %{nginx_confdir}/scgi_params.default
341%config(noreplace) %{nginx_confdir}/uwsgi_params
342%config(noreplace) %{nginx_confdir}/uwsgi_params.default
343%if %{with wsgi}
344%config(noreplace) %{nginx_confdir}/wsgi_vars
345%endif
346%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
347%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
348%dir %{perl_vendorarch}/auto/%{name}
349%{perl_vendorarch}/%{name}.pm
350%{perl_vendorarch}/auto/%{name}/%{name}.so
351%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
352%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
353%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
354%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
355
356%files passenger
357%defattr(-,root,root,-)
358%doc passenger-%{passenger_version}/doc/*.md
359%doc passenger-%{passenger_version}/doc/*.txt
360%doc passenger-%{passenger_version}/doc/*.html
361%doc passenger-%{passenger_version}/doc/templates
362%doc passenger-%{passenger_version}/doc/users_guide_snippets
363%doc passenger-%{passenger_version}/doc/images
364%{_sbindir}/%{name}.passenger
365
366
367%changelog
368* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
369- new upstream release
370
371* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
372- update to 1.9.3
373- update passenger to 5.0.11
374
375* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
376- updated Source4 (ssl.conf).
377
378* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
379- update to 1.9.2
380- update passenger to 5.0.10
381- update ngx-fancyindex to 0.3.5
382
383* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
384- update to 1.6.2
385- update passenger to 4.0.52
386
387* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
388- new upstream release
389
390* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
391- rebuild with new environment
392
393* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
394- update passenger to 4.0.45
395
396* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
397- update to 1.6.0 (stable)
398
399* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
400- update fancyindex to 0.3.3
401
402* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
403- update to 1.5.10
404- update passenger to 4.0.37
405
406* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
407- rebuilt with GeoIP-1.6.0.
408- added Patch100.
409
410* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
411- update to 1.5.6
412- update passenger to 4.0.21
413
414* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
415- rebuilt with gd-2.1.0.
416
417* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
418- update to 1.4.1
419
420* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
421- update to 1.4.0
422- enable SPDY module
423
424* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
425- new upstream release
426- update passenger to 3.0.19
427- update ngx-fancyindex to upstream git master
428
429* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
430- new upstream release
431- update passenger to 3.0.17
432
433* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
434- rebuild with pcre-8.31
435
436* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
437- added http_geoip_module.
438
439* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
440- update to 1.2.4
441
442* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
443- update to 1.2.2
444
445* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
446- update to 1.2.1
447- change nginx user from nginx to www-data
448- R(pre): www-common
449
450* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
451- update to 1.2.0
452- update passenger to 3.0.12
453- drop http_upstream_keepalive
454
455* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
456- new upstream release
457
458* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
459- update to 1.0.12
460
461* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
462- update to 1.0.11
463- update passenger to 3.0.11
464
465* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
466- update to 1.0.10
467
468* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
469- update passenger to 3.0.9
470
471* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
472- update to 1.0.6
473
474* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
475- update to 1.0.4
476
477* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
478- add gnosek-nginx-upstream-fair module
479- add ngx_http_upstream_keepalive module
480
481* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
482- add nginx-passenger sub pakckage
483  - use alternatives to choose nginx with or without passenger
484  - add BR: ruby, rubygems, rubygem-rake
485
486* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
487- update to 1.0.2
488
489* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
490- update to 1.0.1
491
492* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
493- add bcond_with wsgi for mod_wsgi
494- add bcond_with passenger
495  - you need to install rake.gem to build with this option.
496- add Provides: webserver
497
498* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
499- new upstream release 1.0.0!
500
501* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
502- rebuild with perl-5.12.3
503
504* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
505- update to 0.8.54
506
507* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
508- update to 0.8.53
509- add nginx_accept_language_module
510
511* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
512- update to 0.8.50
513- update ngx-fancyindex to 0.3
514- add BR: libxml2-devel, libxslt-devel
515- add scgi_params* and uwsgi_params* to %%files
516
517* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
518- update to 0.8.35 (development version)
519- add sites.d/ to store vitualhost settings
520- split out default server settings to sites.d/default
521- add fancyindex module
522
523* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
524- new upstream release
525
526* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
527- update to 0.7.62 (included security fix: VU#180065)
528
529* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
530- fix typo
531
532* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
533- add translated descriptions
534
535* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
536- update 404.html/50x.html to use powered by vine logo.
537
538* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
539- initial build for Vine Linux
540- update to 0.7.61
541
542* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
543- init script updates from Gena Makhomed
544- remove nginx-upstream-fair
545
546* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
547-  update to 0.6.36
548
549* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
550- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
551
552* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
553- rebuild
554
555* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
556- update to 0.6.35
557
558* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
559- rebuild with new openssl
560
561* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
562- update to 0.6.34
563
564* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
565- Fix inclusion of /usr/share/nginx tree => no unowned directories.
566
567* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
568- update to 0.6.33
569
570* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
571- update to 0.6.32
572- nginx now supports DESTDIR so removed the patches that enabled it
573
574* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
575- init script fixes
576- resolve 'listen 80 default' [#447873]
577
578* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
579- update to 0.6.31
580
581* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
582- upate to new upstream stable branch 0.6
583- added 3rd party module nginx-upstream-fair
584- added default webpages
585
586* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
587- update init script to match recommended guidelines
588- add /etc/nginx/conf.d support [#443280]
589- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
590
591* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
592- add Requires for versioned perl (libperl.so)
593- drop silly file Requires
594
595* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
596- Autorebuild for GCC 4.3
597
598* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
599- update to 0.5.35
600
601* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
602- update to 0.5.34
603
604* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
605 - Rebuild for deps
606
607* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
608- update to 0.5.33
609
610* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
611- updated to 0.5.32
612- fixed rpmlint UTF-8 complaints.
613
614* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
615- added --with-http_stub_status_module build option.
616- added --with-http_sub_module build option.
617- added use of pcre-config --cflags
618
619* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
620- Update to 0.5.31
621- specify license is BSD
622
623* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
624- Add BuildRequires: perl-devel - fixing rawhide build
625
626* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
627- Update to 0.5.30
628
629* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
630- Update to 0.5.29
631
632* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
633- Update to 0.5.28
634
635* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
636- Update to 0.5.27
637
638* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
639- Update to 0.5.26
640
641* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
642- Update to 0.5.19
643
644* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
645- Update to 0.5.17
646
647* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
648- Update to 0.5.16
649- add ownership of /usr/share/nginx/html (#233950)
650
651* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
652- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
653
654* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
655- fixed package review bugs (#233522) given by kevin@tummy.com
656
657* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
658- create patches to assist with building for Fedora
659- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.