source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 8983

Revision 8983, 21.4 KB checked in by daisuke, 10 years ago (diff)

nginx: update to 1.6.2

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.6.2
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 0.3.3
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 4.0.52
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66
67# to fix https://svn.boost.org/trac/boost/ticket/8731
68Patch100:   boost-changeset_84950.diff
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
71
72BuildRequires:      pcre-devel
73BuildRequires:      zlib-devel
74BuildRequires:      openssl-devel
75BuildRequires:      gd-devel
76BuildRequires:      perl
77BuildRequires:      perl(ExtUtils::Embed)
78BuildRequires:      libxml2-devel
79BuildRequires:      libxslt-devel
80BuildRequires:      curl-devel
81%if %{with geoip}
82BuildRequires:      GeoIP-devel
83%endif
84
85%if "%{?_dist_release}" == "vl4"
86Requires:           perl >= 5.8.6
87%else
88Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
89%endif
90# for /usr/sbin/useradd
91Requires(pre):      shadow-utils
92Requires(post):     chkconfig
93# for /sbin/service
94Requires(preun):    chkconfig, initscripts
95Requires(postun):   initscripts
96%if "%{_dist_release}" > "vl6"
97Requires(pre):      www-common
98%endif
99
100Provides: webserver
101
102Vendor: Project Vine
103Distribution: Vine Linux
104Packager: daisuke
105
106%description
107Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
108proxy server written by Igor Sysoev.
109
110%description -l ja
111Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
112堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
113 - HTTP(S) サーバ
114 - HTTP(S) リバースプロキシサーバ
115 - IMAP/POP3 プロキシサーバ
116
117%package passenger
118Summary: Nginx with mod_passenger support
119Summary(ja): Passenger サポート入りの Nginx
120Group: System Environment/Daemons
121BuildRequires: ruby, rubygem-rake
122Requires: ruby, rubygem-rake
123%if "%{_dist_release}" >= "vl7"
124BuildRequires: ruby-devel, ruby-rubygems
125Requires: ruby-rubygems
126%else
127BuildRequires: rubygems
128Requires: rubygems
129%endif
130Requires: nginx
131
132%description passenger
133Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
134This package contains nginx server with passenger support.
135
136%description -l ja passenger
137Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
138堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
139 - HTTP(S) サーバ
140 - HTTP(S) リバースプロキシサーバ
141 - IMAP/POP3 プロキシサーバ
142このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
143
144%prep
145%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
146
147%patch0 -p0
148
149pushd passenger-%{passenger_version}/ext/
150%patch100 -p2
151popd
152
153%build
154# nginx does not utilize a standard configure script.  It has its own
155# and the standard configure options cause the nginx configure script
156# to error out.  This is is also the reason for the DESTDIR environment
157# variable.  The configure script(s) have been patched (Patch1 and
158# Patch2) in order to support installing into a build environment.
159
160export DESTDIR=%{buildroot}
161
162
163CONFIGOPTS="\
164    --user=%{nginx_user} \
165    --group=%{nginx_group} \
166    --prefix=%{nginx_datadir} \
167    --sbin-path=%{_sbindir}/%{name} \
168    --conf-path=%{nginx_confdir}/%{name}.conf \
169    --error-log-path=%{nginx_logdir}/error.log \
170    --http-log-path=%{nginx_logdir}/access.log \
171    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
172    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
173    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
174    --pid-path=%{_localstatedir}/run/%{name}.pid \
175    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
176    --with-file-aio \
177    --with-ipv6 \
178    --with-http_ssl_module \
179    --with-http_spdy_module \
180    --with-http_realip_module \
181    --with-http_addition_module \
182    --with-http_xslt_module \
183    --with-http_image_filter_module \
184%if %{with geoip}
185    --with-http_geoip_module \
186%endif
187    --with-http_sub_module \
188    --with-http_dav_module \
189    --with-http_flv_module \
190    --with-http_mp4_module \
191    --with-http_gunzip_module \
192    --with-http_gzip_static_module \
193    --with-http_auth_request_module \
194    --with-http_random_index_module \
195    --with-http_secure_link_module \
196    --with-http_degradation_module \
197    --with-http_stub_status_module \
198    --with-http_perl_module \
199    --with-mail \
200    --with-mail_ssl_module \
201    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
202    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
203    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
204%if %{with wsgi}
205    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
206%endif
207%ifarch i686
208    --with-cpu-opt=pentiumpro \
209    --with-zlib-asm=pentiumpro \
210    --with-md5-asm \
211    --with-sha1-asm \
212%endif
213"
214
215
216## build with passenger
217./configure \
218    $CONFIGOPTS \
219    --with-cc-opt="%{optflags}" \
220    --add-module=passenger-%{passenger_version}/ext/nginx
221
222make %{?_smp_mflags}
223mv objs/nginx objs/nginx.passenger
224
225## build without passenger
226./configure \
227    $CONFIGOPTS \
228    --with-cc-opt="%{optflags}"
229
230make %{?_smp_mflags}
231
232%install
233rm -rf %{buildroot}
234make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
235find %{buildroot} -type f -name .packlist -exec rm -f {} \;
236find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
237find %{buildroot} -type f -empty -exec rm -f {} \;
238find %{buildroot} -type f -exec chmod 0644 {} \;
239find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
240mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
241%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
242chmod 0755 %{buildroot}%{_sbindir}/nginx.*
243%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
244%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
245%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
246%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
247%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
248%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
249%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
250%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
251%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
252%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
253%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
254%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
255%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
256%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
257%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
258%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
259%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
260%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
261%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
262%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
263
264%if %{with wsgi}
265%{__install} -p -m 0644 \
266    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
267    %{buildroot}%{nginx_confdir}
268cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
269%endif
270
271# upstream fair module document
272cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
273
274touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
275
276# convert to UTF-8 all files that give warnings.
277for textfile in CHANGES
278do
279    mv $textfile $textfile.old
280    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
281    rm -f $textfile.old
282done
283
284%clean
285rm -rf %{buildroot}
286
287%post
288if [ $1 == 1 ]; then
289    /sbin/chkconfig --add %{name}
290fi
291update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
292
293%post passenger
294update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
295
296%preun
297if [ $1 = 0 ]; then
298    /sbin/service %{name} stop >/dev/null 2>&1
299    /sbin/chkconfig --del %{name}
300    update-alternatives --remove nginx %{_sbindir}/nginx.normal
301fi
302
303%preun passenger
304if [ $1 = 0 ]; then
305    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
306fi
307
308
309%postun
310if [ $1 == 2 ]; then
311    /sbin/service %{name} upgrade || :
312fi
313
314%files
315%defattr(-,root,root,-)
316%doc LICENSE CHANGES README
317%doc README.upstream_fair
318%doc %{?with_wsgi:README.mod_wsgi}
319%{nginx_datadir}/
320%{_sbindir}/%{name}.normal
321%{_mandir}/man3/%{name}.3pm.gz
322%{_initrddir}/%{name}
323%dir %{nginx_confdir}
324%dir %{nginx_confdir}/conf.d
325%config(noreplace) %{nginx_confdir}/conf.d/*.conf
326%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
327%config(noreplace) %{nginx_confdir}/sites.d/*
328%config(noreplace) %{nginx_confdir}/win-utf
329%config(noreplace) %{nginx_confdir}/%{name}.conf.default
330%config(noreplace) %{nginx_confdir}/mime.types.default
331%config(noreplace) %{nginx_confdir}/fastcgi_params
332%config(noreplace) %{nginx_confdir}/fastcgi_params.default
333%config(noreplace) %{nginx_confdir}/koi-win
334%config(noreplace) %{nginx_confdir}/koi-utf
335%config(noreplace) %{nginx_confdir}/%{name}.conf
336%config(noreplace) %{nginx_confdir}/mime.types
337%config(noreplace) %{nginx_confdir}/fastcgi.conf
338%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
339%config(noreplace) %{nginx_confdir}/scgi_params
340%config(noreplace) %{nginx_confdir}/scgi_params.default
341%config(noreplace) %{nginx_confdir}/uwsgi_params
342%config(noreplace) %{nginx_confdir}/uwsgi_params.default
343%if %{with wsgi}
344%config(noreplace) %{nginx_confdir}/wsgi_vars
345%endif
346%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
347%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
348%dir %{perl_vendorarch}/auto/%{name}
349%{perl_vendorarch}/%{name}.pm
350%{perl_vendorarch}/auto/%{name}/%{name}.so
351%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
352%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
353%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
354%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
355
356%files passenger
357%defattr(-,root,root,-)
358%doc passenger-%{passenger_version}/doc/*.md
359%doc passenger-%{passenger_version}/doc/*.txt
360%doc passenger-%{passenger_version}/doc/*.html
361%doc passenger-%{passenger_version}/doc/*.h
362%doc passenger-%{passenger_version}/doc/templates
363%doc passenger-%{passenger_version}/doc/users_guide_snippets
364%doc passenger-%{passenger_version}/doc/images
365%{_sbindir}/%{name}.passenger
366
367
368%changelog
369* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
370- update to 1.6.2
371- update passenger to 4.0.52
372
373* Fri Aug 008 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
374- new upstream release
375
376* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
377- rebuild with new environment
378
379* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
380- update passenger to 4.0.45
381
382* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
383- update to 1.6.0 (stable)
384
385* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
386- update fancyindex to 0.3.3
387
388* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
389- update to 1.5.10
390- update passenger to 4.0.37
391
392* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
393- rebuilt with GeoIP-1.6.0.
394- added Patch100.
395
396* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
397- update to 1.5.6
398- update passenger to 4.0.21
399
400* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
401- rebuilt with gd-2.1.0.
402
403* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
404- update to 1.4.1
405
406* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
407- update to 1.4.0
408- enable SPDY module
409
410* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
411- new upstream release
412- update passenger to 3.0.19
413- update ngx-fancyindex to upstream git master
414
415* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
416- new upstream release
417- update passenger to 3.0.17
418
419* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
420- rebuild with pcre-8.31
421
422* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
423- added http_geoip_module.
424
425* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
426- update to 1.2.4
427
428* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
429- update to 1.2.2
430
431* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
432- update to 1.2.1
433- change nginx user from nginx to www-data
434- R(pre): www-common
435
436* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
437- update to 1.2.0
438- update passenger to 3.0.12
439- drop http_upstream_keepalive
440
441* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
442- new upstream release
443
444* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
445- update to 1.0.12
446
447* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
448- update to 1.0.11
449- update passenger to 3.0.11
450
451* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
452- update to 1.0.10
453
454* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
455- update passenger to 3.0.9
456
457* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
458- update to 1.0.6
459
460* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
461- update to 1.0.4
462
463* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
464- add gnosek-nginx-upstream-fair module
465- add ngx_http_upstream_keepalive module
466
467* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
468- add nginx-passenger sub pakckage
469  - use alternatives to choose nginx with or without passenger
470  - add BR: ruby, rubygems, rubygem-rake
471
472* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
473- update to 1.0.2
474
475* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
476- update to 1.0.1
477
478* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
479- add bcond_with wsgi for mod_wsgi
480- add bcond_with passenger
481  - you need to install rake.gem to build with this option.
482- add Provides: webserver
483
484* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
485- new upstream release 1.0.0!
486
487* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
488- rebuild with perl-5.12.3
489
490* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
491- update to 0.8.54
492
493* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
494- update to 0.8.53
495- add nginx_accept_language_module
496
497* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
498- update to 0.8.50
499- update ngx-fancyindex to 0.3
500- add BR: libxml2-devel, libxslt-devel
501- add scgi_params* and uwsgi_params* to %%files
502
503* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
504- update to 0.8.35 (development version)
505- add sites.d/ to store vitualhost settings
506- split out default server settings to sites.d/default
507- add fancyindex module
508
509* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
510- new upstream release
511
512* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
513- update to 0.7.62 (included security fix: VU#180065)
514
515* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
516- fix typo
517
518* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
519- add translated descriptions
520
521* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
522- update 404.html/50x.html to use powered by vine logo.
523
524* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
525- initial build for Vine Linux
526- update to 0.7.61
527
528* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
529- init script updates from Gena Makhomed
530- remove nginx-upstream-fair
531
532* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
533-  update to 0.6.36
534
535* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
536- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
537
538* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
539- rebuild
540
541* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
542- update to 0.6.35
543
544* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
545- rebuild with new openssl
546
547* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
548- update to 0.6.34
549
550* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
551- Fix inclusion of /usr/share/nginx tree => no unowned directories.
552
553* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
554- update to 0.6.33
555
556* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
557- update to 0.6.32
558- nginx now supports DESTDIR so removed the patches that enabled it
559
560* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
561- init script fixes
562- resolve 'listen 80 default' [#447873]
563
564* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
565- update to 0.6.31
566
567* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
568- upate to new upstream stable branch 0.6
569- added 3rd party module nginx-upstream-fair
570- added default webpages
571
572* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
573- update init script to match recommended guidelines
574- add /etc/nginx/conf.d support [#443280]
575- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
576
577* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
578- add Requires for versioned perl (libperl.so)
579- drop silly file Requires
580
581* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
582- Autorebuild for GCC 4.3
583
584* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
585- update to 0.5.35
586
587* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
588- update to 0.5.34
589
590* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
591 - Rebuild for deps
592
593* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
594- update to 0.5.33
595
596* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
597- updated to 0.5.32
598- fixed rpmlint UTF-8 complaints.
599
600* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
601- added --with-http_stub_status_module build option.
602- added --with-http_sub_module build option.
603- added use of pcre-config --cflags
604
605* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
606- Update to 0.5.31
607- specify license is BSD
608
609* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
610- Add BuildRequires: perl-devel - fixing rawhide build
611
612* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
613- Update to 0.5.30
614
615* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
616- Update to 0.5.29
617
618* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
619- Update to 0.5.28
620
621* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
622- Update to 0.5.27
623
624* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
625- Update to 0.5.26
626
627* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
628- Update to 0.5.19
629
630* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
631- Update to 0.5.17
632
633* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
634- Update to 0.5.16
635- add ownership of /usr/share/nginx/html (#233950)
636
637* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
638- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
639
640* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
641- fixed package review bugs (#233522) given by kevin@tummy.com
642
643* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
644- create patches to assist with building for Fedora
645- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.