source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 8125

Revision 8125, 20.6 KB checked in by tomop, 10 years ago (diff)

xl2tpd-1.3.3-1

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.5.6
29Release:        2%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 20130213
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 4.0.21
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66
67# to fix https://svn.boost.org/trac/boost/ticket/8731
68Patch100:   boost-changeset_84950.diff
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
71
72BuildRequires:      pcre-devel
73BuildRequires:      zlib-devel
74BuildRequires:      openssl-devel
75BuildRequires:      gd-devel
76BuildRequires:      perl
77BuildRequires:      perl(ExtUtils::Embed)
78BuildRequires:      libxml2-devel
79BuildRequires:      libxslt-devel
80BuildRequires:      curl-devel
81%if %{with geoip}
82BuildRequires:      GeoIP-devel
83%endif
84
85%if "%{?_dist_release}" == "vl4"
86Requires:           perl >= 5.8.6
87%else
88Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
89%endif
90# for /usr/sbin/useradd
91Requires(pre):      shadow-utils
92Requires(post):     chkconfig
93# for /sbin/service
94Requires(preun):    chkconfig, initscripts
95Requires(postun):   initscripts
96%if "%{_dist_release}" > "vl6"
97Requires(pre):      www-common
98%endif
99
100Provides: webserver
101
102Vendor: Project Vine
103Distribution: Vine Linux
104Packager: daisuke
105
106%description
107Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
108proxy server written by Igor Sysoev.
109
110%description -l ja
111Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
112堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
113 - HTTP(S) サーバ
114 - HTTP(S) リバースプロキシサーバ
115 - IMAP/POP3 プロキシサーバ
116
117%package passenger
118Summary: Nginx with mod_passenger support
119Summary(ja): Passenger サポート入りの Nginx
120Group: System Environment/Daemons
121BuildRequires: ruby, rubygem-rake
122Requires: ruby, rubygem-rake
123%if "%{_dist_release}" >= "vl7"
124BuildRequires: ruby-devel, ruby-rubygems
125Requires: ruby-rubygems
126%else
127BuildRequires: rubygems
128Requires: rubygems
129%endif
130Requires: nginx
131
132%description passenger
133Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
134This package contains nginx server with passenger support.
135
136%description -l ja passenger
137Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
138堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
139 - HTTP(S) サーバ
140 - HTTP(S) リバースプロキシサーバ
141 - IMAP/POP3 プロキシサーバ
142このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
143
144%prep
145%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
146
147%patch0 -p0
148
149pushd passenger-4.0.21/ext/
150%patch100 -p2
151popd
152
153%build
154# nginx does not utilize a standard configure script.  It has its own
155# and the standard configure options cause the nginx configure script
156# to error out.  This is is also the reason for the DESTDIR environment
157# variable.  The configure script(s) have been patched (Patch1 and
158# Patch2) in order to support installing into a build environment.
159
160export DESTDIR=%{buildroot}
161
162
163CONFIGOPTS="\
164    --user=%{nginx_user} \
165    --group=%{nginx_group} \
166    --prefix=%{nginx_datadir} \
167    --sbin-path=%{_sbindir}/%{name} \
168    --conf-path=%{nginx_confdir}/%{name}.conf \
169    --error-log-path=%{nginx_logdir}/error.log \
170    --http-log-path=%{nginx_logdir}/access.log \
171    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
172    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
173    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
174    --pid-path=%{_localstatedir}/run/%{name}.pid \
175    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
176    --with-file-aio \
177    --with-ipv6 \
178    --with-http_ssl_module \
179    --with-http_spdy_module \
180    --with-http_realip_module \
181    --with-http_addition_module \
182    --with-http_xslt_module \
183    --with-http_image_filter_module \
184    --with-http_sub_module \
185    --with-http_dav_module \
186    --with-http_flv_module \
187    --with-http_mp4_module \
188    --with-http_gzip_static_module \
189    --with-http_gunzip_module \
190    --with-http_random_index_module \
191    --with-http_secure_link_module \
192    --with-http_degradation_module \
193    --with-http_stub_status_module \
194    --with-http_perl_module \
195    --with-http_degradation_module \
196%if %{with geoip}
197    --with-http_geoip_module \
198%endif
199    --with-http_auth_request_module \
200    --with-mail \
201    --with-mail_ssl_module \
202    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
203    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
204    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
205%if %{with wsgi}
206    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
207%endif
208%ifarch i686
209    --with-cpu-opt=pentiumpro \
210    --with-zlib-asm=pentiumpro \
211    --with-md5-asm \
212    --with-sha1-asm \
213%endif
214"
215
216
217## build with passenger
218./configure \
219    $CONFIGOPTS \
220    --with-cc-opt="%{optflags}" \
221    --add-module=passenger-%{passenger_version}/ext/nginx
222
223make %{?_smp_mflags}
224mv objs/nginx objs/nginx.passenger
225
226## build without passenger
227./configure \
228    $CONFIGOPTS \
229    --with-cc-opt="%{optflags}"
230
231make %{?_smp_mflags}
232
233%install
234rm -rf %{buildroot}
235make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
236find %{buildroot} -type f -name .packlist -exec rm -f {} \;
237find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
238find %{buildroot} -type f -empty -exec rm -f {} \;
239find %{buildroot} -type f -exec chmod 0644 {} \;
240find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
241mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
242%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
243chmod 0755 %{buildroot}%{_sbindir}/nginx.*
244%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
245%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
246%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
247%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
248%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
249%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
250%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
251%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
252%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
253%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
254%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
255%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
256%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
257%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
258%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
259%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
260%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
261%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
262%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
263%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
264
265%if %{with wsgi}
266%{__install} -p -m 0644 \
267    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
268    %{buildroot}%{nginx_confdir}
269cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
270%endif
271
272# upstream fair module document
273cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
274
275touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
276
277# convert to UTF-8 all files that give warnings.
278for textfile in CHANGES
279do
280    mv $textfile $textfile.old
281    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
282    rm -f $textfile.old
283done
284
285%clean
286rm -rf %{buildroot}
287
288%post
289if [ $1 == 1 ]; then
290    /sbin/chkconfig --add %{name}
291fi
292update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
293
294%post passenger
295update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
296
297%preun
298if [ $1 = 0 ]; then
299    /sbin/service %{name} stop >/dev/null 2>&1
300    /sbin/chkconfig --del %{name}
301    update-alternatives --remove nginx %{_sbindir}/nginx.normal
302fi
303
304%preun passenger
305if [ $1 = 0 ]; then
306    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
307fi
308
309
310%postun
311if [ $1 == 2 ]; then
312    /sbin/service %{name} upgrade || :
313fi
314
315%files
316%defattr(-,root,root,-)
317%doc LICENSE CHANGES README
318%doc README.upstream_fair
319%doc %{?with_wsgi:README.mod_wsgi}
320%{nginx_datadir}/
321%{_sbindir}/%{name}.normal
322%{_mandir}/man3/%{name}.3pm.gz
323%{_initrddir}/%{name}
324%dir %{nginx_confdir}
325%dir %{nginx_confdir}/conf.d
326%config(noreplace) %{nginx_confdir}/conf.d/*.conf
327%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
328%config(noreplace) %{nginx_confdir}/sites.d/*
329%config(noreplace) %{nginx_confdir}/win-utf
330%config(noreplace) %{nginx_confdir}/%{name}.conf.default
331%config(noreplace) %{nginx_confdir}/mime.types.default
332%config(noreplace) %{nginx_confdir}/fastcgi_params
333%config(noreplace) %{nginx_confdir}/fastcgi_params.default
334%config(noreplace) %{nginx_confdir}/koi-win
335%config(noreplace) %{nginx_confdir}/koi-utf
336%config(noreplace) %{nginx_confdir}/%{name}.conf
337%config(noreplace) %{nginx_confdir}/mime.types
338%config(noreplace) %{nginx_confdir}/fastcgi.conf
339%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
340%config(noreplace) %{nginx_confdir}/scgi_params
341%config(noreplace) %{nginx_confdir}/scgi_params.default
342%config(noreplace) %{nginx_confdir}/uwsgi_params
343%config(noreplace) %{nginx_confdir}/uwsgi_params.default
344%if %{with wsgi}
345%config(noreplace) %{nginx_confdir}/wsgi_vars
346%endif
347%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
348%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
349%dir %{perl_vendorarch}/auto/%{name}
350%{perl_vendorarch}/%{name}.pm
351%{perl_vendorarch}/auto/%{name}/%{name}.so
352%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
353%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
354%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
355%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
356
357%files passenger
358%defattr(-,root,root,-)
359%doc passenger-%{passenger_version}/doc/*.txt
360%doc passenger-%{passenger_version}/doc/*.html
361%doc passenger-%{passenger_version}/doc/template
362%doc passenger-%{passenger_version}/doc/users_guide_snippets
363%doc passenger-%{passenger_version}/doc/images
364%{_sbindir}/%{name}.passenger
365
366
367%changelog
368* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
369- rebuilt with GeoIP-1.6.0.
370- added Patch100.
371
372* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
373- update to 1.5.6
374- update passenger to 4.0.21
375
376* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
377- rebuilt with gd-2.1.0.
378
379* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
380- update to 1.4.1
381
382* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
383- update to 1.4.0
384- enable SPDY module
385
386* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
387- new upstream release
388- update passenger to 3.0.19
389- update ngx-fancyindex to upstream git master
390
391* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
392- new upstream release
393- update passenger to 3.0.17
394
395* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
396- rebuild with pcre-8.31
397
398* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
399- added http_geoip_module.
400
401* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
402- update to 1.2.4
403
404* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
405- update to 1.2.2
406
407* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
408- update to 1.2.1
409- change nginx user from nginx to www-data
410- R(pre): www-common
411
412* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
413- update to 1.2.0
414- update passenger to 3.0.12
415- drop http_upstream_keepalive
416
417* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
418- new upstream release
419
420* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
421- update to 1.0.12
422
423* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
424- update to 1.0.11
425- update passenger to 3.0.11
426
427* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
428- update to 1.0.10
429
430* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
431- update passenger to 3.0.9
432
433* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
434- update to 1.0.6
435
436* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
437- update to 1.0.4
438
439* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
440- add gnosek-nginx-upstream-fair module
441- add ngx_http_upstream_keepalive module
442
443* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
444- add nginx-passenger sub pakckage
445  - use alternatives to choose nginx with or without passenger
446  - add BR: ruby, rubygems, rubygem-rake
447
448* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
449- update to 1.0.2
450
451* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
452- update to 1.0.1
453
454* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
455- add bcond_with wsgi for mod_wsgi
456- add bcond_with passenger
457  - you need to install rake.gem to build with this option.
458- add Provides: webserver
459
460* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
461- new upstream release 1.0.0!
462
463* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
464- rebuild with perl-5.12.3
465
466* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
467- update to 0.8.54
468
469* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
470- update to 0.8.53
471- add nginx_accept_language_module
472
473* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
474- update to 0.8.50
475- update ngx-fancyindex to 0.3
476- add BR: libxml2-devel, libxslt-devel
477- add scgi_params* and uwsgi_params* to %%files
478
479* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
480- update to 0.8.35 (development version)
481- add sites.d/ to store vitualhost settings
482- split out default server settings to sites.d/default
483- add fancyindex module
484
485* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
486- new upstream release
487
488* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
489- update to 0.7.62 (included security fix: VU#180065)
490
491* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
492- fix typo
493
494* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
495- add translated descriptions
496
497* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
498- update 404.html/50x.html to use powered by vine logo.
499
500* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
501- initial build for Vine Linux
502- update to 0.7.61
503
504* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
505- init script updates from Gena Makhomed
506- remove nginx-upstream-fair
507
508* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
509-  update to 0.6.36
510
511* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
512- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
513
514* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
515- rebuild
516
517* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
518- update to 0.6.35
519
520* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
521- rebuild with new openssl
522
523* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
524- update to 0.6.34
525
526* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
527- Fix inclusion of /usr/share/nginx tree => no unowned directories.
528
529* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
530- update to 0.6.33
531
532* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
533- update to 0.6.32
534- nginx now supports DESTDIR so removed the patches that enabled it
535
536* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
537- init script fixes
538- resolve 'listen 80 default' [#447873]
539
540* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
541- update to 0.6.31
542
543* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
544- upate to new upstream stable branch 0.6
545- added 3rd party module nginx-upstream-fair
546- added default webpages
547
548* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
549- update init script to match recommended guidelines
550- add /etc/nginx/conf.d support [#443280]
551- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
552
553* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
554- add Requires for versioned perl (libperl.so)
555- drop silly file Requires
556
557* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
558- Autorebuild for GCC 4.3
559
560* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
561- update to 0.5.35
562
563* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
564- update to 0.5.34
565
566* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
567 - Rebuild for deps
568
569* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
570- update to 0.5.33
571
572* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
573- updated to 0.5.32
574- fixed rpmlint UTF-8 complaints.
575
576* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
577- added --with-http_stub_status_module build option.
578- added --with-http_sub_module build option.
579- added use of pcre-config --cflags
580
581* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
582- Update to 0.5.31
583- specify license is BSD
584
585* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
586- Add BuildRequires: perl-devel - fixing rawhide build
587
588* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
589- Update to 0.5.30
590
591* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
592- Update to 0.5.29
593
594* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
595- Update to 0.5.28
596
597* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
598- Update to 0.5.27
599
600* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
601- Update to 0.5.26
602
603* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
604- Update to 0.5.19
605
606* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
607- Update to 0.5.17
608
609* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
610- Update to 0.5.16
611- add ownership of /usr/share/nginx/html (#233950)
612
613* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
614- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
615
616* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
617- fixed package review bugs (#233522) given by kevin@tummy.com
618
619* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
620- create patches to assist with building for Fedora
621- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.