source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 7947

Revision 7947, 20.4 KB checked in by daisuke, 11 years ago (diff)

nginx:

  • update to 1.5.6
  • update passenger to 4.0.21
Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.5.6
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 20130213
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 4.0.21
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66
67BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
68
69BuildRequires:      pcre-devel
70BuildRequires:      zlib-devel
71BuildRequires:      openssl-devel
72BuildRequires:      gd-devel
73BuildRequires:      perl
74BuildRequires:      perl(ExtUtils::Embed)
75BuildRequires:      libxml2-devel
76BuildRequires:      libxslt-devel
77BuildRequires:      curl-devel
78%if %{with geoip}
79BuildRequires:      GeoIP-devel
80%endif
81
82%if "%{?_dist_release}" == "vl4"
83Requires:           perl >= 5.8.6
84%else
85Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
86%endif
87# for /usr/sbin/useradd
88Requires(pre):      shadow-utils
89Requires(post):     chkconfig
90# for /sbin/service
91Requires(preun):    chkconfig, initscripts
92Requires(postun):   initscripts
93%if "%{_dist_release}" > "vl6"
94Requires(pre):      www-common
95%endif
96
97Provides: webserver
98
99Vendor: Project Vine
100Distribution: Vine Linux
101Packager: daisuke
102
103%description
104Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
105proxy server written by Igor Sysoev.
106
107%description -l ja
108Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
109堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
110 - HTTP(S) サーバ
111 - HTTP(S) リバースプロキシサーバ
112 - IMAP/POP3 プロキシサーバ
113
114%package passenger
115Summary: Nginx with mod_passenger support
116Summary(ja): Passenger サポート入りの Nginx
117Group: System Environment/Daemons
118BuildRequires: ruby, rubygem-rake
119Requires: ruby, rubygem-rake
120%if "%{_dist_release}" >= "vl7"
121BuildRequires: ruby-devel, ruby-rubygems
122Requires: ruby-rubygems
123%else
124BuildRequires: rubygems
125Requires: rubygems
126%endif
127Requires: nginx
128
129%description passenger
130Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
131This package contains nginx server with passenger support.
132
133%description -l ja passenger
134Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
135堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
136 - HTTP(S) サーバ
137 - HTTP(S) リバースプロキシサーバ
138 - IMAP/POP3 プロキシサーバ
139このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
140
141%prep
142%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
143
144%patch0 -p0
145
146%build
147# nginx does not utilize a standard configure script.  It has its own
148# and the standard configure options cause the nginx configure script
149# to error out.  This is is also the reason for the DESTDIR environment
150# variable.  The configure script(s) have been patched (Patch1 and
151# Patch2) in order to support installing into a build environment.
152
153export DESTDIR=%{buildroot}
154
155
156CONFIGOPTS="\
157    --user=%{nginx_user} \
158    --group=%{nginx_group} \
159    --prefix=%{nginx_datadir} \
160    --sbin-path=%{_sbindir}/%{name} \
161    --conf-path=%{nginx_confdir}/%{name}.conf \
162    --error-log-path=%{nginx_logdir}/error.log \
163    --http-log-path=%{nginx_logdir}/access.log \
164    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
165    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
166    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
167    --pid-path=%{_localstatedir}/run/%{name}.pid \
168    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
169    --with-file-aio \
170    --with-ipv6 \
171    --with-http_ssl_module \
172    --with-http_spdy_module \
173    --with-http_realip_module \
174    --with-http_addition_module \
175    --with-http_xslt_module \
176    --with-http_image_filter_module \
177    --with-http_sub_module \
178    --with-http_dav_module \
179    --with-http_flv_module \
180    --with-http_mp4_module \
181    --with-http_gzip_static_module \
182    --with-http_gunzip_module \
183    --with-http_random_index_module \
184    --with-http_secure_link_module \
185    --with-http_degradation_module \
186    --with-http_stub_status_module \
187    --with-http_perl_module \
188    --with-http_degradation_module \
189%if %{with geoip}
190    --with-http_geoip_module \
191%endif
192    --with-http_auth_request_module \
193    --with-mail \
194    --with-mail_ssl_module \
195    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
196    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
197    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
198%if %{with wsgi}
199    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
200%endif
201%ifarch i686
202    --with-cpu-opt=pentiumpro \
203    --with-zlib-asm=pentiumpro \
204    --with-md5-asm \
205    --with-sha1-asm \
206%endif
207"
208
209
210## build with passenger
211./configure \
212    $CONFIGOPTS \
213    --with-cc-opt="%{optflags}" \
214    --add-module=passenger-%{passenger_version}/ext/nginx
215
216make %{?_smp_mflags}
217mv objs/nginx objs/nginx.passenger
218
219## build without passenger
220./configure \
221    $CONFIGOPTS \
222    --with-cc-opt="%{optflags}"
223
224make %{?_smp_mflags}
225
226%install
227rm -rf %{buildroot}
228make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
229find %{buildroot} -type f -name .packlist -exec rm -f {} \;
230find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
231find %{buildroot} -type f -empty -exec rm -f {} \;
232find %{buildroot} -type f -exec chmod 0644 {} \;
233find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
234mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
235%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
236chmod 0755 %{buildroot}%{_sbindir}/nginx.*
237%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
238%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
239%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
240%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
241%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
242%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
243%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
244%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
245%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
246%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
247%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
248%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
249%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
250%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
251%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
252%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
253%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
254%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
255%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
256%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
257
258%if %{with wsgi}
259%{__install} -p -m 0644 \
260    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
261    %{buildroot}%{nginx_confdir}
262cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
263%endif
264
265# upstream fair module document
266cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
267
268touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
269
270# convert to UTF-8 all files that give warnings.
271for textfile in CHANGES
272do
273    mv $textfile $textfile.old
274    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
275    rm -f $textfile.old
276done
277
278%clean
279rm -rf %{buildroot}
280
281%post
282if [ $1 == 1 ]; then
283    /sbin/chkconfig --add %{name}
284fi
285update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
286
287%post passenger
288update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
289
290%preun
291if [ $1 = 0 ]; then
292    /sbin/service %{name} stop >/dev/null 2>&1
293    /sbin/chkconfig --del %{name}
294    update-alternatives --remove nginx %{_sbindir}/nginx.normal
295fi
296
297%preun passenger
298if [ $1 = 0 ]; then
299    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
300fi
301
302
303%postun
304if [ $1 == 2 ]; then
305    /sbin/service %{name} upgrade || :
306fi
307
308%files
309%defattr(-,root,root,-)
310%doc LICENSE CHANGES README
311%doc README.upstream_fair
312%doc %{?with_wsgi:README.mod_wsgi}
313%{nginx_datadir}/
314%{_sbindir}/%{name}.normal
315%{_mandir}/man3/%{name}.3pm.gz
316%{_initrddir}/%{name}
317%dir %{nginx_confdir}
318%dir %{nginx_confdir}/conf.d
319%config(noreplace) %{nginx_confdir}/conf.d/*.conf
320%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
321%config(noreplace) %{nginx_confdir}/sites.d/*
322%config(noreplace) %{nginx_confdir}/win-utf
323%config(noreplace) %{nginx_confdir}/%{name}.conf.default
324%config(noreplace) %{nginx_confdir}/mime.types.default
325%config(noreplace) %{nginx_confdir}/fastcgi_params
326%config(noreplace) %{nginx_confdir}/fastcgi_params.default
327%config(noreplace) %{nginx_confdir}/koi-win
328%config(noreplace) %{nginx_confdir}/koi-utf
329%config(noreplace) %{nginx_confdir}/%{name}.conf
330%config(noreplace) %{nginx_confdir}/mime.types
331%config(noreplace) %{nginx_confdir}/fastcgi.conf
332%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
333%config(noreplace) %{nginx_confdir}/scgi_params
334%config(noreplace) %{nginx_confdir}/scgi_params.default
335%config(noreplace) %{nginx_confdir}/uwsgi_params
336%config(noreplace) %{nginx_confdir}/uwsgi_params.default
337%if %{with wsgi}
338%config(noreplace) %{nginx_confdir}/wsgi_vars
339%endif
340%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
341%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
342%dir %{perl_vendorarch}/auto/%{name}
343%{perl_vendorarch}/%{name}.pm
344%{perl_vendorarch}/auto/%{name}/%{name}.so
345%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
346%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
347%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
348%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
349
350%files passenger
351%defattr(-,root,root,-)
352%doc passenger-%{passenger_version}/doc/*.txt
353%doc passenger-%{passenger_version}/doc/*.html
354%doc passenger-%{passenger_version}/doc/template
355%doc passenger-%{passenger_version}/doc/users_guide_snippets
356%doc passenger-%{passenger_version}/doc/images
357%{_sbindir}/%{name}.passenger
358
359
360%changelog
361* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
362- update to 1.5.6
363- update passenger to 4.0.21
364
365* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
366- rebuilt with gd-2.1.0.
367
368* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
369- update to 1.4.1
370
371* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
372- update to 1.4.0
373- enable SPDY module
374
375* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
376- new upstream release
377- update passenger to 3.0.19
378- update ngx-fancyindex to upstream git master
379
380* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
381- new upstream release
382- update passenger to 3.0.17
383
384* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
385- rebuild with pcre-8.31
386
387* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
388- added http_geoip_module.
389
390* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
391- update to 1.2.4
392
393* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
394- update to 1.2.2
395
396* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
397- update to 1.2.1
398- change nginx user from nginx to www-data
399- R(pre): www-common
400
401* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
402- update to 1.2.0
403- update passenger to 3.0.12
404- drop http_upstream_keepalive
405
406* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
407- new upstream release
408
409* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
410- update to 1.0.12
411
412* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
413- update to 1.0.11
414- update passenger to 3.0.11
415
416* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
417- update to 1.0.10
418
419* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
420- update passenger to 3.0.9
421
422* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
423- update to 1.0.6
424
425* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
426- update to 1.0.4
427
428* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
429- add gnosek-nginx-upstream-fair module
430- add ngx_http_upstream_keepalive module
431
432* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
433- add nginx-passenger sub pakckage
434  - use alternatives to choose nginx with or without passenger
435  - add BR: ruby, rubygems, rubygem-rake
436
437* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
438- update to 1.0.2
439
440* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
441- update to 1.0.1
442
443* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
444- add bcond_with wsgi for mod_wsgi
445- add bcond_with passenger
446  - you need to install rake.gem to build with this option.
447- add Provides: webserver
448
449* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
450- new upstream release 1.0.0!
451
452* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
453- rebuild with perl-5.12.3
454
455* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
456- update to 0.8.54
457
458* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
459- update to 0.8.53
460- add nginx_accept_language_module
461
462* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
463- update to 0.8.50
464- update ngx-fancyindex to 0.3
465- add BR: libxml2-devel, libxslt-devel
466- add scgi_params* and uwsgi_params* to %%files
467
468* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
469- update to 0.8.35 (development version)
470- add sites.d/ to store vitualhost settings
471- split out default server settings to sites.d/default
472- add fancyindex module
473
474* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
475- new upstream release
476
477* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
478- update to 0.7.62 (included security fix: VU#180065)
479
480* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
481- fix typo
482
483* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
484- add translated descriptions
485
486* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
487- update 404.html/50x.html to use powered by vine logo.
488
489* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
490- initial build for Vine Linux
491- update to 0.7.61
492
493* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
494- init script updates from Gena Makhomed
495- remove nginx-upstream-fair
496
497* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
498-  update to 0.6.36
499
500* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
501- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
502
503* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
504- rebuild
505
506* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
507- update to 0.6.35
508
509* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
510- rebuild with new openssl
511
512* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
513- update to 0.6.34
514
515* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
516- Fix inclusion of /usr/share/nginx tree => no unowned directories.
517
518* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
519- update to 0.6.33
520
521* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
522- update to 0.6.32
523- nginx now supports DESTDIR so removed the patches that enabled it
524
525* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
526- init script fixes
527- resolve 'listen 80 default' [#447873]
528
529* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
530- update to 0.6.31
531
532* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
533- upate to new upstream stable branch 0.6
534- added 3rd party module nginx-upstream-fair
535- added default webpages
536
537* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
538- update init script to match recommended guidelines
539- add /etc/nginx/conf.d support [#443280]
540- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
541
542* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
543- add Requires for versioned perl (libperl.so)
544- drop silly file Requires
545
546* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
547- Autorebuild for GCC 4.3
548
549* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
550- update to 0.5.35
551
552* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
553- update to 0.5.34
554
555* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
556 - Rebuild for deps
557
558* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
559- update to 0.5.33
560
561* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
562- updated to 0.5.32
563- fixed rpmlint UTF-8 complaints.
564
565* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
566- added --with-http_stub_status_module build option.
567- added --with-http_sub_module build option.
568- added use of pcre-config --cflags
569
570* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
571- Update to 0.5.31
572- specify license is BSD
573
574* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
575- Add BuildRequires: perl-devel - fixing rawhide build
576
577* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
578- Update to 0.5.30
579
580* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
581- Update to 0.5.29
582
583* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
584- Update to 0.5.28
585
586* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
587- Update to 0.5.27
588
589* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
590- Update to 0.5.26
591
592* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
593- Update to 0.5.19
594
595* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
596- Update to 0.5.17
597
598* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
599- Update to 0.5.16
600- add ownership of /usr/share/nginx/html (#233950)
601
602* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
603- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
604
605* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
606- fixed package review bugs (#233522) given by kevin@tummy.com
607
608* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
609- create patches to assist with building for Fedora
610- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.