source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 7856

Revision 7856, 20.3 KB checked in by tomop, 11 years ago (diff)

gd-2.1.0-1 and dependencies.

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.4.1
29Release:        2%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 20130213
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 3.0.19
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66# configuration patch to match all the Vine Linux paths for logs, pid files
67# etc.
68Patch1:     nginx-conf.patch
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
71
72BuildRequires:      pcre-devel
73BuildRequires:      zlib-devel
74BuildRequires:      openssl-devel
75BuildRequires:      gd-devel
76BuildRequires:      perl
77BuildRequires:      perl(ExtUtils::Embed)
78BuildRequires:      libxml2-devel
79BuildRequires:      libxslt-devel
80BuildRequires:      curl-devel
81%if %{with geoip}
82BuildRequires:      GeoIP-devel
83%endif
84
85%if "%{?_dist_release}" == "vl4"
86Requires:           perl >= 5.8.6
87%else
88Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
89%endif
90# for /usr/sbin/useradd
91Requires(pre):      shadow-utils
92Requires(post):     chkconfig
93# for /sbin/service
94Requires(preun):    chkconfig, initscripts
95Requires(postun):   initscripts
96%if "%{_dist_release}" > "vl6"
97Requires(pre):      www-common
98%endif
99
100Provides: webserver
101
102Vendor: Project Vine
103Distribution: Vine Linux
104Packager: daisuke
105
106%description
107Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
108proxy server written by Igor Sysoev.
109
110%description -l ja
111Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
112堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
113 - HTTP(S) サーバ
114 - HTTP(S) リバースプロキシサーバ
115 - IMAP/POP3 プロキシサーバ
116
117%package passenger
118Summary: Nginx with mod_passenger support
119Summary(ja): Passenger サポート入りの Nginx
120Group: System Environment/Daemons
121BuildRequires: ruby, rubygem-rake
122Requires: ruby, rubygem-rake
123%if "%{_dist_release}" >= "vl7"
124BuildRequires: ruby-devel, ruby-rubygems
125Requires: ruby-rubygems
126%else
127BuildRequires: rubygems
128Requires: rubygems
129%endif
130Requires: nginx
131
132%description passenger
133Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
134This package contains nginx server with passenger support.
135
136%description -l ja passenger
137Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
138堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
139 - HTTP(S) サーバ
140 - HTTP(S) リバースプロキシサーバ
141 - IMAP/POP3 プロキシサーバ
142このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
143
144%prep
145%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
146
147%patch0 -p0
148%patch1 -p1
149
150%build
151# nginx does not utilize a standard configure script.  It has its own
152# and the standard configure options cause the nginx configure script
153# to error out.  This is is also the reason for the DESTDIR environment
154# variable.  The configure script(s) have been patched (Patch1 and
155# Patch2) in order to support installing into a build environment.
156
157export DESTDIR=%{buildroot}
158
159
160CONFIGOPTS="\
161    --user=%{nginx_user} \
162    --group=%{nginx_group} \
163    --prefix=%{nginx_datadir} \
164    --sbin-path=%{_sbindir}/%{name} \
165    --conf-path=%{nginx_confdir}/%{name}.conf \
166    --error-log-path=%{nginx_logdir}/error.log \
167    --http-log-path=%{nginx_logdir}/access.log \
168    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
169    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
170    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
171    --pid-path=%{_localstatedir}/run/%{name}.pid \
172    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
173    --with-file-aio \
174    --with-ipv6 \
175    --with-http_ssl_module \
176    --with-http_spdy_module \
177    --with-http_realip_module \
178    --with-http_addition_module \
179    --with-http_xslt_module \
180    --with-http_image_filter_module \
181    --with-http_sub_module \
182    --with-http_dav_module \
183    --with-http_flv_module \
184    --with-http_mp4_module \
185    --with-http_gzip_static_module \
186    --with-http_random_index_module \
187    --with-http_secure_link_module \
188    --with-http_degradation_module \
189    --with-http_stub_status_module \
190    --with-http_perl_module \
191    --with-http_degradation_module \
192%if %{with geoip}
193    --with-http_geoip_module \
194%endif
195    --with-mail \
196    --with-mail_ssl_module \
197    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
198    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
199    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
200%if %{with wsgi}
201    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
202%endif
203%ifarch i686
204    --with-cpu-opt=pentiumpro \
205    --with-zlib-asm=pentiumpro \
206    --with-md5-asm \
207    --with-sha1-asm \
208%endif
209"
210
211
212## build with passenger
213./configure \
214    $CONFIGOPTS \
215    --with-cc-opt="%{optflags}" \
216    --add-module=passenger-%{passenger_version}/ext/nginx
217
218make %{?_smp_mflags}
219mv objs/nginx objs/nginx.passenger
220
221## build without passenger
222./configure \
223    $CONFIGOPTS \
224    --with-cc-opt="%{optflags}"
225
226make %{?_smp_mflags}
227
228%install
229rm -rf %{buildroot}
230make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
231find %{buildroot} -type f -name .packlist -exec rm -f {} \;
232find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
233find %{buildroot} -type f -empty -exec rm -f {} \;
234find %{buildroot} -type f -exec chmod 0644 {} \;
235find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
236mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
237%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
238chmod 0755 %{buildroot}%{_sbindir}/nginx.*
239%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
240%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
241%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
242%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
243%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
244%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
245%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
246%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
247%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
248%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
249%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
250%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
251%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
252%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
253%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
254%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
255%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
256%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
257%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
258%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
259
260%if %{with wsgi}
261%{__install} -p -m 0644 \
262    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
263    %{buildroot}%{nginx_confdir}
264cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
265%endif
266
267# upstream fair module document
268cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
269
270touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
271
272# convert to UTF-8 all files that give warnings.
273for textfile in CHANGES
274do
275    mv $textfile $textfile.old
276    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
277    rm -f $textfile.old
278done
279
280%clean
281rm -rf %{buildroot}
282
283%post
284if [ $1 == 1 ]; then
285    /sbin/chkconfig --add %{name}
286fi
287update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
288
289%post passenger
290update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
291
292%preun
293if [ $1 = 0 ]; then
294    /sbin/service %{name} stop >/dev/null 2>&1
295    /sbin/chkconfig --del %{name}
296    update-alternatives --remove nginx %{_sbindir}/nginx.normal
297fi
298
299%preun passenger
300if [ $1 = 0 ]; then
301    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
302fi
303
304
305%postun
306if [ $1 == 2 ]; then
307    /sbin/service %{name} upgrade || :
308fi
309
310%files
311%defattr(-,root,root,-)
312%doc LICENSE CHANGES README
313%doc README.upstream_fair
314%doc %{?with_wsgi:README.mod_wsgi}
315%{nginx_datadir}/
316%{_sbindir}/%{name}.normal
317%{_mandir}/man3/%{name}.3pm.gz
318%{_initrddir}/%{name}
319%dir %{nginx_confdir}
320%dir %{nginx_confdir}/conf.d
321%config(noreplace) %{nginx_confdir}/conf.d/*.conf
322%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
323%config(noreplace) %{nginx_confdir}/sites.d/*
324%config(noreplace) %{nginx_confdir}/win-utf
325%config(noreplace) %{nginx_confdir}/%{name}.conf.default
326%config(noreplace) %{nginx_confdir}/mime.types.default
327%config(noreplace) %{nginx_confdir}/fastcgi_params
328%config(noreplace) %{nginx_confdir}/fastcgi_params.default
329%config(noreplace) %{nginx_confdir}/koi-win
330%config(noreplace) %{nginx_confdir}/koi-utf
331%config(noreplace) %{nginx_confdir}/%{name}.conf
332%config(noreplace) %{nginx_confdir}/mime.types
333%config(noreplace) %{nginx_confdir}/fastcgi.conf
334%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
335%config(noreplace) %{nginx_confdir}/scgi_params
336%config(noreplace) %{nginx_confdir}/scgi_params.default
337%config(noreplace) %{nginx_confdir}/uwsgi_params
338%config(noreplace) %{nginx_confdir}/uwsgi_params.default
339%if %{with wsgi}
340%config(noreplace) %{nginx_confdir}/wsgi_vars
341%endif
342%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
343%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
344%dir %{perl_vendorarch}/auto/%{name}
345%{perl_vendorarch}/%{name}.pm
346%{perl_vendorarch}/auto/%{name}/%{name}.so
347%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
348%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
349%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
350%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
351
352%files passenger
353%defattr(-,root,root,-)
354%doc passenger-%{passenger_version}/doc/*.txt
355%doc passenger-%{passenger_version}/doc/*.html
356%doc passenger-%{passenger_version}/doc/template
357%doc passenger-%{passenger_version}/doc/users_guide_snippets
358%doc passenger-%{passenger_version}/doc/images
359%{_sbindir}/%{name}.passenger
360
361
362%changelog
363* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
364- rebuilt with gd-2.1.0.
365
366* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
367- update to 1.4.1
368
369* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
370- update to 1.4.0
371- enable SPDY module
372
373* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
374- new upstream release
375- update passenger to 3.0.19
376- update ngx-fancyindex to upstream git master
377
378* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
379- new upstream release
380- update passenger to 3.0.17
381
382* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
383- rebuild with pcre-8.31
384
385* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
386- added http_geoip_module.
387
388* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
389- update to 1.2.4
390
391* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
392- update to 1.2.2
393
394* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
395- update to 1.2.1
396- change nginx user from nginx to www-data
397- R(pre): www-common
398
399* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
400- update to 1.2.0
401- update passenger to 3.0.12
402- drop http_upstream_keepalive
403
404* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
405- new upstream release
406
407* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
408- update to 1.0.12
409
410* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
411- update to 1.0.11
412- update passenger to 3.0.11
413
414* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
415- update to 1.0.10
416
417* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
418- update passenger to 3.0.9
419
420* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
421- update to 1.0.6
422
423* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
424- update to 1.0.4
425
426* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
427- add gnosek-nginx-upstream-fair module
428- add ngx_http_upstream_keepalive module
429
430* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
431- add nginx-passenger sub pakckage
432  - use alternatives to choose nginx with or without passenger
433  - add BR: ruby, rubygems, rubygem-rake
434
435* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
436- update to 1.0.2
437
438* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
439- update to 1.0.1
440
441* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
442- add bcond_with wsgi for mod_wsgi
443- add bcond_with passenger
444  - you need to install rake.gem to build with this option.
445- add Provides: webserver
446
447* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
448- new upstream release 1.0.0!
449
450* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
451- rebuild with perl-5.12.3
452
453* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
454- update to 0.8.54
455
456* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
457- update to 0.8.53
458- add nginx_accept_language_module
459
460* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
461- update to 0.8.50
462- update ngx-fancyindex to 0.3
463- add BR: libxml2-devel, libxslt-devel
464- add scgi_params* and uwsgi_params* to %%files
465
466* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
467- update to 0.8.35 (development version)
468- add sites.d/ to store vitualhost settings
469- split out default server settings to sites.d/default
470- add fancyindex module
471
472* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
473- new upstream release
474
475* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
476- update to 0.7.62 (included security fix: VU#180065)
477
478* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
479- fix typo
480
481* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
482- add translated descriptions
483
484* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
485- update 404.html/50x.html to use powered by vine logo.
486
487* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
488- initial build for Vine Linux
489- update to 0.7.61
490
491* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
492- init script updates from Gena Makhomed
493- remove nginx-upstream-fair
494
495* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
496-  update to 0.6.36
497
498* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
499- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
500
501* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
502- rebuild
503
504* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
505- update to 0.6.35
506
507* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
508- rebuild with new openssl
509
510* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
511- update to 0.6.34
512
513* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
514- Fix inclusion of /usr/share/nginx tree => no unowned directories.
515
516* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
517- update to 0.6.33
518
519* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
520- update to 0.6.32
521- nginx now supports DESTDIR so removed the patches that enabled it
522
523* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
524- init script fixes
525- resolve 'listen 80 default' [#447873]
526
527* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
528- update to 0.6.31
529
530* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
531- upate to new upstream stable branch 0.6
532- added 3rd party module nginx-upstream-fair
533- added default webpages
534
535* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
536- update init script to match recommended guidelines
537- add /etc/nginx/conf.d support [#443280]
538- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
539
540* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
541- add Requires for versioned perl (libperl.so)
542- drop silly file Requires
543
544* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
545- Autorebuild for GCC 4.3
546
547* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
548- update to 0.5.35
549
550* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
551- update to 0.5.34
552
553* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
554 - Rebuild for deps
555
556* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
557- update to 0.5.33
558
559* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
560- updated to 0.5.32
561- fixed rpmlint UTF-8 complaints.
562
563* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
564- added --with-http_stub_status_module build option.
565- added --with-http_sub_module build option.
566- added use of pcre-config --cflags
567
568* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
569- Update to 0.5.31
570- specify license is BSD
571
572* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
573- Add BuildRequires: perl-devel - fixing rawhide build
574
575* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
576- Update to 0.5.30
577
578* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
579- Update to 0.5.29
580
581* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
582- Update to 0.5.28
583
584* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
585- Update to 0.5.27
586
587* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
588- Update to 0.5.26
589
590* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
591- Update to 0.5.19
592
593* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
594- Update to 0.5.17
595
596* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
597- Update to 0.5.16
598- add ownership of /usr/share/nginx/html (#233950)
599
600* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
601- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
602
603* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
604- fixed package review bugs (#233522) given by kevin@tummy.com
605
606* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
607- create patches to assist with building for Fedora
608- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.