source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 7472

Revision 7472, 21.7 KB checked in by daisuke, 11 years ago (diff)

nginx:

  • update to 1.2.7
  • update passenger to 3.0.19
  • update ngx-fancyindex to upstream git master
Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.2.7
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 20130213
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 3.0.19
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66# configuration patch to match all the Vine Linux paths for logs, pid files
67# etc.
68Patch1:     nginx-conf.patch
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
71
72BuildRequires:      pcre-devel
73BuildRequires:      zlib-devel
74BuildRequires:      openssl-devel
75BuildRequires:      gd-devel
76BuildRequires:      perl
77BuildRequires:      perl(ExtUtils::Embed)
78BuildRequires:      libxml2-devel
79BuildRequires:      libxslt-devel
80BuildRequires:      curl-devel
81%if %{with geoip}
82BuildRequires:      GeoIP-devel
83%endif
84
85%if "%{?_dist_release}" == "vl4"
86Requires:           perl >= 5.8.6
87%else
88Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
89%endif
90# for /usr/sbin/useradd
91Requires(pre):      shadow-utils
92Requires(post):     chkconfig
93# for /sbin/service
94Requires(preun):    chkconfig, initscripts
95Requires(postun):   initscripts
96%if "%{_dist_release}" > "vl6"
97Requires(pre):      www-common
98%endif
99
100Provides: webserver
101
102Vendor: Project Vine
103Distribution: Vine Linux
104Packager: daisuke
105
106%description
107Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
108proxy server written by Igor Sysoev.
109
110%description -l ja
111Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
112堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
113 - HTTP(S) サーバ
114 - HTTP(S) リバースプロキシサーバ
115 - IMAP/POP3 プロキシサーバ
116
117%package passenger
118Summary: Nginx with mod_passenger support
119Summary(ja): Passenger サポート入りの Nginx
120Group: System Environment/Daemons
121BuildRequires: ruby, rubygem-rake
122Requires: ruby, rubygem-rake
123%if "%{_dist_release}" >= "vl7"
124BuildRequires: ruby-devel, ruby-rubygems
125Requires: ruby-rubygems
126%else
127BuildRequires: rubygems
128Requires: rubygems
129%endif
130Requires: nginx
131
132%description passenger
133Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
134This package contains nginx server with passenger support.
135
136%description -l ja passenger
137Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
138堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
139 - HTTP(S) サーバ
140 - HTTP(S) リバースプロキシサーバ
141 - IMAP/POP3 プロキシサーバ
142このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
143
144%prep
145%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
146
147%patch0 -p0
148%patch1 -p1
149
150%build
151# nginx does not utilize a standard configure script.  It has its own
152# and the standard configure options cause the nginx configure script
153# to error out.  This is is also the reason for the DESTDIR environment
154# variable.  The configure script(s) have been patched (Patch1 and
155# Patch2) in order to support installing into a build environment.
156
157export DESTDIR=%{buildroot}
158
159## build with passenger
160./configure \
161    --user=%{nginx_user} \
162    --group=%{nginx_group} \
163    --prefix=%{nginx_datadir} \
164    --sbin-path=%{_sbindir}/%{name} \
165    --conf-path=%{nginx_confdir}/%{name}.conf \
166    --error-log-path=%{nginx_logdir}/error.log \
167    --http-log-path=%{nginx_logdir}/access.log \
168    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
169    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
170    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
171    --pid-path=%{_localstatedir}/run/%{name}.pid \
172    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
173    --with-file-aio \
174    --with-ipv6 \
175    --with-http_ssl_module \
176    --with-http_realip_module \
177    --with-http_addition_module \
178    --with-http_xslt_module \
179    --with-http_image_filter_module \
180    --with-http_sub_module \
181    --with-http_dav_module \
182    --with-http_flv_module \
183    --with-http_mp4_module \
184    --with-http_gzip_static_module \
185    --with-http_random_index_module \
186    --with-http_secure_link_module \
187    --with-http_stub_status_module \
188    --with-http_perl_module \
189    --with-http_degradation_module \
190%if %{with geoip}
191    --with-http_geoip_module \
192%endif
193    --with-mail \
194    --with-mail_ssl_module \
195    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
196    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
197    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
198%if %{with wsgi}
199    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
200%endif
201    --add-module=passenger-%{passenger_version}/ext/nginx \
202%ifarch i686
203    --with-cpu-opt=pentiumpro \
204    --with-zlib-asm=pentiumpro \
205    --with-md5-asm \
206    --with-sha1-asm \
207%endif
208    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
209make %{?_smp_mflags}
210mv objs/nginx objs/nginx.passenger
211
212## build without passenger
213./configure \
214    --user=%{nginx_user} \
215    --group=%{nginx_group} \
216    --prefix=%{nginx_datadir} \
217    --sbin-path=%{_sbindir}/%{name} \
218    --conf-path=%{nginx_confdir}/%{name}.conf \
219    --error-log-path=%{nginx_logdir}/error.log \
220    --http-log-path=%{nginx_logdir}/access.log \
221    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
222    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
223    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
224    --pid-path=%{_localstatedir}/run/%{name}.pid \
225    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
226    --with-file-aio \
227    --with-ipv6 \
228    --with-http_ssl_module \
229    --with-http_realip_module \
230    --with-http_addition_module \
231    --with-http_xslt_module \
232    --with-http_image_filter_module \
233    --with-http_sub_module \
234    --with-http_dav_module \
235    --with-http_flv_module \
236    --with-http_gzip_static_module \
237    --with-http_random_index_module \
238    --with-http_secure_link_module \
239    --with-http_stub_status_module \
240    --with-http_perl_module \
241%if %{with geoip}
242    --with-http_geoip_module \
243%endif
244    --with-mail \
245    --with-mail_ssl_module \
246    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
247    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
248    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
249%if %{with wsgi}
250    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
251%endif
252%ifarch i686
253    --with-cpu-opt=pentiumpro \
254    --with-zlib-asm=pentiumpro \
255    --with-md5-asm \
256    --with-sha1-asm \
257%endif
258    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
259make %{?_smp_mflags}
260
261%install
262rm -rf %{buildroot}
263make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
264find %{buildroot} -type f -name .packlist -exec rm -f {} \;
265find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
266find %{buildroot} -type f -empty -exec rm -f {} \;
267find %{buildroot} -type f -exec chmod 0644 {} \;
268find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
269mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
270%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
271chmod 0755 %{buildroot}%{_sbindir}/nginx.*
272%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
273%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
274%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
275%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
276%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
277%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
278%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
279%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
280%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
281%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
282%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
283%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
284%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
285%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
286%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
287%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
288%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
289%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
290%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
291%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
292
293%if %{with wsgi}
294%{__install} -p -m 0644 \
295    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
296    %{buildroot}%{nginx_confdir}
297cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
298%endif
299
300# upstream fair module document
301cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
302
303touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
304
305# convert to UTF-8 all files that give warnings.
306for textfile in CHANGES
307do
308    mv $textfile $textfile.old
309    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
310    rm -f $textfile.old
311done
312
313%clean
314rm -rf %{buildroot}
315
316%post
317if [ $1 == 1 ]; then
318    /sbin/chkconfig --add %{name}
319fi
320update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
321
322%post passenger
323update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
324
325%preun
326if [ $1 = 0 ]; then
327    /sbin/service %{name} stop >/dev/null 2>&1
328    /sbin/chkconfig --del %{name}
329    update-alternatives --remove nginx %{_sbindir}/nginx.normal
330fi
331
332%preun passenger
333if [ $1 = 0 ]; then
334    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
335fi
336
337
338%postun
339if [ $1 == 2 ]; then
340    /sbin/service %{name} upgrade || :
341fi
342
343%files
344%defattr(-,root,root,-)
345%doc LICENSE CHANGES README
346%doc README.upstream_fair
347%doc %{?with_wsgi:README.mod_wsgi}
348%{nginx_datadir}/
349%{_sbindir}/%{name}.normal
350%{_mandir}/man3/%{name}.3pm.gz
351%{_initrddir}/%{name}
352%dir %{nginx_confdir}
353%dir %{nginx_confdir}/conf.d
354%config(noreplace) %{nginx_confdir}/conf.d/*.conf
355%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
356%config(noreplace) %{nginx_confdir}/sites.d/*
357%config(noreplace) %{nginx_confdir}/win-utf
358%config(noreplace) %{nginx_confdir}/%{name}.conf.default
359%config(noreplace) %{nginx_confdir}/mime.types.default
360%config(noreplace) %{nginx_confdir}/fastcgi_params
361%config(noreplace) %{nginx_confdir}/fastcgi_params.default
362%config(noreplace) %{nginx_confdir}/koi-win
363%config(noreplace) %{nginx_confdir}/koi-utf
364%config(noreplace) %{nginx_confdir}/%{name}.conf
365%config(noreplace) %{nginx_confdir}/mime.types
366%config(noreplace) %{nginx_confdir}/fastcgi.conf
367%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
368%config(noreplace) %{nginx_confdir}/scgi_params
369%config(noreplace) %{nginx_confdir}/scgi_params.default
370%config(noreplace) %{nginx_confdir}/uwsgi_params
371%config(noreplace) %{nginx_confdir}/uwsgi_params.default
372%if %{with wsgi}
373%config(noreplace) %{nginx_confdir}/wsgi_vars
374%endif
375%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
376%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
377%dir %{perl_vendorarch}/auto/%{name}
378%{perl_vendorarch}/%{name}.pm
379%{perl_vendorarch}/auto/%{name}/%{name}.so
380%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
381%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
382%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
383%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
384
385%files passenger
386%defattr(-,root,root,-)
387%doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
388%doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
389%doc passenger-%{passenger_version}/doc/Architectural\ overview.*
390%doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
391%doc passenger-%{passenger_version}/doc/template
392%doc passenger-%{passenger_version}/doc/users_guide_snippets
393%doc passenger-%{passenger_version}/doc/images
394%{_sbindir}/%{name}.passenger
395
396
397%changelog
398* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
399- new upstream release
400- update passenger to 3.0.19
401- update ngx-fancyindex to upstream git master
402
403* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
404- new upstream release
405- update passenger to 3.0.17
406
407* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
408- rebuild with pcre-8.31
409
410* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
411- added http_geoip_module.
412
413* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
414- update to 1.2.4
415
416* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
417- update to 1.2.2
418
419* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
420- update to 1.2.1
421- change nginx user from nginx to www-data
422- R(pre): www-common
423
424* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
425- update to 1.2.0
426- update passenger to 3.0.12
427- drop http_upstream_keepalive
428
429* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
430- new upstream release
431
432* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
433- update to 1.0.12
434
435* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
436- update to 1.0.11
437- update passenger to 3.0.11
438
439* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
440- update to 1.0.10
441
442* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
443- update passenger to 3.0.9
444
445* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
446- update to 1.0.6
447
448* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
449- update to 1.0.4
450
451* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
452- add gnosek-nginx-upstream-fair module
453- add ngx_http_upstream_keepalive module
454
455* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
456- add nginx-passenger sub pakckage
457  - use alternatives to choose nginx with or without passenger
458  - add BR: ruby, rubygems, rubygem-rake
459
460* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
461- update to 1.0.2
462
463* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
464- update to 1.0.1
465
466* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
467- add bcond_with wsgi for mod_wsgi
468- add bcond_with passenger
469  - you need to install rake.gem to build with this option.
470- add Provides: webserver
471
472* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
473- new upstream release 1.0.0!
474
475* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
476- rebuild with perl-5.12.3
477
478* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
479- update to 0.8.54
480
481* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
482- update to 0.8.53
483- add nginx_accept_language_module
484
485* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
486- update to 0.8.50
487- update ngx-fancyindex to 0.3
488- add BR: libxml2-devel, libxslt-devel
489- add scgi_params* and uwsgi_params* to %%files
490
491* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
492- update to 0.8.35 (development version)
493- add sites.d/ to store vitualhost settings
494- split out default server settings to sites.d/default
495- add fancyindex module
496
497* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
498- new upstream release
499
500* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
501- update to 0.7.62 (included security fix: VU#180065)
502
503* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
504- fix typo
505
506* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
507- add translated descriptions
508
509* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
510- update 404.html/50x.html to use powered by vine logo.
511
512* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
513- initial build for Vine Linux
514- update to 0.7.61
515
516* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
517- init script updates from Gena Makhomed
518- remove nginx-upstream-fair
519
520* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
521-  update to 0.6.36
522
523* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
524- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
525
526* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
527- rebuild
528
529* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
530- update to 0.6.35
531
532* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
533- rebuild with new openssl
534
535* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
536- update to 0.6.34
537
538* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
539- Fix inclusion of /usr/share/nginx tree => no unowned directories.
540
541* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
542- update to 0.6.33
543
544* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
545- update to 0.6.32
546- nginx now supports DESTDIR so removed the patches that enabled it
547
548* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
549- init script fixes
550- resolve 'listen 80 default' [#447873]
551
552* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
553- update to 0.6.31
554
555* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
556- upate to new upstream stable branch 0.6
557- added 3rd party module nginx-upstream-fair
558- added default webpages
559
560* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
561- update init script to match recommended guidelines
562- add /etc/nginx/conf.d support [#443280]
563- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
564
565* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
566- add Requires for versioned perl (libperl.so)
567- drop silly file Requires
568
569* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
570- Autorebuild for GCC 4.3
571
572* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
573- update to 0.5.35
574
575* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
576- update to 0.5.34
577
578* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
579 - Rebuild for deps
580
581* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
582- update to 0.5.33
583
584* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
585- updated to 0.5.32
586- fixed rpmlint UTF-8 complaints.
587
588* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
589- added --with-http_stub_status_module build option.
590- added --with-http_sub_module build option.
591- added use of pcre-config --cflags
592
593* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
594- Update to 0.5.31
595- specify license is BSD
596
597* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
598- Add BuildRequires: perl-devel - fixing rawhide build
599
600* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
601- Update to 0.5.30
602
603* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
604- Update to 0.5.29
605
606* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
607- Update to 0.5.28
608
609* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
610- Update to 0.5.27
611
612* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
613- Update to 0.5.26
614
615* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
616- Update to 0.5.19
617
618* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
619- Update to 0.5.17
620
621* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
622- Update to 0.5.16
623- add ownership of /usr/share/nginx/html (#233950)
624
625* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
626- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
627
628* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
629- fixed package review bugs (#233522) given by kevin@tummy.com
630
631* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
632- create patches to assist with building for Fedora
633- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.