source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 7199

Revision 7199, 21.4 KB checked in by daisuke, 11 years ago (diff)

nginx: update to 1.2.5, update passenger to 3.0.17

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.2.5
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 0.3
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 3.0.17
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66# configuration patch to match all the Vine Linux paths for logs, pid files
67# etc.
68Patch1:     nginx-conf.patch
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
71
72BuildRequires:      pcre-devel
73BuildRequires:      zlib-devel
74BuildRequires:      openssl-devel
75BuildRequires:      gd-devel
76BuildRequires:      perl
77BuildRequires:      perl(ExtUtils::Embed)
78BuildRequires:      libxml2-devel
79BuildRequires:      libxslt-devel
80BuildRequires:      curl-devel
81%if %{with geoip}
82BuildRequires:      GeoIP-devel
83%endif
84
85%if "%{?_dist_release}" == "vl4"
86Requires:           perl >= 5.8.6
87%else
88Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
89%endif
90# for /usr/sbin/useradd
91Requires(pre):      shadow-utils
92Requires(post):     chkconfig
93# for /sbin/service
94Requires(preun):    chkconfig, initscripts
95Requires(postun):   initscripts
96%if "%{_dist_release}" > "vl6"
97Requires(pre):      www-common
98%endif
99
100Provides: webserver
101
102Vendor: Project Vine
103Distribution: Vine Linux
104Packager: daisuke
105
106%description
107Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
108proxy server written by Igor Sysoev.
109
110%description -l ja
111Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
112堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
113 - HTTP(S) サーバ
114 - HTTP(S) リバースプロキシサーバ
115 - IMAP/POP3 プロキシサーバ
116
117%package passenger
118Summary: Nginx with mod_passenger support
119Summary(ja): Passenger サポート入りの Nginx
120Group: System Environment/Daemons
121BuildRequires: ruby, rubygem-rake
122Requires: ruby, rubygem-rake
123%if "%{_dist_release}" >= "vl7"
124BuildRequires: ruby-devel, ruby-rubygems
125Requires: ruby-rubygems
126%else
127BuildRequires: rubygems
128Requires: rubygems
129%endif
130Requires: nginx
131
132%description passenger
133Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
134This package contains nginx server with passenger support.
135
136%description -l ja passenger
137Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
138堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
139 - HTTP(S) サーバ
140 - HTTP(S) リバースプロキシサーバ
141 - IMAP/POP3 プロキシサーバ
142このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
143
144%prep
145%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
146
147%patch0 -p0
148%patch1 -p1
149
150%build
151# nginx does not utilize a standard configure script.  It has its own
152# and the standard configure options cause the nginx configure script
153# to error out.  This is is also the reason for the DESTDIR environment
154# variable.  The configure script(s) have been patched (Patch1 and
155# Patch2) in order to support installing into a build environment.
156
157export DESTDIR=%{buildroot}
158
159## build with passenger
160./configure \
161    --user=%{nginx_user} \
162    --group=%{nginx_group} \
163    --prefix=%{nginx_datadir} \
164    --sbin-path=%{_sbindir}/%{name} \
165    --conf-path=%{nginx_confdir}/%{name}.conf \
166    --error-log-path=%{nginx_logdir}/error.log \
167    --http-log-path=%{nginx_logdir}/access.log \
168    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
169    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
170    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
171    --pid-path=%{_localstatedir}/run/%{name}.pid \
172    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
173    --with-file-aio \
174    --with-ipv6 \
175    --with-http_ssl_module \
176    --with-http_realip_module \
177    --with-http_addition_module \
178    --with-http_xslt_module \
179    --with-http_image_filter_module \
180    --with-http_sub_module \
181    --with-http_dav_module \
182    --with-http_flv_module \
183    --with-http_gzip_static_module \
184    --with-http_random_index_module \
185    --with-http_secure_link_module \
186    --with-http_stub_status_module \
187    --with-http_perl_module \
188%if %{with geoip}
189    --with-http_geoip_module \
190%endif
191    --with-mail \
192    --with-mail_ssl_module \
193    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
194    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
195    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
196%if %{with wsgi}
197    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
198%endif
199    --add-module=passenger-%{passenger_version}/ext/nginx \
200%ifarch i686
201    --with-cpu-opt=pentiumpro \
202    --with-zlib-asm=pentiumpro \
203    --with-md5-asm \
204    --with-sha1-asm \
205%endif
206    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
207make %{?_smp_mflags}
208mv objs/nginx objs/nginx.passenger
209
210## build without passenger
211./configure \
212    --user=%{nginx_user} \
213    --group=%{nginx_group} \
214    --prefix=%{nginx_datadir} \
215    --sbin-path=%{_sbindir}/%{name} \
216    --conf-path=%{nginx_confdir}/%{name}.conf \
217    --error-log-path=%{nginx_logdir}/error.log \
218    --http-log-path=%{nginx_logdir}/access.log \
219    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
220    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
221    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
222    --pid-path=%{_localstatedir}/run/%{name}.pid \
223    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
224    --with-file-aio \
225    --with-ipv6 \
226    --with-http_ssl_module \
227    --with-http_realip_module \
228    --with-http_addition_module \
229    --with-http_xslt_module \
230    --with-http_image_filter_module \
231    --with-http_sub_module \
232    --with-http_dav_module \
233    --with-http_flv_module \
234    --with-http_gzip_static_module \
235    --with-http_random_index_module \
236    --with-http_secure_link_module \
237    --with-http_stub_status_module \
238    --with-http_perl_module \
239%if %{with geoip}
240    --with-http_geoip_module \
241%endif
242    --with-mail \
243    --with-mail_ssl_module \
244    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
245    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
246    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
247%if %{with wsgi}
248    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
249%endif
250%ifarch i686
251    --with-cpu-opt=pentiumpro \
252    --with-zlib-asm=pentiumpro \
253    --with-md5-asm \
254    --with-sha1-asm \
255%endif
256    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
257make %{?_smp_mflags}
258
259%install
260rm -rf %{buildroot}
261make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
262find %{buildroot} -type f -name .packlist -exec rm -f {} \;
263find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
264find %{buildroot} -type f -empty -exec rm -f {} \;
265find %{buildroot} -type f -exec chmod 0644 {} \;
266find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
267mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
268%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
269chmod 0755 %{buildroot}%{_sbindir}/nginx.*
270%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
271%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
272%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
273%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
274%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
275%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
276%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
277%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
278%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
279%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
280%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
281%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
282%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
283%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
284%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
285%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
286%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
287%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
288%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
289%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
290
291%if %{with wsgi}
292%{__install} -p -m 0644 \
293    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
294    %{buildroot}%{nginx_confdir}
295cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
296%endif
297
298# upstream fair module document
299cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
300
301touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
302
303# convert to UTF-8 all files that give warnings.
304for textfile in CHANGES
305do
306    mv $textfile $textfile.old
307    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
308    rm -f $textfile.old
309done
310
311%clean
312rm -rf %{buildroot}
313
314%post
315if [ $1 == 1 ]; then
316    /sbin/chkconfig --add %{name}
317fi
318update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
319
320%post passenger
321update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
322
323%preun
324if [ $1 = 0 ]; then
325    /sbin/service %{name} stop >/dev/null 2>&1
326    /sbin/chkconfig --del %{name}
327    update-alternatives --remove nginx %{_sbindir}/nginx.normal
328fi
329
330%preun passenger
331if [ $1 = 0 ]; then
332    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
333fi
334
335
336%postun
337if [ $1 == 2 ]; then
338    /sbin/service %{name} upgrade || :
339fi
340
341%files
342%defattr(-,root,root,-)
343%doc LICENSE CHANGES README
344%doc README.upstream_fair
345%doc %{?with_wsgi:README.mod_wsgi}
346%{nginx_datadir}/
347%{_sbindir}/%{name}.normal
348%{_mandir}/man3/%{name}.3pm.gz
349%{_initrddir}/%{name}
350%dir %{nginx_confdir}
351%dir %{nginx_confdir}/conf.d
352%config(noreplace) %{nginx_confdir}/conf.d/*.conf
353%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
354%config(noreplace) %{nginx_confdir}/sites.d/*
355%config(noreplace) %{nginx_confdir}/win-utf
356%config(noreplace) %{nginx_confdir}/%{name}.conf.default
357%config(noreplace) %{nginx_confdir}/mime.types.default
358%config(noreplace) %{nginx_confdir}/fastcgi_params
359%config(noreplace) %{nginx_confdir}/fastcgi_params.default
360%config(noreplace) %{nginx_confdir}/koi-win
361%config(noreplace) %{nginx_confdir}/koi-utf
362%config(noreplace) %{nginx_confdir}/%{name}.conf
363%config(noreplace) %{nginx_confdir}/mime.types
364%config(noreplace) %{nginx_confdir}/fastcgi.conf
365%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
366%config(noreplace) %{nginx_confdir}/scgi_params
367%config(noreplace) %{nginx_confdir}/scgi_params.default
368%config(noreplace) %{nginx_confdir}/uwsgi_params
369%config(noreplace) %{nginx_confdir}/uwsgi_params.default
370%if %{with wsgi}
371%config(noreplace) %{nginx_confdir}/wsgi_vars
372%endif
373%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
374%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
375%dir %{perl_vendorarch}/auto/%{name}
376%{perl_vendorarch}/%{name}.pm
377%{perl_vendorarch}/auto/%{name}/%{name}.so
378%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
379%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
380%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
381%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
382
383%files passenger
384%defattr(-,root,root,-)
385%doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
386%doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
387%doc passenger-%{passenger_version}/doc/Architectural\ overview.*
388%doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
389%doc passenger-%{passenger_version}/doc/template
390%doc passenger-%{passenger_version}/doc/users_guide_snippets
391%doc passenger-%{passenger_version}/doc/images
392%{_sbindir}/%{name}.passenger
393
394
395%changelog
396* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
397- new upstream release
398- update passenger to 3.0.17
399
400* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
401- rebuild with pcre-8.31
402
403* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
404- added http_geoip_module.
405
406* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
407- update to 1.2.4
408
409* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
410- update to 1.2.2
411
412* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
413- update to 1.2.1
414- change nginx user from nginx to www-data
415- R(pre): www-common
416
417* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
418- update to 1.2.0
419- update passenger to 3.0.12
420- drop http_upstream_keepalive
421
422* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
423- new upstream release
424
425* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
426- update to 1.0.12
427
428* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
429- update to 1.0.11
430- update passenger to 3.0.11
431
432* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
433- update to 1.0.10
434
435* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
436- update passenger to 3.0.9
437
438* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
439- update to 1.0.6
440
441* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
442- update to 1.0.4
443
444* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
445- add gnosek-nginx-upstream-fair module
446- add ngx_http_upstream_keepalive module
447
448* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
449- add nginx-passenger sub pakckage
450  - use alternatives to choose nginx with or without passenger
451  - add BR: ruby, rubygems, rubygem-rake
452
453* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
454- update to 1.0.2
455
456* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
457- update to 1.0.1
458
459* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
460- add bcond_with wsgi for mod_wsgi
461- add bcond_with passenger
462  - you need to install rake.gem to build with this option.
463- add Provides: webserver
464
465* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
466- new upstream release 1.0.0!
467
468* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
469- rebuild with perl-5.12.3
470
471* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
472- update to 0.8.54
473
474* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
475- update to 0.8.53
476- add nginx_accept_language_module
477
478* Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
479- update to 0.8.50
480- update ngx-fancyindex to 0.3
481- add BR: libxml2-devel, libxslt-devel
482- add scgi_params* and uwsgi_params* to %%files
483
484* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
485- update to 0.8.35 (development version)
486- add sites.d/ to store vitualhost settings
487- split out default server settings to sites.d/default
488- add fancyindex module
489
490* Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
491- new upstream release
492
493* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
494- update to 0.7.62 (included security fix: VU#180065)
495
496* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
497- fix typo
498
499* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
500- add translated descriptions
501
502* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
503- update 404.html/50x.html to use powered by vine logo.
504
505* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
506- initial build for Vine Linux
507- update to 0.7.61
508
509* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
510- init script updates from Gena Makhomed
511- remove nginx-upstream-fair
512
513* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
514-  update to 0.6.36
515
516* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
517- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
518
519* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
520- rebuild
521
522* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
523- update to 0.6.35
524
525* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
526- rebuild with new openssl
527
528* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
529- update to 0.6.34
530
531* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
532- Fix inclusion of /usr/share/nginx tree => no unowned directories.
533
534* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
535- update to 0.6.33
536
537* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
538- update to 0.6.32
539- nginx now supports DESTDIR so removed the patches that enabled it
540
541* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
542- init script fixes
543- resolve 'listen 80 default' [#447873]
544
545* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
546- update to 0.6.31
547
548* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
549- upate to new upstream stable branch 0.6
550- added 3rd party module nginx-upstream-fair
551- added default webpages
552
553* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
554- update init script to match recommended guidelines
555- add /etc/nginx/conf.d support [#443280]
556- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
557
558* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
559- add Requires for versioned perl (libperl.so)
560- drop silly file Requires
561
562* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
563- Autorebuild for GCC 4.3
564
565* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
566- update to 0.5.35
567
568* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
569- update to 0.5.34
570
571* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
572 - Rebuild for deps
573
574* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
575- update to 0.5.33
576
577* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
578- updated to 0.5.32
579- fixed rpmlint UTF-8 complaints.
580
581* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
582- added --with-http_stub_status_module build option.
583- added --with-http_sub_module build option.
584- added use of pcre-config --cflags
585
586* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
587- Update to 0.5.31
588- specify license is BSD
589
590* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
591- Add BuildRequires: perl-devel - fixing rawhide build
592
593* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
594- Update to 0.5.30
595
596* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
597- Update to 0.5.29
598
599* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
600- Update to 0.5.28
601
602* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
603- Update to 0.5.27
604
605* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
606- Update to 0.5.26
607
608* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
609- Update to 0.5.19
610
611* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
612- Update to 0.5.17
613
614* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
615- Update to 0.5.16
616- add ownership of /usr/share/nginx/html (#233950)
617
618* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
619- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
620
621* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
622- fixed package review bugs (#233522) given by kevin@tummy.com
623
624* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
625- create patches to assist with building for Fedora
626- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.