source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 6903

Revision 6903, 21.0 KB checked in by tomop, 12 years ago (diff)

nginx-1.2.4-2

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%bcond_without geoip
6
7%if "%{_dist_release}" > "vl6"
8%define nginx_user      www-data
9%else
10%define nginx_user      nginx
11%endif
12%define nginx_group     %{nginx_user}
13%define nginx_home      %{_localstatedir}/lib/nginx
14%define nginx_home_tmp  %{nginx_home}/tmp
15%define nginx_home_cache %{nginx_home}/cache
16%define nginx_logdir    %{_localstatedir}/log/nginx
17%define nginx_confdir   %{_sysconfdir}/nginx
18%define nginx_datadir   %{_datadir}/nginx
19%define nginx_webroot   %{nginx_datadir}/html
20
21Summary:        Robust, small and high performance http and reverse proxy server
22Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
23Name:           nginx
24Version:        1.2.4
25Release:        2%{?_dist_release}
26
27Group:          System Environment/Daemons   
28# BSD License (two clause)
29# http://www.freebsd.org/copyright/freebsd-license.html
30License:        BSD
31URL:            http://nginx.net/
32
33Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
34Source1:    %{name}.init
35Source2:    %{name}.logrotate
36Source3:    nginx-virtual.conf.template
37Source4:    nginx-ssl.conf
38Source5:    %{name}.sysconfig
39Source10:   nginx-vine.conf
40Source11:   nginx-default-vine
41Source20:   proxy_cache.conf
42Source100:  nginx-index.html
43Source101:  poweredby-vine.png
44Source102:  nginx-logo.png
45Source103:  nginx-50x.html
46Source104:  nginx-404.html
47%define ngx_fancyindex_version 0.3
48Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
49%define nginx_accept_language_module_version 02262ce
50Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
51%define passenger_version 3.0.12
52Source1020: passenger-%{passenger_version}.tar.gz
53%define upstream_fair_version 2131c73
54Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
55
56%define mod_wsgi_version 6975f0ec7eeb
57Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
58
59# removes -Werror in upstream build scripts.  -Werror conflicts with
60# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
61Patch0:     nginx-auto-cc-gcc.patch
62# configuration patch to match all the Vine Linux paths for logs, pid files
63# etc.
64Patch1:     nginx-conf.patch
65
66BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
67
68BuildRequires:      pcre-devel
69BuildRequires:      zlib-devel
70BuildRequires:      openssl-devel
71BuildRequires:      gd-devel
72BuildRequires:      perl
73BuildRequires:      perl(ExtUtils::Embed)
74BuildRequires:      libxml2-devel
75BuildRequires:      libxslt-devel
76BuildRequires:      curl-devel
77%if %{with geoip}
78BuildRequires:      GeoIP-devel
79%endif
80
81%if "%{?_dist_release}" == "vl4"
82Requires:           perl >= 5.8.6
83%else
84Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
85%endif
86# for /usr/sbin/useradd
87Requires(pre):      shadow-utils
88Requires(post):     chkconfig
89# for /sbin/service
90Requires(preun):    chkconfig, initscripts
91Requires(postun):   initscripts
92%if "%{_dist_release}" > "vl6"
93Requires(pre):      www-common
94%endif
95
96Provides: webserver
97
98Vendor: Project Vine
99Distribution: Vine Linux
100Packager: daisuke
101
102%description
103Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
104proxy server written by Igor Sysoev.
105
106%description -l ja
107Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
108堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
109 - HTTP(S) サーバ
110 - HTTP(S) リバースプロキシサーバ
111 - IMAP/POP3 プロキシサーバ
112
113%package passenger
114Summary: Nginx with mod_passenger support
115Summary(ja): Passenger サポート入りの Nginx
116Group: System Environment/Daemons   
117BuildRequires: ruby, rubygems, rubygem-rake
118Requires: nginx
119
120%description passenger
121Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
122This package contains nginx server with passenger support.
123
124%description -l ja passenger
125Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
126堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
127 - HTTP(S) サーバ
128 - HTTP(S) リバースプロキシサーバ
129 - IMAP/POP3 プロキシサーバ
130このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
131
132%prep
133%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
134
135%patch0 -p0
136%patch1 -p1
137
138%build
139# nginx does not utilize a standard configure script.  It has its own
140# and the standard configure options cause the nginx configure script
141# to error out.  This is is also the reason for the DESTDIR environment
142# variable.  The configure script(s) have been patched (Patch1 and
143# Patch2) in order to support installing into a build environment.
144
145export DESTDIR=%{buildroot}
146
147## build with passenger
148./configure \
149    --user=%{nginx_user} \
150    --group=%{nginx_group} \
151    --prefix=%{nginx_datadir} \
152    --sbin-path=%{_sbindir}/%{name} \
153    --conf-path=%{nginx_confdir}/%{name}.conf \
154    --error-log-path=%{nginx_logdir}/error.log \
155    --http-log-path=%{nginx_logdir}/access.log \
156    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
157    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
158    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
159    --pid-path=%{_localstatedir}/run/%{name}.pid \
160    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
161    --with-file-aio \
162    --with-ipv6 \
163    --with-http_ssl_module \
164    --with-http_realip_module \
165    --with-http_addition_module \
166    --with-http_xslt_module \
167    --with-http_image_filter_module \
168    --with-http_sub_module \
169    --with-http_dav_module \
170    --with-http_flv_module \
171    --with-http_gzip_static_module \
172    --with-http_random_index_module \
173    --with-http_secure_link_module \
174    --with-http_stub_status_module \
175    --with-http_perl_module \
176%if %{with geoip}
177    --with-http_geoip_module \
178%endif
179    --with-mail \
180    --with-mail_ssl_module \
181    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
182    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
183    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
184%if %{with wsgi}
185    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
186%endif
187    --add-module=passenger-%{passenger_version}/ext/nginx \
188%ifarch i686
189    --with-cpu-opt=pentiumpro \
190    --with-zlib-asm=pentiumpro \
191    --with-md5-asm \
192    --with-sha1-asm \
193%endif
194    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
195make %{?_smp_mflags}
196mv objs/nginx objs/nginx.passenger
197
198## build without passenger
199./configure \
200    --user=%{nginx_user} \
201    --group=%{nginx_group} \
202    --prefix=%{nginx_datadir} \
203    --sbin-path=%{_sbindir}/%{name} \
204    --conf-path=%{nginx_confdir}/%{name}.conf \
205    --error-log-path=%{nginx_logdir}/error.log \
206    --http-log-path=%{nginx_logdir}/access.log \
207    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
208    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
209    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
210    --pid-path=%{_localstatedir}/run/%{name}.pid \
211    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
212    --with-file-aio \
213    --with-ipv6 \
214    --with-http_ssl_module \
215    --with-http_realip_module \
216    --with-http_addition_module \
217    --with-http_xslt_module \
218    --with-http_image_filter_module \
219    --with-http_sub_module \
220    --with-http_dav_module \
221    --with-http_flv_module \
222    --with-http_gzip_static_module \
223    --with-http_random_index_module \
224    --with-http_secure_link_module \
225    --with-http_stub_status_module \
226    --with-http_perl_module \
227%if %{with geoip}
228    --with-http_geoip_module \
229%endif
230    --with-mail \
231    --with-mail_ssl_module \
232    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
233    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
234    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
235%if %{with wsgi}
236    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
237%endif
238%ifarch i686
239    --with-cpu-opt=pentiumpro \
240    --with-zlib-asm=pentiumpro \
241    --with-md5-asm \
242    --with-sha1-asm \
243%endif
244    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
245make %{?_smp_mflags}
246
247%install
248rm -rf %{buildroot}
249make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
250find %{buildroot} -type f -name .packlist -exec rm -f {} \;
251find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
252find %{buildroot} -type f -empty -exec rm -f {} \;
253find %{buildroot} -type f -exec chmod 0644 {} \;
254find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
255mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
256%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
257chmod 0755 %{buildroot}%{_sbindir}/nginx.*
258%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
259%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
260%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
261%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
262%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
263%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
264%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
265%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
266%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
267%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
268%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
269%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
270%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
271%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
272%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
273%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
274%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
275%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
276%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
277%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
278
279%if %{with wsgi}
280%{__install} -p -m 0644 \
281    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
282    %{buildroot}%{nginx_confdir}
283cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
284%endif
285
286# upstream fair module document
287cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
288
289touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
290
291# convert to UTF-8 all files that give warnings.
292for textfile in CHANGES
293do
294    mv $textfile $textfile.old
295    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
296    rm -f $textfile.old
297done
298
299%clean
300rm -rf %{buildroot}
301
302%post
303if [ $1 == 1 ]; then
304    /sbin/chkconfig --add %{name}
305fi
306update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
307
308%post passenger
309update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
310
311%preun
312if [ $1 = 0 ]; then
313    /sbin/service %{name} stop >/dev/null 2>&1
314    /sbin/chkconfig --del %{name}
315    update-alternatives --remove nginx %{_sbindir}/nginx.normal
316fi
317
318%preun passenger
319if [ $1 = 0 ]; then
320    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
321fi
322
323
324%postun
325if [ $1 == 2 ]; then
326    /sbin/service %{name} upgrade || :
327fi
328
329%files
330%defattr(-,root,root,-)
331%doc LICENSE CHANGES README
332%doc README.upstream_fair
333%doc %{?with_wsgi:README.mod_wsgi}
334%{nginx_datadir}/
335%{_sbindir}/%{name}.normal
336%{_mandir}/man3/%{name}.3pm.gz
337%{_initrddir}/%{name}
338%dir %{nginx_confdir}
339%dir %{nginx_confdir}/conf.d
340%config(noreplace) %{nginx_confdir}/conf.d/*.conf
341%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
342%config(noreplace) %{nginx_confdir}/sites.d/*
343%config(noreplace) %{nginx_confdir}/win-utf
344%config(noreplace) %{nginx_confdir}/%{name}.conf.default
345%config(noreplace) %{nginx_confdir}/mime.types.default
346%config(noreplace) %{nginx_confdir}/fastcgi_params
347%config(noreplace) %{nginx_confdir}/fastcgi_params.default
348%config(noreplace) %{nginx_confdir}/koi-win
349%config(noreplace) %{nginx_confdir}/koi-utf
350%config(noreplace) %{nginx_confdir}/%{name}.conf
351%config(noreplace) %{nginx_confdir}/mime.types
352%config(noreplace) %{nginx_confdir}/fastcgi.conf
353%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
354%config(noreplace) %{nginx_confdir}/scgi_params
355%config(noreplace) %{nginx_confdir}/scgi_params.default
356%config(noreplace) %{nginx_confdir}/uwsgi_params
357%config(noreplace) %{nginx_confdir}/uwsgi_params.default
358%if %{with wsgi}
359%config(noreplace) %{nginx_confdir}/wsgi_vars
360%endif
361%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
362%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
363%dir %{perl_vendorarch}/auto/%{name}
364%{perl_vendorarch}/%{name}.pm
365%{perl_vendorarch}/auto/%{name}/%{name}.so
366%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
367%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
368%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
369%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
370
371%files passenger
372%defattr(-,root,root,-)
373%doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
374%doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
375%doc passenger-%{passenger_version}/doc/Architectural\ overview.*
376%doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
377%doc passenger-%{passenger_version}/doc/template
378%doc passenger-%{passenger_version}/doc/users_guide_snippets
379%doc passenger-%{passenger_version}/doc/images
380%{_sbindir}/%{name}.passenger
381
382
383%changelog
384* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
385- added http_geoip_module.
386
387* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
388- update to 1.2.4
389
390* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
391- update to 1.2.2
392
393* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
394- update to 1.2.1
395- change nginx user from nginx to www-data
396- R(pre): www-common
397
398* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
399- update to 1.2.0
400- update passenger to 3.0.12
401- drop http_upstream_keepalive
402
403* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
404- new upstream release
405
406* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
407- update to 1.0.12
408
409* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
410- update to 1.0.11
411- update passenger to 3.0.11
412
413* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
414- update to 1.0.10
415
416* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
417- update passenger to 3.0.9
418
419* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
420- update to 1.0.6
421
422* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
423- update to 1.0.4
424
425* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
426- add gnosek-nginx-upstream-fair module
427- add ngx_http_upstream_keepalive module
428
429* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
430- add nginx-passenger sub pakckage
431  - use alternatives to choose nginx with or without passenger
432  - add BR: ruby, rubygems, rubygem-rake
433
434* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
435- update to 1.0.2
436
437* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
438- update to 1.0.1
439
440* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
441- add bcond_with wsgi for mod_wsgi
442- add bcond_with passenger
443  - you need to install rake.gem to build with this option.
444- add Provides: webserver
445
446* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
447- new upstream release 1.0.0!
448
449* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
450- rebuild with perl-5.12.3
451
452* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
453- update to 0.8.54
454
455* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
456- update to 0.8.53
457- add nginx_accept_language_module
458
459* Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
460- update to 0.8.50
461- update ngx-fancyindex to 0.3
462- add BR: libxml2-devel, libxslt-devel
463- add scgi_params* and uwsgi_params* to %%files
464
465* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
466- update to 0.8.35 (development version)
467- add sites.d/ to store vitualhost settings
468- split out default server settings to sites.d/default
469- add fancyindex module
470
471* Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
472- new upstream release
473
474* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
475- update to 0.7.62 (included security fix: VU#180065)
476
477* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
478- fix typo
479
480* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
481- add translated descriptions
482
483* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
484- update 404.html/50x.html to use powered by vine logo.
485
486* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
487- initial build for Vine Linux
488- update to 0.7.61
489
490* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
491- init script updates from Gena Makhomed
492- remove nginx-upstream-fair
493
494* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
495-  update to 0.6.36
496
497* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
498- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
499
500* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
501- rebuild
502
503* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
504- update to 0.6.35
505
506* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
507- rebuild with new openssl
508
509* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
510- update to 0.6.34
511
512* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
513- Fix inclusion of /usr/share/nginx tree => no unowned directories.
514
515* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
516- update to 0.6.33
517
518* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
519- update to 0.6.32
520- nginx now supports DESTDIR so removed the patches that enabled it
521
522* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
523- init script fixes
524- resolve 'listen 80 default' [#447873]
525
526* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
527- update to 0.6.31
528
529* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
530- upate to new upstream stable branch 0.6
531- added 3rd party module nginx-upstream-fair
532- added default webpages
533
534* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
535- update init script to match recommended guidelines
536- add /etc/nginx/conf.d support [#443280]
537- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
538
539* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
540- add Requires for versioned perl (libperl.so)
541- drop silly file Requires
542
543* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
544- Autorebuild for GCC 4.3
545
546* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
547- update to 0.5.35
548
549* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
550- update to 0.5.34
551
552* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
553 - Rebuild for deps
554
555* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
556- update to 0.5.33
557
558* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
559- updated to 0.5.32
560- fixed rpmlint UTF-8 complaints.
561
562* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
563- added --with-http_stub_status_module build option.
564- added --with-http_sub_module build option.
565- added use of pcre-config --cflags
566
567* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
568- Update to 0.5.31
569- specify license is BSD
570
571* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
572- Add BuildRequires: perl-devel - fixing rawhide build
573
574* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
575- Update to 0.5.30
576
577* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
578- Update to 0.5.29
579
580* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
581- Update to 0.5.28
582
583* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
584- Update to 0.5.27
585
586* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
587- Update to 0.5.26
588
589* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
590- Update to 0.5.19
591
592* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
593- Update to 0.5.17
594
595* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
596- Update to 0.5.16
597- add ownership of /usr/share/nginx/html (#233950)
598
599* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
600- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
601
602* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
603- fixed package review bugs (#233522) given by kevin@tummy.com
604
605* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
606- create patches to assist with building for Fedora
607- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.