source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 4684

Revision 4684, 20.4 KB checked in by daisuke, 13 years ago (diff)

nginx: update to 1.0.6

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4%define nginx_user      nginx
5%define nginx_group     %{nginx_user}
6%define nginx_home      %{_localstatedir}/lib/nginx
7%define nginx_home_tmp  %{nginx_home}/tmp
8%define nginx_home_cache %{nginx_home}/cache
9%define nginx_logdir    %{_localstatedir}/log/nginx
10%define nginx_confdir   %{_sysconfdir}/nginx
11%define nginx_datadir   %{_datadir}/nginx
12%define nginx_webroot   %{nginx_datadir}/html
13
14Summary:        Robust, small and high performance http and reverse proxy server
15Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
16Name:           nginx
17Version:        1.0.6
18Release:        1%{?_dist_release}
19
20Group:          System Environment/Daemons   
21# BSD License (two clause)
22# http://www.freebsd.org/copyright/freebsd-license.html
23License:        BSD
24URL:            http://nginx.net/
25
26Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
27Source1:    %{name}.init
28Source2:    %{name}.logrotate
29Source3:    nginx-virtual.conf.template
30Source4:    nginx-ssl.conf
31Source5:    %{name}.sysconfig
32Source10:   nginx-vine.conf
33Source11:   nginx-default-vine
34Source20:   proxy_cache.conf
35Source100:  nginx-index.html
36Source101:  poweredby-vine.png
37Source102:  nginx-logo.png
38Source103:  nginx-50x.html
39Source104:  nginx-404.html
40%define ngx_fancyindex_version 0.3
41Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
42%define nginx_accept_language_module_version 02262ce
43Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
44%define passenger_version 3.0.5
45Source1020: passenger-%{passenger_version}.tar.gz
46%define upstream_fair_version 2131c73
47Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
48%define upstream_keepalive_version 2ee28064a04a
49Source1040: ngx_http_upstream_keepalive-%{upstream_keepalive_version}.tar.gz
50
51%define mod_wsgi_version 6975f0ec7eeb
52Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
53
54# removes -Werror in upstream build scripts.  -Werror conflicts with
55# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
56Patch0:     nginx-auto-cc-gcc.patch
57# configuration patch to match all the Vine Linux paths for logs, pid files
58# etc.
59Patch1:     nginx-conf.patch
60
61BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
62
63BuildRequires:      pcre-devel
64BuildRequires:      zlib-devel
65BuildRequires:      openssl-devel
66BuildRequires:      gd-devel
67BuildRequires:      perl
68BuildRequires:      perl(ExtUtils::Embed)
69BuildRequires:      libxml2-devel
70BuildRequires:      libxslt-devel
71BuildRequires:      curl-devel
72
73%if "%{?_dist_release}" == "vl4"
74Requires:           perl >= 5.8.6
75%else
76Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
77%endif
78# for /usr/sbin/useradd
79Requires(pre):      shadow-utils
80Requires(post):     chkconfig
81# for /sbin/service
82Requires(preun):    chkconfig, initscripts
83Requires(postun):   initscripts
84
85Provides: webserver
86
87Vendor: Project Vine
88Distribution: Vine Linux
89Packager: daisuke
90
91%description
92Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
93proxy server written by Igor Sysoev.
94
95%description -l ja
96Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
97堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
98 - HTTP(S) サーバ
99 - HTTP(S) リバースプロキシサーバ
100 - IMAP/POP3 プロキシサーバ
101
102%package passenger
103Summary: Nginx with mod_passenger support
104Summary(ja): Passenger サポート入りの Nginx
105Group: System Environment/Daemons   
106BuildRequires: ruby, rubygems, rubygem-rake
107Requires: nginx
108
109%description passenger
110Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
111This package contains nginx server with passenger support.
112
113%description -l ja passenger
114Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
115堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
116 - HTTP(S) サーバ
117 - HTTP(S) リバースプロキシサーバ
118 - IMAP/POP3 プロキシサーバ
119このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
120
121%prep
122%setup -q -a 1000 -a 1010 -a 1020 -a 1030 -a 1040 %{?with_wsgi:-a 2000}
123
124%patch0 -p0
125%patch1 -p1
126
127%build
128# nginx does not utilize a standard configure script.  It has its own
129# and the standard configure options cause the nginx configure script
130# to error out.  This is is also the reason for the DESTDIR environment
131# variable.  The configure script(s) have been patched (Patch1 and
132# Patch2) in order to support installing into a build environment.
133
134export DESTDIR=%{buildroot}
135
136## build with passenger
137./configure \
138    --user=%{nginx_user} \
139    --group=%{nginx_group} \
140    --prefix=%{nginx_datadir} \
141    --sbin-path=%{_sbindir}/%{name} \
142    --conf-path=%{nginx_confdir}/%{name}.conf \
143    --error-log-path=%{nginx_logdir}/error.log \
144    --http-log-path=%{nginx_logdir}/access.log \
145    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
146    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
147    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
148    --pid-path=%{_localstatedir}/run/%{name}.pid \
149    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
150    --with-file-aio \
151    --with-ipv6 \
152    --with-http_ssl_module \
153    --with-http_realip_module \
154    --with-http_addition_module \
155    --with-http_xslt_module \
156    --with-http_image_filter_module \
157    --with-http_sub_module \
158    --with-http_dav_module \
159    --with-http_flv_module \
160    --with-http_gzip_static_module \
161    --with-http_random_index_module \
162    --with-http_secure_link_module \
163    --with-http_stub_status_module \
164    --with-http_perl_module \
165    --with-mail \
166    --with-mail_ssl_module \
167    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
168    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
169    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
170    --add-module=ngx_http_upstream_keepalive-%{upstream_keepalive_version} \
171%if %{with wsgi}
172    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
173%endif
174    --add-module=passenger-%{passenger_version}/ext/nginx \
175%ifarch i686
176    --with-cpu-opt=pentiumpro \
177    --with-zlib-asm=pentiumpro \
178    --with-md5-asm \
179    --with-sha1-asm \
180%endif
181    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
182make %{?_smp_mflags}
183mv objs/nginx objs/nginx.passenger
184
185## build without passenger
186./configure \
187    --user=%{nginx_user} \
188    --group=%{nginx_group} \
189    --prefix=%{nginx_datadir} \
190    --sbin-path=%{_sbindir}/%{name} \
191    --conf-path=%{nginx_confdir}/%{name}.conf \
192    --error-log-path=%{nginx_logdir}/error.log \
193    --http-log-path=%{nginx_logdir}/access.log \
194    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
195    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
196    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
197    --pid-path=%{_localstatedir}/run/%{name}.pid \
198    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
199    --with-file-aio \
200    --with-ipv6 \
201    --with-http_ssl_module \
202    --with-http_realip_module \
203    --with-http_addition_module \
204    --with-http_xslt_module \
205    --with-http_image_filter_module \
206    --with-http_sub_module \
207    --with-http_dav_module \
208    --with-http_flv_module \
209    --with-http_gzip_static_module \
210    --with-http_random_index_module \
211    --with-http_secure_link_module \
212    --with-http_stub_status_module \
213    --with-http_perl_module \
214    --with-mail \
215    --with-mail_ssl_module \
216    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
217    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
218    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
219    --add-module=ngx_http_upstream_keepalive-%{upstream_keepalive_version} \
220%if %{with wsgi}
221    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
222%endif
223%ifarch i686
224    --with-cpu-opt=pentiumpro \
225    --with-zlib-asm=pentiumpro \
226    --with-md5-asm \
227    --with-sha1-asm \
228%endif
229    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
230make %{?_smp_mflags}
231
232%install
233rm -rf %{buildroot}
234make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
235find %{buildroot} -type f -name .packlist -exec rm -f {} \;
236find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
237find %{buildroot} -type f -empty -exec rm -f {} \;
238find %{buildroot} -type f -exec chmod 0644 {} \;
239find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
240mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
241%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
242chmod 0755 %{buildroot}%{_sbindir}/nginx.*
243%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
244%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
245%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
246%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
247%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
248%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
249%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
250%{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf
251%{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf.default
252%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
253%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
254%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
255%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
256%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
257%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
258%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
259%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
260%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
261%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
262%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
263
264%if %{with wsgi}
265%{__install} -p -m 0644 \
266    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
267    %{buildroot}%{nginx_confdir}
268cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
269%endif
270
271# upstream fair module document
272cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
273
274# upstream keepalive module document and sample
275mkdir -p upstream_keepalive_example
276cp -f ngx_http_upstream_keepalive-%{upstream_keepalive_version}/README README.upstream_keepalive
277cp -f ngx_http_upstream_keepalive-%{upstream_keepalive_version}/t/* upstream_keepalive_example
278
279touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
280
281# convert to UTF-8 all files that give warnings.
282for textfile in CHANGES
283do
284    mv $textfile $textfile.old
285    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
286    rm -f $textfile.old
287done
288
289%clean
290rm -rf %{buildroot}
291
292%pre
293if [ $1 == 1 ]; then
294    %{_sbindir}/useradd -c "Nginx user" -s /bin/false -r -d %{nginx_home} %{nginx_user} 2>/dev/null || :
295fi
296
297%post
298if [ $1 == 1 ]; then
299    /sbin/chkconfig --add %{name}
300fi
301update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
302
303%post passenger
304update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
305
306%preun
307if [ $1 = 0 ]; then
308    /sbin/service %{name} stop >/dev/null 2>&1
309    /sbin/chkconfig --del %{name}
310    update-alternatives --remove nginx %{_sbindir}/nginx.normal
311fi
312
313%preun passenger
314if [ $1 = 0 ]; then
315    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
316fi
317
318
319%postun
320if [ $1 == 2 ]; then
321    /sbin/service %{name} upgrade || :
322fi
323
324%files
325%defattr(-,root,root,-)
326%doc LICENSE CHANGES README
327%doc README.upstream_fair
328%doc README.upstream_keepalive upstream_keepalive_example/
329%doc %{?with_wsgi:README.mod_wsgi}
330%{nginx_datadir}/
331%{_sbindir}/%{name}.normal
332%{_mandir}/man3/%{name}.3pm.gz
333%{_initrddir}/%{name}
334%dir %{nginx_confdir}
335%dir %{nginx_confdir}/conf.d
336%config(noreplace) %{nginx_confdir}/conf.d/*.conf
337%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
338%config(noreplace) %{nginx_confdir}/sites.d/*
339%config(noreplace) %{nginx_confdir}/win-utf
340%config(noreplace) %{nginx_confdir}/%{name}.conf.default
341%config(noreplace) %{nginx_confdir}/mime.types.default
342%config(noreplace) %{nginx_confdir}/fastcgi_params
343%config(noreplace) %{nginx_confdir}/fastcgi_params.default
344%config(noreplace) %{nginx_confdir}/koi-win
345%config(noreplace) %{nginx_confdir}/koi-utf
346%config(noreplace) %{nginx_confdir}/%{name}.conf
347%config(noreplace) %{nginx_confdir}/mime.types
348%config(noreplace) %{nginx_confdir}/fastcgi.conf
349%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
350%config(noreplace) %{nginx_confdir}/scgi_params
351%config(noreplace) %{nginx_confdir}/scgi_params.default
352%config(noreplace) %{nginx_confdir}/uwsgi_params
353%config(noreplace) %{nginx_confdir}/uwsgi_params.default
354%if %{with wsgi}
355%config(noreplace) %{nginx_confdir}/wsgi_vars
356%endif
357%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
358%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
359%dir %{perl_vendorarch}/auto/%{name}
360%{perl_vendorarch}/%{name}.pm
361%{perl_vendorarch}/auto/%{name}/%{name}.so
362%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
363%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
364%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
365%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
366
367%files passenger
368%defattr(-,root,root,-)
369%doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
370%doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
371%doc passenger-%{passenger_version}/doc/Architectural\ overview.*
372%doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
373%doc passenger-%{passenger_version}/doc/template
374%doc passenger-%{passenger_version}/doc/users_guide_snippets
375%doc passenger-%{passenger_version}/doc/images
376%{_sbindir}/%{name}.passenger
377
378
379%changelog
380* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
381- update to 1.0.6
382
383* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
384- update to 1.0.4
385
386* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
387- add gnosek-nginx-upstream-fair module
388- add ngx_http_upstream_keepalive module
389
390* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
391- add nginx-passenger sub pakckage
392  - use alternatives to choose nginx with or without passenger
393  - add BR: ruby, rubygems, rubygem-rake
394
395* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
396- update to 1.0.2
397
398* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
399- update to 1.0.1
400
401* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
402- add bcond_with wsgi for mod_wsgi
403- add bcond_with passenger
404  - you need to install rake.gem to build with this option.
405- add Provides: webserver
406
407* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
408- new upstream release 1.0.0!
409
410* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
411- rebuild with perl-5.12.3
412
413* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
414- update to 0.8.54
415
416* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
417- update to 0.8.53
418- add nginx_accept_language_module
419
420* Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
421- update to 0.8.50
422- update ngx-fancyindex to 0.3
423- add BR: libxml2-devel, libxslt-devel
424- add scgi_params* and uwsgi_params* to %%files
425
426* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
427- update to 0.8.35 (development version)
428- add sites.d/ to store vitualhost settings
429- split out default server settings to sites.d/default
430- add fancyindex module
431
432* Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
433- new upstream release
434
435* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
436- update to 0.7.62 (included security fix: VU#180065)
437
438* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
439- fix typo
440
441* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
442- add translated descriptions
443
444* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
445- update 404.html/50x.html to use powered by vine logo.
446
447* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
448- initial build for Vine Linux
449- update to 0.7.61
450
451* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
452- init script updates from Gena Makhomed
453- remove nginx-upstream-fair
454
455* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
456-  update to 0.6.36
457
458* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
459- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
460
461* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
462- rebuild
463
464* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
465- update to 0.6.35
466
467* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
468- rebuild with new openssl
469
470* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
471- update to 0.6.34
472
473* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
474- Fix inclusion of /usr/share/nginx tree => no unowned directories.
475
476* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
477- update to 0.6.33
478
479* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
480- update to 0.6.32
481- nginx now supports DESTDIR so removed the patches that enabled it
482
483* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
484- init script fixes
485- resolve 'listen 80 default' [#447873]
486
487* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
488- update to 0.6.31
489
490* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
491- upate to new upstream stable branch 0.6
492- added 3rd party module nginx-upstream-fair
493- added default webpages
494
495* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
496- update init script to match recommended guidelines
497- add /etc/nginx/conf.d support [#443280]
498- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
499
500* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
501- add Requires for versioned perl (libperl.so)
502- drop silly file Requires
503
504* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
505- Autorebuild for GCC 4.3
506
507* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
508- update to 0.5.35
509
510* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
511- update to 0.5.34
512
513* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
514 - Rebuild for deps
515
516* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
517- update to 0.5.33
518
519* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
520- updated to 0.5.32
521- fixed rpmlint UTF-8 complaints.
522
523* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
524- added --with-http_stub_status_module build option.
525- added --with-http_sub_module build option.
526- added use of pcre-config --cflags
527
528* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
529- Update to 0.5.31
530- specify license is BSD
531
532* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
533- Add BuildRequires: perl-devel - fixing rawhide build
534
535* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
536- Update to 0.5.30
537
538* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
539- Update to 0.5.29
540
541* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
542- Update to 0.5.28
543
544* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
545- Update to 0.5.27
546
547* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
548- Update to 0.5.26
549
550* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
551- Update to 0.5.19
552
553* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
554- Update to 0.5.17
555
556* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
557- Update to 0.5.16
558- add ownership of /usr/share/nginx/html (#233950)
559
560* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
561- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
562
563* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
564- fixed package review bugs (#233522) given by kevin@tummy.com
565
566* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
567- create patches to assist with building for Fedora
568- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.