source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 3847

Revision 3847, 19.0 KB checked in by daisuke, 13 years ago (diff)

nginx:

  • add passenger sub package
  • use alternatives to select nginx with or without passenger
  • add BR: ruby, rubygems, rubygem-rake to nginx-passenger
Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4%define nginx_user      nginx
5%define nginx_group     %{nginx_user}
6%define nginx_home      %{_localstatedir}/lib/nginx
7%define nginx_home_tmp  %{nginx_home}/tmp
8%define nginx_home_cache %{nginx_home}/cache
9%define nginx_logdir    %{_localstatedir}/log/nginx
10%define nginx_confdir   %{_sysconfdir}/nginx
11%define nginx_datadir   %{_datadir}/nginx
12%define nginx_webroot   %{nginx_datadir}/html
13
14Summary:        Robust, small and high performance http and reverse proxy server
15Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
16Name:           nginx
17Version:        1.0.2
18Release:        2%{?_dist_release}
19
20Group:          System Environment/Daemons   
21# BSD License (two clause)
22# http://www.freebsd.org/copyright/freebsd-license.html
23License:        BSD
24URL:            http://nginx.net/
25
26Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
27Source1:    %{name}.init
28Source2:    %{name}.logrotate
29Source3:    nginx-virtual.conf.template
30Source4:    nginx-ssl.conf
31Source5:    %{name}.sysconfig
32Source10:   nginx-vine.conf
33Source11:   nginx-default-vine
34Source20:   proxy_cache.conf
35Source100:  nginx-index.html
36Source101:  poweredby-vine.png
37Source102:  nginx-logo.png
38Source103:  nginx-50x.html
39Source104:  nginx-404.html
40%define ngx_fancyindex_version 0.3
41Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
42%define nginx_accept_language_module_version 02262ce
43Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
44%define mod_wsgi_version 6975f0ec7eeb
45Source1020: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
46%define passenger_version 3.0.5
47Source1030: passenger-%{passenger_version}.tar.gz
48
49# removes -Werror in upstream build scripts.  -Werror conflicts with
50# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
51Patch0:     nginx-auto-cc-gcc.patch
52# configuration patch to match all the Vine Linux paths for logs, pid files
53# etc.
54Patch1:     nginx-conf.patch
55
56BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
57
58BuildRequires:      pcre-devel
59BuildRequires:      zlib-devel
60BuildRequires:      openssl-devel
61BuildRequires:      gd-devel
62BuildRequires:      perl
63BuildRequires:      perl(ExtUtils::Embed)
64BuildRequires:      libxml2-devel
65BuildRequires:      libxslt-devel
66
67
68%if "%{?_dist_release}" == "vl4"
69Requires:           perl >= 5.8.6
70%else
71Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
72%endif
73# for /usr/sbin/useradd
74Requires(pre):      shadow-utils
75Requires(post):     chkconfig
76# for /sbin/service
77Requires(preun):    chkconfig, initscripts
78Requires(postun):   initscripts
79
80Provides: webserver
81
82Vendor: Project Vine
83Distribution: Vine Linux
84Packager: daisuke
85
86%description
87Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
88proxy server written by Igor Sysoev.
89
90%description -l ja
91Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
92堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
93 - HTTP(S) サーバ
94 - HTTP(S) リバースプロキシサーバ
95 - IMAP/POP3 プロキシサーバ
96
97%package passenger
98Summary: Nginx with mod_passenger support
99Summary(ja): Passenger サポート入りの Nginx
100Group: System Environment/Daemons   
101BuildRequires: ruby, rubygems, rubygem-rake
102Requires: nginx
103
104%description passenger
105Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
106This package contains nginx server with passenger support.
107
108%description -l ja passenger
109Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
110堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
111 - HTTP(S) サーバ
112 - HTTP(S) リバースプロキシサーバ
113 - IMAP/POP3 プロキシサーバ
114このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
115
116%prep
117%setup -q -a 1000 -a 1010 -a 1030 %{?with_wsgi:-a 1020}
118
119%patch0 -p0
120%patch1 -p1
121
122%build
123# nginx does not utilize a standard configure script.  It has its own
124# and the standard configure options cause the nginx configure script
125# to error out.  This is is also the reason for the DESTDIR environment
126# variable.  The configure script(s) have been patched (Patch1 and
127# Patch2) in order to support installing into a build environment.
128
129export DESTDIR=%{buildroot}
130
131## build with passenger
132./configure \
133    --user=%{nginx_user} \
134    --group=%{nginx_group} \
135    --prefix=%{nginx_datadir} \
136    --sbin-path=%{_sbindir}/%{name} \
137    --conf-path=%{nginx_confdir}/%{name}.conf \
138    --error-log-path=%{nginx_logdir}/error.log \
139    --http-log-path=%{nginx_logdir}/access.log \
140    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
141    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
142    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
143    --pid-path=%{_localstatedir}/run/%{name}.pid \
144    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
145    --with-file-aio \
146    --with-ipv6 \
147    --with-http_ssl_module \
148    --with-http_realip_module \
149    --with-http_addition_module \
150    --with-http_xslt_module \
151    --with-http_image_filter_module \
152    --with-http_sub_module \
153    --with-http_dav_module \
154    --with-http_flv_module \
155    --with-http_gzip_static_module \
156    --with-http_random_index_module \
157    --with-http_secure_link_module \
158    --with-http_stub_status_module \
159    --with-http_perl_module \
160    --with-mail \
161    --with-mail_ssl_module \
162    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
163    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
164%if %{with wsgi}
165    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
166%endif
167    --add-module=passenger-%{passenger_version}/ext/nginx \
168%ifarch i686
169    --with-cpu-opt=pentiumpro \
170    --with-zlib-asm=pentiumpro \
171    --with-md5-asm \
172    --with-sha1-asm \
173%endif
174    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
175make %{?_smp_mflags}
176mv objs/nginx objs/nginx.passenger
177
178## build without passenger
179./configure \
180    --user=%{nginx_user} \
181    --group=%{nginx_group} \
182    --prefix=%{nginx_datadir} \
183    --sbin-path=%{_sbindir}/%{name} \
184    --conf-path=%{nginx_confdir}/%{name}.conf \
185    --error-log-path=%{nginx_logdir}/error.log \
186    --http-log-path=%{nginx_logdir}/access.log \
187    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
188    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
189    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
190    --pid-path=%{_localstatedir}/run/%{name}.pid \
191    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
192    --with-file-aio \
193    --with-ipv6 \
194    --with-http_ssl_module \
195    --with-http_realip_module \
196    --with-http_addition_module \
197    --with-http_xslt_module \
198    --with-http_image_filter_module \
199    --with-http_sub_module \
200    --with-http_dav_module \
201    --with-http_flv_module \
202    --with-http_gzip_static_module \
203    --with-http_random_index_module \
204    --with-http_secure_link_module \
205    --with-http_stub_status_module \
206    --with-http_perl_module \
207    --with-mail \
208    --with-mail_ssl_module \
209    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
210    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
211%if %{with wsgi}
212    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
213%endif
214%ifarch i686
215    --with-cpu-opt=pentiumpro \
216    --with-zlib-asm=pentiumpro \
217    --with-md5-asm \
218    --with-sha1-asm \
219%endif
220    --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
221make %{?_smp_mflags}
222
223%install
224rm -rf %{buildroot}
225make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
226find %{buildroot} -type f -name .packlist -exec rm -f {} \;
227find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
228find %{buildroot} -type f -empty -exec rm -f {} \;
229find %{buildroot} -type f -exec chmod 0644 {} \;
230find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
231mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
232%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
233chmod 0755 %{buildroot}%{_sbindir}/nginx.*
234%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
235%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
236%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
237%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
238%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
239%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
240%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
241%{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf
242%{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf.default
243%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
244%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
245%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
246%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
247%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
248%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
249%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
250%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
251%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
252%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
253%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
254
255%if %{with wsgi}
256%{__install} -p -m 0644 \
257    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
258    %{buildroot}%{nginx_confdir}
259cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
260%endif
261
262touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
263
264# convert to UTF-8 all files that give warnings.
265for textfile in CHANGES
266do
267    mv $textfile $textfile.old
268    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
269    rm -f $textfile.old
270done
271
272%clean
273rm -rf %{buildroot}
274
275%pre
276if [ $1 == 1 ]; then
277    %{_sbindir}/useradd -c "Nginx user" -s /bin/false -r -d %{nginx_home} %{nginx_user} 2>/dev/null || :
278fi
279
280%post
281if [ $1 == 1 ]; then
282    /sbin/chkconfig --add %{name}
283fi
284update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
285
286%post passenger
287update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
288
289%preun
290if [ $1 = 0 ]; then
291    /sbin/service %{name} stop >/dev/null 2>&1
292    /sbin/chkconfig --del %{name}
293    update-alternatives --remove nginx %{_sbindir}/nginx.normal
294fi
295
296%preun passenger
297if [ $1 = 0 ]; then
298    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
299fi
300
301
302%postun
303if [ $1 == 2 ]; then
304    /sbin/service %{name} upgrade || :
305fi
306
307%files
308%defattr(-,root,root,-)
309%doc LICENSE CHANGES README %{?with_wsgi:README.mod_wsgi}
310%{nginx_datadir}/
311%{_sbindir}/%{name}.normal
312%{_mandir}/man3/%{name}.3pm.gz
313%{_initrddir}/%{name}
314%dir %{nginx_confdir}
315%dir %{nginx_confdir}/conf.d
316%config(noreplace) %{nginx_confdir}/conf.d/*.conf
317%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
318%config(noreplace) %{nginx_confdir}/sites.d/*
319%config(noreplace) %{nginx_confdir}/win-utf
320%config(noreplace) %{nginx_confdir}/%{name}.conf.default
321%config(noreplace) %{nginx_confdir}/mime.types.default
322%config(noreplace) %{nginx_confdir}/fastcgi_params
323%config(noreplace) %{nginx_confdir}/fastcgi_params.default
324%config(noreplace) %{nginx_confdir}/koi-win
325%config(noreplace) %{nginx_confdir}/koi-utf
326%config(noreplace) %{nginx_confdir}/%{name}.conf
327%config(noreplace) %{nginx_confdir}/mime.types
328%config(noreplace) %{nginx_confdir}/fastcgi.conf
329%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
330%config(noreplace) %{nginx_confdir}/scgi_params
331%config(noreplace) %{nginx_confdir}/scgi_params.default
332%config(noreplace) %{nginx_confdir}/uwsgi_params
333%config(noreplace) %{nginx_confdir}/uwsgi_params.default
334%if %{with wsgi}
335%config(noreplace) %{nginx_confdir}/wsgi_vars
336%endif
337%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
338%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
339%dir %{perl_vendorarch}/auto/%{name}
340%{perl_vendorarch}/%{name}.pm
341%{perl_vendorarch}/auto/%{name}/%{name}.so
342%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
343%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
344%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
345%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
346
347%files passenger
348%defattr(-,root,root,-)
349%doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
350%doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
351%doc passenger-%{passenger_version}/doc/Architectural\ overview.*
352%doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
353%doc passenger-%{passenger_version}/doc/template
354%doc passenger-%{passenger_version}/doc/users_guide_snippets
355%doc passenger-%{passenger_version}/doc/images
356%{_sbindir}/%{name}.passenger
357
358
359%changelog
360* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
361- add nginx-passenger sub pakckage
362  - use alternatives to choose nginx with or without passenger
363  - add BR: ruby, rubygems, rubygem-rake
364
365* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
366- update to 1.0.2
367
368* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
369- update to 1.0.1
370
371* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
372- add bcond_with wsgi for mod_wsgi
373- add bcond_with passenger
374  - you need to install rake.gem to build with this option.
375- add Provides: webserver
376
377* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
378- new upstream release 1.0.0!
379
380* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
381- rebuild with perl-5.12.3
382
383* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
384- update to 0.8.54
385
386* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
387- update to 0.8.53
388- add nginx_accept_language_module
389
390* Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
391- update to 0.8.50
392- update ngx-fancyindex to 0.3
393- add BR: libxml2-devel, libxslt-devel
394- add scgi_params* and uwsgi_params* to %%files
395
396* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
397- update to 0.8.35 (development version)
398- add sites.d/ to store vitualhost settings
399- split out default server settings to sites.d/default
400- add fancyindex module
401
402* Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
403- new upstream release
404
405* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
406- update to 0.7.62 (included security fix: VU#180065)
407
408* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
409- fix typo
410
411* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
412- add translated descriptions
413
414* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
415- update 404.html/50x.html to use powered by vine logo.
416
417* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
418- initial build for Vine Linux
419- update to 0.7.61
420
421* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
422- init script updates from Gena Makhomed
423- remove nginx-upstream-fair
424
425* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
426-  update to 0.6.36
427
428* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
429- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
430
431* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
432- rebuild
433
434* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
435- update to 0.6.35
436
437* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
438- rebuild with new openssl
439
440* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
441- update to 0.6.34
442
443* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
444- Fix inclusion of /usr/share/nginx tree => no unowned directories.
445
446* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
447- update to 0.6.33
448
449* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
450- update to 0.6.32
451- nginx now supports DESTDIR so removed the patches that enabled it
452
453* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
454- init script fixes
455- resolve 'listen 80 default' [#447873]
456
457* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
458- update to 0.6.31
459
460* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
461- upate to new upstream stable branch 0.6
462- added 3rd party module nginx-upstream-fair
463- added default webpages
464
465* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
466- update init script to match recommended guidelines
467- add /etc/nginx/conf.d support [#443280]
468- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
469
470* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
471- add Requires for versioned perl (libperl.so)
472- drop silly file Requires
473
474* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
475- Autorebuild for GCC 4.3
476
477* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
478- update to 0.5.35
479
480* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
481- update to 0.5.34
482
483* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
484 - Rebuild for deps
485
486* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
487- update to 0.5.33
488
489* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
490- updated to 0.5.32
491- fixed rpmlint UTF-8 complaints.
492
493* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
494- added --with-http_stub_status_module build option.
495- added --with-http_sub_module build option.
496- added use of pcre-config --cflags
497
498* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
499- Update to 0.5.31
500- specify license is BSD
501
502* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
503- Add BuildRequires: perl-devel - fixing rawhide build
504
505* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
506- Update to 0.5.30
507
508* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
509- Update to 0.5.29
510
511* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
512- Update to 0.5.28
513
514* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
515- Update to 0.5.27
516
517* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
518- Update to 0.5.26
519
520* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
521- Update to 0.5.19
522
523* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
524- Update to 0.5.17
525
526* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
527- Update to 0.5.16
528- add ownership of /usr/share/nginx/html (#233950)
529
530* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
531- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
532
533* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
534- fixed package review bugs (#233522) given by kevin@tummy.com
535
536* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
537- create patches to assist with building for Fedora
538- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.