source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 11577

Revision 11577, 25.7 KB checked in by tomop, 6 years ago (diff)

nginx-1.13.9-1

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.13.9
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51
52%define ngx_fancyindex_version 0.4.2
53Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
54
55%define nginx_accept_language_module_version 2f69842
56Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
57
58## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
59%define passenger_version 5.2.1
60Source1020: passenger-%{passenger_version}.tar.gz
61
62%define upstream_fair_version a18b409
63Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
64
65%define mod_wsgi_version 6975f0ec7eeb
66Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
67
68%define nginx_dav_ext_module_version 0.1.0
69Source2010: https://github.com/arut/nginx-dav-ext-module/archive/v%{nginx_dav_ext_module_version}.tar.gz#/nginx-dav-ext-module-%{nginx_dav_ext_module_version}.tar.gz
70
71# removes -Werror in upstream build scripts.  -Werror conflicts with
72# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
73Patch0:     nginx-auto-cc-gcc.patch
74
75# to fix https://svn.boost.org/trac/boost/ticket/8731
76Patch100:   boost-changeset_84950.diff
77
78# to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
79Patch101:   gnosek-nginx-upstream-fair-pull-23.patch
80
81# to fix compile error with C++11.
82Patch1000: passenger-5.0.28-boost.patch
83
84
85BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
86
87%if "%{_dist_release}" > "vl6"
88BuildRequires:      libboost-devel
89%endif
90BuildRequires:      pcre-devel
91BuildRequires:      zlib-devel
92BuildRequires:      openssl-devel
93BuildRequires:      gd-devel
94BuildRequires:      perl
95BuildRequires:      perl(ExtUtils::Embed)
96BuildRequires:      libxml2-devel
97BuildRequires:      libxslt-devel
98BuildRequires:      curl-devel
99%if %{with geoip}
100BuildRequires:      GeoIP-devel
101%endif
102
103Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
104# for /usr/sbin/useradd
105Requires(pre):      shadow-utils
106Requires(post):     chkconfig
107# for /sbin/service
108Requires(preun):    chkconfig, initscripts
109Requires(postun):   initscripts
110%if "%{_dist_release}" > "vl6"
111Requires(pre):      www-common
112%endif
113
114Provides: webserver
115
116Vendor: Project Vine
117Distribution: Vine Linux
118Packager: daisuke
119
120%description
121Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
122proxy server written by Igor Sysoev.
123
124%description -l ja
125Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
126堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
127 - HTTP(S) サーバ
128 - HTTP(S) リバースプロキシサーバ
129 - IMAP/POP3 プロキシサーバ
130
131%package passenger
132Summary: Nginx with mod_passenger support
133Summary(ja): Passenger サポート入りの Nginx
134Group: System Environment/Daemons
135BuildRequires: ruby, rubygem-rake
136Requires: ruby, rubygem-rake
137%if "%{_dist_release}" >= "vl7"
138BuildRequires: ruby-devel, ruby-rubygems
139Requires: ruby-rubygems
140%else
141BuildRequires: rubygems
142Requires: rubygems
143%endif
144Requires: nginx
145
146%description passenger
147Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
148This package contains nginx server with passenger support.
149
150%description -l ja passenger
151Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
152堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
153 - HTTP(S) サーバ
154 - HTTP(S) リバースプロキシサーバ
155 - IMAP/POP3 プロキシサーバ
156このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
157
158%prep
159%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000} -a 2010
160
161%patch0 -p0
162
163# pushd passenger-%{passenger_version}/ext/
164# %patch100 -p2
165# popd
166
167pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
168%patch101 -p1
169popd
170
171%if %{?_dist_release} == "vl7"
172pushd passenger-%{passenger_version}
173#% patch1000 -p1
174popd
175%endif
176
177%build
178# nginx does not utilize a standard configure script.  It has its own
179# and the standard configure options cause the nginx configure script
180# to error out.  This is is also the reason for the DESTDIR environment
181# variable.  The configure script(s) have been patched (Patch1 and
182# Patch2) in order to support installing into a build environment.
183
184export DESTDIR=%{buildroot}
185
186
187CONFIGOPTS="\
188    --user=%{nginx_user} \
189    --group=%{nginx_group} \
190    --prefix=%{nginx_datadir} \
191    --sbin-path=%{_sbindir}/%{name} \
192    --conf-path=%{nginx_confdir}/%{name}.conf \
193    --error-log-path=%{nginx_logdir}/error.log \
194    --http-log-path=%{nginx_logdir}/access.log \
195    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
196    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
197    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
198    --pid-path=%{_localstatedir}/run/%{name}.pid \
199    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
200    --with-file-aio \
201    --with-ipv6 \
202    --with-http_ssl_module \
203    --with-http_v2_module \
204    --with-http_realip_module \
205    --with-http_addition_module \
206    --with-http_xslt_module \
207    --with-http_image_filter_module \
208%if %{with geoip}
209    --with-http_geoip_module \
210%endif
211    --with-http_sub_module \
212    --with-http_dav_module \
213    --with-http_flv_module \
214    --with-http_mp4_module \
215    --with-http_gunzip_module \
216    --with-http_gzip_static_module \
217    --with-http_auth_request_module \
218    --with-http_random_index_module \
219    --with-http_secure_link_module \
220    --with-http_degradation_module \
221    --with-http_stub_status_module \
222    --with-http_perl_module \
223    --with-mail \
224    --with-mail_ssl_module \
225    --with-stream \
226    --with-stream_ssl_preread_module \
227    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
228    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
229    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
230%if %{with wsgi}
231    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
232%endif
233    --add-module=nginx-dav-ext-module-%{nginx_dav_ext_module_version} \
234%ifarch i686
235    --with-cpu-opt=pentiumpro \
236    --with-zlib-asm=pentiumpro \
237    --with-md5-asm \
238    --with-sha1-asm \
239%endif
240"
241
242
243## build with passenger
244./configure \
245    $CONFIGOPTS \
246    --with-cc-opt="%{optflags}" \
247    --add-module=passenger-%{passenger_version}/src/nginx_module
248
249make %{?_smp_mflags}
250mv objs/nginx objs/nginx.passenger
251
252## build without passenger
253./configure \
254    $CONFIGOPTS \
255    --with-cc-opt="%{optflags}"
256
257make %{?_smp_mflags}
258
259%install
260rm -rf %{buildroot}
261make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
262find %{buildroot} -type f -name .packlist -exec rm -f {} \;
263find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
264find %{buildroot} -type f -empty -exec rm -f {} \;
265find %{buildroot} -type f -exec chmod 0644 {} \;
266find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
267mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
268%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
269chmod 0755 %{buildroot}%{_sbindir}/nginx.*
270%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
271%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
272%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
273%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
274%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
275%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
276%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
277%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
278%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
279%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
280%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
281%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
282%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
283%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
284%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
285%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
286%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
287%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
288%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
289%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
290
291%if %{with wsgi}
292%{__install} -p -m 0644 \
293    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
294    %{buildroot}%{nginx_confdir}
295cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
296%endif
297
298# upstream fair module document
299cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
300
301# document for nginx-dav-ext-module
302cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/LICENSE LICENSE.dav-ext-module
303cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/README.rst README.dav-ext-module.rst
304
305touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
306
307# convert to UTF-8 all files that give warnings.
308for textfile in CHANGES
309do
310    mv $textfile $textfile.old
311    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
312    rm -f $textfile.old
313done
314
315%clean
316rm -rf %{buildroot}
317
318%post
319if [ $1 == 1 ]; then
320    /sbin/chkconfig --add %{name}
321fi
322update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
323
324%post passenger
325update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
326
327%preun
328if [ $1 = 0 ]; then
329    /sbin/service %{name} stop >/dev/null 2>&1
330    /sbin/chkconfig --del %{name}
331    update-alternatives --remove nginx %{_sbindir}/nginx.normal
332fi
333
334%preun passenger
335if [ $1 = 0 ]; then
336    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
337fi
338
339
340%postun
341if [ $1 == 2 ]; then
342    /sbin/service %{name} upgrade || :
343fi
344
345%files
346%defattr(-,root,root,-)
347%doc LICENSE CHANGES README LICENSE.dav-ext-module
348%doc README.upstream_fair
349%doc README.dav-ext-module.rst
350%doc %{?with_wsgi:README.mod_wsgi}
351%{nginx_datadir}/
352%{_sbindir}/%{name}.normal
353%{_mandir}/man3/%{name}.3pm.gz
354%{_initrddir}/%{name}
355%dir %{nginx_confdir}
356%dir %{nginx_confdir}/conf.d
357%config(noreplace) %{nginx_confdir}/conf.d/*.conf
358%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
359%config(noreplace) %{nginx_confdir}/sites.d/*
360%config(noreplace) %{nginx_confdir}/win-utf
361%config(noreplace) %{nginx_confdir}/%{name}.conf.default
362%config(noreplace) %{nginx_confdir}/mime.types.default
363%config(noreplace) %{nginx_confdir}/fastcgi_params
364%config(noreplace) %{nginx_confdir}/fastcgi_params.default
365%config(noreplace) %{nginx_confdir}/koi-win
366%config(noreplace) %{nginx_confdir}/koi-utf
367%config(noreplace) %{nginx_confdir}/%{name}.conf
368%config(noreplace) %{nginx_confdir}/mime.types
369%config(noreplace) %{nginx_confdir}/fastcgi.conf
370%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
371%config(noreplace) %{nginx_confdir}/scgi_params
372%config(noreplace) %{nginx_confdir}/scgi_params.default
373%config(noreplace) %{nginx_confdir}/uwsgi_params
374%config(noreplace) %{nginx_confdir}/uwsgi_params.default
375%if %{with wsgi}
376%config(noreplace) %{nginx_confdir}/wsgi_vars
377%endif
378%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
379%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
380%dir %{perl_vendorarch}/auto/%{name}
381%{perl_vendorarch}/%{name}.pm
382%{perl_vendorarch}/auto/%{name}/%{name}.so
383%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
384%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
385%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
386%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
387
388%files passenger
389%defattr(-,root,root,-)
390%doc passenger-%{passenger_version}/doc/*.md
391%doc passenger-%{passenger_version}/doc/*.txt
392%doc passenger-%{passenger_version}/doc/*.html
393%doc passenger-%{passenger_version}/doc/templates
394%doc passenger-%{passenger_version}/doc/users_guide_snippets
395%doc passenger-%{passenger_version}/doc/images
396%{_sbindir}/%{name}.passenger
397
398
399%changelog
400* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.9-1
401- updated to 1.13.9.
402- updated ngx-fancyindex to 0.4.2.
403- updated nginx-accept_language_module to git HEAD.
404- updated nginx-upstream-fair to git HEAD.
405- updated passenger to 5.2.1.
406- added Source2010 (nginx-dav-ext-module).
407- enabled --with-stream and --with-stream_ssl_preread_module.
408
409* Fri Sep  8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.5-1
410- updated to 1.13.5
411- updated passenger to 5.1.8
412
413* Fri Aug 11 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.4-1
414- updated to 1.13.4
415- updated passenger to 5.1.7
416
417* Fri Jul 14 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.3-1
418- updated to 1.13.3
419
420* Sat Jul  1 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.2-1
421- updated to 1.13.2
422
423* Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.1-1
424- updated to 1.13.1
425- updated passenger to 5.1.5
426
427* Wed Apr 26 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.0-1
428- updated to 1.13.0
429
430* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
431- updated to 1.11.13
432
433* Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
434- updated to 1.11.12
435
436* Tue Mar  7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
437- updated to 1.11.10
438- updated passenger to 5.1.2
439
440* Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
441- updated to 1.11.9
442
443* Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
444- updated to 1.11.8
445
446* Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
447- updated to 1.11.6
448- applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
449
450* Mon Sep  5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
451- updated to 1.11.3
452- updated passenger to 5.0.30
453
454* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
455- rebuild with gcc-5.4.0
456
457* Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
458- updated to 1.10.1.
459- updated passenger to 5.0.28.
460
461* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
462- updated to 1.9.15
463
464* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
465- updated to 1.9.14
466- updated passenger to 5.0.27
467
468* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
469- new upstream release
470
471* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
472- updated to 1.9.12.
473- updated passenger to 5.0.26.
474
475* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
476- new upstream release
477
478* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
479- update to 1.9.10
480- update passenger to 5.0.24
481
482* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
483- update passenger to 5.0.23
484
485* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
486- new upstream release
487
488* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
489- new upstream release
490
491* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
492- new upstream release
493
494* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
495- new upstream release
496
497* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
498- update to 1.9.3
499- update passenger to 5.0.11
500
501* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
502- updated Source4 (ssl.conf).
503
504* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
505- update to 1.9.2
506- update passenger to 5.0.10
507- update ngx-fancyindex to 0.3.5
508
509* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
510- update to 1.6.2
511- update passenger to 4.0.52
512
513* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
514- new upstream release
515
516* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
517- rebuild with new environment
518
519* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
520- update passenger to 4.0.45
521
522* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
523- update to 1.6.0 (stable)
524
525* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
526- update fancyindex to 0.3.3
527
528* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
529- update to 1.5.10
530- update passenger to 4.0.37
531
532* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
533- rebuilt with GeoIP-1.6.0.
534- added Patch100.
535
536* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
537- update to 1.5.6
538- update passenger to 4.0.21
539
540* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
541- rebuilt with gd-2.1.0.
542
543* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
544- update to 1.4.1
545
546* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
547- update to 1.4.0
548- enable SPDY module
549
550* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
551- new upstream release
552- update passenger to 3.0.19
553- update ngx-fancyindex to upstream git master
554
555* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
556- new upstream release
557- update passenger to 3.0.17
558
559* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
560- rebuild with pcre-8.31
561
562* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
563- added http_geoip_module.
564
565* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
566- update to 1.2.4
567
568* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
569- update to 1.2.2
570
571* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
572- update to 1.2.1
573- change nginx user from nginx to www-data
574- R(pre): www-common
575
576* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
577- update to 1.2.0
578- update passenger to 3.0.12
579- drop http_upstream_keepalive
580
581* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
582- new upstream release
583
584* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
585- update to 1.0.12
586
587* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
588- update to 1.0.11
589- update passenger to 3.0.11
590
591* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
592- update to 1.0.10
593
594* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
595- update passenger to 3.0.9
596
597* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
598- update to 1.0.6
599
600* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
601- update to 1.0.4
602
603* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
604- add gnosek-nginx-upstream-fair module
605- add ngx_http_upstream_keepalive module
606
607* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
608- add nginx-passenger sub pakckage
609  - use alternatives to choose nginx with or without passenger
610  - add BR: ruby, rubygems, rubygem-rake
611
612* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
613- update to 1.0.2
614
615* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
616- update to 1.0.1
617
618* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
619- add bcond_with wsgi for mod_wsgi
620- add bcond_with passenger
621  - you need to install rake.gem to build with this option.
622- add Provides: webserver
623
624* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
625- new upstream release 1.0.0!
626
627* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
628- rebuild with perl-5.12.3
629
630* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
631- update to 0.8.54
632
633* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
634- update to 0.8.53
635- add nginx_accept_language_module
636
637* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
638- update to 0.8.50
639- update ngx-fancyindex to 0.3
640- add BR: libxml2-devel, libxslt-devel
641- add scgi_params* and uwsgi_params* to %%files
642
643* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
644- update to 0.8.35 (development version)
645- add sites.d/ to store vitualhost settings
646- split out default server settings to sites.d/default
647- add fancyindex module
648
649* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
650- new upstream release
651
652* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
653- update to 0.7.62 (included security fix: VU#180065)
654
655* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
656- fix typo
657
658* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
659- add translated descriptions
660
661* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
662- update 404.html/50x.html to use powered by vine logo.
663
664* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
665- initial build for Vine Linux
666- update to 0.7.61
667
668* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
669- init script updates from Gena Makhomed
670- remove nginx-upstream-fair
671
672* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
673-  update to 0.6.36
674
675* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
676- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
677
678* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
679- rebuild
680
681* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
682- update to 0.6.35
683
684* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
685- rebuild with new openssl
686
687* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
688- update to 0.6.34
689
690* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
691- Fix inclusion of /usr/share/nginx tree => no unowned directories.
692
693* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
694- update to 0.6.33
695
696* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
697- update to 0.6.32
698- nginx now supports DESTDIR so removed the patches that enabled it
699
700* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
701- init script fixes
702- resolve 'listen 80 default' [#447873]
703
704* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
705- update to 0.6.31
706
707* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
708- upate to new upstream stable branch 0.6
709- added 3rd party module nginx-upstream-fair
710- added default webpages
711
712* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
713- update init script to match recommended guidelines
714- add /etc/nginx/conf.d support [#443280]
715- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
716
717* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
718- add Requires for versioned perl (libperl.so)
719- drop silly file Requires
720
721* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
722- Autorebuild for GCC 4.3
723
724* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
725- update to 0.5.35
726
727* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
728- update to 0.5.34
729
730* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
731 - Rebuild for deps
732
733* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
734- update to 0.5.33
735
736* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
737- updated to 0.5.32
738- fixed rpmlint UTF-8 complaints.
739
740* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
741- added --with-http_stub_status_module build option.
742- added --with-http_sub_module build option.
743- added use of pcre-config --cflags
744
745* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
746- Update to 0.5.31
747- specify license is BSD
748
749* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
750- Add BuildRequires: perl-devel - fixing rawhide build
751
752* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
753- Update to 0.5.30
754
755* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
756- Update to 0.5.29
757
758* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
759- Update to 0.5.28
760
761* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
762- Update to 0.5.27
763
764* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
765- Update to 0.5.26
766
767* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
768- Update to 0.5.19
769
770* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
771- Update to 0.5.17
772
773* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
774- Update to 0.5.16
775- add ownership of /usr/share/nginx/html (#233950)
776
777* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
778- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
779
780* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
781- fixed package review bugs (#233522) given by kevin@tummy.com
782
783* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
784- create patches to assist with building for Fedora
785- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.