source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 10824

Revision 10824, 23.6 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.11.6
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 0.3.5
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55
56## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
57%define passenger_version 5.0.30
58Source1020: passenger-%{passenger_version}.tar.gz
59%define upstream_fair_version 2131c73
60Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
61
62%define mod_wsgi_version 6975f0ec7eeb
63Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
64
65# removes -Werror in upstream build scripts.  -Werror conflicts with
66# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
67Patch0:     nginx-auto-cc-gcc.patch
68
69# to fix https://svn.boost.org/trac/boost/ticket/8731
70Patch100:   boost-changeset_84950.diff
71
72# to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
73Patch101:   gnosek-nginx-upstream-fair-pull-23.patch
74
75# to fix compile error with C++11.
76Patch1000: passenger-5.0.28-boost.patch
77
78
79BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
80
81BuildRequires:      pcre-devel
82BuildRequires:      zlib-devel
83BuildRequires:      openssl-devel
84BuildRequires:      gd-devel
85BuildRequires:      perl
86BuildRequires:      perl(ExtUtils::Embed)
87BuildRequires:      libxml2-devel
88BuildRequires:      libxslt-devel
89BuildRequires:      curl-devel
90%if %{with geoip}
91BuildRequires:      GeoIP-devel
92%endif
93
94Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
95# for /usr/sbin/useradd
96Requires(pre):      shadow-utils
97Requires(post):     chkconfig
98# for /sbin/service
99Requires(preun):    chkconfig, initscripts
100Requires(postun):   initscripts
101%if "%{_dist_release}" > "vl6"
102Requires(pre):      www-common
103%endif
104
105Provides: webserver
106
107Vendor: Project Vine
108Distribution: Vine Linux
109Packager: daisuke
110
111%description
112Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
113proxy server written by Igor Sysoev.
114
115%description -l ja
116Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
117堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
118 - HTTP(S) サーバ
119 - HTTP(S) リバースプロキシサーバ
120 - IMAP/POP3 プロキシサーバ
121
122%package passenger
123Summary: Nginx with mod_passenger support
124Summary(ja): Passenger サポート入りの Nginx
125Group: System Environment/Daemons
126BuildRequires: ruby, rubygem-rake
127Requires: ruby, rubygem-rake
128%if "%{_dist_release}" >= "vl7"
129BuildRequires: ruby-devel, ruby-rubygems
130Requires: ruby-rubygems
131%else
132BuildRequires: rubygems
133Requires: rubygems
134%endif
135Requires: nginx
136
137%description passenger
138Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
139This package contains nginx server with passenger support.
140
141%description -l ja passenger
142Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
143堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
144 - HTTP(S) サーバ
145 - HTTP(S) リバースプロキシサーバ
146 - IMAP/POP3 プロキシサーバ
147このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
148
149%prep
150%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
151
152%patch0 -p0
153
154# pushd passenger-%{passenger_version}/ext/
155# %patch100 -p2
156# popd
157
158pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
159%patch101 -p1
160popd
161
162%if %{?_dist_release} == "vl7"
163pushd passenger-%{passenger_version}
164%patch1000 -p1
165popd
166%endif
167
168%build
169# nginx does not utilize a standard configure script.  It has its own
170# and the standard configure options cause the nginx configure script
171# to error out.  This is is also the reason for the DESTDIR environment
172# variable.  The configure script(s) have been patched (Patch1 and
173# Patch2) in order to support installing into a build environment.
174
175export DESTDIR=%{buildroot}
176
177
178CONFIGOPTS="\
179    --user=%{nginx_user} \
180    --group=%{nginx_group} \
181    --prefix=%{nginx_datadir} \
182    --sbin-path=%{_sbindir}/%{name} \
183    --conf-path=%{nginx_confdir}/%{name}.conf \
184    --error-log-path=%{nginx_logdir}/error.log \
185    --http-log-path=%{nginx_logdir}/access.log \
186    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
187    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
188    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
189    --pid-path=%{_localstatedir}/run/%{name}.pid \
190    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
191    --with-file-aio \
192    --with-ipv6 \
193    --with-http_ssl_module \
194    --with-http_v2_module \
195    --with-http_realip_module \
196    --with-http_addition_module \
197    --with-http_xslt_module \
198    --with-http_image_filter_module \
199%if %{with geoip}
200    --with-http_geoip_module \
201%endif
202    --with-http_sub_module \
203    --with-http_dav_module \
204    --with-http_flv_module \
205    --with-http_mp4_module \
206    --with-http_gunzip_module \
207    --with-http_gzip_static_module \
208    --with-http_auth_request_module \
209    --with-http_random_index_module \
210    --with-http_secure_link_module \
211    --with-http_degradation_module \
212    --with-http_stub_status_module \
213    --with-http_perl_module \
214    --with-mail \
215    --with-mail_ssl_module \
216    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
217    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
218    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
219%if %{with wsgi}
220    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
221%endif
222%ifarch i686
223    --with-cpu-opt=pentiumpro \
224    --with-zlib-asm=pentiumpro \
225    --with-md5-asm \
226    --with-sha1-asm \
227%endif
228"
229
230
231## build with passenger
232./configure \
233    $CONFIGOPTS \
234    --with-cc-opt="%{optflags}" \
235    --add-module=passenger-%{passenger_version}/src/nginx_module
236
237make %{?_smp_mflags}
238mv objs/nginx objs/nginx.passenger
239
240## build without passenger
241./configure \
242    $CONFIGOPTS \
243    --with-cc-opt="%{optflags}"
244
245make %{?_smp_mflags}
246
247%install
248rm -rf %{buildroot}
249make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
250find %{buildroot} -type f -name .packlist -exec rm -f {} \;
251find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
252find %{buildroot} -type f -empty -exec rm -f {} \;
253find %{buildroot} -type f -exec chmod 0644 {} \;
254find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
255mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
256%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
257chmod 0755 %{buildroot}%{_sbindir}/nginx.*
258%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
259%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
260%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
261%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
262%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
263%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
264%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
265%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
266%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
267%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
268%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
269%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
270%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
271%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
272%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
273%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
274%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
275%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
276%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
277%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
278
279%if %{with wsgi}
280%{__install} -p -m 0644 \
281    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
282    %{buildroot}%{nginx_confdir}
283cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
284%endif
285
286# upstream fair module document
287cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
288
289touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
290
291# convert to UTF-8 all files that give warnings.
292for textfile in CHANGES
293do
294    mv $textfile $textfile.old
295    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
296    rm -f $textfile.old
297done
298
299%clean
300rm -rf %{buildroot}
301
302%post
303if [ $1 == 1 ]; then
304    /sbin/chkconfig --add %{name}
305fi
306update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
307
308%post passenger
309update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
310
311%preun
312if [ $1 = 0 ]; then
313    /sbin/service %{name} stop >/dev/null 2>&1
314    /sbin/chkconfig --del %{name}
315    update-alternatives --remove nginx %{_sbindir}/nginx.normal
316fi
317
318%preun passenger
319if [ $1 = 0 ]; then
320    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
321fi
322
323
324%postun
325if [ $1 == 2 ]; then
326    /sbin/service %{name} upgrade || :
327fi
328
329%files
330%defattr(-,root,root,-)
331%doc LICENSE CHANGES README
332%doc README.upstream_fair
333%doc %{?with_wsgi:README.mod_wsgi}
334%{nginx_datadir}/
335%{_sbindir}/%{name}.normal
336%{_mandir}/man3/%{name}.3pm.gz
337%{_initrddir}/%{name}
338%dir %{nginx_confdir}
339%dir %{nginx_confdir}/conf.d
340%config(noreplace) %{nginx_confdir}/conf.d/*.conf
341%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
342%config(noreplace) %{nginx_confdir}/sites.d/*
343%config(noreplace) %{nginx_confdir}/win-utf
344%config(noreplace) %{nginx_confdir}/%{name}.conf.default
345%config(noreplace) %{nginx_confdir}/mime.types.default
346%config(noreplace) %{nginx_confdir}/fastcgi_params
347%config(noreplace) %{nginx_confdir}/fastcgi_params.default
348%config(noreplace) %{nginx_confdir}/koi-win
349%config(noreplace) %{nginx_confdir}/koi-utf
350%config(noreplace) %{nginx_confdir}/%{name}.conf
351%config(noreplace) %{nginx_confdir}/mime.types
352%config(noreplace) %{nginx_confdir}/fastcgi.conf
353%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
354%config(noreplace) %{nginx_confdir}/scgi_params
355%config(noreplace) %{nginx_confdir}/scgi_params.default
356%config(noreplace) %{nginx_confdir}/uwsgi_params
357%config(noreplace) %{nginx_confdir}/uwsgi_params.default
358%if %{with wsgi}
359%config(noreplace) %{nginx_confdir}/wsgi_vars
360%endif
361%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
362%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
363%dir %{perl_vendorarch}/auto/%{name}
364%{perl_vendorarch}/%{name}.pm
365%{perl_vendorarch}/auto/%{name}/%{name}.so
366%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
367%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
368%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
369%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
370
371%files passenger
372%defattr(-,root,root,-)
373%doc passenger-%{passenger_version}/doc/*.md
374%doc passenger-%{passenger_version}/doc/*.txt
375%doc passenger-%{passenger_version}/doc/*.html
376%doc passenger-%{passenger_version}/doc/templates
377%doc passenger-%{passenger_version}/doc/users_guide_snippets
378%doc passenger-%{passenger_version}/doc/images
379%{_sbindir}/%{name}.passenger
380
381
382%changelog
383* Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
384- updated to 1.11.6
385- applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
386
387* Mon Sep  5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
388- updated to 1.11.3
389- updated passenger to 5.0.30
390
391* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
392- rebuild with gcc-5.4.0
393
394* Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
395- updated to 1.10.1.
396- updated passenger to 5.0.28.
397
398* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
399- updated to 1.9.15
400
401* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
402- updated to 1.9.14
403- updated passenger to 5.0.27
404
405* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
406- new upstream release
407
408* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
409- updated to 1.9.12.
410- updated passenger to 5.0.26.
411
412* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
413- new upstream release
414
415* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
416- update to 1.9.10
417- update passenger to 5.0.24
418
419* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
420- update passenger to 5.0.23
421
422* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
423- new upstream release
424
425* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
426- new upstream release
427
428* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
429- new upstream release
430
431* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
432- new upstream release
433
434* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
435- update to 1.9.3
436- update passenger to 5.0.11
437
438* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
439- updated Source4 (ssl.conf).
440
441* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
442- update to 1.9.2
443- update passenger to 5.0.10
444- update ngx-fancyindex to 0.3.5
445
446* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
447- update to 1.6.2
448- update passenger to 4.0.52
449
450* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
451- new upstream release
452
453* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
454- rebuild with new environment
455
456* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
457- update passenger to 4.0.45
458
459* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
460- update to 1.6.0 (stable)
461
462* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
463- update fancyindex to 0.3.3
464
465* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
466- update to 1.5.10
467- update passenger to 4.0.37
468
469* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
470- rebuilt with GeoIP-1.6.0.
471- added Patch100.
472
473* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
474- update to 1.5.6
475- update passenger to 4.0.21
476
477* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
478- rebuilt with gd-2.1.0.
479
480* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
481- update to 1.4.1
482
483* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
484- update to 1.4.0
485- enable SPDY module
486
487* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
488- new upstream release
489- update passenger to 3.0.19
490- update ngx-fancyindex to upstream git master
491
492* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
493- new upstream release
494- update passenger to 3.0.17
495
496* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
497- rebuild with pcre-8.31
498
499* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
500- added http_geoip_module.
501
502* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
503- update to 1.2.4
504
505* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
506- update to 1.2.2
507
508* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
509- update to 1.2.1
510- change nginx user from nginx to www-data
511- R(pre): www-common
512
513* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
514- update to 1.2.0
515- update passenger to 3.0.12
516- drop http_upstream_keepalive
517
518* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
519- new upstream release
520
521* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
522- update to 1.0.12
523
524* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
525- update to 1.0.11
526- update passenger to 3.0.11
527
528* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
529- update to 1.0.10
530
531* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
532- update passenger to 3.0.9
533
534* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
535- update to 1.0.6
536
537* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
538- update to 1.0.4
539
540* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
541- add gnosek-nginx-upstream-fair module
542- add ngx_http_upstream_keepalive module
543
544* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
545- add nginx-passenger sub pakckage
546  - use alternatives to choose nginx with or without passenger
547  - add BR: ruby, rubygems, rubygem-rake
548
549* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
550- update to 1.0.2
551
552* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
553- update to 1.0.1
554
555* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
556- add bcond_with wsgi for mod_wsgi
557- add bcond_with passenger
558  - you need to install rake.gem to build with this option.
559- add Provides: webserver
560
561* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
562- new upstream release 1.0.0!
563
564* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
565- rebuild with perl-5.12.3
566
567* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
568- update to 0.8.54
569
570* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
571- update to 0.8.53
572- add nginx_accept_language_module
573
574* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
575- update to 0.8.50
576- update ngx-fancyindex to 0.3
577- add BR: libxml2-devel, libxslt-devel
578- add scgi_params* and uwsgi_params* to %%files
579
580* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
581- update to 0.8.35 (development version)
582- add sites.d/ to store vitualhost settings
583- split out default server settings to sites.d/default
584- add fancyindex module
585
586* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
587- new upstream release
588
589* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
590- update to 0.7.62 (included security fix: VU#180065)
591
592* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
593- fix typo
594
595* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
596- add translated descriptions
597
598* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
599- update 404.html/50x.html to use powered by vine logo.
600
601* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
602- initial build for Vine Linux
603- update to 0.7.61
604
605* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
606- init script updates from Gena Makhomed
607- remove nginx-upstream-fair
608
609* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
610-  update to 0.6.36
611
612* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
613- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
614
615* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
616- rebuild
617
618* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
619- update to 0.6.35
620
621* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
622- rebuild with new openssl
623
624* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
625- update to 0.6.34
626
627* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
628- Fix inclusion of /usr/share/nginx tree => no unowned directories.
629
630* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
631- update to 0.6.33
632
633* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
634- update to 0.6.32
635- nginx now supports DESTDIR so removed the patches that enabled it
636
637* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
638- init script fixes
639- resolve 'listen 80 default' [#447873]
640
641* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
642- update to 0.6.31
643
644* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
645- upate to new upstream stable branch 0.6
646- added 3rd party module nginx-upstream-fair
647- added default webpages
648
649* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
650- update init script to match recommended guidelines
651- add /etc/nginx/conf.d support [#443280]
652- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
653
654* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
655- add Requires for versioned perl (libperl.so)
656- drop silly file Requires
657
658* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
659- Autorebuild for GCC 4.3
660
661* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
662- update to 0.5.35
663
664* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
665- update to 0.5.34
666
667* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
668 - Rebuild for deps
669
670* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
671- update to 0.5.33
672
673* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
674- updated to 0.5.32
675- fixed rpmlint UTF-8 complaints.
676
677* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
678- added --with-http_stub_status_module build option.
679- added --with-http_sub_module build option.
680- added use of pcre-config --cflags
681
682* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
683- Update to 0.5.31
684- specify license is BSD
685
686* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
687- Add BuildRequires: perl-devel - fixing rawhide build
688
689* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
690- Update to 0.5.30
691
692* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
693- Update to 0.5.29
694
695* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
696- Update to 0.5.28
697
698* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
699- Update to 0.5.27
700
701* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
702- Update to 0.5.26
703
704* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
705- Update to 0.5.19
706
707* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
708- Update to 0.5.17
709
710* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
711- Update to 0.5.16
712- add ownership of /usr/share/nginx/html (#233950)
713
714* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
715- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
716
717* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
718- fixed package review bugs (#233522) given by kevin@tummy.com
719
720* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
721- create patches to assist with building for Fedora
722- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.