source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 10767

Revision 10767, 23.1 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.10.1
29Release:        2%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 0.3.5
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55
56## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
57%define passenger_version 5.0.28
58Source1020: passenger-%{passenger_version}.tar.gz
59%define upstream_fair_version 2131c73
60Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
61
62%define mod_wsgi_version 6975f0ec7eeb
63Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
64
65# removes -Werror in upstream build scripts.  -Werror conflicts with
66# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
67Patch0:     nginx-auto-cc-gcc.patch
68
69# to fix https://svn.boost.org/trac/boost/ticket/8731
70Patch100:   boost-changeset_84950.diff
71
72# to fix compile error with C++11.
73Patch1000: passenger-5.0.28-boost.patch
74
75
76BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
77
78BuildRequires:      pcre-devel
79BuildRequires:      zlib-devel
80BuildRequires:      openssl-devel
81BuildRequires:      gd-devel
82BuildRequires:      perl
83BuildRequires:      perl(ExtUtils::Embed)
84BuildRequires:      libxml2-devel
85BuildRequires:      libxslt-devel
86BuildRequires:      curl-devel
87%if %{with geoip}
88BuildRequires:      GeoIP-devel
89%endif
90
91Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
92# for /usr/sbin/useradd
93Requires(pre):      shadow-utils
94Requires(post):     chkconfig
95# for /sbin/service
96Requires(preun):    chkconfig, initscripts
97Requires(postun):   initscripts
98%if "%{_dist_release}" > "vl6"
99Requires(pre):      www-common
100%endif
101
102Provides: webserver
103
104Vendor: Project Vine
105Distribution: Vine Linux
106Packager: daisuke
107
108%description
109Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
110proxy server written by Igor Sysoev.
111
112%description -l ja
113Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
114堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
115 - HTTP(S) サーバ
116 - HTTP(S) リバースプロキシサーバ
117 - IMAP/POP3 プロキシサーバ
118
119%package passenger
120Summary: Nginx with mod_passenger support
121Summary(ja): Passenger サポート入りの Nginx
122Group: System Environment/Daemons
123BuildRequires: ruby, rubygem-rake
124Requires: ruby, rubygem-rake
125%if "%{_dist_release}" >= "vl7"
126BuildRequires: ruby-devel, ruby-rubygems
127Requires: ruby-rubygems
128%else
129BuildRequires: rubygems
130Requires: rubygems
131%endif
132Requires: nginx
133
134%description passenger
135Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
136This package contains nginx server with passenger support.
137
138%description -l ja passenger
139Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
140堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
141 - HTTP(S) サーバ
142 - HTTP(S) リバースプロキシサーバ
143 - IMAP/POP3 プロキシサーバ
144このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
145
146%prep
147%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
148
149%patch0 -p0
150
151# pushd passenger-%{passenger_version}/ext/
152# %patch100 -p2
153# popd
154
155pushd passenger-%{passenger_version}
156%patch1000 -p1
157popd
158
159%build
160# nginx does not utilize a standard configure script.  It has its own
161# and the standard configure options cause the nginx configure script
162# to error out.  This is is also the reason for the DESTDIR environment
163# variable.  The configure script(s) have been patched (Patch1 and
164# Patch2) in order to support installing into a build environment.
165
166export DESTDIR=%{buildroot}
167
168
169CONFIGOPTS="\
170    --user=%{nginx_user} \
171    --group=%{nginx_group} \
172    --prefix=%{nginx_datadir} \
173    --sbin-path=%{_sbindir}/%{name} \
174    --conf-path=%{nginx_confdir}/%{name}.conf \
175    --error-log-path=%{nginx_logdir}/error.log \
176    --http-log-path=%{nginx_logdir}/access.log \
177    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
178    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
179    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
180    --pid-path=%{_localstatedir}/run/%{name}.pid \
181    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
182    --with-file-aio \
183    --with-ipv6 \
184    --with-http_ssl_module \
185    --with-http_v2_module \
186    --with-http_realip_module \
187    --with-http_addition_module \
188    --with-http_xslt_module \
189    --with-http_image_filter_module \
190%if %{with geoip}
191    --with-http_geoip_module \
192%endif
193    --with-http_sub_module \
194    --with-http_dav_module \
195    --with-http_flv_module \
196    --with-http_mp4_module \
197    --with-http_gunzip_module \
198    --with-http_gzip_static_module \
199    --with-http_auth_request_module \
200    --with-http_random_index_module \
201    --with-http_secure_link_module \
202    --with-http_degradation_module \
203    --with-http_stub_status_module \
204    --with-http_perl_module \
205    --with-mail \
206    --with-mail_ssl_module \
207    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
208    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
209    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
210%if %{with wsgi}
211    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
212%endif
213%ifarch i686
214    --with-cpu-opt=pentiumpro \
215    --with-zlib-asm=pentiumpro \
216    --with-md5-asm \
217    --with-sha1-asm \
218%endif
219"
220
221
222## build with passenger
223./configure \
224    $CONFIGOPTS \
225    --with-cc-opt="%{optflags}" \
226    --add-module=passenger-%{passenger_version}/src/nginx_module
227
228make %{?_smp_mflags}
229mv objs/nginx objs/nginx.passenger
230
231## build without passenger
232./configure \
233    $CONFIGOPTS \
234    --with-cc-opt="%{optflags}"
235
236make %{?_smp_mflags}
237
238%install
239rm -rf %{buildroot}
240make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
241find %{buildroot} -type f -name .packlist -exec rm -f {} \;
242find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
243find %{buildroot} -type f -empty -exec rm -f {} \;
244find %{buildroot} -type f -exec chmod 0644 {} \;
245find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
246mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
247%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
248chmod 0755 %{buildroot}%{_sbindir}/nginx.*
249%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
250%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
251%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
252%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
253%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
254%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
255%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
256%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
257%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
258%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
259%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
260%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
261%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
262%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
263%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
264%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
265%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
266%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
267%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
268%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
269
270%if %{with wsgi}
271%{__install} -p -m 0644 \
272    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
273    %{buildroot}%{nginx_confdir}
274cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
275%endif
276
277# upstream fair module document
278cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
279
280touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
281
282# convert to UTF-8 all files that give warnings.
283for textfile in CHANGES
284do
285    mv $textfile $textfile.old
286    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
287    rm -f $textfile.old
288done
289
290%clean
291rm -rf %{buildroot}
292
293%post
294if [ $1 == 1 ]; then
295    /sbin/chkconfig --add %{name}
296fi
297update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
298
299%post passenger
300update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
301
302%preun
303if [ $1 = 0 ]; then
304    /sbin/service %{name} stop >/dev/null 2>&1
305    /sbin/chkconfig --del %{name}
306    update-alternatives --remove nginx %{_sbindir}/nginx.normal
307fi
308
309%preun passenger
310if [ $1 = 0 ]; then
311    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
312fi
313
314
315%postun
316if [ $1 == 2 ]; then
317    /sbin/service %{name} upgrade || :
318fi
319
320%files
321%defattr(-,root,root,-)
322%doc LICENSE CHANGES README
323%doc README.upstream_fair
324%doc %{?with_wsgi:README.mod_wsgi}
325%{nginx_datadir}/
326%{_sbindir}/%{name}.normal
327%{_mandir}/man3/%{name}.3pm.gz
328%{_initrddir}/%{name}
329%dir %{nginx_confdir}
330%dir %{nginx_confdir}/conf.d
331%config(noreplace) %{nginx_confdir}/conf.d/*.conf
332%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
333%config(noreplace) %{nginx_confdir}/sites.d/*
334%config(noreplace) %{nginx_confdir}/win-utf
335%config(noreplace) %{nginx_confdir}/%{name}.conf.default
336%config(noreplace) %{nginx_confdir}/mime.types.default
337%config(noreplace) %{nginx_confdir}/fastcgi_params
338%config(noreplace) %{nginx_confdir}/fastcgi_params.default
339%config(noreplace) %{nginx_confdir}/koi-win
340%config(noreplace) %{nginx_confdir}/koi-utf
341%config(noreplace) %{nginx_confdir}/%{name}.conf
342%config(noreplace) %{nginx_confdir}/mime.types
343%config(noreplace) %{nginx_confdir}/fastcgi.conf
344%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
345%config(noreplace) %{nginx_confdir}/scgi_params
346%config(noreplace) %{nginx_confdir}/scgi_params.default
347%config(noreplace) %{nginx_confdir}/uwsgi_params
348%config(noreplace) %{nginx_confdir}/uwsgi_params.default
349%if %{with wsgi}
350%config(noreplace) %{nginx_confdir}/wsgi_vars
351%endif
352%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
353%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
354%dir %{perl_vendorarch}/auto/%{name}
355%{perl_vendorarch}/%{name}.pm
356%{perl_vendorarch}/auto/%{name}/%{name}.so
357%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
358%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
359%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
360%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
361
362%files passenger
363%defattr(-,root,root,-)
364%doc passenger-%{passenger_version}/doc/*.md
365%doc passenger-%{passenger_version}/doc/*.txt
366%doc passenger-%{passenger_version}/doc/*.html
367%doc passenger-%{passenger_version}/doc/templates
368%doc passenger-%{passenger_version}/doc/users_guide_snippets
369%doc passenger-%{passenger_version}/doc/images
370%{_sbindir}/%{name}.passenger
371
372
373%changelog
374* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
375- rebuild with gcc-5.4.0
376
377* Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
378- updated to 1.10.1.
379- updated passenger to 5.0.28.
380
381* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
382- updated to 1.9.15
383
384* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
385- updated to 1.9.14
386- updated passenger to 5.0.27
387
388* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
389- new upstream release
390
391* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
392- updated to 1.9.12.
393- updated passenger to 5.0.26.
394
395* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
396- new upstream release
397
398* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
399- update to 1.9.10
400- update passenger to 5.0.24
401
402* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
403- update passenger to 5.0.23
404
405* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
406- new upstream release
407
408* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
409- new upstream release
410
411* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
412- new upstream release
413
414* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
415- new upstream release
416
417* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
418- update to 1.9.3
419- update passenger to 5.0.11
420
421* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
422- updated Source4 (ssl.conf).
423
424* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
425- update to 1.9.2
426- update passenger to 5.0.10
427- update ngx-fancyindex to 0.3.5
428
429* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
430- update to 1.6.2
431- update passenger to 4.0.52
432
433* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
434- new upstream release
435
436* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
437- rebuild with new environment
438
439* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
440- update passenger to 4.0.45
441
442* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
443- update to 1.6.0 (stable)
444
445* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
446- update fancyindex to 0.3.3
447
448* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
449- update to 1.5.10
450- update passenger to 4.0.37
451
452* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
453- rebuilt with GeoIP-1.6.0.
454- added Patch100.
455
456* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
457- update to 1.5.6
458- update passenger to 4.0.21
459
460* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
461- rebuilt with gd-2.1.0.
462
463* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
464- update to 1.4.1
465
466* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
467- update to 1.4.0
468- enable SPDY module
469
470* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
471- new upstream release
472- update passenger to 3.0.19
473- update ngx-fancyindex to upstream git master
474
475* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
476- new upstream release
477- update passenger to 3.0.17
478
479* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
480- rebuild with pcre-8.31
481
482* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
483- added http_geoip_module.
484
485* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
486- update to 1.2.4
487
488* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
489- update to 1.2.2
490
491* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
492- update to 1.2.1
493- change nginx user from nginx to www-data
494- R(pre): www-common
495
496* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
497- update to 1.2.0
498- update passenger to 3.0.12
499- drop http_upstream_keepalive
500
501* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
502- new upstream release
503
504* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
505- update to 1.0.12
506
507* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
508- update to 1.0.11
509- update passenger to 3.0.11
510
511* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
512- update to 1.0.10
513
514* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
515- update passenger to 3.0.9
516
517* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
518- update to 1.0.6
519
520* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
521- update to 1.0.4
522
523* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
524- add gnosek-nginx-upstream-fair module
525- add ngx_http_upstream_keepalive module
526
527* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
528- add nginx-passenger sub pakckage
529  - use alternatives to choose nginx with or without passenger
530  - add BR: ruby, rubygems, rubygem-rake
531
532* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
533- update to 1.0.2
534
535* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
536- update to 1.0.1
537
538* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
539- add bcond_with wsgi for mod_wsgi
540- add bcond_with passenger
541  - you need to install rake.gem to build with this option.
542- add Provides: webserver
543
544* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
545- new upstream release 1.0.0!
546
547* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
548- rebuild with perl-5.12.3
549
550* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
551- update to 0.8.54
552
553* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
554- update to 0.8.53
555- add nginx_accept_language_module
556
557* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
558- update to 0.8.50
559- update ngx-fancyindex to 0.3
560- add BR: libxml2-devel, libxslt-devel
561- add scgi_params* and uwsgi_params* to %%files
562
563* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
564- update to 0.8.35 (development version)
565- add sites.d/ to store vitualhost settings
566- split out default server settings to sites.d/default
567- add fancyindex module
568
569* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
570- new upstream release
571
572* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
573- update to 0.7.62 (included security fix: VU#180065)
574
575* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
576- fix typo
577
578* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
579- add translated descriptions
580
581* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
582- update 404.html/50x.html to use powered by vine logo.
583
584* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
585- initial build for Vine Linux
586- update to 0.7.61
587
588* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
589- init script updates from Gena Makhomed
590- remove nginx-upstream-fair
591
592* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
593-  update to 0.6.36
594
595* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
596- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
597
598* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
599- rebuild
600
601* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
602- update to 0.6.35
603
604* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
605- rebuild with new openssl
606
607* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
608- update to 0.6.34
609
610* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
611- Fix inclusion of /usr/share/nginx tree => no unowned directories.
612
613* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
614- update to 0.6.33
615
616* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
617- update to 0.6.32
618- nginx now supports DESTDIR so removed the patches that enabled it
619
620* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
621- init script fixes
622- resolve 'listen 80 default' [#447873]
623
624* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
625- update to 0.6.31
626
627* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
628- upate to new upstream stable branch 0.6
629- added 3rd party module nginx-upstream-fair
630- added default webpages
631
632* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
633- update init script to match recommended guidelines
634- add /etc/nginx/conf.d support [#443280]
635- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
636
637* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
638- add Requires for versioned perl (libperl.so)
639- drop silly file Requires
640
641* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
642- Autorebuild for GCC 4.3
643
644* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
645- update to 0.5.35
646
647* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
648- update to 0.5.34
649
650* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
651 - Rebuild for deps
652
653* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
654- update to 0.5.33
655
656* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
657- updated to 0.5.32
658- fixed rpmlint UTF-8 complaints.
659
660* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
661- added --with-http_stub_status_module build option.
662- added --with-http_sub_module build option.
663- added use of pcre-config --cflags
664
665* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
666- Update to 0.5.31
667- specify license is BSD
668
669* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
670- Add BuildRequires: perl-devel - fixing rawhide build
671
672* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
673- Update to 0.5.30
674
675* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
676- Update to 0.5.29
677
678* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
679- Update to 0.5.28
680
681* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
682- Update to 0.5.27
683
684* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
685- Update to 0.5.26
686
687* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
688- Update to 0.5.19
689
690* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
691- Update to 0.5.17
692
693* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
694- Update to 0.5.16
695- add ownership of /usr/share/nginx/html (#233950)
696
697* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
698- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
699
700* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
701- fixed package review bugs (#233522) given by kevin@tummy.com
702
703* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
704- create patches to assist with building for Fedora
705- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.