source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 10205

Revision 10205, 22.7 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.9.15
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 0.3.5
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55%define passenger_version 5.0.27
56Source1020: passenger-%{passenger_version}.tar.gz
57%define upstream_fair_version 2131c73
58Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
59
60%define mod_wsgi_version 6975f0ec7eeb
61Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
62
63# removes -Werror in upstream build scripts.  -Werror conflicts with
64# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
65Patch0:     nginx-auto-cc-gcc.patch
66
67# to fix https://svn.boost.org/trac/boost/ticket/8731
68Patch100:   boost-changeset_84950.diff
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
71
72BuildRequires:      pcre-devel
73BuildRequires:      zlib-devel
74BuildRequires:      openssl-devel
75BuildRequires:      gd-devel
76BuildRequires:      perl
77BuildRequires:      perl(ExtUtils::Embed)
78BuildRequires:      libxml2-devel
79BuildRequires:      libxslt-devel
80BuildRequires:      curl-devel
81%if %{with geoip}
82BuildRequires:      GeoIP-devel
83%endif
84
85Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
86# for /usr/sbin/useradd
87Requires(pre):      shadow-utils
88Requires(post):     chkconfig
89# for /sbin/service
90Requires(preun):    chkconfig, initscripts
91Requires(postun):   initscripts
92%if "%{_dist_release}" > "vl6"
93Requires(pre):      www-common
94%endif
95
96Provides: webserver
97
98Vendor: Project Vine
99Distribution: Vine Linux
100Packager: daisuke
101
102%description
103Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
104proxy server written by Igor Sysoev.
105
106%description -l ja
107Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
108堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
109 - HTTP(S) サーバ
110 - HTTP(S) リバースプロキシサーバ
111 - IMAP/POP3 プロキシサーバ
112
113%package passenger
114Summary: Nginx with mod_passenger support
115Summary(ja): Passenger サポート入りの Nginx
116Group: System Environment/Daemons
117BuildRequires: ruby, rubygem-rake
118Requires: ruby, rubygem-rake
119%if "%{_dist_release}" >= "vl7"
120BuildRequires: ruby-devel, ruby-rubygems
121Requires: ruby-rubygems
122%else
123BuildRequires: rubygems
124Requires: rubygems
125%endif
126Requires: nginx
127
128%description passenger
129Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
130This package contains nginx server with passenger support.
131
132%description -l ja passenger
133Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
134堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
135 - HTTP(S) サーバ
136 - HTTP(S) リバースプロキシサーバ
137 - IMAP/POP3 プロキシサーバ
138このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
139
140%prep
141%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
142
143%patch0 -p0
144
145# pushd passenger-%{passenger_version}/ext/
146# %patch100 -p2
147# popd
148
149%build
150# nginx does not utilize a standard configure script.  It has its own
151# and the standard configure options cause the nginx configure script
152# to error out.  This is is also the reason for the DESTDIR environment
153# variable.  The configure script(s) have been patched (Patch1 and
154# Patch2) in order to support installing into a build environment.
155
156export DESTDIR=%{buildroot}
157
158
159CONFIGOPTS="\
160    --user=%{nginx_user} \
161    --group=%{nginx_group} \
162    --prefix=%{nginx_datadir} \
163    --sbin-path=%{_sbindir}/%{name} \
164    --conf-path=%{nginx_confdir}/%{name}.conf \
165    --error-log-path=%{nginx_logdir}/error.log \
166    --http-log-path=%{nginx_logdir}/access.log \
167    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
168    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
169    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
170    --pid-path=%{_localstatedir}/run/%{name}.pid \
171    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
172    --with-file-aio \
173    --with-ipv6 \
174    --with-http_ssl_module \
175    --with-http_v2_module \
176    --with-http_realip_module \
177    --with-http_addition_module \
178    --with-http_xslt_module \
179    --with-http_image_filter_module \
180%if %{with geoip}
181    --with-http_geoip_module \
182%endif
183    --with-http_sub_module \
184    --with-http_dav_module \
185    --with-http_flv_module \
186    --with-http_mp4_module \
187    --with-http_gunzip_module \
188    --with-http_gzip_static_module \
189    --with-http_auth_request_module \
190    --with-http_random_index_module \
191    --with-http_secure_link_module \
192    --with-http_degradation_module \
193    --with-http_stub_status_module \
194    --with-http_perl_module \
195    --with-mail \
196    --with-mail_ssl_module \
197    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
198    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
199    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
200%if %{with wsgi}
201    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
202%endif
203%ifarch i686
204    --with-cpu-opt=pentiumpro \
205    --with-zlib-asm=pentiumpro \
206    --with-md5-asm \
207    --with-sha1-asm \
208%endif
209"
210
211
212## build with passenger
213./configure \
214    $CONFIGOPTS \
215    --with-cc-opt="%{optflags}" \
216    --add-module=passenger-%{passenger_version}/src/nginx_module
217
218make %{?_smp_mflags}
219mv objs/nginx objs/nginx.passenger
220
221## build without passenger
222./configure \
223    $CONFIGOPTS \
224    --with-cc-opt="%{optflags}"
225
226make %{?_smp_mflags}
227
228%install
229rm -rf %{buildroot}
230make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
231find %{buildroot} -type f -name .packlist -exec rm -f {} \;
232find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
233find %{buildroot} -type f -empty -exec rm -f {} \;
234find %{buildroot} -type f -exec chmod 0644 {} \;
235find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
236mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
237%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
238chmod 0755 %{buildroot}%{_sbindir}/nginx.*
239%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
240%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
241%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
242%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
243%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
244%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
245%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
246%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
247%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
248%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
249%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
250%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
251%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
252%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
253%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
254%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
255%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
256%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
257%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
258%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
259
260%if %{with wsgi}
261%{__install} -p -m 0644 \
262    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
263    %{buildroot}%{nginx_confdir}
264cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
265%endif
266
267# upstream fair module document
268cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
269
270touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
271
272# convert to UTF-8 all files that give warnings.
273for textfile in CHANGES
274do
275    mv $textfile $textfile.old
276    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
277    rm -f $textfile.old
278done
279
280%clean
281rm -rf %{buildroot}
282
283%post
284if [ $1 == 1 ]; then
285    /sbin/chkconfig --add %{name}
286fi
287update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
288
289%post passenger
290update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
291
292%preun
293if [ $1 = 0 ]; then
294    /sbin/service %{name} stop >/dev/null 2>&1
295    /sbin/chkconfig --del %{name}
296    update-alternatives --remove nginx %{_sbindir}/nginx.normal
297fi
298
299%preun passenger
300if [ $1 = 0 ]; then
301    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
302fi
303
304
305%postun
306if [ $1 == 2 ]; then
307    /sbin/service %{name} upgrade || :
308fi
309
310%files
311%defattr(-,root,root,-)
312%doc LICENSE CHANGES README
313%doc README.upstream_fair
314%doc %{?with_wsgi:README.mod_wsgi}
315%{nginx_datadir}/
316%{_sbindir}/%{name}.normal
317%{_mandir}/man3/%{name}.3pm.gz
318%{_initrddir}/%{name}
319%dir %{nginx_confdir}
320%dir %{nginx_confdir}/conf.d
321%config(noreplace) %{nginx_confdir}/conf.d/*.conf
322%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
323%config(noreplace) %{nginx_confdir}/sites.d/*
324%config(noreplace) %{nginx_confdir}/win-utf
325%config(noreplace) %{nginx_confdir}/%{name}.conf.default
326%config(noreplace) %{nginx_confdir}/mime.types.default
327%config(noreplace) %{nginx_confdir}/fastcgi_params
328%config(noreplace) %{nginx_confdir}/fastcgi_params.default
329%config(noreplace) %{nginx_confdir}/koi-win
330%config(noreplace) %{nginx_confdir}/koi-utf
331%config(noreplace) %{nginx_confdir}/%{name}.conf
332%config(noreplace) %{nginx_confdir}/mime.types
333%config(noreplace) %{nginx_confdir}/fastcgi.conf
334%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
335%config(noreplace) %{nginx_confdir}/scgi_params
336%config(noreplace) %{nginx_confdir}/scgi_params.default
337%config(noreplace) %{nginx_confdir}/uwsgi_params
338%config(noreplace) %{nginx_confdir}/uwsgi_params.default
339%if %{with wsgi}
340%config(noreplace) %{nginx_confdir}/wsgi_vars
341%endif
342%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
343%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
344%dir %{perl_vendorarch}/auto/%{name}
345%{perl_vendorarch}/%{name}.pm
346%{perl_vendorarch}/auto/%{name}/%{name}.so
347%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
348%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
349%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
350%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
351
352%files passenger
353%defattr(-,root,root,-)
354%doc passenger-%{passenger_version}/doc/*.md
355%doc passenger-%{passenger_version}/doc/*.txt
356%doc passenger-%{passenger_version}/doc/*.html
357%doc passenger-%{passenger_version}/doc/templates
358%doc passenger-%{passenger_version}/doc/users_guide_snippets
359%doc passenger-%{passenger_version}/doc/images
360%{_sbindir}/%{name}.passenger
361
362
363%changelog
364* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
365- updated to 1.9.15
366
367* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
368- updated to 1.9.14
369- updated passenger to 5.0.27
370
371* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
372- new upstream release
373
374* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
375- updated to 1.9.12.
376- updated passenger to 5.0.26.
377
378* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
379- new upstream release
380
381* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
382- update to 1.9.10
383- update passenger to 5.0.24
384
385* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
386- update passenger to 5.0.23
387
388* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
389- new upstream release
390
391* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
392- new upstream release
393
394* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
395- new upstream release
396
397* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
398- new upstream release
399
400* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
401- update to 1.9.3
402- update passenger to 5.0.11
403
404* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
405- updated Source4 (ssl.conf).
406
407* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
408- update to 1.9.2
409- update passenger to 5.0.10
410- update ngx-fancyindex to 0.3.5
411
412* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
413- update to 1.6.2
414- update passenger to 4.0.52
415
416* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
417- new upstream release
418
419* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
420- rebuild with new environment
421
422* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
423- update passenger to 4.0.45
424
425* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
426- update to 1.6.0 (stable)
427
428* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
429- update fancyindex to 0.3.3
430
431* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
432- update to 1.5.10
433- update passenger to 4.0.37
434
435* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
436- rebuilt with GeoIP-1.6.0.
437- added Patch100.
438
439* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
440- update to 1.5.6
441- update passenger to 4.0.21
442
443* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
444- rebuilt with gd-2.1.0.
445
446* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
447- update to 1.4.1
448
449* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
450- update to 1.4.0
451- enable SPDY module
452
453* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
454- new upstream release
455- update passenger to 3.0.19
456- update ngx-fancyindex to upstream git master
457
458* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
459- new upstream release
460- update passenger to 3.0.17
461
462* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
463- rebuild with pcre-8.31
464
465* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
466- added http_geoip_module.
467
468* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
469- update to 1.2.4
470
471* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
472- update to 1.2.2
473
474* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
475- update to 1.2.1
476- change nginx user from nginx to www-data
477- R(pre): www-common
478
479* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
480- update to 1.2.0
481- update passenger to 3.0.12
482- drop http_upstream_keepalive
483
484* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
485- new upstream release
486
487* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
488- update to 1.0.12
489
490* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
491- update to 1.0.11
492- update passenger to 3.0.11
493
494* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
495- update to 1.0.10
496
497* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
498- update passenger to 3.0.9
499
500* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
501- update to 1.0.6
502
503* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
504- update to 1.0.4
505
506* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
507- add gnosek-nginx-upstream-fair module
508- add ngx_http_upstream_keepalive module
509
510* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
511- add nginx-passenger sub pakckage
512  - use alternatives to choose nginx with or without passenger
513  - add BR: ruby, rubygems, rubygem-rake
514
515* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
516- update to 1.0.2
517
518* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
519- update to 1.0.1
520
521* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
522- add bcond_with wsgi for mod_wsgi
523- add bcond_with passenger
524  - you need to install rake.gem to build with this option.
525- add Provides: webserver
526
527* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
528- new upstream release 1.0.0!
529
530* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
531- rebuild with perl-5.12.3
532
533* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
534- update to 0.8.54
535
536* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
537- update to 0.8.53
538- add nginx_accept_language_module
539
540* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
541- update to 0.8.50
542- update ngx-fancyindex to 0.3
543- add BR: libxml2-devel, libxslt-devel
544- add scgi_params* and uwsgi_params* to %%files
545
546* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
547- update to 0.8.35 (development version)
548- add sites.d/ to store vitualhost settings
549- split out default server settings to sites.d/default
550- add fancyindex module
551
552* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
553- new upstream release
554
555* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
556- update to 0.7.62 (included security fix: VU#180065)
557
558* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
559- fix typo
560
561* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
562- add translated descriptions
563
564* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
565- update 404.html/50x.html to use powered by vine logo.
566
567* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
568- initial build for Vine Linux
569- update to 0.7.61
570
571* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
572- init script updates from Gena Makhomed
573- remove nginx-upstream-fair
574
575* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
576-  update to 0.6.36
577
578* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
579- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
580
581* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
582- rebuild
583
584* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
585- update to 0.6.35
586
587* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
588- rebuild with new openssl
589
590* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
591- update to 0.6.34
592
593* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
594- Fix inclusion of /usr/share/nginx tree => no unowned directories.
595
596* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
597- update to 0.6.33
598
599* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
600- update to 0.6.32
601- nginx now supports DESTDIR so removed the patches that enabled it
602
603* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
604- init script fixes
605- resolve 'listen 80 default' [#447873]
606
607* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
608- update to 0.6.31
609
610* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
611- upate to new upstream stable branch 0.6
612- added 3rd party module nginx-upstream-fair
613- added default webpages
614
615* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
616- update init script to match recommended guidelines
617- add /etc/nginx/conf.d support [#443280]
618- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
619
620* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
621- add Requires for versioned perl (libperl.so)
622- drop silly file Requires
623
624* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
625- Autorebuild for GCC 4.3
626
627* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
628- update to 0.5.35
629
630* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
631- update to 0.5.34
632
633* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
634 - Rebuild for deps
635
636* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
637- update to 0.5.33
638
639* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
640- updated to 0.5.32
641- fixed rpmlint UTF-8 complaints.
642
643* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
644- added --with-http_stub_status_module build option.
645- added --with-http_sub_module build option.
646- added use of pcre-config --cflags
647
648* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
649- Update to 0.5.31
650- specify license is BSD
651
652* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
653- Add BuildRequires: perl-devel - fixing rawhide build
654
655* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
656- Update to 0.5.30
657
658* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
659- Update to 0.5.29
660
661* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
662- Update to 0.5.28
663
664* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
665- Update to 0.5.27
666
667* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
668- Update to 0.5.26
669
670* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
671- Update to 0.5.19
672
673* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
674- Update to 0.5.17
675
676* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
677- Update to 0.5.16
678- add ownership of /usr/share/nginx/html (#233950)
679
680* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
681- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
682
683* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
684- fixed package review bugs (#233522) given by kevin@tummy.com
685
686* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
687- create patches to assist with building for Fedora
688- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.