source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 10984

Revision 10984, 24.1 KB checked in by munepi, 7 years ago (diff)

new upstream release

Line 
1# build mod_wsgi
2%bcond_with wsgi
3
4# build http_geoip_module
5%if "%{_dist_release}" >= "vl7"
6%bcond_without geoip
7%else
8%bcond_with geoip
9%endif
10
11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
14%define nginx_user      nginx
15%endif
16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
19%define nginx_home_cache %{nginx_home}/cache
20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
28Version:        1.11.13
29Release:        1%{?_dist_release}
30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
51%define ngx_fancyindex_version 0.3.5
52Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
53%define nginx_accept_language_module_version 02262ce
54Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
55
56## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
57%define passenger_version 5.1.2
58Source1020: passenger-%{passenger_version}.tar.gz
59%define upstream_fair_version 2131c73
60Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
61
62%define mod_wsgi_version 6975f0ec7eeb
63Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
64
65# removes -Werror in upstream build scripts.  -Werror conflicts with
66# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
67Patch0:     nginx-auto-cc-gcc.patch
68
69# to fix https://svn.boost.org/trac/boost/ticket/8731
70Patch100:   boost-changeset_84950.diff
71
72# to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
73Patch101:   gnosek-nginx-upstream-fair-pull-23.patch
74
75# to fix compile error with C++11.
76Patch1000: passenger-5.0.28-boost.patch
77
78
79BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
80
81%if "%{_dist_release}" > "vl6"
82BuildRequires:      libboost-devel
83%endif
84BuildRequires:      pcre-devel
85BuildRequires:      zlib-devel
86BuildRequires:      openssl-devel
87BuildRequires:      gd-devel
88BuildRequires:      perl
89BuildRequires:      perl(ExtUtils::Embed)
90BuildRequires:      libxml2-devel
91BuildRequires:      libxslt-devel
92BuildRequires:      curl-devel
93%if %{with geoip}
94BuildRequires:      GeoIP-devel
95%endif
96
97Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
98# for /usr/sbin/useradd
99Requires(pre):      shadow-utils
100Requires(post):     chkconfig
101# for /sbin/service
102Requires(preun):    chkconfig, initscripts
103Requires(postun):   initscripts
104%if "%{_dist_release}" > "vl6"
105Requires(pre):      www-common
106%endif
107
108Provides: webserver
109
110Vendor: Project Vine
111Distribution: Vine Linux
112Packager: daisuke
113
114%description
115Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
116proxy server written by Igor Sysoev.
117
118%description -l ja
119Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
120堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
121 - HTTP(S) サーバ
122 - HTTP(S) リバースプロキシサーバ
123 - IMAP/POP3 プロキシサーバ
124
125%package passenger
126Summary: Nginx with mod_passenger support
127Summary(ja): Passenger サポート入りの Nginx
128Group: System Environment/Daemons
129BuildRequires: ruby, rubygem-rake
130Requires: ruby, rubygem-rake
131%if "%{_dist_release}" >= "vl7"
132BuildRequires: ruby-devel, ruby-rubygems
133Requires: ruby-rubygems
134%else
135BuildRequires: rubygems
136Requires: rubygems
137%endif
138Requires: nginx
139
140%description passenger
141Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
142This package contains nginx server with passenger support.
143
144%description -l ja passenger
145Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
146堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
147 - HTTP(S) サーバ
148 - HTTP(S) リバースプロキシサーバ
149 - IMAP/POP3 プロキシサーバ
150このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
151
152%prep
153%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
154
155%patch0 -p0
156
157# pushd passenger-%{passenger_version}/ext/
158# %patch100 -p2
159# popd
160
161pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
162%patch101 -p1
163popd
164
165%if %{?_dist_release} == "vl7"
166pushd passenger-%{passenger_version}
167#% patch1000 -p1
168popd
169%endif
170
171%build
172# nginx does not utilize a standard configure script.  It has its own
173# and the standard configure options cause the nginx configure script
174# to error out.  This is is also the reason for the DESTDIR environment
175# variable.  The configure script(s) have been patched (Patch1 and
176# Patch2) in order to support installing into a build environment.
177
178export DESTDIR=%{buildroot}
179
180
181CONFIGOPTS="\
182    --user=%{nginx_user} \
183    --group=%{nginx_group} \
184    --prefix=%{nginx_datadir} \
185    --sbin-path=%{_sbindir}/%{name} \
186    --conf-path=%{nginx_confdir}/%{name}.conf \
187    --error-log-path=%{nginx_logdir}/error.log \
188    --http-log-path=%{nginx_logdir}/access.log \
189    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
190    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
191    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
192    --pid-path=%{_localstatedir}/run/%{name}.pid \
193    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
194    --with-file-aio \
195    --with-ipv6 \
196    --with-http_ssl_module \
197    --with-http_v2_module \
198    --with-http_realip_module \
199    --with-http_addition_module \
200    --with-http_xslt_module \
201    --with-http_image_filter_module \
202%if %{with geoip}
203    --with-http_geoip_module \
204%endif
205    --with-http_sub_module \
206    --with-http_dav_module \
207    --with-http_flv_module \
208    --with-http_mp4_module \
209    --with-http_gunzip_module \
210    --with-http_gzip_static_module \
211    --with-http_auth_request_module \
212    --with-http_random_index_module \
213    --with-http_secure_link_module \
214    --with-http_degradation_module \
215    --with-http_stub_status_module \
216    --with-http_perl_module \
217    --with-mail \
218    --with-mail_ssl_module \
219    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
220    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
221    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
222%if %{with wsgi}
223    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
224%endif
225%ifarch i686
226    --with-cpu-opt=pentiumpro \
227    --with-zlib-asm=pentiumpro \
228    --with-md5-asm \
229    --with-sha1-asm \
230%endif
231"
232
233
234## build with passenger
235./configure \
236    $CONFIGOPTS \
237    --with-cc-opt="%{optflags}" \
238    --add-module=passenger-%{passenger_version}/src/nginx_module
239
240make %{?_smp_mflags}
241mv objs/nginx objs/nginx.passenger
242
243## build without passenger
244./configure \
245    $CONFIGOPTS \
246    --with-cc-opt="%{optflags}"
247
248make %{?_smp_mflags}
249
250%install
251rm -rf %{buildroot}
252make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
253find %{buildroot} -type f -name .packlist -exec rm -f {} \;
254find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
255find %{buildroot} -type f -empty -exec rm -f {} \;
256find %{buildroot} -type f -exec chmod 0644 {} \;
257find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
258mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
259%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
260chmod 0755 %{buildroot}%{_sbindir}/nginx.*
261%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
262%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
263%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
264%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
265%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
266%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
267%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
268%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
269%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
270%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
271%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
272%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
273%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
274%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
275%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
276%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
277%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
278%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
279%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
280%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
281
282%if %{with wsgi}
283%{__install} -p -m 0644 \
284    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
285    %{buildroot}%{nginx_confdir}
286cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
287%endif
288
289# upstream fair module document
290cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
291
292touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
293
294# convert to UTF-8 all files that give warnings.
295for textfile in CHANGES
296do
297    mv $textfile $textfile.old
298    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
299    rm -f $textfile.old
300done
301
302%clean
303rm -rf %{buildroot}
304
305%post
306if [ $1 == 1 ]; then
307    /sbin/chkconfig --add %{name}
308fi
309update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
310
311%post passenger
312update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
313
314%preun
315if [ $1 = 0 ]; then
316    /sbin/service %{name} stop >/dev/null 2>&1
317    /sbin/chkconfig --del %{name}
318    update-alternatives --remove nginx %{_sbindir}/nginx.normal
319fi
320
321%preun passenger
322if [ $1 = 0 ]; then
323    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
324fi
325
326
327%postun
328if [ $1 == 2 ]; then
329    /sbin/service %{name} upgrade || :
330fi
331
332%files
333%defattr(-,root,root,-)
334%doc LICENSE CHANGES README
335%doc README.upstream_fair
336%doc %{?with_wsgi:README.mod_wsgi}
337%{nginx_datadir}/
338%{_sbindir}/%{name}.normal
339%{_mandir}/man3/%{name}.3pm.gz
340%{_initrddir}/%{name}
341%dir %{nginx_confdir}
342%dir %{nginx_confdir}/conf.d
343%config(noreplace) %{nginx_confdir}/conf.d/*.conf
344%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
345%config(noreplace) %{nginx_confdir}/sites.d/*
346%config(noreplace) %{nginx_confdir}/win-utf
347%config(noreplace) %{nginx_confdir}/%{name}.conf.default
348%config(noreplace) %{nginx_confdir}/mime.types.default
349%config(noreplace) %{nginx_confdir}/fastcgi_params
350%config(noreplace) %{nginx_confdir}/fastcgi_params.default
351%config(noreplace) %{nginx_confdir}/koi-win
352%config(noreplace) %{nginx_confdir}/koi-utf
353%config(noreplace) %{nginx_confdir}/%{name}.conf
354%config(noreplace) %{nginx_confdir}/mime.types
355%config(noreplace) %{nginx_confdir}/fastcgi.conf
356%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
357%config(noreplace) %{nginx_confdir}/scgi_params
358%config(noreplace) %{nginx_confdir}/scgi_params.default
359%config(noreplace) %{nginx_confdir}/uwsgi_params
360%config(noreplace) %{nginx_confdir}/uwsgi_params.default
361%if %{with wsgi}
362%config(noreplace) %{nginx_confdir}/wsgi_vars
363%endif
364%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
365%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
366%dir %{perl_vendorarch}/auto/%{name}
367%{perl_vendorarch}/%{name}.pm
368%{perl_vendorarch}/auto/%{name}/%{name}.so
369%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
370%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
371%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
372%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
373
374%files passenger
375%defattr(-,root,root,-)
376%doc passenger-%{passenger_version}/doc/*.md
377%doc passenger-%{passenger_version}/doc/*.txt
378%doc passenger-%{passenger_version}/doc/*.html
379%doc passenger-%{passenger_version}/doc/templates
380%doc passenger-%{passenger_version}/doc/users_guide_snippets
381%doc passenger-%{passenger_version}/doc/images
382%{_sbindir}/%{name}.passenger
383
384
385%changelog
386* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
387- updated to 1.11.13
388
389* Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
390- updated to 1.11.12
391
392* Tue Mar  7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
393- updated to 1.11.10
394- updated passenger to 5.1.2
395
396* Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
397- updated to 1.11.9
398
399* Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
400- updated to 1.11.8
401
402* Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
403- updated to 1.11.6
404- applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
405
406* Mon Sep  5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
407- updated to 1.11.3
408- updated passenger to 5.0.30
409
410* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
411- rebuild with gcc-5.4.0
412
413* Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
414- updated to 1.10.1.
415- updated passenger to 5.0.28.
416
417* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
418- updated to 1.9.15
419
420* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
421- updated to 1.9.14
422- updated passenger to 5.0.27
423
424* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
425- new upstream release
426
427* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
428- updated to 1.9.12.
429- updated passenger to 5.0.26.
430
431* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
432- new upstream release
433
434* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
435- update to 1.9.10
436- update passenger to 5.0.24
437
438* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
439- update passenger to 5.0.23
440
441* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
442- new upstream release
443
444* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
445- new upstream release
446
447* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
448- new upstream release
449
450* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
451- new upstream release
452
453* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
454- update to 1.9.3
455- update passenger to 5.0.11
456
457* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
458- updated Source4 (ssl.conf).
459
460* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
461- update to 1.9.2
462- update passenger to 5.0.10
463- update ngx-fancyindex to 0.3.5
464
465* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
466- update to 1.6.2
467- update passenger to 4.0.52
468
469* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
470- new upstream release
471
472* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
473- rebuild with new environment
474
475* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
476- update passenger to 4.0.45
477
478* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
479- update to 1.6.0 (stable)
480
481* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
482- update fancyindex to 0.3.3
483
484* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
485- update to 1.5.10
486- update passenger to 4.0.37
487
488* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
489- rebuilt with GeoIP-1.6.0.
490- added Patch100.
491
492* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
493- update to 1.5.6
494- update passenger to 4.0.21
495
496* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
497- rebuilt with gd-2.1.0.
498
499* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
500- update to 1.4.1
501
502* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
503- update to 1.4.0
504- enable SPDY module
505
506* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
507- new upstream release
508- update passenger to 3.0.19
509- update ngx-fancyindex to upstream git master
510
511* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
512- new upstream release
513- update passenger to 3.0.17
514
515* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
516- rebuild with pcre-8.31
517
518* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
519- added http_geoip_module.
520
521* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
522- update to 1.2.4
523
524* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
525- update to 1.2.2
526
527* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
528- update to 1.2.1
529- change nginx user from nginx to www-data
530- R(pre): www-common
531
532* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
533- update to 1.2.0
534- update passenger to 3.0.12
535- drop http_upstream_keepalive
536
537* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
538- new upstream release
539
540* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
541- update to 1.0.12
542
543* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
544- update to 1.0.11
545- update passenger to 3.0.11
546
547* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
548- update to 1.0.10
549
550* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
551- update passenger to 3.0.9
552
553* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
554- update to 1.0.6
555
556* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
557- update to 1.0.4
558
559* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
560- add gnosek-nginx-upstream-fair module
561- add ngx_http_upstream_keepalive module
562
563* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
564- add nginx-passenger sub pakckage
565  - use alternatives to choose nginx with or without passenger
566  - add BR: ruby, rubygems, rubygem-rake
567
568* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
569- update to 1.0.2
570
571* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
572- update to 1.0.1
573
574* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
575- add bcond_with wsgi for mod_wsgi
576- add bcond_with passenger
577  - you need to install rake.gem to build with this option.
578- add Provides: webserver
579
580* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
581- new upstream release 1.0.0!
582
583* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
584- rebuild with perl-5.12.3
585
586* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
587- update to 0.8.54
588
589* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
590- update to 0.8.53
591- add nginx_accept_language_module
592
593* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
594- update to 0.8.50
595- update ngx-fancyindex to 0.3
596- add BR: libxml2-devel, libxslt-devel
597- add scgi_params* and uwsgi_params* to %%files
598
599* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
600- update to 0.8.35 (development version)
601- add sites.d/ to store vitualhost settings
602- split out default server settings to sites.d/default
603- add fancyindex module
604
605* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
606- new upstream release
607
608* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
609- update to 0.7.62 (included security fix: VU#180065)
610
611* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
612- fix typo
613
614* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
615- add translated descriptions
616
617* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
618- update 404.html/50x.html to use powered by vine logo.
619
620* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
621- initial build for Vine Linux
622- update to 0.7.61
623
624* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
625- init script updates from Gena Makhomed
626- remove nginx-upstream-fair
627
628* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
629-  update to 0.6.36
630
631* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
632- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
633
634* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
635- rebuild
636
637* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
638- update to 0.6.35
639
640* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
641- rebuild with new openssl
642
643* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
644- update to 0.6.34
645
646* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
647- Fix inclusion of /usr/share/nginx tree => no unowned directories.
648
649* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
650- update to 0.6.33
651
652* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
653- update to 0.6.32
654- nginx now supports DESTDIR so removed the patches that enabled it
655
656* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
657- init script fixes
658- resolve 'listen 80 default' [#447873]
659
660* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
661- update to 0.6.31
662
663* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
664- upate to new upstream stable branch 0.6
665- added 3rd party module nginx-upstream-fair
666- added default webpages
667
668* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
669- update init script to match recommended guidelines
670- add /etc/nginx/conf.d support [#443280]
671- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
672
673* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
674- add Requires for versioned perl (libperl.so)
675- drop silly file Requires
676
677* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
678- Autorebuild for GCC 4.3
679
680* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
681- update to 0.5.35
682
683* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
684- update to 0.5.34
685
686* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
687 - Rebuild for deps
688
689* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
690- update to 0.5.33
691
692* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
693- updated to 0.5.32
694- fixed rpmlint UTF-8 complaints.
695
696* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
697- added --with-http_stub_status_module build option.
698- added --with-http_sub_module build option.
699- added use of pcre-config --cflags
700
701* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
702- Update to 0.5.31
703- specify license is BSD
704
705* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
706- Add BuildRequires: perl-devel - fixing rawhide build
707
708* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
709- Update to 0.5.30
710
711* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
712- Update to 0.5.29
713
714* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
715- Update to 0.5.28
716
717* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
718- Update to 0.5.27
719
720* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
721- Update to 0.5.26
722
723* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
724- Update to 0.5.19
725
726* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
727- Update to 0.5.17
728
729* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
730- Update to 0.5.16
731- add ownership of /usr/share/nginx/html (#233950)
732
733* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
734- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
735
736* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
737- fixed package review bugs (#233522) given by kevin@tummy.com
738
739* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
740- create patches to assist with building for Fedora
741- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.