source: projects/specs/trunk/n/nginx/nginx-vl.spec @ 11873

Revision 11873, 26.0 KB checked in by tomop, 6 years ago (diff)

nginx-1.15.5-1

RevLine 
[3785]1# build mod_wsgi
2%bcond_with wsgi
3
[6903]4# build http_geoip_module
[7199]5%if "%{_dist_release}" >= "vl7"
[6903]6%bcond_without geoip
[7199]7%else
8%bcond_with geoip
9%endif
[6903]10
[6601]11%if "%{_dist_release}" > "vl6"
12%define nginx_user      www-data
13%else
[521]14%define nginx_user      nginx
[6601]15%endif
[521]16%define nginx_group     %{nginx_user}
17%define nginx_home      %{_localstatedir}/lib/nginx
18%define nginx_home_tmp  %{nginx_home}/tmp
[854]19%define nginx_home_cache %{nginx_home}/cache
[521]20%define nginx_logdir    %{_localstatedir}/log/nginx
21%define nginx_confdir   %{_sysconfdir}/nginx
22%define nginx_datadir   %{_datadir}/nginx
23%define nginx_webroot   %{nginx_datadir}/html
24
25Summary:        Robust, small and high performance http and reverse proxy server
26Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
27Name:           nginx
[11873]28Version:        1.15.5
[10778]29Release:        1%{?_dist_release}
[521]30
31Group:          System Environment/Daemons   
32# BSD License (two clause)
33# http://www.freebsd.org/copyright/freebsd-license.html
34License:        BSD
35URL:            http://nginx.net/
[854]36
37Source0:    http://sysoev.ru/nginx/nginx-%{version}.tar.gz
38Source1:    %{name}.init
39Source2:    %{name}.logrotate
40Source3:    nginx-virtual.conf.template
41Source4:    nginx-ssl.conf
42Source5:    %{name}.sysconfig
43Source10:   nginx-vine.conf
44Source11:   nginx-default-vine
45Source20:   proxy_cache.conf
46Source100:  nginx-index.html
47Source101:  poweredby-vine.png
48Source102:  nginx-logo.png
49Source103:  nginx-50x.html
50Source104:  nginx-404.html
[11577]51
[11873]52%define ngx_fancyindex_version 0.4.3
[11577]53Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
54
55%define nginx_accept_language_module_version 2f69842
[2236]56Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
[10356]57
58## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
[11873]59%define passenger_version 5.3.6
[3906]60Source1020: passenger-%{passenger_version}.tar.gz
[11577]61
62%define upstream_fair_version a18b409
[3906]63Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
[854]64
[3906]65%define mod_wsgi_version 6975f0ec7eeb
66Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
67
[11577]68%define nginx_dav_ext_module_version 0.1.0
69Source2010: https://github.com/arut/nginx-dav-ext-module/archive/v%{nginx_dav_ext_module_version}.tar.gz#/nginx-dav-ext-module-%{nginx_dav_ext_module_version}.tar.gz
70
[854]71# removes -Werror in upstream build scripts.  -Werror conflicts with
72# -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
73Patch0:     nginx-auto-cc-gcc.patch
74
[8125]75# to fix https://svn.boost.org/trac/boost/ticket/8731
76Patch100:   boost-changeset_84950.diff
77
[10824]78# to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
79Patch101:   gnosek-nginx-upstream-fair-pull-23.patch
80
[10356]81# to fix compile error with C++11.
82Patch1000: passenger-5.0.28-boost.patch
83
[11873]84# to fix compile error with curl-7.62.0
85Patch1001: passenger-with-curl-7.62.0.patch
[10356]86
[521]87BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
88
[10925]89%if "%{_dist_release}" > "vl6"
90BuildRequires:      libboost-devel
91%endif
[521]92BuildRequires:      pcre-devel
93BuildRequires:      zlib-devel
94BuildRequires:      openssl-devel
[854]95BuildRequires:      gd-devel
[521]96BuildRequires:      perl
97BuildRequires:      perl(ExtUtils::Embed)
[1898]98BuildRequires:      libxml2-devel
99BuildRequires:      libxslt-devel
[3906]100BuildRequires:      curl-devel
[6903]101%if %{with geoip}
102BuildRequires:      GeoIP-devel
103%endif
[1898]104
[521]105Requires:           perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
106# for /usr/sbin/useradd
107Requires(pre):      shadow-utils
108Requires(post):     chkconfig
109# for /sbin/service
110Requires(preun):    chkconfig, initscripts
111Requires(postun):   initscripts
[6601]112%if "%{_dist_release}" > "vl6"
113Requires(pre):      www-common
114%endif
[521]115
[3785]116Provides: webserver
117
[854]118Vendor: Project Vine
119Distribution: Vine Linux
120Packager: daisuke
[521]121
122%description
123Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
124proxy server written by Igor Sysoev.
125
126%description -l ja
127Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
128堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
129 - HTTP(S) サーバ
130 - HTTP(S) リバースプロキシサーバ
131 - IMAP/POP3 プロキシサーバ
132
[3847]133%package passenger
134Summary: Nginx with mod_passenger support
135Summary(ja): Passenger サポート入りの Nginx
[7199]136Group: System Environment/Daemons
137BuildRequires: ruby, rubygem-rake
138Requires: ruby, rubygem-rake
139%if "%{_dist_release}" >= "vl7"
140BuildRequires: ruby-devel, ruby-rubygems
141Requires: ruby-rubygems
142%else
143BuildRequires: rubygems
144Requires: rubygems
145%endif
[3847]146Requires: nginx
147
148%description passenger
149Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
150This package contains nginx server with passenger support.
151
152%description -l ja passenger
153Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
154堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
155 - HTTP(S) サーバ
156 - HTTP(S) リバースプロキシサーバ
157 - IMAP/POP3 プロキシサーバ
158このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
159
[521]160%prep
[11577]161%setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000} -a 2010
[521]162
163%patch0 -p0
164
[9935]165# pushd passenger-%{passenger_version}/ext/
166# %patch100 -p2
167# popd
[8125]168
[10824]169pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
170%patch101 -p1
171popd
172
173%if %{?_dist_release} == "vl7"
[10356]174pushd passenger-%{passenger_version}
[10925]175#% patch1000 -p1
[11873]176%patch1001 -p1
[10356]177popd
[10824]178%endif
[10356]179
[521]180%build
181# nginx does not utilize a standard configure script.  It has its own
182# and the standard configure options cause the nginx configure script
183# to error out.  This is is also the reason for the DESTDIR environment
184# variable.  The configure script(s) have been patched (Patch1 and
185# Patch2) in order to support installing into a build environment.
[3847]186
[521]187export DESTDIR=%{buildroot}
[3847]188
[7655]189
190CONFIGOPTS="\
[521]191    --user=%{nginx_user} \
192    --group=%{nginx_group} \
193    --prefix=%{nginx_datadir} \
194    --sbin-path=%{_sbindir}/%{name} \
195    --conf-path=%{nginx_confdir}/%{name}.conf \
196    --error-log-path=%{nginx_logdir}/error.log \
197    --http-log-path=%{nginx_logdir}/access.log \
198    --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
199    --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
200    --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
201    --pid-path=%{_localstatedir}/run/%{name}.pid \
202    --lock-path=%{_localstatedir}/lock/subsys/%{name} \
[854]203    --with-file-aio \
204    --with-ipv6 \
[521]205    --with-http_ssl_module \
[9935]206    --with-http_v2_module \
[521]207    --with-http_realip_module \
208    --with-http_addition_module \
[854]209    --with-http_xslt_module \
210    --with-http_image_filter_module \
[8257]211%if %{with geoip}
212    --with-http_geoip_module \
213%endif
[521]214    --with-http_sub_module \
215    --with-http_dav_module \
216    --with-http_flv_module \
[7472]217    --with-http_mp4_module \
[8257]218    --with-http_gunzip_module \
[521]219    --with-http_gzip_static_module \
[8257]220    --with-http_auth_request_module \
[854]221    --with-http_random_index_module \
222    --with-http_secure_link_module \
[7655]223    --with-http_degradation_module \
[521]224    --with-http_stub_status_module \
225    --with-http_perl_module \
226    --with-mail \
227    --with-mail_ssl_module \
[11577]228    --with-stream \
229    --with-stream_ssl_preread_module \
[1898]230    --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
[2236]231    --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
[3906]232    --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
[3785]233%if %{with wsgi}
234    --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
235%endif
[11577]236    --add-module=nginx-dav-ext-module-%{nginx_dav_ext_module_version} \
[3847]237%ifarch i686
238    --with-cpu-opt=pentiumpro \
239    --with-zlib-asm=pentiumpro \
240    --with-md5-asm \
241    --with-sha1-asm \
[3785]242%endif
[7655]243"
244
245
246## build with passenger
247./configure \
248    $CONFIGOPTS \
249    --with-cc-opt="%{optflags}" \
[9935]250    --add-module=passenger-%{passenger_version}/src/nginx_module
[7655]251
[3847]252make %{?_smp_mflags}
253mv objs/nginx objs/nginx.passenger
254
255## build without passenger
256./configure \
[7655]257    $CONFIGOPTS \
258    --with-cc-opt="%{optflags}"
259
[521]260make %{?_smp_mflags}
261
262%install
263rm -rf %{buildroot}
264make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
265find %{buildroot} -type f -name .packlist -exec rm -f {} \;
266find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
267find %{buildroot} -type f -empty -exec rm -f {} \;
268find %{buildroot} -type f -exec chmod 0644 {} \;
269find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
[3847]270mv  %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
271%{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
272chmod 0755 %{buildroot}%{_sbindir}/nginx.*
[521]273%{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
274%{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
275%{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
276%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
[854]277%{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
278%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
[521]279%{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
[6601]280%{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
281%{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
[854]282%{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
283%{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
284%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
[521]285%{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
286%{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
287%{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
288%{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
289%{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
290%{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
291%{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
292%{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
293
[3785]294%if %{with wsgi}
295%{__install} -p -m 0644 \
296    lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
297    %{buildroot}%{nginx_confdir}
298cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
299%endif
300
[3906]301# upstream fair module document
302cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
303
[11577]304# document for nginx-dav-ext-module
305cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/LICENSE LICENSE.dav-ext-module
306cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/README.rst README.dav-ext-module.rst
307
[854]308touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
309
[521]310# convert to UTF-8 all files that give warnings.
311for textfile in CHANGES
312do
313    mv $textfile $textfile.old
314    iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
315    rm -f $textfile.old
316done
317
318%clean
319rm -rf %{buildroot}
320
321%post
322if [ $1 == 1 ]; then
323    /sbin/chkconfig --add %{name}
324fi
[3847]325update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
[521]326
[3847]327%post passenger
328update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
329
[521]330%preun
331if [ $1 = 0 ]; then
332    /sbin/service %{name} stop >/dev/null 2>&1
333    /sbin/chkconfig --del %{name}
[3847]334    update-alternatives --remove nginx %{_sbindir}/nginx.normal
[521]335fi
336
[3847]337%preun passenger
338if [ $1 = 0 ]; then
339    update-alternatives --remove nginx %{_sbindir}/nginx.passenger
340fi
341
342
[521]343%postun
344if [ $1 == 2 ]; then
345    /sbin/service %{name} upgrade || :
346fi
347
348%files
349%defattr(-,root,root,-)
[11577]350%doc LICENSE CHANGES README LICENSE.dav-ext-module
[3906]351%doc README.upstream_fair
[11577]352%doc README.dav-ext-module.rst
[3906]353%doc %{?with_wsgi:README.mod_wsgi}
[521]354%{nginx_datadir}/
[3847]355%{_sbindir}/%{name}.normal
[521]356%{_mandir}/man3/%{name}.3pm.gz
357%{_initrddir}/%{name}
358%dir %{nginx_confdir}
359%dir %{nginx_confdir}/conf.d
360%config(noreplace) %{nginx_confdir}/conf.d/*.conf
[854]361%ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
362%config(noreplace) %{nginx_confdir}/sites.d/*
[521]363%config(noreplace) %{nginx_confdir}/win-utf
364%config(noreplace) %{nginx_confdir}/%{name}.conf.default
365%config(noreplace) %{nginx_confdir}/mime.types.default
366%config(noreplace) %{nginx_confdir}/fastcgi_params
367%config(noreplace) %{nginx_confdir}/fastcgi_params.default
368%config(noreplace) %{nginx_confdir}/koi-win
369%config(noreplace) %{nginx_confdir}/koi-utf
370%config(noreplace) %{nginx_confdir}/%{name}.conf
371%config(noreplace) %{nginx_confdir}/mime.types
[854]372%config(noreplace) %{nginx_confdir}/fastcgi.conf
373%config(noreplace) %{nginx_confdir}/fastcgi.conf.default
[1898]374%config(noreplace) %{nginx_confdir}/scgi_params
375%config(noreplace) %{nginx_confdir}/scgi_params.default
376%config(noreplace) %{nginx_confdir}/uwsgi_params
377%config(noreplace) %{nginx_confdir}/uwsgi_params.default
[3785]378%if %{with wsgi}
379%config(noreplace) %{nginx_confdir}/wsgi_vars
380%endif
[521]381%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
382%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
383%dir %{perl_vendorarch}/auto/%{name}
384%{perl_vendorarch}/%{name}.pm
385%{perl_vendorarch}/auto/%{name}/%{name}.so
386%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
387%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
[854]388%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
[521]389%attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
390
[3847]391%files passenger
392%defattr(-,root,root,-)
[8386]393%doc passenger-%{passenger_version}/doc/*.md
[7655]394%doc passenger-%{passenger_version}/doc/*.txt
395%doc passenger-%{passenger_version}/doc/*.html
[8386]396%doc passenger-%{passenger_version}/doc/templates
[3847]397%doc passenger-%{passenger_version}/doc/users_guide_snippets
398%doc passenger-%{passenger_version}/doc/images
399%{_sbindir}/%{name}.passenger
[521]400
[3847]401
[521]402%changelog
[11873]403* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
404- updated to 1.15.5.
405- updated passenger to 5.3.6.
406- updated ngx_fancyindex_version to 0.4.3.
407
[11577]408* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.9-1
409- updated to 1.13.9.
410- updated ngx-fancyindex to 0.4.2.
411- updated nginx-accept_language_module to git HEAD.
412- updated nginx-upstream-fair to git HEAD.
413- updated passenger to 5.2.1.
414- added Source2010 (nginx-dav-ext-module).
415- enabled --with-stream and --with-stream_ssl_preread_module.
416
[11181]417* Fri Sep  8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.5-1
418- updated to 1.13.5
419- updated passenger to 5.1.8
420
[11143]421* Fri Aug 11 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.4-1
422- updated to 1.13.4
423- updated passenger to 5.1.7
424
[11130]425* Fri Jul 14 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.3-1
426- updated to 1.13.3
427
[11124]428* Sat Jul  1 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.2-1
429- updated to 1.13.2
430
[11115]431* Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.1-1
432- updated to 1.13.1
433- updated passenger to 5.1.5
434
435* Wed Apr 26 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.0-1
436- updated to 1.13.0
437
[10984]438* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
439- updated to 1.11.13
440
[10977]441* Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
442- updated to 1.11.12
443
[10925]444* Tue Mar  7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
445- updated to 1.11.10
446- updated passenger to 5.1.2
447
448* Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
449- updated to 1.11.9
450
[10868]451* Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
452- updated to 1.11.8
453
[10824]454* Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
455- updated to 1.11.6
456- applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
457
[10778]458* Mon Sep  5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
459- updated to 1.11.3
460- updated passenger to 5.0.30
461
[10767]462* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
463- rebuild with gcc-5.4.0
464
[10356]465* Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
466- updated to 1.10.1.
467- updated passenger to 5.0.28.
468
[10205]469* Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
470- updated to 1.9.15
471
[10124]472* Thu Apr  7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
473- updated to 1.9.14
474- updated passenger to 5.0.27
475
[10122]476* Wed Apr  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
477- new upstream release
478
[10074]479* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
480- updated to 1.9.12.
481- updated passenger to 5.0.26.
482
[10033]483* Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
484- new upstream release
485
[10003]486* Wed Feb  3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
487- update to 1.9.10
488- update passenger to 5.0.24
489
[9935]490* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
491- update passenger to 5.0.23
492
493* Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
494- new upstream release
495
496* Sat Dec  5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
497- new upstream release
498
499* Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
500- new upstream release
501
[9712]502* Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
503- new upstream release
504
505* Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
506- update to 1.9.3
507- update passenger to 5.0.11
508
[9624]509* Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
510- updated Source4 (ssl.conf).
511
[9619]512* Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
513- update to 1.9.2
514- update passenger to 5.0.10
515- update ngx-fancyindex to 0.3.5
516
[8983]517* Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
518- update to 1.6.2
519- update passenger to 4.0.52
520
[9619]521* Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
[8893]522- new upstream release
523
[8754]524* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
525- rebuild with new environment
526
527* Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
528- update passenger to 4.0.45
529
[8386]530* Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
531- update to 1.6.0 (stable)
532
[8275]533* Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
534- update fancyindex to 0.3.3
535
[8257]536* Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
537- update to 1.5.10
538- update passenger to 4.0.37
539
[8125]540* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
541- rebuilt with GeoIP-1.6.0.
542- added Patch100.
543
[7947]544* Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
545- update to 1.5.6
546- update passenger to 4.0.21
547
[7856]548* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
549- rebuilt with gd-2.1.0.
550
[7662]551* Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
552- update to 1.4.1
553
[7655]554* Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
555- update to 1.4.0
556- enable SPDY module
557
[7472]558* Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
559- new upstream release
560- update passenger to 3.0.19
561- update ngx-fancyindex to upstream git master
562
[7199]563* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
564- new upstream release
565- update passenger to 3.0.17
566
[6997]567* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
568- rebuild with pcre-8.31
569
[6903]570* Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
571- added http_geoip_module.
572
[6847]573* Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
574- update to 1.2.4
575
[6601]576* Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
577- update to 1.2.2
578
579* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
580- update to 1.2.1
581- change nginx user from nginx to www-data
582- R(pre): www-common
583
[6028]584* Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
585- update to 1.2.0
586- update passenger to 3.0.12
587- drop http_upstream_keepalive
588
[5922]589* Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
590- new upstream release
591
[5741]592* Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
593- update to 1.0.12
594
[5388]595* Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
596- update to 1.0.11
597- update passenger to 3.0.11
598
[5167]599* Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
600- update to 1.0.10
601
602* Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
603- update passenger to 3.0.9
604
[4684]605* Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
606- update to 1.0.6
607
[4093]608* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
609- update to 1.0.4
610
[3906]611* Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
612- add gnosek-nginx-upstream-fair module
613- add ngx_http_upstream_keepalive module
614
[3847]615* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
616- add nginx-passenger sub pakckage
617  - use alternatives to choose nginx with or without passenger
618  - add BR: ruby, rubygems, rubygem-rake
619
[3844]620* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
621- update to 1.0.2
622
[3785]623* Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
624- update to 1.0.1
625
626* Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
627- add bcond_with wsgi for mod_wsgi
628- add bcond_with passenger
629  - you need to install rake.gem to build with this option.
630- add Provides: webserver
631
[3419]632* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
633- new upstream release 1.0.0!
634
[3146]635* Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
636- rebuild with perl-5.12.3
637
[2525]638* Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
639- update to 0.8.54
640
[2236]641* Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
642- update to 0.8.53
643- add nginx_accept_language_module
644
[7472]645* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
[1898]646- update to 0.8.50
647- update ngx-fancyindex to 0.3
648- add BR: libxml2-devel, libxslt-devel
649- add scgi_params* and uwsgi_params* to %%files
650
[854]651* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
652- update to 0.8.35 (development version)
653- add sites.d/ to store vitualhost settings
654- split out default server settings to sites.d/default
655- add fancyindex module
656
[7472]657* Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
[521]658- new upstream release
659
660* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
661- update to 0.7.62 (included security fix: VU#180065)
662
663* Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
664- fix typo
665
666* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
667- add translated descriptions
668
669* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
670- update 404.html/50x.html to use powered by vine logo.
671
672* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
673- initial build for Vine Linux
674- update to 0.7.61
675
676* Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
677- init script updates from Gena Makhomed
678- remove nginx-upstream-fair
679
680* Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
681-  update to 0.6.36
682
683* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
684- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
685
686* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
687- rebuild
688
689* Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
690- update to 0.6.35
691
692* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
693- rebuild with new openssl
694
695* Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
696- update to 0.6.34
697
698* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
699- Fix inclusion of /usr/share/nginx tree => no unowned directories.
700
701* Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
702- update to 0.6.33
703
704* Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
705- update to 0.6.32
706- nginx now supports DESTDIR so removed the patches that enabled it
707
708* Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
709- init script fixes
710- resolve 'listen 80 default' [#447873]
711
712* Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
713- update to 0.6.31
714
715* Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
716- upate to new upstream stable branch 0.6
717- added 3rd party module nginx-upstream-fair
718- added default webpages
719
720* Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
721- update init script to match recommended guidelines
722- add /etc/nginx/conf.d support [#443280]
723- use /etc/sysconfig/nginx to determine nginx.conf [#442708]
724
725* Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
726- add Requires for versioned perl (libperl.so)
727- drop silly file Requires
728
729* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
730- Autorebuild for GCC 4.3
731
732* Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
733- update to 0.5.35
734
735* Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
736- update to 0.5.34
737
738* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
739 - Rebuild for deps
740
741* Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
742- update to 0.5.33
743
744* Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
745- updated to 0.5.32
746- fixed rpmlint UTF-8 complaints.
747
748* Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
749- added --with-http_stub_status_module build option.
750- added --with-http_sub_module build option.
751- added use of pcre-config --cflags
752
753* Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
754- Update to 0.5.31
755- specify license is BSD
756
757* Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
758- Add BuildRequires: perl-devel - fixing rawhide build
759
760* Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
761- Update to 0.5.30
762
763* Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
764- Update to 0.5.29
765
766* Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
767- Update to 0.5.28
768
769* Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
770- Update to 0.5.27
771
772* Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
773- Update to 0.5.26
774
775* Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
776- Update to 0.5.19
777
778* Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
779- Update to 0.5.17
780
781* Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
782- Update to 0.5.16
783- add ownership of /usr/share/nginx/html (#233950)
784
785* Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
786- fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
787
788* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
789- fixed package review bugs (#233522) given by kevin@tummy.com
790
791* Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
792- create patches to assist with building for Fedora
793- initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.