source: projects/specs/trunk/n/nghttp2/nghttp2-vl.spec @ 12131

Revision 12131, 9.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

RevLine 
[10631]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
[10358]3%bcond_with test
[11294]4%bcond_without app
[10358]5
[10932]6%define _unpackaged_files_terminate_build 1
7
[10358]8Summary: Experimental HTTP/2 client, server and proxy
9Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
10Name: nghttp2
[12131]11Version: 1.39.2
[11610]12Release: 1%{?_dist_release}
[10358]13License: MIT
14Group: Applications/Internet
15URL: https://nghttp2.org/
[10559]16
17Vendor: Project Vine
18Distribution: Vine Linux
[10932]19Packager: tomop
[10559]20
[10358]21Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
22
23%if %{with test}
24BuildRequires: CUnit-devel
25%endif
26BuildRequires: jemalloc-devel
27BuildRequires: libboost-devel
28BuildRequires: libboost-thread
29BuildRequires: libev-devel
30BuildRequires: openssl-devel
31BuildRequires: zlib-devel
32
[10932]33%if %{with app}
[10358]34Requires: libnghttp2 = %{version}-%{release}
[11294]35BuildRequires: c-ares-devel
[10932]36BuildRequires: jansson-devel
37BuildRequires: libxml2-devel
38%endif
[10358]39
40%description
41This package contains the HTTP/2 client, server and proxy programs.
42
43%description -l ja
44This package contains the HTTP/2 client, server and proxy programs.
45 このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
46が含まれています。
47
48
49%package -n libnghttp2
50Summary: A library implementing the HTTP/2 protocol
51Summary(ja): HTTP/2ライブラリ
52Group: Development/Libraries
53
54%description -n libnghttp2
55libnghttp2 is a library implementing the Hypertext Transfer Protocol
56version 2 (HTTP/2) protocol in C.
57
58%description -l ja -n libnghttp2
59 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
60実装したライブラリです。
61
62
63%package -n libnghttp2-devel
64Summary: Files needed for building applications with libnghttp2
65Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
66Group: Development/Libraries
67Requires: libnghttp2%{?_isa} = %{version}-%{release}
68Requires: pkgconfig
69
70%description -n libnghttp2-devel
71The libnghttp2-devel package includes libraries and header files needed
72for building applications with libnghttp2.
73
74%description -l ja -n libnghttp2-devel
75 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
76をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
77す。
78
79
[10631]80%package -n compat32-libnghttp2
81Summary: A library implementing the HTTP/2 protocol
82Summary(ja): HTTP/2ライブラリ
83Group: Development/Libraries
84
85%description -n compat32-libnghttp2
86libnghttp2 is a library implementing the Hypertext Transfer Protocol
87version 2 (HTTP/2) protocol in C.
88
89%description -l ja -n compat32-libnghttp2
90 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
91実装したライブラリです。
92
93
94%package -n compat32-libnghttp2-devel
95Summary: Files needed for building applications with libnghttp2
96Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
97Group: Development/Libraries
98Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
99Requires: pkgconfig
100
101%description -n compat32-libnghttp2-devel
102The libnghttp2-devel package includes libraries and header files needed
103for building applications with libnghttp2.
104
105%description -l ja -n compat32-libnghttp2-devel
106 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
107をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
108す。
109
110
[10358]111%prep
112%setup -q
113
114
115%build
116CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"    \
117CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"  \
118%configure                                  \
[10932]119%if %{with app}
[10358]120    --enable-app                            \
[10932]121%endif
122        --enable-asio-lib                       \
[10358]123    --with-pic                              \
124    --with-boost                            \
125    --with-boost-asio                       \
126    --with-boost-system                     \
127    --with-boost-thread                     \
128    --disable-python-bindings               \
129    --disable-static                        \
130    --without-libxml2                       \
131    --without-spdylay
132
133# avoid using rpath
134sed -i libtool                              \
135    -e 's/^runpath_var=.*/runpath_var=/'    \
136    -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
137
138make %{?_smp_mflags} V=1
139
140
141%install
142%make_install
143
144# not needed on Fedora/RHEL
[10932]145rm -f %{buildroot}%{_libdir}/libnghttp2*.la
[10358]146
147# will be installed via %%doc
[10932]148rm -f "%{buildroot}%{_datadir}/doc/nghttp2/README.rst"
[10358]149
[10932]150%if ! %{with app}
151rm -f %{buildroot}%{_mandir}/man1/*
152%endif
153
154
[10631]155%post -n libnghttp2
156/sbin/ldconfig
[10358]157
[10631]158%postun -n libnghttp2
159/sbin/ldconfig
[10358]160
[10631]161%post -n compat32-libnghttp2
162/sbin/ldconfig
[10358]163
[10631]164%postun -n compat32-libnghttp2
165/sbin/ldconfig
166
167
[10358]168%check
169%if %{with test}
170# test the just built library instead of the system one, without using rpath
[10932]171export "LD_LIBRARY_PATH=%{buildroot}%{_libdir}:$LD_LIBRARY_PATH"
[10358]172make %{?_smp_mflags} check
173%endif
174
[10932]175%if %{with app}
[10358]176%files
177%{_bindir}/h2load
178%{_bindir}/nghttp
179%{_bindir}/nghttpd
180%{_bindir}/nghttpx
[11294]181%{_bindir}/deflatehd
182%{_bindir}/inflatehd
[10358]183%{_datadir}/nghttp2
184%{_mandir}/man1/h2load.1*
185%{_mandir}/man1/nghttp.1*
186%{_mandir}/man1/nghttpd.1*
187%{_mandir}/man1/nghttpx.1*
[10932]188%endif
[10358]189
190%files -n libnghttp2
191%{_libdir}/libnghttp2*.so.*
[10932]192%{_datadir}/%{name}/fetch-ocsp-response
[10358]193%{!?_licensedir:%global license %%doc}
194%license COPYING
195
196%files -n libnghttp2-devel
197%{_includedir}/nghttp2
198%{_libdir}/pkgconfig/libnghttp2*.pc
199%{_libdir}/libnghttp2*.so
200%doc README.rst
201
[10631]202%if %{build_compat32}
203%files -n compat32-libnghttp2
204%{_libdir}/libnghttp2*.so.*
205%{!?_licensedir:%global license %%doc}
206%license COPYING
[10358]207
[10631]208%files -n compat32-libnghttp2-devel
209%{_includedir}/nghttp2
210%{_libdir}/pkgconfig/libnghttp2*.pc
211%{_libdir}/libnghttp2*.so
212%doc README.rst
213%endif
214
[10358]215%changelog
[12131]216* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.39.2-1
217- new upstream release.
218
[11839]219* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.34.0-1
220- new upstream release.
221
[11610]222* Fri Mar 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31.0-1
223- new upstream release.
224
[11349]225* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-2
226- rebuilt with libboost-1.66.0.
227
[11294]228* Sun Dec 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-1
229- new upstream release.
230- enabled to build apps as default.
231
[11061]232* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
233- new upstream release.
234
[10932]235* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.0-1
236- new upstream release.
237- disabled to build apps as default.
238
[10851]239* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.0-1
240- new upstream release.
241
[10631]242* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
243- added compat32-* packages.
244
[10559]245* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
246- new upstream release.
247
[10358]248* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
249- initial build for Vne Linux.
250
251* Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
252- update to the latest upstream release
253
254* Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
255- update to the latest upstream release
256
257* Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
258- update to the latest upstream release
259
260* Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
261- update to the latest upstream release
262
263* Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
264- update to the latest upstream release
265
266* Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
267- update to the latest upstream release
268
269* Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
270- update to the latest upstream release (fixes CVE-2016-1544)
271
272* Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
273- make the package compile with gcc-6
274
275* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
276- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
277
278* Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
279- update to the latest upstream release
280
281* Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
282- update to the latest upstream release (fixes CVE-2015-8659)
283
284* Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
285- update to the latest upstream release
286
287* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
288- update to the latest upstream release
289
290* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
291- update to the latest upstream release
292
293* Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
294- update to the latest upstream release
295
296* Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
297- update to the latest upstream release
298
299* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
300- update to the latest upstream release
301
302* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
303- update to the latest upstream release
304
305* Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
306- update to the latest upstream release
307
308* Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
309- update to the latest upstream release
310
311* Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
312- update to the latest upstream release
313
314* Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
315- packaged for Fedora (#1237247)
Note: See TracBrowser for help on using the repository browser.