source: projects/specs/trunk/n/newt/newt-vl.spec @ 8831

Revision 8831, 10.7 KB checked in by daisuke, 10 years ago (diff)

newt: update to 0.52.17

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary: A development library for text mode user interfaces.
5Summary(ja): テキストモードインターフェースのための開発ライブラリ
6Name: newt
7Version: 0.52.17
8Release: 1%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11URL: https://fedorahosted.org/newt/
12
13Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
14# patches from mdv
15Patch1: newt-0.51.4-fix-wstrlen-for-non-utf8-strings.patch
16
17# patches from ubuntu
18Patch10: newt-python_memory_allocation.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: python-devel, popt-devel, slang-devel
22Provides: snack = %{version}-%{release}
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: daisuke
27
28
29%description
30Newt is a programming library for color text mode, widget based user
31interfaces.  Newt can be used to add stacked windows, entry widgets,
32checkboxes, radio buttons, labels, plain text fields, scrollbars,
33etc., to text mode user interfaces.  This package also contains the
34shared library needed by programs built with newt, as well as a
35/usr/bin/dialog replacement called whiptail.  Newt is based on the
36slang library.
37
38
39%package devel
40Summary: Newt windowing toolkit development files.
41Summary(ja): Newt ウィンドウツールキット開発ファイル集
42Requires: slang-devel %{name} = %{version}
43Group: Development/Libraries
44
45
46%description devel
47The newt-devel package contains the header files and libraries
48necessary for developing applications which use newt.  Newt is a
49development library for text mode user interfaces.  Newt is based on
50the slang library.
51
52Install newt-devel if you want to develop applications which will use
53newt.
54
55
56## to build compat32 for x86_64 architecture support
57%package -n compat32-%{name}
58Summary: A development library for text mode user interfaces.
59Group: System Environment/Libraries
60%description -n compat32-%{name}
61Newt is a programming library for color text mode, widget based user
62interfaces.  Newt can be used to add stacked windows, entry widgets,
63checkboxes, radio buttons, labels, plain text fields, scrollbars,
64etc., to text mode user interfaces.  This package also contains the
65shared library needed by programs built with newt, as well as a
66/usr/bin/dialog replacement called whiptail.  Newt is based on the
67slang library.
68
69%package -n compat32-%{name}-devel
70Summary: Newt windowing toolkit development files.
71Group: Development/Libraries
72Requires: compat32-%{name} = %{version}
73%description -n compat32-%{name}-devel
74The newt-devel package contains the header files and libraries
75necessary for developing applications which use newt.  Newt is a
76development library for text mode user interfaces.  Newt is based on
77the slang library.
78
79Install newt-devel if you want to develop applications which will use
80newt.
81
82
83%prep
84%setup -q -n %{name}-%{version}
85%patch1 -p1 -b .fix-wstrlen-for-non-utf8-strings
86%patch10 -p1 -b .python_memory_allocation
87
88%build
89%if %{build_compat32}
90export CC='gcc -m32'
91%configure --without-tcl
92make CC='gcc -m32'
93#make CC='gcc -m32' shared
94%else
95%configure --without-tcl
96make
97make shared
98%endif
99chmod 0644 peanuts.py popcorn.py
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make instroot=$RPM_BUILD_ROOT install
104
105%find_lang %{name}
106
107%post -p /sbin/ldconfig
108
109%postun -p /sbin/ldconfig
110
111%if %{build_compat32}
112%post -n compat32-%{name} -p /sbin/ldconfig
113%postun -n compat32-%{name} -p /sbin/ldconfig
114%endif
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%files -f %{name}.lang
120%defattr (-,root,root)
121%doc CHANGES COPYING
122%{_libdir}/libnewt.so.*
123%{_bindir}/whiptail
124%{python_sitearch}/*.py*
125%{python_sitearch}/*.so
126%{_mandir}/man1/whiptail.1*
127
128%files devel
129%defattr (-,root,root)
130%doc tutorial.sgml peanuts.py popcorn.py
131%{_includedir}/newt.h
132%{_libdir}/libnewt.a
133%{_libdir}/libnewt.so
134%{_libdir}/pkgconfig/libnewt.pc
135
136%if %{build_compat32}
137%files -n compat32-%{name}
138%defattr (-,root,root)
139%{_libdir}/libnewt.so.*
140
141%files -n compat32-%{name}-devel
142%defattr (-,root,root)
143%{_libdir}/libnewt.a
144%{_libdir}/libnewt.so
145%endif
146
147
148%changelog
149* Tue Jul 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.52.17-1
150- update to 0.52.17
151
152* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.52.14-1
153- new upstram release
154
155* Thu Oct 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.13-1
156- new upstram release
157
158* Sat Jun 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-2
159- add patch2,3 from mdv
160- add patch10 from ubuntu
161
162* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-1
163- update to 0.52.12
164- add patch0: don't hang in form when stdin disappears
165- remove patch100, fixed in upstream
166
167* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
168- rebuilt with recent environment.
169
170* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
171- rebuilt with gcc-4.4.3-3 on ppc
172
173* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
174- rebuilt with rpm-4.8.0-3 (on ppc)
175
176* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
177- rebuilt with python-2.6.4
178
179* Thu Oct  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
180- fix build_compat32 if-endif
181
182* Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
183- add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
184
185* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
186- new upstream release
187- use %%python_sitearch macro
188- remove --with-gpm-support
189- drop obsolete patches
190
191* Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
192- rebuild to fix dependency problem on x86_64 architecture
193
194* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
195- added BuildRequires: slang-devel
196- added newt-0.50.35-Makefile.in.patch
197- updated newt-0.50.35-make.patch
198- changed /usr/lib to %%{_libdir}
199- added compat32-* packages for x86_64 architecture support
200
201* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
202- rebuild with python-2.4.1-0vl1
203
204* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
205- rebuild with python-2.3.3-0vl1
206
207* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
208- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
209
210* Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
211- build against python-2.2
212- drop Patch20
213
214* Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
215- updated to new upstream release 0.50.35
216- updated Patch11 and added Patch20
217  (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
218
219* Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
220- update to new upstream release
221
222* Mon Jul  2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
223- 0.50.22-0vl1
224- updated to 0.50.22
225- use Release No for Vine Linux
226- use better macros
227- bytecompile the snack python module
228
229* Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
230- fix spec file
231
232* Sat Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
233- added Japanese support patch
234
235* Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
236- added suspend/resume to snack
237
238* Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
239- enable gpm support
240
241* Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
242- added hotkey assignment for gridforms, changed listbox.setcurrent to
243  take the item key
244
245* Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
246- fixed snack callback function refcounts, as well as optional data args
247- fixed suspend callback ref counts
248
249* Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
250- added buttons argument to entrywindow
251
252* Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
253- multi-state checkboxtrees. Woohoo.
254
255* Mon Aug  9 1999 Matt Wilson <msw@redhat.com>
256- added snack wrappings for checkbox flag setting
257
258* Thu Aug  5 1999 Matt Wilson <msw@redhat.com>
259- added snack bindings for setting current listbox selection
260- added argument to set default selection in snack ListboxChoiceWindow
261
262* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
263- added checkboxtree
264- improved snack binding
265
266* Fri Apr  9 1999 Matt Wilson <msw@redhat.com>
267- fixed a glibc related bug in reflow that was truncating all text to 1000
268chars
269
270* Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
271- fixed bug that made newt apps crash when you hit <insert> followed by lots
272of keys
273
274* Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
275- fix from Jakub Jelinek for listbox keypresses
276
277* Sat Feb 27 1999 Matt Wilson <msw@redhat.com>
278- fixed support for navigating listboxes with alphabetical keypresses
279
280* Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
281- updated descriptions
282- added support for navigating listboxes with alphabetical keypresses
283
284* Mon Feb  8 1999 Matt Wilson <msw@redhat.com>
285- made grid wrapped windows at least the size of their title bars
286
287* Fri Feb  5 1999 Matt Wilson <msw@redhat.com>
288- Function to set checkbox flags.  This will go away later when I have
289  a generic flag setting function and signals to comps to go insensitive.
290
291* Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
292- Stopped using libgpm, internalized all gpm calls.  Still need some cleanups.
293
294* Thu Jan  7 1999 Matt Wilson <msw@redhat.com>
295- Added GPM mouse support
296- Moved to autoconf to allow compiling without GPM support
297- Changed revision to 0.40
298
299* Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
300- built against slang-1.2.2
301
302* Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
303- bugfixes for text reflow
304- added docs
305
306* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
307- devel package moved to Development/Libraries
308
309* Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
310- removed whiptcl.so -- it should be in a separate package
311
312* Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
313- added newtWinMenu()
314- many bug fixes in grid code
315
316* Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
317- removed newtWinTernary()
318- made newtWinChoice() return codes consistent with newtWinTernary()
319
320* Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
321- added changes from Bruce Perens
322    - small cleanups
323    - lets whiptail automatically resize windows
324- the order of placing a grid and adding components to a form no longer
325  matters
326- added newtGridAddComponentsToForm()
327
328* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
329- added newtWinTernary()
330
331* Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
332- made Make/spec files use a buildroot
333- added grid support (for newt 0.11 actually)
334
335* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
336- Added patched from Clarence Smith for setting the size of a listbox
337- Version 0.9
338
339* Wed May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
340- Touchups on Makefile
341- Cleaned up NEWT_FLAGS_*
342
343* Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
344- Cleaned up listbox
345- Added whiptail
346- Added newtButtonCompact button type and associated colors
347- Added newtTextboxGetNumLines() and newtTextboxSetHeight()
348
349* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
350- Added changes from sopwith for C++ cleanliness and some listbox fixes.
351
Note: See TracBrowser for help on using the repository browser.