source: projects/specs/trunk/n/newt/newt-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary: A development library for text mode user interfaces.
5Summary(ja): テキストモードインターフェースのための開発ライブラリ
6Name: newt
7Version: 0.52.10
8Release: 6%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11URL: https://fedorahosted.org/newt/
12
13Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
14# Security fix
15Patch100: newt-0.52.10-reflowbuffer.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
21BuildRequires: python-devel, popt-devel, slang-devel
22Provides: snack = %{version}-%{release}
23
24
25%description
26Newt is a programming library for color text mode, widget based user
27interfaces.  Newt can be used to add stacked windows, entry widgets,
28checkboxes, radio buttons, labels, plain text fields, scrollbars,
29etc., to text mode user interfaces.  This package also contains the
30shared library needed by programs built with newt, as well as a
31/usr/bin/dialog replacement called whiptail.  Newt is based on the
32slang library.
33
34
35%package devel
36Summary: Newt windowing toolkit development files.
37Summary(ja): Newt ウィンドウツールキット開発ファイル集
38Requires: slang-devel %{name} = %{version}
39Group: Development/Libraries
40
41
42%description devel
43The newt-devel package contains the header files and libraries
44necessary for developing applications which use newt.  Newt is a
45development library for text mode user interfaces.  Newt is based on
46the slang library.
47
48Install newt-devel if you want to develop applications which will use
49newt.
50
51
52## to build compat32 for x86_64 architecture support
53%package -n compat32-%{name}
54Summary: A development library for text mode user interfaces.
55Group: System Environment/Libraries
56%description -n compat32-%{name}
57Newt is a programming library for color text mode, widget based user
58interfaces.  Newt can be used to add stacked windows, entry widgets,
59checkboxes, radio buttons, labels, plain text fields, scrollbars,
60etc., to text mode user interfaces.  This package also contains the
61shared library needed by programs built with newt, as well as a
62/usr/bin/dialog replacement called whiptail.  Newt is based on the
63slang library.
64
65%package -n compat32-%{name}-devel
66Summary: Newt windowing toolkit development files.
67Group: Development/Libraries
68Requires: compat32-%{name} = %{version}
69%description -n compat32-%{name}-devel
70The newt-devel package contains the header files and libraries
71necessary for developing applications which use newt.  Newt is a
72development library for text mode user interfaces.  Newt is based on
73the slang library.
74
75Install newt-devel if you want to develop applications which will use
76newt.
77
78
79%prep
80%setup -q -n %{name}-%{version}
81
82%patch100 -p1 -b .CVE-2009-2905
83
84%build
85%if %{build_compat32}
86export CC='gcc -m32'
87%configure --without-tcl
88make CC='gcc -m32'
89#make CC='gcc -m32' shared
90%else
91%configure --without-tcl
92make
93make shared
94%endif
95chmod 0644 peanuts.py popcorn.py
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make instroot=$RPM_BUILD_ROOT install
100
101%find_lang %{name}
102
103%post -p /sbin/ldconfig
104
105%postun -p /sbin/ldconfig
106
107%if %{build_compat32}
108%post -n compat32-%{name} -p /sbin/ldconfig
109%postun -n compat32-%{name} -p /sbin/ldconfig
110%endif
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files -f %{name}.lang
116%defattr (-,root,root)
117%doc CHANGES COPYING
118%{_libdir}/libnewt.so.*
119%{_bindir}/whiptail
120%{python_sitearch}/*.py*
121%{python_sitearch}/*.so
122%{_mandir}/man1/whiptail.1*
123
124%files devel
125%defattr (-,root,root)
126%doc tutorial.sgml peanuts.py popcorn.py
127%{_includedir}/newt.h
128%{_libdir}/libnewt.a
129%{_libdir}/libnewt.so
130
131%if %{build_compat32}
132%files -n compat32-%{name}
133%defattr (-,root,root)
134%{_libdir}/libnewt.so.*
135%{python_sitearch}/*.py*
136%{python_sitearch}/*.so
137
138%files -n compat32-%{name}-devel
139%defattr (-,root,root)
140%{_libdir}/libnewt.a
141%{_libdir}/libnewt.so
142%endif
143
144
145%changelog
146* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
147- rebuilt with gcc-4.4.3-3 on ppc
148
149* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
150- rebuilt with rpm-4.8.0-3 (on ppc)
151
152* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
153- rebuilt with python-2.6.4
154
155* Thu Oct  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
156- fix build_compat32 if-endif
157
158* Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
159- add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
160
161* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
162- new upstream release
163- use %%python_sitearch macro
164- remove --with-gpm-support
165- drop obsolete patches
166
167* Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
168- rebuild to fix dependency problem on x86_64 architecture
169
170* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
171- added BuildRequires: slang-devel
172- added newt-0.50.35-Makefile.in.patch
173- updated newt-0.50.35-make.patch
174- changed /usr/lib to %%{_libdir}
175- added compat32-* packages for x86_64 architecture support
176
177* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
178- rebuild with python-2.4.1-0vl1
179
180* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
181- rebuild with python-2.3.3-0vl1
182
183* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
184- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
185
186* Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
187- build against python-2.2
188- drop Patch20
189
190* Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
191- updated to new upstream release 0.50.35
192- updated Patch11 and added Patch20
193  (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
194
195* Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
196- update to new upstream release
197
198* Mon Jul  2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
199- 0.50.22-0vl1
200- updated to 0.50.22
201- use Release No for Vine Linux
202- use better macros
203- bytecompile the snack python module
204
205* Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
206- fix spec file
207
208* Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
209- added Japanese support patch
210
211* Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
212- added suspend/resume to snack
213
214* Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
215- enable gpm support
216
217* Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
218- added hotkey assignment for gridforms, changed listbox.setcurrent to
219  take the item key
220
221* Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
222- fixed snack callback function refcounts, as well as optional data args
223- fixed suspend callback ref counts
224
225* Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
226- added buttons argument to entrywindow
227
228* Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
229- multi-state checkboxtrees. Woohoo.
230
231* Mon Aug  9 1999 Matt Wilson <msw@redhat.com>
232- added snack wrappings for checkbox flag setting
233
234* Thu Aug  5 1999 Matt Wilson <msw@redhat.com>
235- added snack bindings for setting current listbox selection
236- added argument to set default selection in snack ListboxChoiceWindow
237
238* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
239- added checkboxtree
240- improved snack binding
241
242* Fri Apr  9 1999 Matt Wilson <msw@redhat.com>
243- fixed a glibc related bug in reflow that was truncating all text to 1000
244chars
245
246* Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
247- fixed bug that made newt apps crash when you hit <insert> followed by lots
248of keys
249
250* Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
251- fix from Jakub Jelinek for listbox keypresses
252
253* Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
254- fixed support for navigating listboxes with alphabetical keypresses
255
256* Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
257- updated descriptions
258- added support for navigating listboxes with alphabetical keypresses
259
260* Mon Feb  8 1999 Matt Wilson <msw@redhat.com>
261- made grid wrapped windows at least the size of their title bars
262
263* Fri Feb  5 1999 Matt Wilson <msw@redhat.com>
264- Function to set checkbox flags.  This will go away later when I have
265  a generic flag setting function and signals to comps to go insensitive.
266
267* Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
268- Stopped using libgpm, internalized all gpm calls.  Still need some cleanups.
269
270* Thu Jan  7 1999 Matt Wilson <msw@redhat.com>
271- Added GPM mouse support
272- Moved to autoconf to allow compiling without GPM support
273- Changed revision to 0.40
274
275* Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
276- built against slang-1.2.2
277
278* Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
279- bugfixes for text reflow
280- added docs
281
282* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
283- devel package moved to Development/Libraries
284
285* Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
286- removed whiptcl.so -- it should be in a separate package
287
288* Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
289- added newtWinMenu()
290- many bug fixes in grid code
291
292* Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
293- removed newtWinTernary()
294- made newtWinChoice() return codes consistent with newtWinTernary()
295
296* Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
297- added changes from Bruce Perens
298    - small cleanups
299    - lets whiptail automatically resize windows
300- the order of placing a grid and adding components to a form no longer
301  matters
302- added newtGridAddComponentsToForm()
303
304* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
305- added newtWinTernary()
306
307* Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
308- made Make/spec files use a buildroot
309- added grid support (for newt 0.11 actually)
310
311* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
312- Added patched from Clarence Smith for setting the size of a listbox
313- Version 0.9
314
315* Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
316- Touchups on Makefile
317- Cleaned up NEWT_FLAGS_*
318
319* Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
320- Cleaned up listbox
321- Added whiptail
322- Added newtButtonCompact button type and associated colors
323- Added newtTextboxGetNumLines() and newtTextboxSetHeight()
324
325* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
326- Added changes from sopwith for C++ cleanliness and some listbox fixes.
327
Note: See TracBrowser for help on using the repository browser.