source: projects/specs/trunk/n/network-manager-applet/network-manager-applet-vl.spec @ 8447

Revision 8447, 5.2 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.2

Line 
1%define dbus_version 1.4.20
2%define dbus_glib_version 0.96
3
4%define gtk3_version    3.10.0
5%define wireless_tools_version 29
6%define libnl3_version 3.2.14
7%define ppp_version 2.4.5
8
9%define applet_version 0.9.8.10
10
11#define snapshot .git20090414
12#define applet_snapshot %{nil}
13
14Name: network-manager-applet
15Summary: GNOME applications for use with NetworkManager
16Summary(ja): NetworkManager 用 GNOME アプリケーション
17Version: 0.9.8.10
18Release: 1%{?snapshot}%{?_dist_release}
19Group: Applications/Internet
20License: GPLv2+
21URL: http://www.gnome.org/projects/NetworkManager/
22
23Source: %{name}-%{version}.tar.xz
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27Requires(post): chkconfig
28Requires(preun): chkconfig
29
30Requires: libnm-gtk = %{version}-%{release}
31Requires: NetworkManager >= %{version}
32
33Requires: dbus
34Requires: dbus-glib
35Requires: libnotify
36Requires: gnome-keyring
37Requires: nss
38Requires: gnome-icon-theme
39
40Obsoletes:      NetworkManager-gnome < 0.9.7.0
41Provides:       NetworkManager-gnome = 0.9.7.0
42
43BuildRequires: NetworkManager-glib-devel >= %{version}
44BuildRequires: ModemManager-glib-devel
45BuildRequires: dbus-devel >= %{dbus_version}
46BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
47BuildRequires: gtk3-devel
48BuildRequires: GConf2-devel
49BuildRequires: libgnome-keyring-devel
50BuildRequires: gettext
51BuildRequires: libnotify-devel >= 0.7
52BuildRequires: libgudev1-devel
53BuildRequires: libsecret-devel
54BuildRequires: iso-codes
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: Takemikaduchi
59
60%description
61This package contains GNOME utilities and applications for use with
62NetworkManager, including a panel applet for wireless networks.
63
64
65%package -n libnm-gtk
66Summary:        Private libraries for NetworkManager GUI support
67Group:          Development/Libraries
68Requires:       gtk3 >= %{gtk3_version}
69Obsoletes:      NetworkManager-gtk < 0.9.7.0
70Provides:       NetworkManager-gtk = 0.9.7.0
71
72%description -n libnm-gtk
73This package contains private libraries to be used only by nm-applet and
74the GNOME Control Center.
75
76
77%package -n libnm-gtk-devel
78Summary:        Private header files for NetworkManager GUI support
79Group:          Development/Libraries
80Requires:       libnm-gtk = %{version}-%{release}
81Requires:       gtk3-devel
82Requires:       dbus-glib-devel
83Requires:       pkgconfig
84Obsoletes:      NetworkManager-gtk-devel < 0.9.7.0
85Provides:       NetworkManager-gtk-devel = 0.9.7.0
86
87%description -n libnm-gtk-devel
88This package contains private header and pkg-config files to be used only by
89nm-applet and the GNOME control center.
90
91
92%prep
93%setup -q
94
95%build
96export CFLAGS="$CFLAGS -Wno-error=deprecated-declarations"
97NOCONFIGURE=1 ./autogen.sh
98%configure --disable-static
99make
100 
101%install
102%{__rm} -rf $RPM_BUILD_ROOT
103
104# install the applet
105make install DESTDIR=$RPM_BUILD_ROOT
106
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
108
109mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-vpn-properties
110
111%find_lang nm-applet
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116
117%post
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x /usr/bin/gtk-update-icon-cache ]; then
120  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
121fi
122
123%postun
124touch --no-create %{_datadir}/icons/hicolor
125if [ -x /usr/bin/gtk-update-icon-cache ]; then
126  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
127fi
128if [ $1 -eq 0 ]; then
129  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130fi
131
132%posttrans
133glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
134
135%post -n libnm-gtk -p /sbin/ldconfig
136
137%postun -n libnm-gtk -p /sbin/ldconfig
138
139
140%files -f nm-applet.lang
141%defattr(-,root,root,0755)
142%{_bindir}/nm-applet
143%{_bindir}/nm-connection-editor
144%{_libexecdir}/nm-applet-migration-tool
145%{_datadir}/applications/*.desktop
146%{_datadir}/nm-applet/
147%{_datadir}/GConf/gsettings/nm-applet.convert
148%{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
149%{_datadir}/icons/hicolor/16x16/apps/*.png
150%{_datadir}/icons/hicolor/22x22/apps/*.png
151%{_datadir}/icons/hicolor/32x32/apps/*.png
152%{_datadir}/icons/hicolor/48x48/apps/*.png
153%{_datadir}/icons/hicolor/scalable/apps/*.svg
154%{_sysconfdir}/xdg/autostart/nm-applet.desktop
155%dir %{_datadir}/gnome-vpn-properties
156##%{_libdir}/gnome-bluetooth/plugins/libnma.so
157%{_mandir}/man1/nm-applet.1.gz
158%{_mandir}/man1/nm-connection-editor.1.gz
159
160%files -n libnm-gtk
161%defattr(-,root,root,-)
162%{_libdir}/libnm-gtk.so.*
163%{_libdir}/girepository-1.0/NMGtk-1.0.typelib
164%dir %{_datadir}/libnm-gtk
165%{_datadir}/libnm-gtk/*.ui
166
167%files -n libnm-gtk-devel
168%defattr(-,root,root,-)
169%{_includedir}/libnm-gtk
170%{_libdir}/pkgconfig/libnm-gtk.pc
171%{_libdir}/libnm-gtk.so
172%{_datadir}/gir-1.0/NMGtk-1.0.gir
173
174
175%changelog
176* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.10-1
177- new upstream release
178
179* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.9-1
180- new upstream release
181
182* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.8-1
183- new upstream release
184
185* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.4-1
186- new upstream release
187- remove Patch0 (network-manager-applet--0.9.8.2-git20130801.patch)
188- add BuildRequires: ModemManager-glib-devel
189
190* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.2-2
191- add Patch0 (network-manager-applet--0.9.8.2-git20130801.patch)
192
193* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.2-1
194- update to 0.9.8.2
195- add BuildRequires: libsecret-devel
196
197* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.0-1
198- initial package split from NetworkManager
199
Note: See TracBrowser for help on using the repository browser.