source: projects/specs/trunk/n/nettle271/nettle271-vl.spec @ 9899

Revision 9899, 4.4 KB checked in by iwamoto, 8 years ago (diff)

nettle271: new compatible package nettle271

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define sname nettle
3
4Name:           nettle271
5Version:        2.7.1
6Release:        5%{?_dist_release}
7Summary:        A low-level cryptographic library
8Summary(ja):    低レベル暗号化ライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.lysator.liu.se/~nisse/nettle/
13Source0:        http://www.lysator.liu.se/~nisse/archive/%{sname}-%{version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gmp-devel
17BuildRequires:  m4
18
19Requires(post): /sbin/install-info
20Requires(preun): /sbin/install-info
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25%if %{build_compat32}
26%package -n compat32-%{name}
27Summary:        A low-level cryptographic library
28Summary(ja):    低レベル暗号化ライブラリ
29Group:          System Environment/Libraries
30Requires:       %{name} = %{version}-%{release}
31%endif
32
33%description
34Nettle is a cryptographic library that is designed to fit easily in more
35or less any context: In crypto toolkits for object-oriented languages
36(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
37kernel space.
38
39%if %{build_compat32}
40%description -n compat32-%{name}
41Nettle is a cryptographic library that is designed to fit easily in more
42or less any context: In crypto toolkits for object-oriented languages
43(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
44kernel space.
45%endif
46
47%prep
48%setup -q -n %{sname}-%{version}
49
50%build
51%configure --enable-shared
52make %{?_smp_mflags}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
57make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
58#/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
59#/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
60#/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
61mkdir -p $RPM_BUILD_ROOT%{_infodir}
62install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
63
64chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
65chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
66
67rm -rf %{buildroot}/%{_libdir}/*.a
68rm -rf %{buildroot}/%{_infodir}/dir
69
70%check
71make check
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(-,root,root,-)
78%doc AUTHORS ChangeLog COPYING.LIB NEWS README TODO
79# %{_infodir}/nettle.info.gz
80# %{_bindir}/nettle-hash
81# %{_bindir}/nettle-lfib-stream
82# %{_bindir}/pkcs1-conv
83# %{_bindir}/sexp-conv
84%{_libdir}/libhogweed.so.*
85%{_libdir}/libnettle.so.*
86
87# compat32
88%if %{build_compat32}
89%files -n compat32-%{name}
90%defattr(-, root, root, 0755)
91%{_libdir}/libhogweed.so.*
92%{_libdir}/libnettle.so.*
93%endif
94
95%post
96/sbin/ldconfig
97
98%postun -p /sbin/ldconfig
99
100%if %{build_compat32}
101%post -n compat32-%{name} -p /sbin/ldconfig
102
103%postun -n compat32-%{name} -p /sbin/ldconfig
104%endif
105
106%changelog
107* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.1-5
108- compatible package nettle271
109
110* Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-4
111- fixed Requires typo of compat32-nettle-devel package
112
113* Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
114- moved nettle to System Environment/Libraries Group
115
116* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
117- add compat32,compat32-devel packages
118
119* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
120- update to 2.7.1
121
122* Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
123- initial build for VineSeed
124
125* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
127
128* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
130
131* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
132- Moved static lib to -static
133
134* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
135- Added libraries and ldconfig
136
137* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
138- Added provides -static to -devel
139
140* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
141- Removed redundant requires
142- Removed redundant documentation between packages
143- Fixed license tag
144- Fixed -devel description
145- Added the static library back to -devel
146- Added make clean
147
148* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
149- First package build.
Note: See TracBrowser for help on using the repository browser.