source: projects/specs/trunk/n/nettle/nettle-vl.spec @ 9145

Revision 9145, 6.5 KB checked in by inagaki, 9 years ago (diff)

2014-12-12 Ryoichi INAGAKI <ryo1@…>

  • colord, nettle: fixed compat32-* subpackage
  • hyperestraier: rebuilt
  • pcsc-perl, rcs: updated
  • sbc: added Group


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           nettle
4Version:        2.7.1
5Release:        4%{?_dist_release}
6Summary:        A low-level cryptographic library
7Summary(ja):    低レベル暗号化ライブラリ
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.lysator.liu.se/~nisse/nettle/
12Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  gmp-devel
16BuildRequires:  m4
17
18Requires(post): /sbin/install-info
19Requires(preun): /sbin/install-info
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24%package devel
25Summary:        Development headers for a low-level cryptographic library
26Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
27Group:          Development/Libraries
28Requires:       %{name} = %{version}-%{release}
29
30#%package static
31#Summary:        Static libraries for a low-level cryptographic library
32#Group:          Development/Libraries
33#Requires:       %{name}-devel = %{version}-%{release}
34
35%if %{build_compat32}
36%package -n compat32-%{name}
37Summary:        A low-level cryptographic library
38Summary(ja):    低レベル暗号化ライブラリ
39Group:          System Environment/Libraries
40Requires:       %{name} = %{version}-%{release}
41
42%package -n compat32-%{name}-devel
43Summary:        Development headers for a low-level cryptographic library
44Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
45Group:          Development/Libraries
46Requires:       %{name}-devel = %{version}-%{release}
47Requires:       compat32-%{name} = %{version}-%{release}
48%endif
49
50%description
51Nettle is a cryptographic library that is designed to fit easily in more
52or less any context: In crypto toolkits for object-oriented languages
53(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
54kernel space.
55
56%description devel
57Nettle is a cryptographic library that is designed to fit easily in more
58or less any context: In crypto toolkits for object-oriented languages
59(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
60kernel space.  This package contains kernel headers.
61
62%if %{build_compat32}
63%description -n compat32-%{name}
64Nettle is a cryptographic library that is designed to fit easily in more
65or less any context: In crypto toolkits for object-oriented languages
66(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
67kernel space.
68
69%description -n compat32-%{name}-devel
70Nettle is a cryptographic library that is designed to fit easily in more
71or less any context: In crypto toolkits for object-oriented languages
72(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
73kernel space.  This package contains compat libraries.
74%endif
75
76#%description static
77#Nettle is a cryptographic library that is designed to fit easily in more
78#or less any context: In crypto toolkits for object-oriented languages
79#(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
80#kernel space.  This package contains a static library.
81
82%prep
83%setup -q
84
85%build
86%configure --enable-shared
87make %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
92make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
93#/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
94#/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
95#/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
96mkdir -p $RPM_BUILD_ROOT%{_infodir}
97install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
98
99chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
100chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
101
102rm -rf %{buildroot}/%{_libdir}/*.a
103rm -rf %{buildroot}/%{_infodir}/dir
104
105%check
106make check
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%files
112%defattr(-,root,root,-)
113%doc AUTHORS ChangeLog COPYING.LIB NEWS README TODO
114%{_infodir}/nettle.info.gz
115%{_bindir}/nettle-hash
116%{_bindir}/nettle-lfib-stream
117%{_bindir}/pkcs1-conv
118%{_bindir}/sexp-conv
119%{_libdir}/libhogweed.so.*
120%{_libdir}/libnettle.so.*
121
122%files devel
123%defattr(-,root,root,-)
124%doc descore.README nettle.html nettle.pdf COPYING.LIB
125%{_libdir}/libhogweed.so
126%{_libdir}/libnettle.so
127%{_includedir}/nettle
128%{_libdir}/pkgconfig/
129
130# compat32
131%if %{build_compat32}
132%files -n compat32-%{name}
133%defattr(-, root, root, 0755)
134%{_libdir}/libhogweed.so.*
135%{_libdir}/libnettle.so.*
136
137%files -n compat32-%{name}-devel
138%defattr(-, root, root, 0755)
139%{_libdir}/libhogweed.so
140%{_libdir}/libnettle.so
141%{_libdir}/pkgconfig/
142%endif
143
144#%files static
145#%defattr(-,root,root,-)
146#%doc COPYING
147#%{_libdir}/libhogweed.a
148#%{_libdir}/libnettle.a
149
150%post
151/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
152/sbin/ldconfig
153
154%preun
155if [ $1 = 0 ]; then
156  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
157fi
158
159%postun -p /sbin/ldconfig
160
161%if %{build_compat32}
162%post -n compat32-%{name} -p /sbin/ldconfig
163
164%postun -n compat32-%{name} -p /sbin/ldconfig
165%endif
166
167%changelog
168* Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-4
169- fixed Requires typo of compat32-nettle-devel package
170
171* Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
172- moved nettle to System Environment/Libraries Group
173
174* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
175- add compat32,compat32-devel packages
176
177* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
178- update to 2.7.1
179
180* Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
181- initial build for VineSeed
182
183* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
185
186* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
188
189* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
190- Moved static lib to -static
191
192* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
193- Added libraries and ldconfig
194
195* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
196- Added provides -static to -devel
197
198* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
199- Removed redundant requires
200- Removed redundant documentation between packages
201- Fixed license tag
202- Fixed -devel description
203- Added the static library back to -devel
204- Added make clean
205
206* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
207- First package build.
Note: See TracBrowser for help on using the repository browser.