source: projects/specs/trunk/n/nettle/nettle-vl.spec @ 12522

Revision 12522, 6.3 KB checked in by tomop, 3 years ago (diff)

updated 16 packages

SDL2-2.0.14-1

gmp-6.2.1-1

gnupg2-2.2.27-1

gnutls-3.7.0-1

golang-1.15.7-1

iputils-20210202-1

libassuan-2.5.4-1

libgcrypt-1.9.1-1

libgpg-error-1.41-1

libksba-1.5.0-1

libusb1-1.0.24-1

nettle-3.7-1

npth-1.6-2

pcsc-lite-1.9.0-1

python3-3.8.7-1

tcpdump-4.9.3-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A low-level cryptographic library
4Summary(ja):    低レベル暗号化ライブラリ
5Name:           nettle
6Version:        3.7
7Release:        1%{?_dist_release}
8Group:          system
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv3+ or GPLv2+
13URL:            http://www.lysator.liu.se/~nisse/nettle/
14Source0:        https://ftp.gnu.org/gnu/nettle/nettle-%{version}.tar.gz
15Patch0:         nettle-3.4-annocheck.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  gettext-devel
19BuildRequires:  gmp-devel
20BuildRequires:  m4
21
22Requires(post): /sbin/install-info
23Requires(preun): /sbin/install-info
24
25%description
26Nettle is a cryptographic library that is designed to fit easily in more
27or less any context: In crypto toolkits for object-oriented languages
28(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
29kernel space.
30
31
32%package devel
33Summary:        Development headers for a low-level cryptographic library
34Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
35Group:          programming
36Requires:       %{name} = %{version}-%{release}
37Requires:       gmp-devel
38
39%description devel
40Nettle is a cryptographic library that is designed to fit easily in more
41or less any context: In crypto toolkits for object-oriented languages
42(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
43kernel space.  This package contains kernel headers.
44
45
46%if %{build_compat32}
47%package -n compat32-%{name}
48Summary:        A low-level cryptographic library
49Summary(ja):    低レベル暗号化ライブラリ
50Group:          system
51Requires:       %{name} = %{version}-%{release}
52
53%description -n compat32-%{name}
54Nettle is a cryptographic library that is designed to fit easily in more
55or less any context: In crypto toolkits for object-oriented languages
56(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
57kernel space.
58
59
60%package -n compat32-%{name}-devel
61Summary:        Development headers for a low-level cryptographic library
62Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
63Group:          programming
64Requires:       %{name}-devel = %{version}-%{release}
65Requires:       compat32-%{name} = %{version}-%{release}
66Requires:       compat32-gmp-devel
67
68%description -n compat32-%{name}-devel
69Nettle is a cryptographic library that is designed to fit easily in more
70or less any context: In crypto toolkits for object-oriented languages
71(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
72kernel space.  This package contains compat libraries.
73%endif
74
75
76%debug_package
77
78
79%prep
80%autosetup -p1
81
82
83%build
84autoreconf -ifv
85%configure --enable-shared --enable-fat
86make %{?_smp_mflags}
87
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
92make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
93mkdir -p $RPM_BUILD_ROOT%{_infodir}
94install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
95
96chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
97chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
98
99rm -rf %{buildroot}/%{_libdir}/*.a
100rm -rf %{buildroot}/%{_infodir}/dir
101
102
103%check
104make check
105
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110
111%files
112%defattr(-,root,root,-)
113%license COPYING*
114%doc AUTHORS ChangeLog NEWS README TODO
115%{_infodir}/nettle.info.gz
116%{_bindir}/nettle-hash
117%{_bindir}/nettle-lfib-stream
118%{_bindir}/pkcs1-conv
119%{_bindir}/sexp-conv
120%{_bindir}/nettle-pbkdf2
121%{_libdir}/libhogweed.so.*
122%{_libdir}/libnettle.so.*
123
124%files devel
125%defattr(-,root,root,-)
126%doc descore.README nettle.html nettle.pdf
127%{_libdir}/libhogweed.so
128%{_libdir}/libnettle.so
129%{_includedir}/nettle
130%{_libdir}/pkgconfig/*
131
132# compat32
133%if %{build_compat32}
134%files -n compat32-%{name}
135%defattr(-, root, root, 0755)
136%{_libdir}/libhogweed.so.*
137%{_libdir}/libnettle.so.*
138
139%files -n compat32-%{name}-devel
140%defattr(-, root, root, 0755)
141%{_libdir}/libhogweed.so
142%{_libdir}/libnettle.so
143%endif
144
145
146%post
147/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
148/sbin/ldconfig
149
150%preun
151if [ $1 = 0 ]; then
152  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
153fi
154
155%postun -p /sbin/ldconfig
156
157%if %{build_compat32}
158%post -n compat32-%{name} -p /sbin/ldconfig
159%postun -n compat32-%{name} -p /sbin/ldconfig
160%endif
161
162
163%changelog
164* Tue Feb 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7-1
165- new upstream release.
166
167* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6-1
168- new upstream release.
169- imported Patch0 from rawhide.
170
171* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.1-1
172- new upstream release.
173
174* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4-1
175- new upstream release.
176
177* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2-1
178- new upstream release.
179
180* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.1-1
181- new upstream release
182
183* Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-4
184- fixed Requires typo of compat32-nettle-devel package
185
186* Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
187- moved nettle to System Environment/Libraries Group
188
189* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
190- add compat32,compat32-devel packages
191
192* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
193- update to 2.7.1
194
195* Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
196- initial build for VineSeed
197
198* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
200
201* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
203
204* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
205- Moved static lib to -static
206
207* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
208- Added libraries and ldconfig
209
210* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
211- Added provides -static to -devel
212
213* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
214- Removed redundant requires
215- Removed redundant documentation between packages
216- Fixed license tag
217- Fixed -devel description
218- Added the static library back to -devel
219- Added make clean
220
221* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
222- First package build.
Note: See TracBrowser for help on using the repository browser.