source: projects/specs/trunk/n/nettle/nettle-vl.spec @ 12062

Revision 12062, 6.9 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           nettle
4Version:        3.4.1
5Release:        1%{?_dist_release}
6Summary:        A low-level cryptographic library
7Summary(ja):    低レベル暗号化ライブラリ
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.lysator.liu.se/~nisse/nettle/
12Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  gmp-devel
16BuildRequires:  m4
17
18Requires(post): /sbin/install-info
19Requires(preun): /sbin/install-info
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24%package devel
25Summary:        Development headers for a low-level cryptographic library
26Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
27Group:          Development/Libraries
28Requires:       %{name} = %{version}-%{release}
29Requires:       gmp-devel
30
31#%package static
32#Summary:        Static libraries for a low-level cryptographic library
33#Group:          Development/Libraries
34#Requires:       %{name}-devel = %{version}-%{release}
35
36%if %{build_compat32}
37%package -n compat32-%{name}
38Summary:        A low-level cryptographic library
39Summary(ja):    低レベル暗号化ライブラリ
40Group:          System Environment/Libraries
41Requires:       %{name} = %{version}-%{release}
42
43%package -n compat32-%{name}-devel
44Summary:        Development headers for a low-level cryptographic library
45Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
46Group:          Development/Libraries
47Requires:       %{name}-devel = %{version}-%{release}
48Requires:       compat32-%{name} = %{version}-%{release}
49Requires:       compat32-gmp-devel
50%endif
51
52%description
53Nettle is a cryptographic library that is designed to fit easily in more
54or less any context: In crypto toolkits for object-oriented languages
55(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
56kernel space.
57
58%description devel
59Nettle is a cryptographic library that is designed to fit easily in more
60or less any context: In crypto toolkits for object-oriented languages
61(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
62kernel space.  This package contains kernel headers.
63
64%if %{build_compat32}
65%description -n compat32-%{name}
66Nettle is a cryptographic library that is designed to fit easily in more
67or less any context: In crypto toolkits for object-oriented languages
68(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
69kernel space.
70
71%description -n compat32-%{name}-devel
72Nettle is a cryptographic library that is designed to fit easily in more
73or less any context: In crypto toolkits for object-oriented languages
74(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
75kernel space.  This package contains compat libraries.
76%endif
77
78#%description static
79#Nettle is a cryptographic library that is designed to fit easily in more
80#or less any context: In crypto toolkits for object-oriented languages
81#(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
82#kernel space.  This package contains a static library.
83
84%prep
85%setup -q
86
87%build
88%configure --enable-shared
89make %{?_smp_mflags}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
94make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
95#/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
96#/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
97#/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
98mkdir -p $RPM_BUILD_ROOT%{_infodir}
99install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
100
101chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
102chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
103
104rm -rf %{buildroot}/%{_libdir}/*.a
105rm -rf %{buildroot}/%{_infodir}/dir
106
107%check
108make check
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root,-)
115
116%license COPYING*
117%doc AUTHORS ChangeLog NEWS README TODO
118%{_infodir}/nettle.info.gz
119%{_bindir}/nettle-hash
120%{_bindir}/nettle-lfib-stream
121%{_bindir}/pkcs1-conv
122%{_bindir}/sexp-conv
123%{_bindir}/nettle-pbkdf2
124%{_libdir}/libhogweed.so.*
125%{_libdir}/libnettle.so.*
126
127%files devel
128%defattr(-,root,root,-)
129%doc descore.README nettle.html nettle.pdf
130%{_libdir}/libhogweed.so
131%{_libdir}/libnettle.so
132%{_includedir}/nettle
133%{_libdir}/pkgconfig/
134
135# compat32
136%if %{build_compat32}
137%files -n compat32-%{name}
138%defattr(-, root, root, 0755)
139%{_libdir}/libhogweed.so.*
140%{_libdir}/libnettle.so.*
141
142%files -n compat32-%{name}-devel
143%defattr(-, root, root, 0755)
144%{_libdir}/libhogweed.so
145%{_libdir}/libnettle.so
146%{_libdir}/pkgconfig/
147%endif
148
149#%files static
150#%defattr(-,root,root,-)
151#%doc COPYING
152#%{_libdir}/libhogweed.a
153#%{_libdir}/libnettle.a
154
155%post
156/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
157/sbin/ldconfig
158
159%preun
160if [ $1 = 0 ]; then
161  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
162fi
163
164%postun -p /sbin/ldconfig
165
166%if %{build_compat32}
167%post -n compat32-%{name} -p /sbin/ldconfig
168
169%postun -n compat32-%{name} -p /sbin/ldconfig
170%endif
171
172%changelog
173* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.1-1
174- new upstream release.
175
176* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4-1
177- new upstream release.
178
179* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2-1
180- new upstream release.
181
182* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.1-1
183- new upstream release
184
185* Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-4
186- fixed Requires typo of compat32-nettle-devel package
187
188* Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
189- moved nettle to System Environment/Libraries Group
190
191* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
192- add compat32,compat32-devel packages
193
194* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
195- update to 2.7.1
196
197* Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
198- initial build for VineSeed
199
200* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
202
203* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
205
206* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
207- Moved static lib to -static
208
209* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
210- Added libraries and ldconfig
211
212* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
213- Added provides -static to -devel
214
215* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
216- Removed redundant requires
217- Removed redundant documentation between packages
218- Fixed license tag
219- Fixed -devel description
220- Added the static library back to -devel
221- Added make clean
222
223* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
224- First package build.
Note: See TracBrowser for help on using the repository browser.