source: projects/specs/trunk/n/nettle/nettle-vl.spec @ 10542

Revision 10542, 6.7 KB checked in by tomop, 8 years ago (diff)

nettle-3.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           nettle
4Version:        3.2
5Release:        1%{?_dist_release}
6Summary:        A low-level cryptographic library
7Summary(ja):    低レベル暗号化ライブラリ
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.lysator.liu.se/~nisse/nettle/
12Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  gmp-devel
16BuildRequires:  m4
17
18Requires(post): /sbin/install-info
19Requires(preun): /sbin/install-info
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24%package devel
25Summary:        Development headers for a low-level cryptographic library
26Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
27Group:          Development/Libraries
28Requires:       %{name} = %{version}-%{release}
29Requires:       gmp-devel
30
31#%package static
32#Summary:        Static libraries for a low-level cryptographic library
33#Group:          Development/Libraries
34#Requires:       %{name}-devel = %{version}-%{release}
35
36%if %{build_compat32}
37%package -n compat32-%{name}
38Summary:        A low-level cryptographic library
39Summary(ja):    低レベル暗号化ライブラリ
40Group:          System Environment/Libraries
41Requires:       %{name} = %{version}-%{release}
42
43%package -n compat32-%{name}-devel
44Summary:        Development headers for a low-level cryptographic library
45Summary(ja):    低レベル暗号化ライブラリの開発ヘッダ
46Group:          Development/Libraries
47Requires:       %{name}-devel = %{version}-%{release}
48Requires:       compat32-%{name} = %{version}-%{release}
49Requires:       compat32-gmp-devel
50%endif
51
52%description
53Nettle is a cryptographic library that is designed to fit easily in more
54or less any context: In crypto toolkits for object-oriented languages
55(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
56kernel space.
57
58%description devel
59Nettle is a cryptographic library that is designed to fit easily in more
60or less any context: In crypto toolkits for object-oriented languages
61(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
62kernel space.  This package contains kernel headers.
63
64%if %{build_compat32}
65%description -n compat32-%{name}
66Nettle is a cryptographic library that is designed to fit easily in more
67or less any context: In crypto toolkits for object-oriented languages
68(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
69kernel space.
70
71%description -n compat32-%{name}-devel
72Nettle is a cryptographic library that is designed to fit easily in more
73or less any context: In crypto toolkits for object-oriented languages
74(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
75kernel space.  This package contains compat libraries.
76%endif
77
78#%description static
79#Nettle is a cryptographic library that is designed to fit easily in more
80#or less any context: In crypto toolkits for object-oriented languages
81#(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
82#kernel space.  This package contains a static library.
83
84%prep
85%setup -q
86
87%build
88%configure --enable-shared
89make %{?_smp_mflags}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
94make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
95#/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
96#/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
97#/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
98mkdir -p $RPM_BUILD_ROOT%{_infodir}
99install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
100
101chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
102chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
103
104rm -rf %{buildroot}/%{_libdir}/*.a
105rm -rf %{buildroot}/%{_infodir}/dir
106
107%check
108make check
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root,-)
115%doc AUTHORS ChangeLog NEWS README TODO
116%{_infodir}/nettle.info.gz
117%{_bindir}/nettle-hash
118%{_bindir}/nettle-lfib-stream
119%{_bindir}/pkcs1-conv
120%{_bindir}/sexp-conv
121%{_bindir}/nettle-pbkdf2
122%{_libdir}/libhogweed.so.*
123%{_libdir}/libnettle.so.*
124
125%files devel
126%defattr(-,root,root,-)
127%doc descore.README nettle.html nettle.pdf
128%{_libdir}/libhogweed.so
129%{_libdir}/libnettle.so
130%{_includedir}/nettle
131%{_libdir}/pkgconfig/
132
133# compat32
134%if %{build_compat32}
135%files -n compat32-%{name}
136%defattr(-, root, root, 0755)
137%{_libdir}/libhogweed.so.*
138%{_libdir}/libnettle.so.*
139
140%files -n compat32-%{name}-devel
141%defattr(-, root, root, 0755)
142%{_libdir}/libhogweed.so
143%{_libdir}/libnettle.so
144%{_libdir}/pkgconfig/
145%endif
146
147#%files static
148#%defattr(-,root,root,-)
149#%doc COPYING
150#%{_libdir}/libhogweed.a
151#%{_libdir}/libnettle.a
152
153%post
154/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
155/sbin/ldconfig
156
157%preun
158if [ $1 = 0 ]; then
159  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
160fi
161
162%postun -p /sbin/ldconfig
163
164%if %{build_compat32}
165%post -n compat32-%{name} -p /sbin/ldconfig
166
167%postun -n compat32-%{name} -p /sbin/ldconfig
168%endif
169
170%changelog
171* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2-1
172- new upstream release.
173
174* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.1-1
175- new upstream release
176
177* Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-4
178- fixed Requires typo of compat32-nettle-devel package
179
180* Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
181- moved nettle to System Environment/Libraries Group
182
183* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
184- add compat32,compat32-devel packages
185
186* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
187- update to 2.7.1
188
189* Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
190- initial build for VineSeed
191
192* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
194
195* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
197
198* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
199- Moved static lib to -static
200
201* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
202- Added libraries and ldconfig
203
204* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
205- Added provides -static to -devel
206
207* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
208- Removed redundant requires
209- Removed redundant documentation between packages
210- Fixed license tag
211- Fixed -devel description
212- Added the static library back to -devel
213- Added make clean
214
215* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
216- First package build.
Note: See TracBrowser for help on using the repository browser.