source: projects/specs/trunk/n/netpbm/netpbm-vl.spec @ 521

Revision 521, 13.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A library for handling different graphics file formats.
2Summary(ja): 異なる画像ファイル形式を取り扱うためのライブラリ
3Name: netpbm
4Version: 10.27
5Release: 1%{?_dist_release}
6License: Artistic License/GPL/MIT
7Group: System Environment/Libraries
8Source0: netpbm-%{version}.tgz
9Source3: jpeg-to-pnm.fpi
10Source4: pnm-to-ps.fpi
11Source5: bmp-to-pnm.fpi
12Source6: gif-to-pnm.fpi
13Source7: rast-to-pnm.fpi
14Source8: tiff-to-pnm.fpi
15Source9: png-to-pnm.fpi
16Source10: netpbmdoc-%{version}.tar.bz2
17# Patches from fedora core
18Patch1: netpbm-10.17-time.patch
19Patch2: netpbm-9.24-strip.patch
20Patch3: netpbm-10.18-manpath.patch
21Patch4: netpbm-10.19-message.patch
22Patch5: netpbm-10.22-security2.patch
23Patch6: netpbm-10.22-cmapsize.patch
24Patch7: netpbm-10.23-gcc34.patch
25Patch8: netpbm-10.23-security.patch
26Patch9: netpbm-10.23-pngtopnm.patch
27Patch10: netpbm-10.24-nodoc.patch
28Patch11: netpbm-10.26.4-gcc4.patch
29Patch12: netpbm-10.27-badlink.patch
30
31Patch100: netpbm-10.27-rgb_db.patch
32# bugfix
33Patch110: netpbm-10.27-pnmcolormap_segfault.patch
34
35#Security fix
36Patch200: netpbm-10.27-CVE-2005-2471.patch
37Patch210: netpbm-10.27-CVE-2005-2978.patch
38Patch220: netpbm-10.27-CVE-2005-3662.patch
39
40URL: http://netpbm.sourceforge.net/
41Buildroot: %{_tmppath}/%{name}-root
42BuildPrereq: libjpeg-devel, libtiff-devel, zlib-devel, perl
43BuildPrereq: libpng-devel >= 1.2.5
44BuildPrereq: flex
45Obsoletes: libgr
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51The netpbm package contains a library of functions which support
52programs for handling various graphics file formats, including .pbm
53(portable bitmaps), .pgm (portable graymaps), .pnm (portable anymaps),
54.ppm (portable pixmaps) and others.
55
56%package devel
57Summary: Development tools for programs which will use the netpbm libraries.
58Summary(ja): netpbm ライブラリを使うプログラムの開発ツール
59Group: Development/Libraries
60Requires: netpbm = %{version}-%{release}
61Obsoletes: libgr-devel
62
63%description devel
64The netpbm-devel package contains the header files and static libraries,
65etc., for developing programs which can handle the various graphics file
66formats supported by the netpbm libraries.
67
68Install netpbm-devel if you want to develop programs for handling the
69graphics file formats supported by the netpbm libraries.  You will also
70need to have the netpbm package installed.
71
72%package progs
73Summary: Tools for manipulating graphics files in netpbm supported formats.
74Summary(ja): netpbm でサポートするフォーマットの画像ファイルを操作するツール
75Group: Applications/Graphics
76Requires: netpbm = %{version}-%{release}
77Requires: libpng libtiff libjpeg zlib perl bash
78Obsoletes: libgr-progs
79
80%description progs
81The netpbm-progs package contains a group of scripts for manipulating the
82graphics files in formats which are supported by the netpbm libraries.  For
83example, netpbm-progs includes the rasttopnm script, which will convert a
84Sun rasterfile into a portable anymap.  Netpbm-progs contains many other
85scripts for converting from one graphics file format to another.
86
87If you need to use these conversion scripts, you should install
88netpbm-progs.  You will also need to install the netpbm package.
89
90%prep
91%setup -q
92%patch1 -p1 -b .time
93%patch2 -p1 -b .strip
94%patch3 -p1 -b .manpath
95%patch4 -p1 -b .message
96%patch5 -p1 -b .security2
97%patch6 -p1 -b .cmapsize
98%patch7 -p1 -b .gcc34
99%patch8 -p1 -b .security
100%patch9 -p1 -b .pngtopnm
101%patch10 -p1 -b .nodoc
102%patch11 -p1 -b .gcc4
103%patch12 -p1 -b .badlink
104
105%patch100 -p1 -b .rgb_db
106%patch110 -p0 -b .pnmcolor_segfault
107
108%patch200 -p0 -b .CVE-2005-2471.patch
109%patch210 -p0 -b .CVE-2005-2978.patch
110%patch220 -p0 -b .CVE-2005-3662.patch
111
112%build
113[ ! -f "/tmp/netpbm" ] && rm -rf /tmp/netpbm
114
115./configure <<EOF
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132%ifnarch %{ix86}
133
134%endif
135EOF
136
137TOP=`pwd`
138make \
139        CC=%{__cc} \
140        CFLAGS="$RPM_OPT_FLAGS -fPIC" \
141        LDFLAGS="-L$TOP/pbm -L$TOP/pgm -L$TOP/pnm -L$TOP/ppm" \
142        JPEGINC_DIR=%{_includedir} \
143        PNGINC_DIR=%{_includedir} \
144        TIFFINC_DIR=%{_includedir} \
145        JPEGLIB_DIR=%{_libdir} \
146        PNGLIB_DIR=%{_libdir} \
147        TIFFLIB_DIR=%{_libdir} \
148        LINUXSVGALIB=NONE
149
150##make package
151
152%install
153[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
154
155mkdir -p $RPM_BUILD_ROOT
156make package pkgdir=$RPM_BUILD_ROOT/usr LINUXSVGALIB=NONE
157
158# Ugly hack to have libs in correct dir on 64bit archs.
159mkdir -p $RPM_BUILD_ROOT%{_libdir}
160if [ "%{_libdir}" != "/usr/lib" ]; then
161  mv $RPM_BUILD_ROOT/usr/lib/lib* $RPM_BUILD_ROOT%{_libdir}
162fi
163
164cp -af lib/libnetpbm.a $RPM_BUILD_ROOT%{_libdir}/libnetpbm.a
165ln -sf libnetpbm.so.10 $RPM_BUILD_ROOT%{_libdir}/libnetpbm.so
166
167mkdir -p $RPM_BUILD_ROOT%{_mandir}
168tar jxvf %{SOURCE10} -C $RPM_BUILD_ROOT%{_mandir}
169
170# Don't ship man packages for non-existent binaries
171for i in hpcdtoppm.1 pcdovtoppm.1 pnmtojbig.1 \
172         ppmsvgalib.1 vidtoppm.1 picttoppm.1; do
173         rm -f $RPM_BUILD_ROOT%{_mandir}/man1/${i}
174done
175
176mv $RPM_BUILD_ROOT/usr/misc/*.map $RPM_BUILD_ROOT%{_libdir}
177rm -rf $RPM_BUILD_ROOT/usr/README
178rm -rf $RPM_BUILD_ROOT/usr/VERSION
179rm -rf $RPM_BUILD_ROOT/usr/link
180rm -rf $RPM_BUILD_ROOT/usr/misc
181rm -rf $RPM_BUILD_ROOT/usr/man
182rm -rf $RPM_BUILD_ROOT/usr/pkginfo
183rm -rf $RPM_BUILD_ROOT/usr/config_template
184
185mkdir -p $RPM_BUILD_ROOT%{_libdir}/rhs/rhs-printfilters
186for filter in $RPM_SOURCE_DIR/*.fpi ; do
187    install -m755 $filter \
188        $RPM_BUILD_ROOT%{_libdir}/rhs/rhs-printfilters
189done
190
191mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
192install lib/rgb.txt $RPM_BUILD_ROOT%{_datadir}/%{name}/rgb.txt
193
194%clean
195[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
196# clean builddir
197[ ! -f "/tmp/netpbm" ] && rm -rf /tmp/netpbm
198
199%post -p /sbin/ldconfig
200
201%postun -p /sbin/ldconfig
202
203%files
204%defattr(-,root,root)
205%doc README doc/COPYRIGHT.PATENT doc/GPL_LICENSE.txt doc/HISTORY doc/USERDOC
206%{_libdir}/lib*.so.*
207
208%files devel
209%defattr(-,root,root)
210%{_includedir}/*.h
211%{_libdir}/lib*.a
212%{_libdir}/lib*.so
213%{_mandir}/man3/*
214
215%files progs
216%defattr(-,root,root)
217%{_bindir}/*
218%{_libdir}/rhs/rhs-printfilters/jpeg-to-pnm.fpi
219%{_libdir}/rhs/rhs-printfilters/pnm-to-ps.fpi
220%{_libdir}/rhs/rhs-printfilters/bmp-to-pnm.fpi
221%{_libdir}/rhs/rhs-printfilters/gif-to-pnm.fpi
222%{_libdir}/rhs/rhs-printfilters/rast-to-pnm.fpi
223%{_libdir}/rhs/rhs-printfilters/tiff-to-pnm.fpi
224%{_libdir}/rhs/rhs-printfilters/png-to-pnm.fpi
225%{_libdir}/*.map
226%{_datadir}/%{name}/rgb.txt
227%{_mandir}/man1/*
228%{_mandir}/man5/*
229
230%changelog
231* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 10.27-1vl5
232- applied new versioning policy and spec in utf-8
233
234* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.27-0vl6
235- changed progs package Group to Applications/Graphics
236
237* Sun Jan 07 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 10.27-0vl5
238- make with LINUXSVGALIB=NONE not to depend on svgalib
239
240* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.27-0vl4
241- rebuilt for VineSeed
242
243* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 10.27-0vl3.2
244- add Vender/Distribution tag
245
246* Wed Dec 13 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 10.27-0vl3.1
247- add patch200 for fix CVE-2005-2471
248- add patch210 for fix CVE-2005-2978
249- add patch220 for fix CVE-2005-3662
250
251* Wed Dec 13 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 10.27-0vl3.0.1
252- add patch110 for fix pnmcolormap segfault
253
254* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 10.27-0vl3
255- add BuildPrereq: flex
256- fix build on x86_64
257
258* Mon Apr 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 10.27-0vl2
259- add Patch100 to use own rgb.txt as secondary rgb database.
260- add rgb.txt again, and move it to %%{_datadir}/netpbm/
261- remove dependancy to XOrg-libs
262- remove unneeded printconf filters
263
264* Sun Apr 24 2005 Satoshi MACHINO <machino@vinelinux.org> 10.27-0vl1
265- new upstream release
266        -- added some patches from fedora
267- removed rgb.txt because it is included XOrg-libs
268- added XOrg-libs, libpng, libtiff, libjpeg, perl and bash to Requires of progs
269
270* Mon May 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 10.18.12-0vl1
271- new upstream release
272- build without svgalib
273
274* Thu Jan 08 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.18.4-0vl2
275- modified build section for non-ix86 archtectures
276  (svgalib is exclusive package for ix86 arch)
277
278* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.18.4-0vl1
279- update to 10.18.4
280- rebuild with new toolchains
281
282* Tue Oct 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.11.15-0vl1
283- update to 10.11.15
284
285* Sun Jul 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.11.10-0vl1
286- update to 10.11.10
287- s/Copyright/License/
288- fixed License to Artistic License/GPL/MIT
289  (http://sourceforge.net/projects/netpbm/)
290- added URL
291
292* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 10.11.6-0vl2
293- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
294
295* Fri Mar 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.11.6-0vl1
296- update to 10.11.6
297
298* Thu Dec 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.11.2-0vl1
299- update to 10.11.2
300
301* Sun Jun 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 9.24-4vl1
302- merged with rawhide
303
304* Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
305- 9.9-3vl1
306- added Summary(ja)
307
308* Wed Jan 24 2001 Philipp Knirsch <pknirsch@redhat.de>
309- Fixed bugzilla bug #21644 where few manpages had a small error.
310
311* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
312- Fixed bugzilla bug #19487 where asciitopgm dumped core on Alpha. Actually
313  dumped core everywhere
314
315* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
316- update to 9.9
317- Due to patent infringement problems removed the jbig support from the tarball
318  (pnm/jbig + Makefile changes) and created a new tarball
319
320* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
321- include shared libraries missing from previous build
322
323* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
324- update to 9.8
325- make sure shhopt.h is included in the -devel package (#19672)
326- rename shhopt.h to pbmshhopt.h because it's not the same as the normal
327  shhopt.h that other things (like util-linux) expect
328
329* Wed Aug  9 2000 Crutcher Dunnavant <crutcher@redhat.com>
330- added a png-to-pnm.fpi filter
331
332* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
333- rebuilt against new libpng
334
335* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
336- move netpbm-progs to the Applications/Multimedia group
337- reintroduce patches from the old libgr package
338
339* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
340- automatic rebuild
341
342* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
343- update to 9.5
344
345* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
346- update to 9.4
347
348* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
349- switch back to the netpbm tree, which is maintained again
350
351* Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
352- make sure all man pages are included (#9328)
353- fix pstopnm bomb when xres == yres (#9329)
354- add libjpeg and libz because libtiff now needs them
355
356* Wed Feb 02 2000 Nalin Dahyabhai <nalin@redhat.com>
357- added/updated TIFF compression patch from jik@kamens.brookline.ma.us (#8826)
358
359* Mon Dec 06 1999 Michael K. Johnson <johnsonm@redhat.com>
360- added TIFF resolution patch from jik@kamens.brookline.ma.us (#7589)
361
362* Mon Sep 20 1999 Michael K. Johnson <johnsonm@redhat.com>
363- added section 5 man pages
364
365* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
366- fix tiff-to-pnm.fpi (#4267)
367
368* Thu Jul 29 1999 Bill Nottingham <notting@redhat.com>
369- add a pile of foo-to-bar.fpi filters (#4251)
370
371* Mon Mar 23 1999 Michael Johnson <johnsonm@redhat.com>
372- removed old png.h header file that was causing png utils to die
373- build png in build instead of install section...
374
375* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
376- patch for 24-bit .BMP files (from sam@campbellsci.co.uk)
377
378* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
379- auto rebuild in the new build environment (release 15)
380
381* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
382- clean up the spec file
383- build for glibc 2.1
384- patch to fix pktopbm
385
386* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
387- translations modified for de
388
389* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
390- glibc2 defines random in <stdlib.h> (pbm/pbmplus.h problem #693)
391
392* Thu May 07 1998 Prospector System <bugs@redhat.com>
393- translations modified for de, fr, tr
394
395* Thu May 07 1998 Cristian Gafton <gafton@redhat.com>
396- cleaned up the spec file a little bit
397- validated mike's changes :-)
398
399* Wed May 6 1998 Michael Maher <mike@redhat.com>
400- added pnm-to-ps.fpi that was missing from previous packages
401
402* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
403- altered %install so that the package installs now even if a previous
404  version was not installed on the system
405
406* Thu Apr 16 1998 Erik Troan <ewt@redhat.com>
407- built against libpng 1.0
408
409* Thu Nov 06 1997 Donnie Barnes <djb@redhat.com>
410- changed copyright from "distributable" to "freeware"
411- added some missing scripts that existed in netpbm
412- added some binaries that weren't getting built
413- added patch to build tiff manipulation progs (requires libtiff)
414
415* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
416- obsoletes netpbm now
417
418* Tue Oct 14 1997 Erik Troan <ewt@redhat.com>
419- mucked config.guess and Make.Rules to build on Alpha/Linux
420
421* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
422- updated to 2.0.13
423- dropped libjpeg and libtiff (those should come from home sources)
424- removed glibc patch (new version appears to have it!)
425- added i686 as a valid arch type to config.guess
426
427* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
428- built against glibc
429
Note: See TracBrowser for help on using the repository browser.