source: projects/specs/trunk/n/netcfg/netcfg-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A network configuration tool.
2Summary(ja): ¥Í¥Ã¥È¥ï¡¼¥¯ÀßÄê¥Ä¡¼¥ë
3Name: netcfg
4Version: 2.36
5Release: 3vl4
6License: GPL
7Group: Applications/System
8Source0: netcfg-%{version}.tar.bz2
9Source1: netcfg_ja.py
10Source2: netcfg
11Patch0: netcfg-Makefile.patch
12#Patch1: netcfg-2.25-modulesconf.patch
13#Patch2: netcfg-2.36-i18n.patch
14Patch3: netcfg_ja-unicode.patch
15Requires: pythonlib >= 1.20, python, tkinter, initscripts >= 3.24
16Requires: tk >= 8.4.1
17BuildPrereq: nkf >= 2.01
18BuildArchitectures: noarch
19BuildRoot: %{_tmppath}/%{name}-root
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25A Red Hat Linux tool which provides a graphical user interface for
26setting up and configuring networking for your machine.
27
28%description -l ja
29¥Þ¥·¥ó¤Î¥Í¥Ã¥È¥ï¡¼¥¯¤òÀßÄꤹ¤ë¥°¥é¥Õ¥£¥«¥ë¥æ¡¼¥¶¥¤¥ó¥¿¥Õ¥§¡¼¥¹¤ò
30Ä󶡤¹¤ë Red Hat Linux ¤Î¥Ä¡¼¥ë¤Ç¤¹¡£
31
32%prep
33%setup -q
34%patch0
35#%patch1 -p0
36
37# ja.py
38install -p -m 755 %{SOURCE1} netcfg_ja.py
39#%patch2 -b .i18n
40## euc-jp to UTF-8
41#%__mv netcfg_ja.py netcfg_ja.euc
42#nkf -E -w netcfg_ja.euc > netcfg_ja.py
43%patch3 -b .unicode
44
45# netcfg.auth
46mv netcfg.auth netcfg.auth.org
47sed -e 's/^SESSION/#SESSION/' netcfg.auth.org > netcfg.auth
48
49# desktop
50mv netcfg.desktop netcfg.desktop.org
51sed -e 's/penguin.xpm/netcfg.xpm/' netcfg.desktop.org > netcfg.desktop
52
53%build
54unset DISPLAY || true
55export PYTHONPATH=/usr/lib/rhs/python
56make
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61unset DISPLAY || true
62export PYTHONPATH=/usr/lib/rhs/python
63
64make    DESTDIR=$RPM_BUILD_ROOT \
65        INSTALLBIN="install -m755" INSTALLDATA="install -m644" \
66        install
67
68( cd $RPM_BUILD_ROOT
69  mkdir -p ./usr/share/icons
70  cp ./usr/lib/rhs/control-panel/netcfg.xpm ./usr/share/icons
71)
72
73mv -f $RPM_BUILD_ROOT/usr/sbin/netcfg{,.en}
74install -m755 %{SOURCE2} $RPM_BUILD_ROOT/usr/sbin/netcfg
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(-,root,root)
81%config /etc/X11/applnk/System/netcfg.desktop
82%config(noreplace) /etc/pam.d/netcfg
83%config            /etc/security/console.apps/netcfg
84/usr/bin/netcfg
85/usr/sbin/netcfg
86/usr/lib/rhs/netcfg
87/usr/lib/rhs/control-panel/netcfg.init
88/usr/lib/rhs/control-panel/netcfg.xpm
89/usr/share/icons/netcfg.xpm
90
91%changelog
92* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.36-3vl4
93- rebuild with python-2.3.3-0vl1
94
95* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.36-3vl3.1
96- deleted netcfg-2.36-i18n.patch
97- added netcfg_ja-unicode.patch for python-2.3.3
98
99* Sun Jul 20 2003 Masaki Shinomiya <shino@pos.to> 2.36-3vl3
100- i18n.patch to avoid odd charactors on the title bars
101- spec file in euc-jp
102
103* Sat Jul 19 2003 Masaki Shinomiya <shino@pos.to> 2.36-3vl2
104- euc-jp to UTF-8 fo Tcl/Tk >= 8.4.1
105- netcfg.auth, netcfg.desktop
106
107* Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.36-3vl1
108- merged with upstream 2.36-2
109
110* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
111- 2.25-1vl2: ad hoc modules.confiscation
112
113* Thu Aug  3 2000 Jun Nishii <jun@vinelinux.org>
114- 2.25-1vl1
115
116* Wed Jan 13 2000 Norihito Ohmori <nono@kondara.org>
117- ad-hoc i18n.
118
119* Sun Nov 7 1999 Toru Hoshina <t@kondara.org>
120- be a NoSrc :-P
121
122* Mon Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
123- Japanize.
124- Japanese summary and description add.
125
126* Tue Aug 24 1999 Bill Nottingham <notting@redhat.com>
127- actually build the version with the python fixes.
128
129* Thu Apr 08 1999 Preston Brown <pbrown@redhat.com>
130- fixed netcfg version number in python src.
131
132* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
133- fixed bug 881
134
135* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
136- auto rebuild in the new build environment (release 7)
137
138* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
139- build root
140
141* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
142- translations modified for de, fr, tr
143
144* Fri Nov 07 1997 Michael K. Johnson <johnsonm@redhat.com>
145- Bugs fixed:
146 o wmconfig files take no paths
147 o only root should see wmconfig
148
149* Thu Nov 06 1997 Michael K. Johnson <johnsonm@redhat.com>
150- Version 2.19 New features:
151 o Debugging option for PPP devices
152 o Supports active and passive PPP servers with a single configuration.
153
154* Tue Nov 04 1997 Michael K. Johnson <johnsonm@redhat.com>
155- Bugs fixed:
156 o icon name corrected in netcfg.init
157
158* Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
159- Version 2.18 New features:
160 o "Clone" devices allow multiple interface configurations
161 o IP Forwarding option
162 o Menus for modem ports and speeds.
163- Bugs fixed:
164 o physical/logical PPP device name translation
165 o ignores backup files better.
166 o removes dip scripts when removing slip devices
167 o USERCTL fixed for "bus" devices like ethernet
168 o Now asks for interface number for PLIP devices
169
170* Thu Jul 31 1997 Erik Troan <ewt@redhat.com>
171- made a noarch package
172
173* Tue Apr 15 1997 Michael K. Johnson <johnsonm@redhat.com>
174- New features:
175 o Allows ALL device types to be user-controllable
176 o Allows DHCP configuration
177
178* Wed Apr 02 1997 Michael K. Johnson <johnsonm@redhat.com>
179- New features:
180 o Silently disallows senseless lo aliasing
181 o Loudly disallows non-functional SLIP aliasing
182- Bugs fixed:
183 o Didn't always create correct alias numbers
184 o Hung if a device without an IP was aliased
185
186* Wed Feb 26 1997 Michael K. Johnson <johnsonm@redhat.com>
187- New features:
188 o Supports user-controlled interfaces.
189 o Includes PAP support for PPP interfaces.
190 o Supports two kinds of timeouts for PPP interfaces.
191 o Supports MTU as well as MRU
192 o Allows giving arbitrary options to pppd
193 o Sanity checking on /etc/hosts
194- Bugs fixed:
195 o Didn't always find the first free interface number
196 o Sometimes tried to "add" an existing interface number
Note: See TracBrowser for help on using the repository browser.