source: projects/specs/trunk/n/nessus-core/nessus-core-vl.spec @ 2610

Revision 2610, 8.9 KB checked in by Takemikaduchi, 13 years ago (diff)

empathy,telepathy-salut: new upstream release, others: rebuild with openssl-1.0.0c

Line 
1Name:           nessus-core
2Version:        2.2.11
3Release:        6%{?_dist_release}
4Summary:        Network vulnerability scanner
5Summary(ja):    ネットワーク脆弱性スキャナ
6
7Group:          Applications/System
8License:        GPLv2
9URL:            http://www.nessus.org
10#http://www.nessus.org/download/index.php
11Source0:        nessus-core-2.2.11.tar.gz
12Source1:        nessusd.init
13Source2:        nessusd.log
14Source3:        nessus.desktop
15# force nessus into fedora dir structure
16# and use system gd
17# Thanks to Dawid Gajownik for providing these patches =)
18Patch0:         nessus-core-Makefile.patch
19Patch1:         nessus-core-2.2.4.config.h.in.patch
20Patch2:         nessus-core-2.2.4.configure.in.patch
21Patch3:         nessus-core-2.2.4.configure.patch
22Patch4:         nessus-core-2.2.4.gd.patch
23Patch5:         nessus-core-2.2.4.nessus-adduser.in.patch
24Patch6:         nessus-core-2.2.4.nessus-mkcert.patch
25Patch7:         nessus-core-2.2.4.nessus-rmuser.in.patch
26Patch8:         nessus-core-2.2.4.nessus.tmpl.in.patch
27Patch9:         nessus-core-2.2.4.pid.patch
28Patch10:        nessus-core-2.2.11.pki.patch
29# fixes #399211 glibc open check
30Patch11:        nessus-core-open.patch
31
32# Patch for Vine
33Patch100:       nessus-core-2.2.11.pcap.patch
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36BuildRequires:  nessus-libraries-devel
37BuildRequires:  libnasl-devel
38BuildRequires:  gtk2-devel
39BuildRequires:  glib2-devel
40BuildRequires:  libICE-devel
41BuildRequires:  gd-devel
42BuildRequires:  tcp_wrappers
43BuildRequires:  desktop-file-utils
44
45%define pkidir %{_sysconfdir}/pki/nessus
46
47%description
48Nessus is the world's most popular vulnerability scanner used in over 75,000
49organizations world-wide. Many of the world's largest organizations are
50realizing significant cost savings by using Nessus to audit business-critical
51enterprise devices and applications.
52
53The "Nessus" Project was started by Renaud Deraison in 1998 to provide to the
54internet community a free, powerful, up-to-date and easy to use remote
55security scanner. Nessus is currently rated among the top products of its type
56throughout the security industry and is endorsed by professional information
57security organizations such as the SANS Institute.
58
59%package devel
60Summary: Header files for plugin development
61Summary(ja): Nessus プラグイン開発に必要なヘッダファイル
62Group: Development/Libraries
63
64%description devel
65%{summary}
66
67%package -n nessus-server
68Summary: nessusd is the server part of the nessus client-server model
69Summary(ja): nessusd - Nessus クライアントサーバモデルのサーバ
70Group: System Environment/Daemons
71Requires(post): /sbin/chkconfig
72Requires(preun): /sbin/chkconfig
73Requires(preun): /sbin/service
74Requires: nessus-core = %{version}-%{release}
75
76%description -n nessus-server
77%{summary}
78
79%package -n nessus-client
80Summary: Text client interface for nessusd
81Summary(ja): nessusd のテキスト版クライアント
82Group: Applications/Internet
83Requires: nessus-core = %{version}-%{release}
84
85%description -n nessus-client
86%{summary}
87
88%package -n nessus-gui
89Summary: GTK client interface for nessusd
90Summary(ja): Nessusd の GTK+ 版クライアント
91Group: Applications/Internet
92Requires: nessus-core = %{version}-%{release}
93
94%description -n nessus-gui
95%{summary}
96
97%prep
98%setup -q -n %{name}
99
100%patch0  -p1
101%patch1  -p1
102%patch2  -p1
103# You cannot compile against system gd, because nessus-text client
104# will require X.org X11
105%patch3  -p1
106%patch4  -p1
107%patch5  -p1
108%patch6  -p1
109%patch7  -p1
110%patch8  -p1
111%patch9  -p1
112%patch10 -p1
113%patch11 -p1
114
115%patch100 -p0
116
117%build
118# libdir is used by plugins
119# smpflags will break builds sometime...
120%configure \
121        --libdir=%{_localstatedir}/lib \
122        --disable-gtk \
123        --enable-syslog \
124        --enable-tcpwrappers \
125        --without-x
126make -C nessus
127
128mv -f nessus/nessus nessus-text
129make distclean
130
131%configure \
132        --libdir=%{_localstatedir}/lib \
133        --enable-gtk \
134        --enable-syslog \
135        --enable-tcpwrappers \
136        --with-x
137make
138
139%install
140rm -rf $RPM_BUILD_ROOT
141make install DESTDIR=$RPM_BUILD_ROOT
142
143install -p -m 0755 nessus-text $RPM_BUILD_ROOT/%{_bindir}
144
145install -D -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/nessusd
146
147install -D -p -m 0644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nessusd
148install -D -p -m 644 nessus/xpm/nessus.xpm \
149        $RPM_BUILD_ROOT/%{_datadir}/pixmaps/nessus.xpm
150
151desktop-file-install --vendor vine \
152        --dir $RPM_BUILD_ROOT/%{_datadir}/applications\
153        %{SOURCE3}
154
155# generate ghost .pem files
156mkdir -m 0755 -p $RPM_BUILD_ROOT/%{pkidir}/{private,}/CA
157chmod 700 $RPM_BUILD_ROOT/%{pkidir}/private/CA
158touch $RPM_BUILD_ROOT/%{pkidir}/private/CA/{cakey,serverkey}.pem
159chmod 600 $RPM_BUILD_ROOT/%{pkidir}/private/CA/{cakey,serverkey}.pem
160touch $RPM_BUILD_ROOT/%{pkidir}/CA/{cacert,servercert}.pem
161chmod 644 $RPM_BUILD_ROOT/%{pkidir}/CA/{cacert,servercert}.pem
162
163# install services file
164install -D -p -m 644 nessus-services $RPM_BUILD_ROOT/%{_localstatedir}/lib/nessus/nessus-services
165
166# plugin folder
167mkdir -m 0755 -p $RPM_BUILD_ROOT/%{_localstatedir}/lib/nessus/plugins
168
169# generate ghost config files
170touch $RPM_BUILD_ROOT/%{_sysconfdir}/nessus/nessusd.{conf,rules}
171chmod 600 $RPM_BUILD_ROOT/%{_sysconfdir}/nessus/nessusd.conf
172
173# fix multilib conflict for config.h (#342661)
174touch -r CHANGES $RPM_BUILD_ROOT%{_includedir}/nessus/config.h
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post -n nessus-server
180# This adds the proper /etc/rc*.d links for the script
181if [ $1 = 1 ]; then
182/sbin/chkconfig --add nessusd
183fi
184
185%preun -n nessus-server
186if [ $1 = 0 ]; then
187        /sbin/service nessusd stop >/dev/null 2>&1
188        /sbin/chkconfig --del nessusd
189fi
190
191%postun -n nessus-server
192if [ "$1" -ge "1" ]; then
193        /sbin/service nessusd condrestart >/dev/null 2>&1
194fi
195
196%files
197%defattr(-,root,root,-)
198%doc TODO CHANGES README_SSL doc/*txt doc/WARNING.* nessus/COPYING
199%{_bindir}/nessus-mkrand
200%{_bindir}/nessus-mkcert-client
201%{_mandir}/man1/nessus.1*
202%{_mandir}/man1/nessus-mkcert-client.1*
203%{_mandir}/man1/nessus-mkrand.1*
204
205%files devel
206%defattr(-,root,root,-)
207%doc doc/ntp/*
208%dir %{_includedir}/nessus
209%{_includedir}/nessus/*
210%exclude %{_includedir}/nessus/includes.h
211
212%files -n nessus-client
213%defattr(-,root,root,-)
214%{_bindir}/nessus-text
215
216%files -n nessus-gui
217%defattr(-,root,root,-)
218%{_bindir}/nessus
219%{_datadir}/pixmaps/nessus.xpm
220%{_datadir}/applications/*
221
222%files -n nessus-server
223%defattr(-,root,root,-)
224%{_bindir}/nessus-fetch
225%{_sbindir}/nessusd
226%{_sbindir}/nessus-mkcert
227%{_sbindir}/nessus-adduser
228%{_sbindir}/nessus-rmuser
229%{_sbindir}/nessus-check-signature
230%{_mandir}/man1/nessus-fetch.1*
231%{_mandir}/man8/*
232%{_initrddir}/nessusd
233%{_localstatedir}/lib/nessus/nessus-services
234%dir %{_localstatedir}/log/nessus
235%dir %{_localstatedir}/lib/nessus/
236%dir %{_localstatedir}/lib/nessus/plugins
237%dir %{_sysconfdir}/nessus
238%dir %{_sysconfdir}/pki/nessus
239%config(noreplace) %{_sysconfdir}/logrotate.d/nessusd
240%ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{pkidir}/CA/*
241%ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{pkidir}/private/CA/*
242%ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{_sysconfdir}/nessus/*
243
244%changelog
245* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-6
246- rebuild with openssl-1.0.0c
247
248* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-5
249- rebuild with libpcap-1.1.1
250
251* Sat Apr 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.11-4
252- updated nessus based on Fedora Development
253- added Patch100 for building on Vine
254
255* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.11-3
256- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
257
258* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.2.11-2
259- rebuild with new openssl
260
261* Sun Nov 23 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
262- 2.2.11-1
263- fix #465113 FTBFS
264
265* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.10-4
266- Autorebuild for GCC 4.3
267
268* Sat Dec 08 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
269- 2.2.10-3
270- fix build #399211 (patch from Oliver Falk)
271- fix multilib issues #342661
272- fix init scripts #246992
273
274* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.2.10-2
275- Rebuild for deps
276
277* Wed Aug 22 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
278- 2.2.10-1
279- version upgrade
280- new license tag
281
282* Wed Apr 25 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
2832.2.9-2
284- fix #233888
285
286* Tue Dec 19 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
2872.2.9-1
288- version upgrade (#199399)
289
290* Sun Jun 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
2912.2.8-1
292- version upgrade
293
294* Wed May 17 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
2952.2.7-1
296- version upgrade
297
298* Mon Apr 03 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
2992.2.6-3
300- fix description
301- create and own log dir
302- include copying
303
304* Sun Feb 26 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3052.2.6-2
306- fix buildroot
307- add source0 url
308
309* Fri Feb 24 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3102.2.6-1
311- initial version
Note: See TracBrowser for help on using the repository browser.